PDA

View Full Version : s4pi | Updated wrapper for OBJD (CatalogResource) -- preliminary version


plasticbox
19th Aug 2015, 10:01 PM
A small update in OBJD to make it read the EnvironmentScoreEmotionTags correctly and also updates the tag lists. This is preliminary for two reasons:

-- it's mostly built upon Inge/Snaitf's code from here (http://www.simlogical.com/ContentUploadsRemote/uploads/3306/) (plus three handlers that weren't yet included with that), and since I've always been using these wrappers I don't really know how different they are from the release

-- it does not have a fancy dropdown yet for the tags because I'm currently not sure what's the best way to include them (TS4 has this one gigantic tag list that is a little impractical to use when all one wants to do is select between a handful of them) -- if it's going to be changed I don't really want to change this five times .. so for now it simply gives you the correct decimal value of the tag in Grid view so that you can fill in the one you want.


Valid EnvironmentScoreEmotionTags are as follows:

317 -- Mood_Angry
318 -- Mood_Bored
319 -- Mood_Confident
320 -- Mood_Cranky
321 -- Mood_Depressed
322 -- Mood_Drunk
323 -- Mood_Embarrassed
324 -- Mood_Energized
325 -- Mood_Flirty
326 -- Mood_Focused
327 -- Mood_Tense
328 -- Mood_Happy
329 -- Mood_Imaginative
330 -- Mood_Uncomfortable
331 -- Mood_Fine
332 -- Mood_Playful
333 -- Mood_Sad
334 -- Mood_Sloshed

There is also 64 -- Mood_Optimism in that list but I don't think that is actually in use. This is from S4_03B33DDF_00000000_D89CB9186B79ACB7.xml, TagCategory.


Over here (http://modthesims.info/showthread.php?p=4848909#post4848909) Esmeralda noted that

if you download the wrapper plasticbox posted, you must specifically unzip it with 7zip and not the unzip feature that comes with Windows or any other unarchiver. Otherwise the OBJD resource will be unusable - it will have no preview and its Grid will be greyed out.

@Esmeralda do you happen to know why this is? Was that a general word of caution or did you have that problem with this wrapper yourself? I'm just puzzled because I zip everything I upload here with 7zip and no-one seems to have had any issues so far .. I've always thought that this was an issue specifically with github, not with s4pe wrappers per se.

Thanks to Buzzler (http://www.modthesims.info/member.php?u=432522) for helping with this!

Inge Jones
19th Aug 2015, 11:29 PM
I think the unzipping problem usually happens with multiple files which depend on *each other* like a .exe with its dlls. (Eg tools like s4pe complete) If you've just got .packages or just one or two dlls that don't depend on *each other* you're probably ok however you unzip.

plasticbox
19th Aug 2015, 11:33 PM
Ah thank you! Also, I just made a separate thread about the enum tag list stuff =) I realised I forgot to check and update the list(s?) you have in CatalogCommon >.< .. -- updated

Esmeralda
19th Aug 2015, 11:54 PM
Esmeralda do you happen to know why this is? Was that a general word of caution or did you have that problem with this wrapper yourself? I'm just puzzled because I zip everything I upload here with 7zip and no-one seems to have had any issues so far .. I've always thought that this was an issue specifically with github, not with s4pe wrappers per se.
I had the problem with that wrapper (the Grid for the OBJD was greyed out and the OBJD had a blank preview when I at first unzipped it with the built-in Windows Explorer-based unzip, but then when I unzipped it with 7Zip it worked fine) and with everything else s4pe-related I've ever downloaded (including s4pe itself). There have been quite a few threads here mentioning the same type of problems, ever since s4pe came out.

I remember reading someone saying what the problem was (code getting corrupted if unzipping with anything other than 7Zip) way back in the early days of s4pe but can't remember who said it. It's all very strange, but it seems that as long as you use 7Zip to unzip the s4pe stuff, it works fine.

(Like yourself, I zip everything I upload here with 7Zip and nobody has any trouble unzipping those items. I've only seen this problem happen with s4pe-related stuff.)

plasticbox
20th Aug 2015, 12:30 AM
Okay, I now brought the list of catalogue tags up to date (using the XML from 1.10). As far as I've tested (which was not very far) it's all working fine now, showing proper labels for everything. However there are some discrepancies between the previous version and this, such as

Func_Turtle = 1241,
Ensemble_SwimMetalPink = 1242,
Ensemble_SwimBandeauCoral = 1243,
Ensemble_SwimHalterRed = 1244,

vs

Func_Turtle = 1241,
Func_Ingredient_Insect = 1242,
Func_Ingredient_Mushroom = 1243,
Region_Residential = 1244,
Region_Camping = 1245,
Func_Grill_Recipe = 1247,
Func_PicnicTable = 1248,
Func_IceChest = 1249,
Ensemble_SwimMetalPink = 1250,
Ensemble_SwimBandeauCoral = 1251,
Ensemble_SwimHalterRed = 1252,

and I didn't have any MetalSwimPinks or Insect Ingredients (ewww) at hand to check whether this is working properly now. However seeing as the release version apparently has no tags at all this should be an improvement at any rate.

scumbumbo
20th Aug 2015, 3:54 AM
it seems that as long as you use 7Zip to unzip the s4pe stuff, it works fine.
For what it's worth, WinRAR has always worked fine for me as well.

simalary44
20th Aug 2015, 4:48 AM
For what it's worth, WinRAR has always worked fine for me as well.

Really? S4PE wouldn't even run if I used WinRAR. I had to download 7zip just for S4PE.

scumbumbo
20th Aug 2015, 6:04 AM
Really? S4PE wouldn't even run if I used WinRAR. I had to download 7zip just for S4PE.
Huh, weird. Maybe because I have an older version (4.11) of WinRAR, and it's been a while since I updated it? Or maybe as I have a registered copy? Or maybe it's just one of those "Your mileage may vary" things? I sure hope it's not behaving differently for trial vs. registered users. Oh well, glad it works for me at least! :giggler: