Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

MTS Movie Night #4 - posted on Yesterday at 4:46 PM
Replies: 8 (Who?), Viewed: 1029 times.
Field Researcher
Original Poster
#1 Old 13th Jan 2018 at 4:03 PM Last edited by sam&skye : 15th Jan 2018 at 3:05 PM.
Default "No bone on model corresponding to [...]"-error
I'm trying to make a decorative book functional, and thought I could clone one that works the way I want it to, and swap the mesh. That worked when I wanted an arch that functions like a door once; I cloned a door, and exchanged it with an arch mesh.

But the book only looks fine until a sim tries to use it. Then I get an error saying "No bone on model corresponding to name in routing slot on destination object". I've had this problem before so I kind of suspect I'd have to go into the dark sorcery that milkshape is for me to fix this, but I have some hope left. So: is there any way to fix this using SimPE?

What I've done is:
- Clone a custom object that's a stack of books placeable on surfaces, which works like a bookcase (sims pull a book out and can put it back)
- Delete mesh and textures out of it, and import mesh and textures from this book
- adjust the STR that contains the model name (forgot what it's exactly called) to point to the right mesh

I thought about trying to extract a normal maxis book like those that sims will pull out of any bookcase and making it buyable/recolorable, since those look just like the one I wanted. But that would leave this annoying "Put away" option that idk how to get rid of. So I'm hoping someone has an idea on how to avoid this bone-on-model-andsoforth error.
Advertisement
Mad Poster
#2 Old 13th Jan 2018 at 8:06 PM Last edited by simmer22 : 13th Jan 2018 at 8:20 PM.
Did you do bone assignments on the book? If the bookcase has bones or is in any way animated, the book needs to be assigned in Milkshape before exporting. If the meshes are similar, you can use similar assignments as the original mesh. Some meshes can be directly replaced with obj meshes, If the object only has sim animations.

If there aren't any bone assignments, you probably have to replace the mesh in your new object in the GMDC resource. You should be able to use an OBJ mesh, and if using the advanced mode for the import function you can change model names without any issues (again, if you can use an OBJ mesh - if the item has bone assignments, you need to this in Milkshape).

I'm not entirely sure what you mean by changing the STR, though. If you change resource names and such (outside of the advanced mesh import or the GMDC resource in general), you may need to change it several places - but try to avoid this if you can.
just a girl
#3 Old 14th Jan 2018 at 11:20 AM
The error is most probably caused by animation not finding the joint it's expecting on the book. What simmer22 said.

It wouldn't be hard to remove interaction, if you decide to go down that route. I assume book uses semi-global interactions and that why you don't know how to get rid of the option. In this case you gonna have to extract book's semi-global tree table (TTAB) and pie menu strings, make them private (change groups and instances) and delete/edit what you need in them. Then edit one line in OBJD to point to the new tree table
Field Researcher
Original Poster
#4 Old 15th Jan 2018 at 11:29 AM
I don't know how to do bone assignments, use milkshape, or most things to do with meshes really. All I've done is delete one mesh from the package, add another, and point the whole thing to the new mesh by adjusting one of the text lists. (It's called "object model name" or something, I think that varies, and contains the name of the mesh.) I kind of figured that the animations were gonna be a problem, but I thought I'd at least try my best before running here and screaming for help. This has worked with doors and arches before, but then doors and arches are essentially the same thing... this is a book mesh that sims will pick up and read, swapped with a mesh that works like a bookcase. (Meaning, sims pull a book out of it rather than picking the whole thing up.)

I'm gonna try what Lamare said first, for above mentioned milkshape-is-dark-sorcery reasons... (I'm probably gonna fail halfway through and come running back anyway, though.)
Field Researcher
Original Poster
#5 Old 15th Jan 2018 at 1:43 PM Last edited by sam&skye : 15th Jan 2018 at 2:05 PM.
Okay, I've looked around in SimPE and actually found where to import the resources and the right line in the OBJD (I think/hope). Could you just tell me how to best go about making them private? I'm not sure how to get new groups and instances without things possibly conflicting with something.
Mad Poster
#6 Old 15th Jan 2018 at 1:52 PM Last edited by simmer22 : 15th Jan 2018 at 2:50 PM.
Quote:
Originally Posted by sam&skye
All I've done is delete one mesh from the package, add another, and point the whole thing to the new mesh by adjusting one of the text lists. (It's called "object model name" or something, I think that varies, and contains the name of the mesh.)


This isn't the right way to change a mesh, and may explain why you're having issues. You've probably confused the game by editing the "object model name". The text list resources shouldn't need to be touched when just replacing a mesh.

The right way is to extract either the OBJ or GMDC from the mesh you want to use, and replace the old one in the GMDC resource. In your case, using the OBJ might be enough, via the "import" function. When clicking "import", a box pops up. Here you can mark the resource and choose "replace" plus the mesh group to replace it with in the dropdown boxes to the right. Click "ok" and the mesh will be replaced. For the textures, go to the TXTR, right-click the picture, and use the DXT tools to replace the texture (DXT3/DXT5 gives the least issues).

* OBJ is a type of mesh, not the OBJD resource. Just in case you misunderstood. If you extract meshes with the "export" button in the GMDC resource, they'll extract as OBJ.

If you want the new object to be slaved/repositoried to Decat's book, so you don't have to make any recolors, you can try out the tutorial here: http://www.modthesims.info/showthread.php?t=229452
Screenshots
Field Researcher
Original Poster
#7 Old 15th Jan 2018 at 2:10 PM Last edited by sam&skye : 15th Jan 2018 at 2:35 PM.
And that doesn't give me the bone issue? And, did I get this right: I only replace the GMDC, I don't touch the GMND, SHPE or CRES?

Scratch that, it works. But it looks like I screwed up the shadows. Pretty sure those are leftovers from the old mesh... looks like the loft bookcase that the object I'm using was cloned from.
Mad Poster
#8 Old 15th Jan 2018 at 2:40 PM
(I edited my previous post a little, while you were posting).

You have to either delete the shadow resources, or edit them. My guess is that the original creator didn't bother editing them. Looks like residue shadows from a book shelf.

Shadows can be edited the same way as meshes, but if there were shadow resources from the original mesh, use those. For the texture, after importing select "ExtRaw8bit" from the dropdown list under "format" before committing.

Tutorial on adding shadows here: https://esperesa.dreamwidth.org/64063.html
Field Researcher
Original Poster
#9 Old 15th Jan 2018 at 3:04 PM
I had a look at the package with the mesh I'm importing, and it doesn't have any shadows at all. So getting rid of all the leftovers of what must've originally been the shadow fixed it. Everything works the way it's supposed to now. Thanks, you were a huge help (and I'm a little smarter now).
Back to top