Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

2018 MTS Calendar Contest - posted on 12th Nov 2017 at 8:48 PM
Replies: 5 (Who?), Viewed: 860 times.
Lab Assistant
Original Poster
#1 Old 29th Aug 2017 at 2:20 PM

This user has the following games installed:

Sims 3, World Adventures, Ambitions, Late Night, Generations, Pets, Showtime, Supernatural, Seasons, University Life
Default GTX 980 Ti don't apply Nvidia color profile to Sims 3 full screen mode
Hello. I have Dell S2716DG monitor and color is a bit wash out. I need to adjust gamma setting in Nvidia control panel to make things look better.

All of my games respond to this setting except Sims 3 in full screen mode. It only work if I switch to windows mode.

I hate playing in windows mode since some texts in game looks blurry.

Anyone know solution ?

Nobody can answer me at overclock.net (largest PC enthusiast community).
Advertisement
Mad Poster
#2 Old 29th Aug 2017 at 11:51 PM
You'll have to update your Nvidia driver, but I'm sure a lot of people suggested the same thing. I personally had similar issues before, in fullscreen it would be too dark. It was fixed when I updated the driver.

Of course it might also be you need to rollback driver to an older one. At one point when I updated my driver, whole thing got screwy. So I rolled back to an older version that I knew worked, and I'm pretty much stuck on using that one. I'm using 352.86 if you're interested in which version I'm on. I think the newest is 380 something, last time I checked.

Nitromon is a type of Pokemon encountered in the Pokemon Nitrome Version series.

There. Mystery solved.
Lab Assistant
Original Poster
#3 Old 30th Aug 2017 at 2:48 AM
Quote:
Originally Posted by nitromon
You'll have to update your Nvidia driver, but I'm sure a lot of people suggested the same thing. I personally had similar issues before, in fullscreen it would be too dark. It was fixed when I updated the driver.

Of course it might also be you need to rollback driver to an older one. At one point when I updated my driver, whole thing got screwy. So I rolled back to an older version that I knew worked, and I'm pretty much stuck on using that one. I'm using 352.86 if you're interested in which version I'm on. I think the newest is 380 something, last time I checked.


Thanks for reply. I already use the lastest 385.41 WHQL. I will try older driver like you said.
Lab Assistant
Original Poster
#4 Old 31st Aug 2017 at 12:13 PM
Quote:
Originally Posted by nitromon
You'll have to update your Nvidia driver, but I'm sure a lot of people suggested the same thing. I personally had similar issues before, in fullscreen it would be too dark. It was fixed when I updated the driver.

Of course it might also be you need to rollback driver to an older one. At one point when I updated my driver, whole thing got screwy. So I rolled back to an older version that I knew worked, and I'm pretty much stuck on using that one. I'm using 352.86 if you're interested in which version I'm on. I think the newest is 380 something, last time I checked.


Unfortunately this doesn't work but thanks anyways.

Looks like I have to play at windows mode until buying some colorimeter so I don't need to rely on Nvidia gamma setting.
Instructor
#5 Old 31st Aug 2017 at 12:42 PM
Quote:
Originally Posted by enterprise24
All of my games respond to this setting except Sims 3 in full screen mode. It only work if I switch to windows mode.


The GTX 980 Ti by TS3's default is not recognized, so make sure you have your GTX 980 Ti recognized first by TS3 and then try to set the monitor refresh rate in TS3 main menu to 60Hz. Note: If your GTX 980 Ti have more than 1GB VRAM, you need to edit the GraphicRules.sgr as well otherwise you'll have 32MB Texture memory Override in your DeviceConfig.
Lab Assistant
Original Poster
#6 Old 2nd Sep 2017 at 2:00 PM
Quote:
Originally Posted by PapaEmy
The GTX 980 Ti by TS3's default is not recognized, so make sure you have your GTX 980 Ti recognized first by TS3 and then try to set the monitor refresh rate in TS3 main menu to 60Hz. Note: If your GTX 980 Ti have more than 1GB VRAM, you need to edit the GraphicRules.sgr as well otherwise you'll have 32MB Texture memory Override in your DeviceConfig.


Thanks. Already solved the problem by using Borderless Gaming app.

http://store.steampowered.com/app/3...derless_Gaming/

This force Sims 3 to play on borderless windows so I get good color from gamma setting and don't have horrible text from windows mode.

I already report this problem on Nvidia forums. Not just Sims 3 , Grid 2 and Unigine Valley also suffer from this glitch. Dunno will Nvidia able to fix this since I see many people report this problem several years ago or it is upto publisher like EA / Codemaster that can fix this but both games is EOL from support now so I think I must rely on Borderless Gaming app. Hope it will works on every games that don't support borderless windows.
Back to top