Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

Theme Seasons and Celebrations - posted on 1st Oct 2017 at 1:52 PM
Replies: 4 (Who?), Viewed: 553 times.
Lab Assistant
Original Poster
#1 Old 12th Aug 2017 at 8:38 PM Last edited by sydney511 : 12th Aug 2017 at 9:00 PM.

This user has the following games installed:

Sims 2, University, Nightlife, Open for Business, Pets, Seasons, Bon Voyage, Free Time, Apartment Life
Default Help!! Sims 2 game suddenly very glitchy when I move camera - pink boxes, spikey textures, flickering, etc. making game unplayable [RESOLVED]
Hi, I am copying and pasting this from a reddit thread I made as well. I figured I could get some help on here.


Hi, this suddenly started happening only today. The game was working perfectly fine last night. I installed no new cc yesterday and only installed the mod to have more than 8 sims in a household today but uninstalled it when I saw this happen. I removed the mod and rebooted the game but this is still happening. Some other notes:

- Screen is black upon loading household, and stays so until I enter buy mode

- Screen glitches like CRAZY when I move the camera but otherwise I seem to be able to play fine

- Last night when I was playing something very strange happened. When clicking on something to do an action the sims "head" with the web of interactions would get stuck. Also, the icons for interactions in the sim's queue were glitched as well - I can't find the word for it but basically they were duplicated multiple times with the duplicates being very close together. Kind of like when you drag a window and it makes duplicates close together. Sorry for the lame explanation I'll try to find an example.

But otherwise the game was fine yesterday. the glitches happened out of nowhere. I will try repairing my game through origin (I am running UC) and report back.
Advertisement
Lab Assistant
Original Poster
#2 Old 12th Aug 2017 at 8:58 PM
UPDATE: I repaired the game through origin, then launched it in full screen through the origin client. The game was working perfectly on both a premade family and in the legacy I was playing pictured above! Then I launched in windowed mode and once again it was working perfectly fine (my graphics settings got messed up though and the resolution is wonky but I know how to fix that). I suppose I'll just leave this up in case anyone else has a similar problem? I've only repaired The Sims 4 through origin so I'm surprised it worked for The Sims 2 since its an old game.
Now what dammit?
staff: moderator
#3 Old 12th Aug 2017 at 9:01 PM
That sort of pink flashing thing is an indication the video card is struggling - usually with memory - either because it's giving out (unlikely but not unheard of) or because code somewhere got borked and is sending the card round in circles where it isn't able to work out what to show on screen. That it went away when you repaired the game seems to indicate the latter.

Polgannon: Who Murdered Blaise Penhaligan?
(3rd ed. neighbourhood now available with corrections). Poll: http://strawpoll.me/6689876

Polls: length of neighbourhood play: http://www.strawpoll.me/10908815 & http://www.strawpoll.me/10908842

Thread for yakking about making TS2 stuff
Lab Assistant
Original Poster
#4 Old 12th Aug 2017 at 9:20 PM
Quote:
Originally Posted by maxon
That sort of pink flashing thing is an indication the video card is struggling - usually with memory - either because it's giving out (unlikely but not unheard of) or because code somewhere got borked and is sending the card round in circles where it isn't able to work out what to show on screen. That it went away when you repaired the game seems to indicate the latter.


Thanks for the info! I probably should've tried repairing before making this thread but I was panicking my computer is made to run high performance games so when I saw this I was very confused. At least now I know what happened and how to fix it.
Now what dammit?
staff: moderator
#5 Old 13th Aug 2017 at 11:36 AM
Quote:
Originally Posted by sydney511
Thanks for the info! I probably should've tried repairing before making this thread but I was panicking my computer is made to run high performance games so when I saw this I was very confused. At least now I know what happened and how to fix it.

Yeah my rig too - but the game is not high performance - it's a 13 year old game that wasn't designed to run on modern rigs - sometimes it struggles. There are fixes you can use to help peformance but the fact is you shouldn't expect this game to run like modern ones.

Polgannon: Who Murdered Blaise Penhaligan?
(3rd ed. neighbourhood now available with corrections). Poll: http://strawpoll.me/6689876

Polls: length of neighbourhood play: http://www.strawpoll.me/10908815 & http://www.strawpoll.me/10908842

Thread for yakking about making TS2 stuff
Back to top