Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

Sneak Preview of Project CRUMB - posted on 21st May 2017 at 7:32 PM
Replies: 10 (Who?), Viewed: 998 times.
Original Poster
#1 Old 21st Mar 2017 at 1:08 AM
Default newbie here - can't rotate objects
I'm brand new to this version of the game. One of my sims needs to learn to play chess, so I located and bought him a chess table and desk chairs, but got a message that he doesn't have enough chairs, so I thought maybe they weren't situated around the table right. I tried to rotate the table, and......tried to rotate the table, and......tried to rotate the table. I cursed a couple of times and googled how to rotate objects. No one seemed to know. I'm sure this has been figured out by now. Can someone help me?

Frustrated by the sea.

P.S. Wow, they changed everything, didn't they? I spend more time looking stuff up than I do playing.

"Death cannot stop true love; all it can do is delay it for awhile."
Mad Poster
#2 Old 21st Mar 2017 at 1:23 AM
Video: https://www.youtube.com/watch?v=BN40Plsndiw
Basically, the same method as in TS2. If you don't have the <> buttons there, but instead the ,. buttons (like me), use those.

Chairs follow tables in TS4 (anything that can have a chair attached, so tables, desks, chess tables, you name it), so let them "snap" to the table on their own, and then move the table. You should be able to use the <> or ,. buttons to rotate a table with chairs.

I think you must have two chairs for a chess table to work, but I don't want to say that for sure. The chairs should snap into the proper place (in front of the black and white chess pieces).

I'm not sure if there's a difference between the chairs, but dining room chairs and similar should work. Any chairs based on couches or other chairs that don't work with tables probably won't snap to the table.
Mad Poster
#3 Old 21st Mar 2017 at 2:31 AM
I had a problem with chairs and a table once and it turned out I needed a different type of chair. If your chairs aren't "snapping to", as simmer22 described, try a different type.
#4 Old 21st Mar 2017 at 7:41 AM
They need to be the dining chair types and not the living ones from my experience. Try and see what works and what does not.
Original Poster
#5 Old 21st Mar 2017 at 11:42 AM
It couldn't be more different from sims 2. You just click on the objects and rotate it with the mouse in sims 2. That just doesn't work at all in 4. Changing the chairs didn't work, either. Nothing snaps to, and any attempt to rotate the blasted thing just moves the camera or slides the chess table further up, doesn't rotate at all.

I bought the violin and have the same problem so it's not just the chess table.

I'm grateful for the help, but frustrated beyond belief. It's a game; it shouldn't be a chore to try to play.

"Death cannot stop true love; all it can do is delay it for awhile."
dodgy builder
#6 Old 21st Mar 2017 at 1:30 PM Last edited by Volvenom : 21st Mar 2017 at 2:25 PM.
It depends on your keyboard. I have a norwegian keyboard, and it's the , and . buttons at the bottom with the spacebar and AltGr.

I was just in the game putting down some plants, and what I actually do is just to hold down and drag around.
Original Poster
#7 Old 22nd Mar 2017 at 2:47 PM
I don't need to drag them; I just want to rotate so they can play the blasted violin and the stupid chess game. Is it just me or is it stupid to have to watch a youtube video to play a silly game?

"Death cannot stop true love; all it can do is delay it for awhile."
Mad Poster
#8 Old 23rd Mar 2017 at 1:57 AM
I agree, Smorbie. It seems rather stupid to have to watch a video in order to rotate furniture. The thing is, it works easily for most of us, so maybe the video will help you figure out what's going wrong when you try it.

Just a suggestion, but if I had this problem, I'd probably go to one of the rich premades and investigate the set up of their chess set or violin. Or, I'd add on a "stylized" room or download one that came with the set up I wanted, then go into buy/build mode and try to analyze why it worked there.
dodgy builder
#9 Old 23rd Mar 2017 at 6:17 AM
Originally Posted by smorbie1
I don't need to drag them; I just want to rotate so they can play the blasted violin and the stupid chess game. Is it just me or is it stupid to have to watch a youtube video to play a silly game?

That's what I'm saying you hold and rotate.
Lab Assistant
#10 Old 25th Mar 2017 at 6:13 AM Last edited by Skanning : 25th Mar 2017 at 6:15 AM. Reason: add on re; chairs
Try grabbing the item with the left mouse clicker and hold it while clicking on the right clicker...I think that's how I do it lol It's strange because it's such a matter of habit for me that I'm having trouble telling you how to do it :-(
BTW - Desk chairs don't work. You have to use dining chairs.
#11 Old 25th Mar 2017 at 10:05 AM
@smorbie1 - Have you ever worked with neighborhood deco in Sims 2? This looks like it's done the same way. Just imagine you have a piece of railroad track or one of Criquette's custom bridges. Pick the object up, use the keyboard to rotate it while you're still holding it, and only put it down after you've got it facing in the right direction.

I can see why you're having trouble - this is almost the complete opposite of the way furniture is placed in Sims 2. Don't give up! You'll get the hang of it!

Thanks to Crmelsimlover for sharing these rare Christianlov mods for TS2: Cpack editor with working face DNA fixer and Skin Selector Prototype. Instructions for adding custom skins to Skin Selector at post #37 here. Instructions for using the DNA fixer at post # 2662 here .
Back to top