Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

Nysha's New Creators for July - posted on 1st Aug 2018 at 9:00 AM
Replies: 6 (Who?), Viewed: 6309 times.
Original Poster
#1 Old 3rd May 2016 at 6:04 AM Last edited by alverdine : 3rd May 2016 at 6:34 AM.
Default s3pe - error reading resource
I'm recategorising and making other miscellaneous changes to the OBJD resources for a bunch of stuff and keep running into this error.
The main highlighted OBJD shows the error, and the thinner red box highlights other resources that are also affected.

Overview of the problem:
I open up DeltaBuild0 in s3pe, export>to file the resources I need, go to my new package, import the files by dragging and dropping, make the changes then save and test in game.
If all is good then I repeat the process, only doing a few at a time so I can test straight after and make sure I didn't screw anything up. Usually everything is fine, so I keep adding new OBJDs to the same package, editing and then checking in game.
At some point, however, some of the previous OBJDs get messed up and I get that error, at which point I can no longer access the 'grid' button, and if I keep the .package file in my mods folder, all the objects with that error disappear from my catalogue completely.

What am I doing wrong? I used to make recats all the time and never ran into this problem :S

ETA: https://www.dropbox.com/s/4iw6gt5dt...or.package?dl=0 link to DL the problem package if anyone wants to poke and prod it.
Puffin McMuffin
staff: administrator
#2 Old 3rd May 2016 at 3:49 PM
Hmmm seems like S3PE thinks it's corrupted or is missing a file. What exactly did you change in the OBJD files that have this problem?
Original Poster
#3 Old 9th May 2016 at 7:25 AM
Originally Posted by Greenplumbbob
Hmmm seems like S3PE thinks it's corrupted or is missing a file. What exactly did you change in the OBJD files that have this problem?

Goodness, I somehow managed to forget this thread existed. Excuse my hazy brain.

I changed things like wall flags for the curtains and other things I made visible in the catalogue and gave them category and room values, and other items I just changed the categories and/or slot placements. It happened to so many files and they all had different changes applied.

They worked fine when I tested them at first, and subsequent times when testing out other additions to the .package file, but at some point they just get corrupted. I've tried creating fresh packages and starting from scratch a few times and the same thing happens. Very odd problem :S
Site Helper
#4 Old 9th May 2016 at 12:31 PM
I have no idea what you've been doing wrong, unless one of your edits is causing something not to play nicely with the rest of your package, but I was wondering if it would be possible for you to just call that particular package "finished" with the backup you made just before the problem and start a new one beginning with the set that caused the problem with the first package. Then you can see if those packages merge properly once they are completed.

I am Ghost. My husband is sidneydoj. I post, he downloads, and I wanted to keep my post count.
Group for Avatar Makers* Funny Stories *2017 Yearbook
Puffin McMuffin
staff: administrator
#5 Old 9th May 2016 at 2:21 PM
I totally agree with @ghost sdoj! Usually when you make Cc, it's always better to first finish it, THEN merge it together. It might have been the issue that S3PE was like 'wait what's this file for' when you edited it, because maybe it lost some sort of data that S3PE uses to track down to 'what belongs to what'. It might be some hard work if you need to redo it, but I hope you don't have to >-<
Original Poster
#6 Old 23rd May 2016 at 8:46 AM
Apologies for the very late reply once again! (I always forget about self-created threads for some reason).

Creating a new package file for every edit then merging them together after is probably the sensible option, but also time consuming when making changes to so many things, and it was much quicker to just import resources into the same .package without having to save and name everything individually.
I did back up some of the working merged .packages so I could revert to them if the one I was working in got corrupted again, but even then I found that trying to go back to those once working files, they also had become corrupted :S

If I ever get the motivation to attack the messy catalogue again I'll be making smaller packages containing fewer resources and merge them at the end, like you guys suggested
Test Subject
#7 Old 30th Sep 2017 at 10:31 PM
For people with the .7z archive...

For anyone else reading this in the future, here is the solution. Certain un-archiving (my experience winrar) can fail for (I think it's either CRC checks or something to do with filetypes) whatever reason; even though you get no errors or indication that the archive was not properly extracted. I've seen this once before. Simple solution, use 7zip.
Back to top