Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

MTS Movie Night #3 - posted on 20th Oct 2017 at 10:54 PM
Replies: 5 (Who?), Viewed: 1339 times.
Test Subject
Original Poster
#1 Old 25th Jun 2016 at 3:57 PM Last edited by Gamnem : 27th Jun 2016 at 11:29 AM.
[Solved!] Can't Launch game from Origin or the Shortcut
So, i just got The Sims 3 Base Game from a friend, but everytime i try to launch the game, in any way i just get the same screen:
The launcher, with a message saying: "Origin is required to play this game. Please install Origin and relaunch the game. If Origin is already installed and the game is not running, please contact customer support", which i tried, but they never answer.
Anyone got any idea of what could be happening?
Advertisement
Site Helper
#2 Old 26th Jun 2016 at 12:42 AM
I have an idea of what might be happening, but I'm afraid you won't like it.

Your screenshot shows you have version 0.0.0.0, which is only found on a pirate copy. We cannot tell you how to get those to run. (I'm not trying to be mean. MTS is too big and too well-known to be able to get away with things like that.)

I am Ghost. My husband is sidneydoj. I post, he downloads, and I wanted to keep my post count.
Group for Avatar Makers* Funny Stories *2016 Yearbook
Mad Poster
#3 Old 26th Jun 2016 at 2:19 AM
I don't know, the person did contact EA support...

Nitromon is a type of Pokemon encountered in the Pokemon Nitrome Version series.

There. Mystery solved.
Field Researcher
#4 Old 26th Jun 2016 at 2:47 AM Last edited by Naus Allien : 26th Jun 2016 at 5:57 AM.
Quote:
Originally Posted by Ghost sdoj
Your screenshot shows you have version 0.0.0.0, which is only found on a pirate copy.


No, it's not... Here you'll see that it's a common issue related to patches. It seems you need to uninstall Origin, reboot your PC and then reinstall Origin to fix it. You can also delete the cache files that are listed on that page, but I'm not sure it'll help at all. If it doesn't work, you'll probably have to uninstall/reinstall the whole game and every EP/SP.
Top Secret Researcher
#5 Old 26th Jun 2016 at 4:02 AM
Another common source of the Launcher 0.0.0 problem is attempting to apply the 1.67 SuperPatch to a game that is already at Patch 1.69. Not everyone who attempts this lands in such a bad place, but from all reports most still do. Same set of solutions as offered above and on the linked page, though.
Test Subject
Original Poster
#6 Old 27th Jun 2016 at 11:29 AM
Guys, thanks for the help, i re-installed origin, rebooted and now it works perfectly, thanks.
Back to top