Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

Nysha's New Creators for November - posted on 1st Dec 2017 at 10:00 AM
Replies: 72 (Who?), Viewed: 34215 times.
Page 1 of 3
Test Subject
Original Poster
#1 Old 8th Jun 2011 at 2:46 AM

This user has the following games installed:

Sims 3
Default Sim freezes after taking a photo
Hello!

I have recently installed Ambitions from EA download manager (I had to uninstall Sims 3 and World Adventures first as I bought the DVDs for those... how silly is that?!) but I have retained my savegames and has worked perfectly so far... until I decided to bring my sims to Egypt, where my photographic eye sim buys a camera, and tries to take a picture... he does it, and immediately afterwards freezes and does not respond to any input I give him. The only way to break him free is to reset him or load the savegame again.

I don't understand why this is happening, I'm also hoping I'm not the only one!

As I said, my Sims 3 has WA and Ambitions, all digital downloads, version 4.10.1.011037, thanks in advance!!
Advertisement
Be like the 22nd elephant with heated value in space- Bark!
staff: retired moderator
#2 Old 8th Jun 2011 at 3:26 AM
Are you using any mods/ CC? If so, please test the game with fresh user files.

Also, test with a new game. Can a sim in a new game travel and take photographs?
Test Subject
#3 Old 8th Jun 2011 at 5:00 PM
The same happens to me with all expansions, even the generations with the new patch :S
Test Subject
#4 Old 8th Jun 2011 at 9:46 PM Last edited by trukittn : 9th Jun 2011 at 12:35 AM.
I am having this issue as well. Having just installed World Adventures yesterday (Have had LN and Ambitions for some time), it's pretty annoying. The only way to get the sim out of this is to use the resetsim "cheat". But the picture isn't saved and no photography skill is gained.

I've done lots of searching for remedies since yesterday and there's several topics about it already on the main Sims 3 forums.
http://forum.thesims3.com/jforum/posts/list/385702.page
That one being the most recent, but all of them are from within the last few days or so.

It appears to be a problem with the recent patch (which was forced on me to get all my EP's to cooperate, even though I don't have Generations.) and it also appears they aren't likely to do anything about it if the last post has any truth to it. It may be up to some miracle working modders to fix.

Screenshots and taking photos from the cell phone work fine.
But using a camera causes the sim to stand in place forever with the 'take a photo' action locked in after you've clicked to take the photo. You can't cancel the action. The game itself doesn't freeze. Time passes and the stuck sim just stands there wasting away.

What a bummer. This was one of the features I was looking forward to using with WA. :/ And now I'm getting lots of photo skill wishes and challenges that I can't do anything about.

I've tried taking out all CC, and buying a new camera. Nothing yet seems to fix this issue. Gonna try with a fresh game and new sim. Most posters on the main forums say it works on a fresh game, but once you save and reload, it starts happening again.

Edit: Tried with a new game. Still had the problem. :S
Test Subject
Original Poster
#5 Old 9th Jun 2011 at 2:01 AM
So I guess the only workaround at the moment is to not take pictures then...
Be like the 22nd elephant with heated value in space- Bark!
staff: retired moderator
#6 Old 9th Jun 2011 at 2:43 AM
Okay, since my post I've read that some people have had success by making sure their games are fully patched.

Take a look at this table, your games should all match the bottom row (03.Jun.2011 ):
http://www.simswiki.info/wiki.php?t...elp:Patch_Table

Find your gameversions for each EP like this:
http://www.simswiki.info/wiki.php?t...ind_Gameversion

The Launcher will only patch the basegame and latest EP, so if your other games are outdated, download the current patches and apply them:
http://www.simswiki.info/wiki.php?t...ownload/Current

Some simmers on other forums have indicated that their photography worked after fully patching, so try it and see if it helps.
Test Subject
#7 Old 9th Jun 2011 at 8:39 AM
Quote:
Originally Posted by simsample
Okay, since my post I've read that some people have had success by making sure their games are fully patched.

Take a look at this table, your games should all match the bottom row (03.Jun.2011 ):
http://www.simswiki.info/wiki.php?t...elp:Patch_Table

Find your gameversions for each EP like this:
http://www.simswiki.info/wiki.php?t...ind_Gameversion

The Launcher will only patch the basegame and latest EP, so if your other games are outdated, download the current patches and apply them:
http://www.simswiki.info/wiki.php?t...ownload/Current

Some simmers on other forums have indicated that their photography worked after fully patching, so try it and see if it helps.


Thank you for posting this! I just updated the EPs that I had prior to Generations and I'm going to give this a go. Thanks again!
Test Subject
#8 Old 9th Jun 2011 at 8:15 PM Last edited by jesuisdvd : 9th Jun 2011 at 9:29 PM.
My sims still freezes after update all EPs like simsample said
Test Subject
#9 Old 9th Jun 2011 at 11:20 PM
Thanks for the advice on checking the patch versions. You're right. Even though WA was the last one I bought, it was still release version in spite of all the downloads it threw at me upon installation.

Patching both it and Ambitions did fix the problem for me. My very first photograph: a toilet. Yay! :D
Instructor
#10 Old 10th Jun 2011 at 4:11 AM
I was having a similar problem in that I couldn't click on the camera in my Sims' inventories and so no photos. What fixed it for me was traveling to Al Simhara and buying a new camera - at that point, both cameras worked at home and abroad.

"Books don't take time away from us ... They give it back. In this age of abstraction, of multitasking, of speed for speed's sake, they reintroduce us to the elegance - and the relief! - of real tick-tock time." - Home Safe, Elizabeth Berg
Test Subject
#11 Old 10th Jun 2011 at 8:09 PM
For me works fine for a while but not ever, one or two pictures, and then my sim freezes
Test Subject
#12 Old 10th Jun 2011 at 10:22 PM
I may have spoken too soon. Today when I loaded my game and tried to take a picture, she froze up again same as before. ._. What a pain.
Test Subject
#13 Old 11th Jun 2011 at 11:25 PM
I also tried updating all my EPs. First, I tried just updating the EPs, without a full uninstall. That didn't work. Then, after backing up my files, I uninstalled the game and EPs and re-installed everything, updating the individual EPs as I went. After I was done, I restarted my computer. I did this a couple of days ago and haven't had any problems with Photography as of yet.
Test Subject
#14 Old 12th Jun 2011 at 5:32 PM
I am also having the same problem with my sim being stuck after taking a picture. I have checked and all my expansions are up to date with the latest patches.
Test Subject
#15 Old 13th Jun 2011 at 10:28 PM
are any of you using the book of talent mod? my sims were working fine. they weren't freezing after taking a photo, and the photos were saved and they were also gaining their skill points for photos until i installed the book of talent. now my sims freeze after taking a photo. maybe the book of talent doesn't work with the latest wa patch. just a thought. worth a try to delete the book of talent mod and try again. that's what i'm gonna to do.
Test Subject
#16 Old 13th Jun 2011 at 11:22 PM
Im just using the latest mastercontroller (the only core mod), the other mods are clothes and furniture only, and still not working, and i got another bug of the generations expansion, the first time i see this bug, my little child wont appear in my family and let the "sim icon" from the left, green without his face and cannot select him
Field Researcher
#17 Old 13th Jun 2011 at 11:29 PM
jesuisdvd, Master Controller isn't a core mod, even if Delphy's Dashboard says so.

And you should make your own thread because you have added complete different problem than OP, so it would be easier to help you and so
Test Subject
#18 Old 14th Jun 2011 at 12:23 AM
Quote:
Originally Posted by gelis
jesuisdvd, Master Controller isn't a core mod, even if Delphy's Dashboard says so.

And you should make your own thread because you have added complete different problem than OP, so it would be easier to help you and so


Sorry dude i just told the players my kind of bugs with generations, not happen again
Test Subject
#19 Old 14th Jun 2011 at 7:46 AM
I've made some progress in narrowing down what causes this bug, after someone on the main forums mentioned it seems like its tied into opportunities. Already posted this @twallan's site so I'ma just copy paste what I posted there -

So I did some testing on a fresh save game where the bug hadn't crept up yet:

Went and got a camera before accepting any opportunities or adventures and took a photo: Success
Accepted an adventure and completed it, then tried to take a picture: Success
Returned home, tried to take a picture: Success
Accepted a simoleon only reward opportunity, completed it, then tried to take a picture: Success
Returned to a WA locale and tried to take a picture: Success
Accepted another adventure and tried to take a picture before completing it: Sim Froze.
Reloaded the save before this and completed the adventure, saved, then tried taking a photo again: Sim Still Froze
Closed the game, cleared my cache and reloaded the post-adventure save, tried photo: Success

So all you seem to have to do actually is clear the cache and it will fix the bug once it has occurred (that seems easier to me than switching active household which apparently may also fix it).

Seems to me the bug happens when/if you try to take a photo while your household has an opportunity open, but its ok to take opportunities and finish them. Once the bug has occured, however, it will be present on all saves until you clear your cache. Problem is, there's opportunities that require photos to be taken. I haven't had any of them, or any skill-based opportunities to test with yet, but I hope this info helps someone.
In the Arena
staff: retired moderator
#20 Old 14th Jun 2011 at 9:52 AM
Thanks for that report, trukittn.
Hopefully the modders can now squash this one with reliable reports like yours that explain things very clearly on how to replicate the issue and its possible fix.
Top Secret Researcher
#21 Old 14th Jun 2011 at 10:59 AM
Adding my two-cents' worth...I only just got Sims 3 and WA - no other addons. I am running Awesomemod but no other CC. Basegame is patched to 1.22, added the WA patch as well.

I am getting the bug with photo taking as described by others - direct sim to take a photo, and sim is stuck with the command forever. Resetting the sim does get around it.

My sim is able to take photos at home, but not while travelling. I think my sim has been on an Adventure each time she got stuck. She had an unfinished opportunity at home which did not seem to cause any trouble with camera use. I'll try to remember to have her take a picture in China when there is no adventure pending.
Née whiterider
staff: administrator
#22 Old 14th Jun 2011 at 1:03 PM
This bug is intermittent - it took me on a merry dance trying to weed out a CC cause after it randomly fixed itself just when I happened to have taken out all my CC, only to break again through all tests and another test without CC.

I can confirm that while most of the sims it has affected for me were engaged in opportunities (one sim with the police career photography opportunity, one with a painting skill opportunity), I have also observed it in vanilla testing sims with no opportunities or adventures.

I'll try patching my middle EPs and see if that helps.

What I lack in decorum, I make up for with an absence of tact.
Test Subject
#23 Old 14th Jun 2011 at 5:41 PM
Im agree with whiterider the bug is intermittent for me too, but the problem in my case appears without opportunities, in my house, egypt, france or wherever my sim is.
Test Subject
#24 Old 14th Jun 2011 at 11:57 PM
It seems to leak to other saves once it has happened on one. Even saves where the household is not engaged in opportunities. Clearing the cache and changing households both seem to clean up the bug for me, but doesn't prevent it from happening again. I hate thinking that its up to modders to fix stuff like this. :/ But from what I read so far, people reporting it to EA are getting a 'you're playing the game wrong' sort of response from them.

I'll keep testing around. For the record I am playing a single-sim household based in Bridgeport and using the flimsy cam. Her photo skill is currently at 4.
Test Subject
#25 Old 15th Jun 2011 at 10:36 PM
Default Sims 3 Photography Bug Information
A bit of information: I got this bug too. I can confirm it seems to be linked to opportunities. The sim in question had two opportunities up: one was the school one to research the science centre, one was the Scavenger Hunt for rare metals (that might be a Generations one, I don't know.)

Reloading an older save didn't work, I still had my photographer sim freeze. However, after clearing my cache files, and clearing the opportunities from my sim, I could take pictures again without a problem.

I've got Generations, and am patched to 1.22, with all EP's fully patched (no SP's installed).

Hope that helps!
Page 1 of 3
Back to top