Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

MTS Movie Night #3 - posted on 20th Oct 2017 at 10:54 PM
Replies: 5 (Who?), Viewed: 1053 times.
Test Subject
Original Poster
#1 Old 11th Feb 2017 at 12:52 AM

This user has the following games installed:

Sims 3
Default Install button launches my game instead of installing custom content
I recently uninstalled my sims 3 game because I could not longer install or uninstall custom content. I deleted everything, mods, custom content, everything. I used revouninstall to make sure nothing was left behind. I did a reinstall of my game, set up my folders for putting my mods and custom content back into the game. I downloaded one world, which was Riverview. It showed up in the download manager on the launcher, so I hit install and the weirdest thing happened. My game launched with out installing the world. So I let the game continue to load and looked to see if Riverview showed up. It was not there. So I exited the game, and loaded the launcher again. I pushed the install button again, but once again the install button launched my game. I have installed and uninstalled this game 4 times now with the same result. I have googled to see if anyone else has had this specific problem, but from what I could see, no one has experienced their install button on their launcher launching the game instead of installing their cc. I would greatly appreciate it if someone could help me figure out what is going on or what I have done wrong. Thanks.
Advertisement
Site Helper
#2 Old 11th Feb 2017 at 1:47 AM
Ok, what happens if you double-click the Sims3pack instead of having the Launcher find and install it? It should open the launcher and proceed to install it.

I am Ghost. My husband is sidneydoj. I post, he downloads, and I wanted to keep my post count.
Group for Avatar Makers* Funny Stories *2016 Yearbook
Test Subject
Original Poster
#3 Old 11th Feb 2017 at 1:58 AM
Quote:
Originally Posted by Ghost sdoj
Ok, what happens if you double-click the Sims3pack instead of having the Launcher find and install it? It should open the launcher and proceed to install it.


Thank you for replying. I have tried that but it also launches the game. I just can't figure out what it causing it to do that.
Site Helper
#4 Old 11th Feb 2017 at 10:00 PM
That is seriously weird. At this point, I think I would get Delphy's Multi-extractor to convert sims3packs to package files and avoid the launcher except for worlds, patterns, and other things that it can't handle properly. I can't think of anything that might be causing it unless it didn't install properly, but maybe someone else will have an idea. If 4 reinstalls didn't fix it, I doubt that another one will help.

I am Ghost. My husband is sidneydoj. I post, he downloads, and I wanted to keep my post count.
Group for Avatar Makers* Funny Stories *2016 Yearbook
Top Secret Researcher
#5 Old 12th Feb 2017 at 12:56 PM
Maybe your file opening associations are messed up? If you try to right-click on a sims3pack and choose Open With, what's the first program? It should be "Sims3Launcher Starter Application" ([installation folder] \ Electronic Arts \ The Sims 3 \ Game \ Bin \ Sims3Launcher.exe). The behavior you're describing makes me think your program was changed from Sims3Launcher.exe to TSRW.exe, which is the executable for running the game (and is also in the same folder as Sims3Launcher.exe).

Edit: alternately you can try renaming the TSRW executable to something different (TSRWtest.exe) and see if the game still launches this way. If it doesn't and the world installs properly, rename it to TSRW.exe after you're done.

I also have a Simblr: sweetdevil-sims, where I post downloads!
If you have concerns about my stuff, please PM me! I see PMs much faster than thread comments :)
pocci/gardenbreeze CC reupload
Scholar
#6 Old 12th Feb 2017 at 11:59 PM
I have not experienced what you are experiencing but have had just about every possible problem with the Launcher from Hell. One day it works next day doesn't. Different problems off and on. I have found it much easier to install stuff while in game.

If you are on the 1.67 Patch try reinstalling the Superpatch.

The Launcher will load the game to install stuff. Try loading your game to the Main Menu then click on the three little dots in the lower left corner and click on Open Launcher.
Back to top