Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

MTS Summer Movie Night - posted on 13th Jun 2018 at 10:07 PM
Replies: 3 (Who?), Viewed: 4656 times.
Test Subject
Original Poster
#1 Old 14th Oct 2016 at 9:35 PM Last edited by pikkonoloidlee : 15th Oct 2016 at 3:29 PM.
Default Added Slot Crashes Game
I had this idea of adding a deco slot to a loveseat I'm working on and as it's my first time doing this I have no idea what I'm doing wrong but it always seems to end with my game crashing. I've tried various things trying to get it to work so I thought it'd be better to ask for help before messing it up further.

In the zip is the last version I tried and also the original that doesn't have the added slot.
Download - please read all instructions before downloading any files!
File Type: zip CorbyLoveseat.zip (1.84 MB, 6 downloads) - View custom content
Advertisement
Top Secret Researcher
#2 Old 15th Oct 2016 at 1:55 AM
Quote:
Originally Posted by pikkonoloidlee
I had this idea of adding a deco slot to a loveseat I'm working on and as it's my first time doing this I have no idea what I'm doing wrong but it always seems to end with my game crashing. I've tried various things trying to get it to work so I thought it'd be better to ask for help before messing it up further.

In the zip is the last version I tried and also the original that doesn't have the added slot.

I changed three things:
1. In the CRES, you linked your new line to the practical at 0x7, but the package already had a line 0x7. If you click the dropdown menu in the blocklist in cres, you see that 0x0-0x16 were already in use. I changed your slot line to 0x17.

2. Your line's cObjectGraphNode name was route_1_e. The string you added in Model Bones was named deco. Those two things need to have the exact same name, so I changed your cObjectGraphNode to deco.

3. The I9 value in the SLOT box should match the string number your deco slot in Model Bones. So, I changed I9 to 29.

I think I forgot to change this, but your I10 should be one number higher than the largest I10 in the package. So, if the largest I10 number is currently 15, and you add another slot, it should have an I10 of 16.

Might not be totally clear, but the freezer bunny is in your slot. You'll just have to do some adjustments. Actually, you should check on all the numbers you used for the boxes in the SLOT. Because the deco object isn't where I'd expect it to be, based on the values you have in your translation box in the CRES. Copy the numbers from an end table's SLOT.
Screenshots
Download - please read all instructions before downloading any files!
File Type: zip CorbyLoveseat_Mesh_wslot.zip (829.2 KB, 7 downloads) - View custom content
Test Subject
Original Poster
#3 Old 15th Oct 2016 at 1:50 PM Last edited by pikkonoloidlee : 15th Oct 2016 at 3:29 PM.


thanks so much. I'll take a look at it. c:

eta: after I fixed the slot it wouldn't let me select the mesh but I got that fixed too and everything seems to be in working order. thanks again! I probably couldn't have done this without you.
Top Secret Researcher
#4 Old 15th Oct 2016 at 5:27 PM
Glad to help.
Back to top