Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

Nysha's New Creators for November - posted on 1st Dec 2017 at 10:00 AM
Replies: 202 (Who?), Viewed: 158212 times.
Page 1 of 9
˙uʍop ǝpᴉsdn ǝɹ,noʎ 'oN
Original Poster
#1 Old 28th May 2011 at 9:47 PM Last edited by cmomoney : 31st Aug 2012 at 3:08 AM.
Default Testers Wanted: Blender 3D 2.6 GEOM Tools(now imports rig)

What it's for...

This script is for importing/exporting hair and clothing into Blender 3D 2.6. I would appreciate any help in testing and comments/suggestions.


Installation:

Note: Download is now a zip file, and Blender can install directly without extracting.

1. Download the "io_TS3_geom.zip" and put it where you can find it.
2. Start Blender and go to File->User Preferences(or press CTRL+ALT+U).
3. Click the "Add-Ons" button at the top of the User Preferences window.
4. Click the "Import/Export" button on the left, then click the "Install Add-On" button at the bottom.
5. Navigate to where you extracted the file and select the "io_TS3_geom.zip" and click "Install Add-On". Sims 3 GEOM Import is added to the the list.
6. Click the check box to the right of the TS3 Tools in the list. The importer is added to the File->Import menu, and the TS3 GEOM Tools panel is added to the Properties Editor under Scene.

Importing:

Start Blender, and in the Properties editor under Scene, click the Import button in the TS3 GEOM Tools panel or go to File->Import->Sims 3 GEOM. Navigate to the your folder and select the .simgeom file. You can also import more than one file at once.
To import with rig:
You will need the Rig Editor(attatched below, I will give it its on thread soon)
In the Import Geom options(in the left panel towards the bottom) select the rig to be used with the GEOM(if you don't have the Rig Editor, no rig will be loaded, but GEOM will still load).

Exporting
With the GEOM mesh selected, click the Export button in the TS3 GEOM Tools panel or go to File->Export->Sims 3 GEOM. Then select the original file in the browser. The original file will be made into a .bak file, and a new file will be created with the original name.

Update:ver1.2(5.28.12)
-updated for 2.63
-fixed for multiple UVs, now works correctly on animals

Update: ver1.1(3.5.12):
-committed rig import with GEOM. Download is now a .zip file, since Blender can install from zip and put everything where it needs to go.
-added Seam Fix

Update: ver1.0.2 (12.23.11):
-fixed bug that lost certain bone assignments

Update: ver1.0 (12.21.11):
-added export
-add future functionality to import rigs(when rig editor is released)
-import/export correct tangents(thanks Wes)

Update:9-16-11
-added check for empty vertex id list
Screenshots
Download - please read all instructions before downloading any files!
File Type: zip io_TS3_geom.zip (64.0 KB, 8069 downloads) - View custom content
File Type: rar io_TS3_rig.rar (4.9 KB, 4732 downloads) - View custom content

"Part of being a mesher is being persistent through your own confusedness" - HystericalParoxysm
| ( ◡)| (❍ᴥ❍ʋ) [◕ ‿ ◕]
Advertisement
Forum Resident
#2 Old 29th May 2011 at 4:18 AM
Okay, I installed it and loaded a .simgeom. Yay!

I'd been tinkering with something similar, and got as far as writing the
UI stuff. Would you like a copy of what I've got? It filters for .simgeom
files, making it easy to find them in a directory which may have several
other files, such as .dds etc. It also doesn't leave the funny blue thing
on the menu when it's unchecked. (circled in green in attachement)

Other than that,
Screenshots
˙uʍop ǝpᴉsdn ǝɹ,noʎ 'oN
Original Poster
#3 Old 29th May 2011 at 4:05 PM
Okay, now it filters for .simgeom and removes itself from the menu when disabled. Now that you mentioned it, I need to to that to the my other tools. Thanks, lenglel.

"Part of being a mesher is being persistent through your own confusedness" - HystericalParoxysm
| ( ◡)| (❍ᴥ❍ʋ) [◕ ‿ ◕]
Forum Resident
#4 Old 30th May 2011 at 1:25 AM
That's great! (man are you quick!)

But, I got an index out of range in parsefile when loading this geometry:

S3_015A1849_0020033C_00000000AF383E53_amFace_lod0_2%%+GEOM.simgeom

that's not so good, but on the plus side I loaded the feet, bottom and top okay. Does a
single mesh need to be contiguous in blender? I think it might, and this one has the teeth
seperate from the rest of the head.
˙uʍop ǝpᴉsdn ǝɹ,noʎ 'oN
Original Poster
#5 Old 31st May 2011 at 5:44 AM
Okay, fixed that also.

"Part of being a mesher is being persistent through your own confusedness" - HystericalParoxysm
| ( ◡)| (❍ᴥ❍ʋ) [◕ ‿ ◕]
Forum Resident
#6 Old 31st May 2011 at 10:06 AM
Yup, loads without errors now. This next one is minor, but I've noticed I have to
disable and reenable your plugin in user preferences to get it to show up on the
import menu when I first start blender. Even though it's checked it doesn't show
up when I first start blender. Weird. When I install it I uncheck the old version
in user preferences then delete it from blender's add-ons directory. Then I
restart blender and install the new one from where I've unzipped it, saving
the preferences as default. I don't think it has to do with the way I've installed
it, but I'm not ruling it out. What do you think?
˙uʍop ǝpᴉsdn ǝɹ,noʎ 'oN
Original Poster
#7 Old 31st May 2011 at 11:31 AM
Well, you don't have to do all that anymore. You can just install it again, and there is an option to overwrite it which is checked by default(scroll down on the left after clicking 'install addon'). Although i fixed that error, I screwed up the bone assignments/weighting in the process. Somewhere in that mesh I'm losing a bone, which is causing the out of of range. I'll have to look at it some more...

"Part of being a mesher is being persistent through your own confusedness" - HystericalParoxysm
| ( ◡)| (❍ᴥ❍ʋ) [◕ ‿ ◕]
˙uʍop ǝpᴉsdn ǝɹ,noʎ 'oN
Original Poster
#8 Old 2nd Jun 2011 at 7:57 AM
Okay, I got that worked out, so those meshes should import without error and with proper assignments/weighting.

"Part of being a mesher is being persistent through your own confusedness" - HystericalParoxysm
| ( ◡)| (❍ᴥ❍ʋ) [◕ ‿ ◕]
Forum Resident
#9 Old 2nd Jun 2011 at 7:14 PM
Busy coping with latest patch, will get back to this.
Forum Resident
#10 Old 15th Sep 2011 at 12:42 AM
Woo hoo it's there! Thank you very much
I'll let you know how it is over the course of making a hair

Disclaimer: These are the personally, personal opinions of me, myself and I. Yours may vary.
Terms & conditions do not apply
Forum Resident
#11 Old 16th Sep 2011 at 7:24 AM Last edited by missy harries : 16th Sep 2011 at 8:12 AM.
Hiya, everytime a base hair mesh is loaded I get these error's

The hair still load's though : )


EDIT: The GEOM import also disappears from the import tab once blender has been shut down, it has to be re-loaded from user preferences on every start up.
Screenshots

Disclaimer: These are the personally, personal opinions of me, myself and I. Yours may vary.
Terms & conditions do not apply
˙uʍop ǝpᴉsdn ǝɹ,noʎ 'oN
Original Poster
#12 Old 16th Sep 2011 at 2:47 PM
Thanks!

I've updated to remove that error. It wasn't hurting the mesh any, more of a UI problem.

As for the script reloading, if you want it to be there when you open Blender, you have to save you user preferences after you enable the script. Don't save it in the User Preferences window. Just start Blender, open the User preferences window and enable the script. Then close the User Preferences window, and go to File->Save user settings.

"Part of being a mesher is being persistent through your own confusedness" - HystericalParoxysm
| ( ◡)| (❍ᴥ❍ʋ) [◕ ‿ ◕]
Lab Assistant
#13 Old 16th Sep 2011 at 8:21 PM
So far I'm having no issue loading clothing, As you said, the bone assignments are correct. Sadly, I'm not really well versed on what I should be looking for error wise. I'll keep playing around and report any issues, unless there's another way I could be helpful.
˙uʍop ǝpᴉsdn ǝɹ,noʎ 'oN
Original Poster
#14 Old 16th Sep 2011 at 10:20 PM
Quote:
Originally Posted by pandaseal
So far I'm having no issue loading clothing, As you said, the bone assignments are correct. Sadly, I'm not really well versed on what I should be looking for error wise. I'll keep playing around and report any issues, unless there's another way I could be helpful.


Thanks, pandaseal. Really, if there is an error, Blender will happily let you know, believe me. I just needed to know that it is working on various CAS parts before I moved on to the exporter.

"Part of being a mesher is being persistent through your own confusedness" - HystericalParoxysm
| ( ◡)| (❍ᴥ❍ʋ) [◕ ‿ ◕]
Test Subject
#15 Old 16th Oct 2011 at 9:46 PM
I got an error when I try to import this specific hair .simgeom file. I tried a couple other .simgeom hairs before and was fine (with blender 2.49 and the geom script) but for this hair I got errors from both 2.49 and 2.59 and hair won't load. Maybe someone can try the file and see if i'm doing anything wrong? I extracted the .package with s3pe.
Screenshots
Download - please read all instructions before downloading any files!
File Type: rar peggyhair.rar (5.40 MB, 117 downloads) - View custom content
˙uʍop ǝpᴉsdn ǝɹ,noʎ 'oN
Original Poster
#16 Old 16th Oct 2011 at 10:22 PM
Something is wrong with the GEOMs in that package.

"Part of being a mesher is being persistent through your own confusedness" - HystericalParoxysm
| ( ◡)| (❍ᴥ❍ʋ) [◕ ‿ ◕]
Test Subject
#17 Old 10th Nov 2011 at 1:03 AM
Is there any kind of feedback in particular you are looking for? I've been messing around in Blender a little, and I would love to help if I can. I'm using a mac, I don't know if that matters or not though.
Test Subject
#18 Old 13th Nov 2011 at 8:57 PM
Got it to work, hurry up with the export, i need it ASAP. Thanks
Test Subject
#19 Old 25th Nov 2011 at 2:12 AM
Quote:
Originally Posted by missy harries
Hiya, everytime a base hair mesh is loaded I get these error's

The hair still load's though : )


EDIT: The GEOM import also disappears from the import tab once blender has been shut down, it has to be re-loaded from user preferences on every start up.


I have the same problems. So far, I've only gotten this thing to work with clothes meshes for bottoms and tops. Full-body clothes meshes don't work with this addon for me. I've tested this with at least 3 dresses, 1 EA-made and 2 custom made, with the same results - the same errors you recieved with the hair and none of the dresses showed up in Blender.

As for the GEOM import option disappearing, it's very annoying to turn the addon on and off everytime I open Blender, I agree on that, but I can live with it once I can use full-body meshes with Blender...
Test Subject
#20 Old 29th Nov 2011 at 6:51 PM
Default export
Are you going to do the export? Please do it!
Test Subject
#21 Old 10th Dec 2011 at 6:35 AM
umm...dumb question from noob please
if it only does import, how can we ever use the stuff we created here on our sims? i'm sorry if i haven't read thru completely everything nd missed a point, please link me there if u can
also,
thankyou so so so much for the lovely add-ons nd stuff
Test Subject
#22 Old 18th Dec 2011 at 10:05 PM Last edited by Mama0607 : 18th Dec 2011 at 10:17 PM.
Quote:
Originally Posted by yusra347
umm...dumb question from noob please
if it only does import, how can we ever use the stuff we created here on our sims? i'm sorry if i haven't read thru completely everything nd missed a point, please link me there if u can
also,
thankyou so so so much for the lovely add-ons nd stuff


If I read the thread right, there wasn't enough feedback coming in for the plugin he was trying to create for him to keep going.

I think I read that in another thread in the forums.

If you really want to keep creating, you could get the older version of Blender and get the import/export plugins for that version. I am doing that. Milkshape isn't worth 35 dollars at the moment. I don't know if that is still a valid option. I read it somewhere that you could do that.

Found it: http://www.modthesims.info/showthre...5#startcomments
Then it comes here because that one was outdated.

DER:/My Brain/Empty.exe
˙uʍop ǝpᴉsdn ǝɹ,noʎ 'oN
Original Poster
#23 Old 19th Dec 2011 at 6:52 PM
Actually, I have been working pretty hard on the export part, but I've run into some problems with clothes, so I'm not ready to sharing it for testing yet. I do having it working for accessories though, I made these glasses while testing.
Screenshots

"Part of being a mesher is being persistent through your own confusedness" - HystericalParoxysm
| ( ◡)| (❍ᴥ❍ʋ) [◕ ‿ ◕]
˙uʍop ǝpᴉsdn ǝɹ,noʎ 'oN
Original Poster
#24 Old 21st Dec 2011 at 8:35 PM
Updated to add export.

"Part of being a mesher is being persistent through your own confusedness" - HystericalParoxysm
| ( ◡)| (❍ᴥ❍ʋ) [◕ ‿ ◕]
Test Subject
#25 Old 22nd Dec 2011 at 9:43 PM
So far it seems to work without any problems.
Page 1 of 9
Back to top