Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

New Creator Theme: Elders! - posted on 1st Sep 2018 at 11:43 AM
Replies: 7 (Who?), Viewed: 5004 times.
Test Subject
Original Poster
#1 Old 29th Jul 2017 at 3:53 PM
Default [sims3/TSRW/Blender]Create clothes with Blender
I have export a dress mesh with TSRW into .obj file. I edited it with Blender. At this point, all worked fine. But when I import the new mesh to TSRW, it didn't work. The tool didn't import the new mesh, I have an error message.
I made a lot of test with a friend, and we arrived at the conclusion that the problem is with Blender.
I tried :
* with the most recent version of Blender and the 2.6,
* with the last version of TSRW and an old version,
* to import a mesh into Blender and export it without edited it, but it didn't work.
* to rename the group "group 0" and "group 1" with and without this script : https://wiki.blender.org/index.php/...name_Datablocks

Could you help me ? If it's possible, I don't want to use MilkShape3D.

Puffin McMuffin
staff: administrator
#2 Old 31st Jul 2017 at 1:19 PM
Hmm well, the thing is, because the plugins are quite broken, you're basically forced to do everything in Blender>Milkshape> game instead of Blender>game. Renaming things somehow never worked for me, and I know the blender tools should fix that, although the blender tools seem to only work with texture related things sadly, and not with.. well, bones related things, etc. Which is a shame.

So... Milkshape 3D in this case is basically the part where you make things 'game ready' Blender is actually where you make the meshes and prepare it for Milkshape. It's kind of sad, since I would rather have done everything in Blender as well, or a different program like Maya... :/

Also here are the blender tools I was referring to: http://modthesims.info/d/433882
Test Subject
Original Poster
#3 Old 31st Jul 2017 at 4:29 PM
Thank you for your help.
I asked the same question on TSR, and they said that a plugin exist on the TSRW files : C:\Program Files (x86)\The Sims Resource\TSR Workshop\Extras\Blender 2.74
The plugin works. But I can't import the edited wso in TSRW.
Puffin McMuffin
staff: administrator
#4 Old 3rd Aug 2017 at 8:35 PM
I've always had issues with the TSRW blender tools as well, I do know however that, this one is still very compatible and working really well: http://forums.thesimsresource.com/i...texport-script/

Sadly... I guess regarding Blender, I don't think there's a way to fully create things with it unless someone fixes/creates a new script for it. I would have done it long ago if I had more experiences in writing 3D programming scripts, especially for Blender in this case

Although... one thing that you could try is getting an older version of TSRW if you happen to have the latest one, because the latest one is very much broken: http://simfileshare.net/download/206613/
Test Subject
Original Poster
#5 Old 4th Aug 2017 at 10:18 AM
I will try with 3DS Max.
I tried with the older version of TSRW and the problem is still there. When I import the wso into TSRW, I have a "dictionnary key" error.
Test Subject
#6 Old 7th Aug 2017 at 1:45 AM
how do I create clothes
Test Subject
Original Poster
#7 Old 7th Aug 2017 at 11:11 AM
I tried the plugin with 3DS Max, but it didn't work. I think it's because I don't have the right update. What is the version of 3Ds Max do you use ?
I used 3DS Max 2017.
Puffin McMuffin
staff: administrator
#8 Old 7th Aug 2017 at 6:37 PM
I actually still have the 3DS max 2011 version, that one still seems to be compatible. I know after the 2013 versions, the script doesn't really seem to like 3Ds max as much
Back to top