Replies: 9 (Who?), Viewed: 2781 times.
just a girl
Original Poster
#1 Old 2nd Dec 2017 at 8:06 AM
Default Mesh inside out
Mesh looks like it's inside out. Screenshots are from SimPE, but it's the same in game.

I started to suspect problems when Blender refused to unwrap it saying that "it has negative scale and unwrapping works only on unflipped version of the mesh". I haven't flipped anything, not on purpose anyway. About the scale - the mesh was very big when I started and I had to scale it down quite a bit. So, I could have reduced the scale, it's small, but - negative? Can it be fixed without starting all over? I've done a lot of work on it already - reduced polys manually, tweaked shape, added parts. I'd like to save it.
I looked up some answers. Tried to flip normals by Ctrl-N and by Recalculate Normals Outside. Nothing seemed to happen.
Field Researcher
#2 Old 2nd Dec 2017 at 5:24 PM
You may already know this, but if you press "N" in 3D View EDIT MODE to open the properties menu, you can scroll down that menu until you find the heading "Mesh Display", subheading "Normals", and click on the third little cube. That will allow you to see the directions of the normals on all your individual faces. Then you can select the offending faces and flip their normals individually. (This is easier to do if you are in face select mode- not as many wrong things to click on in your way.)

Scaling something smaller very often will flip your faces if you're not extra vigilant. If the above doesn't work, a more tedious (but still easier than restarting) way is to re-mesh just the messed-up section. Make a second copy of your mesh to work on so you don't lose what you have. Then, in object mode, add a new cube or sphere or whatever starting mesh fits the area you need to rebuild. Select this new mesh object, enter edit mode, and move the vertices to the exact spots of your original, being sure not to cross any edges in a way to flip the normals. When happy with that, go back to your original and delete the bad part, then go back to object mode and join the new re-meshed part to your original mesh to replace the deleted part.
just a girl
Original Poster
#3 Old 3rd Dec 2017 at 7:30 AM
Thanks, d4RE.
I looked at normals directions. They looked outside ("hairy"). So I tried to recalculate them INside and it seems promising. I guess, I was confused which way was the right way. I thought they should look outside. Blender still says the scale is negative, but the mesh looks better in SimPE preview. Will get back after I test in game.
Field Researcher
#4 Old 4th Dec 2017 at 3:51 PM Last edited by d4RE : 4th Dec 2017 at 3:59 PM. Reason: typos and brainfart
For most things, they should be outside. Another thing I didn't think to mention, however, is to make sure to unwrap your mesh so it can be mapped to a texture. I *think* that an unwrapped mesh can also present as negative. Just this week , I had some weirdness on a staircase because I had added some new parts to a mesh I had already mapped but forgot to unwrap the new parts. Here's a decent tutorial if you're unsure what I'm talking about:

Another quick fix is to just run it through UV Mapper or similar program, and resave it.
just a girl
Original Poster
#5 Old 4th Dec 2017 at 5:16 PM
Can I leave them inside? Will that cause any problems? I briefly tested in game and I don't see the internals now, so it seems all right.
For unwrapping I followed this one:
Do you know any good tutorials on texturing? With shading and everything. As of now, my object looks pretty cardboard. I'm not exactly an artist, but I might have to do this, if I don't find anyone to outsource it to.
Thank you for answering
Mad Poster
#6 Old 4th Dec 2017 at 11:11 PM
As far as I know, UVmapping (done in the same program you're meshing in) shouldn't make the mesh show inside-out.

However, if you're using Blender and you're exporting the mesh as OBJ, you're in for some trouble if you don't do it right. When exporting from Blender to another program via an OBJ file, always tick "write normals" and "smooth groups" to the left.
just a girl
Original Poster
#7 Old 5th Dec 2017 at 7:53 PM
I fixed the inside-out thing with normals inside. The question is - can I leave them inside or is it a bad thing that'll bork something later?
Field Researcher
#8 Old 5th Dec 2017 at 11:22 PM
Unless you're dealing with some sort of concave object, it's probably better to have your normals outside. Remember, the side the normal is facing is the side that will be textured. In the game, the reverse side (negative normal direction) will appear invisible, see-through, or nothing there at all, unless you cover it with another face.

Experiment with what you have so far, and see if it looks like you want in game. If not, you can then flip the normals back out. If you need more help, I'll be glad to look at your blender file or .obj file and see if there's something else going on. Also, there's a version of JWoods' beginner tutorial co-written with Lethe_S that is specific to using Blender. Some of it is confusing, but there is some great info on the stetings to use when exporting files from Blender to Sims 2. Lethe_s' Bender tute Start to finish tute
just a girl
Original Poster
#9 Old 6th Dec 2017 at 10:00 PM
Originally Posted by d4RE
In the game, the reverse side (negative normal direction) will appear invisible, see-through, or nothing there at all, unless you cover it with another face.

Funny, it seems to be exactly the opposite in my case. When normals were outside they were invisible and see-through in the game.
Thank you. I will see how it goes. My first texture is crappy, so maybe I don't see the consequences of flipping all that well.
Mad Poster
#10 Old 6th Dec 2017 at 10:58 PM
If you need parts to show both sides, you should make those mesh parts two-sided. The easiest way is to mark and duplicate the faces to a new group, then flip the faces, and fix the normals. When everything is fixed, combine the groups into one.

There is one setting that can work in ihe TXMT for showing both sides of a mesh, but I've had mixed results with it.
Back to top