Home | Download | Discussion | Help | Site Map | New Posts | Sign in
Replies: 18 (Who?), Viewed: 8998 times.
Test Subject
Original Poster
#1 Old 5th Apr 2011 at 12:09 AM
Default Pregnant Hero Sim won't give birth
So my monarch sim is pregnant and she moans and screams and the icon appears in the queue, "Have the baby," but then she just stands there till she starves to death. I can't cancel out of it, I can't interact with anything. I'm really new to the game so is there anything I can do to get her to progress past this?! And I looked in the tech help part of this site and couldn't find anything btw. Is there a cheat that will reset her, or if I play as another hero will she just continue on and have the baby (or is she frozen in time while I'm playing another hero?). I'm missing my inTeenimator hack from Sims 2! Any thoughts or help or direction would be appreciated!

~~Kaytebb

PS She was in the middle of a quest so... (sigh) I can quit the quest but it doesn't solve my problem if she's going to KEEP doing this and if every female sim is going to do this!
Advertisement
Field Researcher
#2 Old 5th Apr 2011 at 12:48 AM
I've had two of my female heroes give birth with no problems. It sounds like you're seeing a glitch (and a rather unpleasant one at that).

Have you tried quitting the game and loading it up again? Sometimes this fixes stuff.

If you have testingcheats enabled, you could try force reset on her. No idea if it would help though. :/
Test Subject
#3 Old 5th Apr 2011 at 1:53 AM
My Physician sometimes will go to bed and unable to get off the bed and "relax" for days or years.

I think you are seeing a glitch, if force reset doesn't work you might have to forgo that save and start from earlier save and see what's up.
Scholar
#4 Old 5th Apr 2011 at 1:59 AM
You could try Save & Quit, then load the game and see if the problems been fixed. It's worked for me with my Monarch who got stuck during labour and for my Blacksmith who was just stuck.
Test Subject
#5 Old 5th Apr 2011 at 2:36 AM
I had this problem too... I tried to save and quit but it tells me "you can't save during a birth" so i had to just quit. when i reloaded, my save was from when she was already pregnant, so i tried to have the baby again...same thing. i had testingcheatsenabled and tried to force reset her but it didnt work. now i have a new "abstinence only" kingdom... sad, lonely... but safe i'm saving my pregnant queen's kingdom though, just in case another patch might fix it...*hopes*
Lab Assistant
#6 Old 5th Apr 2011 at 2:46 AM
Quote:
My monarch got stuck in labour. She stood next to her bed for 25 hours before I gave up. I couldn't get her to do anything and it said resetsim was an unknown command, no matter what name or combination I tried. ):
I do have testingcheats enabled. Otherwise she might have starved and/or passed out sooner.
I didn't try any shift-clicking or "resetsim *" or cancelling her "have baby" action and maybe I should have let her pass out. I dunno. :/

Again, stuck in labour. This time it's my wizard. I've shift-clicked and tried forcing a reset. Several times. She can walk a few steps and then the have baby action pops back into her queue. I tried moving her with moveobjects. I moved her downstairs and I moved her just outside, as far as I could.

Surely having testingcheats enabled isn't affecting pregnancy at all. Is there some kind of prerequisite quest you have to do before you can have babies?

I really, really need some kind of fix for this. My monarch has gone flat black and is still stuck. She won't pass out, she won't starve to death. It just keeps resetting the starving debuff. I need to talk to her for a quest but I can't do anything. The action just drops from my queue.

I see we still don't have a solution for this. I was kind of hoping the patch would fix it... Has anyone had this problem after patching?
Screenshots
Test Subject
Original Poster
#7 Old 5th Apr 2011 at 9:16 PM
Yeah I tried leaving and coming back but when you're playing with the sim in labor as your main I ran into the same problem, "You can't save during a birth." I finally had to quit without saving and come back. I had to quit the quest she was in and went in as another hero sim. She went into labor but still ended up just standing there and I also ran into problem of someone needed to interact with her for a quest and she didn't respond. So I saved and quit again and came back, still there. I haven't tried testingcheatsenabled yet. I actually with mmallory89's solution last night just to keep playing and set the messed up kingdom aside and have an abstinence only kingdom playing right now. What I haven't tried is having anyone else in the Stuck Kingdom try having a child yet. So I don't know if this problem is universal or just that one sim.

thepantherprincess, I have the 1.1 patch but that's the only one I can find on the EA website. And I didn't have the testingcheatsenabled on when my sim went haywire so I don't think that had anything to do with it. I asked my friend who has played this game WAAAAAY too much since it came out (cause I thought maybe I was missing a prereq too, the cradle, which I couldn't find in furnishing mode (she explained), or a quest) and she said, nope you just have a baby and the cradle appears and tada, you're a parent. And so far my sim has never passed out or died cause the action appears in her queue, but it's always behind the "Have Baby" action and since she can't seem to do that, she never gets on with the pass out action. (sigh)

It is, oddly, comforting I'm not the only one having this problem. If others are having it too then perhaps there will be a patch out soon.
Test Subject
#8 Old 6th Apr 2011 at 12:37 AM
Before installing the 1.1 patch i had no problem with giving birth. My heroes had children many times. After I installed the patch, this unfortunate glitch occured.

I tried with various heroes, I've been waiting for baby to born up to 10 sim days, I tried with cheats but no solution. As I see on official EA forums, some people experience this glitch, hope EA team solve this soon :'(
Lab Assistant
#9 Old 6th Apr 2011 at 1:05 AM
It seems to me that my heroes just take plain forever to give birth. Everything I click during that time tells me my Sim is too heavy with child to do that. I think I did actually slide her hunger bar up during the last one to keep her from starving and she eventually gave birth after a very long (almost a full day) time of standing and groaning. Maybe just waiting it out and cheating a little bit is the way around this glitch.
(A little OT, but I love how medieval Sims nurse their babies. )
Test Subject
Original Poster
#10 Old 6th Apr 2011 at 7:01 AM
Quote:
Originally Posted by ~Alyx~
It seems to me that my heroes just take plain forever to give birth. Everything I click during that time tells me my Sim is too heavy with child to do that. I think I did actually slide her hunger bar up during the last one to keep her from starving and she eventually gave birth after a very long (almost a full day) time of standing and groaning. Maybe just waiting it out and cheating a little bit is the way around this glitch.
(A little OT, but I love how medieval Sims nurse their babies. )


It does take a while but if you read the previous comments you'll note people say stuff their sims stand there for weeks and days, so we're not talking a patience problem here, it's a glitch. Like I said before, I'm glad others are having it because it's more likely to get fixed with an official EA patch.

I saw a picture of that, I thought that was cute too! The "Too heavy with child" to sit down or lie down that was a little annoying.
Test Subject
#11 Old 6th Apr 2011 at 8:46 AM
I had this happen twice. Both times I had to restart my game. One was before the patched game and one was after. I tried a third time for my Sim to have a baby...she did stand in same place..squealed for maybe 30 seconds then did nothing. Reset or anything else did not work. I even tried to kill her by sliding bars all the way down. It kept saying she was starving, but she never died. I thought if that happened, I could save the game, but then, I didn't want to not be able to have babies. I finally completely uninstalled and reinstalled the game and I haven't had a problem since...although, I didn't patch my game yet because I'm not having problems. I think the way EA put the babies in the game is stupid. Then when they grow up to be children, its boring...they can't be played, you can't change their clothes or pick their traits. After having a few babies, I don't use the family trait anymore because since the kids don't grow and they just roam the city, they are boring. Just my opinion though.
Instructor
#12 Old 6th Apr 2011 at 10:03 AM
You can change their clothes by making them selectable and directing them towards a dresser, and you can change their traits (shift-click on them to get the "change traits" option, I think)... aaand you can grow them up if you have the "edit in CAS" mod.


"Deep down I'm pretty superficial"

Lab Assistant
#13 Old 11th Apr 2011 at 5:57 AM
Anyone find a fix for this yet? I've got two NPC wives now who are utterly useless. I can't reset them, it just goes a second without being pregnant then makes them pregnant again. I would even just be glad to kill them so my heroes could remarry but I don't see a mod that can do that yet.

Edit: Well divorce works, but still, now I've got two NPCs in my game who are useless :\
Lab Assistant
#14 Old 17th Apr 2011 at 6:55 AM
I still need this too. I've pretty much left that kingdom in limbo and started a new one. I can't do anything at all with my silly stuck monarch. ):
Test Subject
#15 Old 18th Apr 2011 at 12:55 PM
Default Baby won't be born
I have the same problem. I was reaching the end of the "A heir for the kingdom" (or sth like that) quest and my monarch sim was going into labour. Suddenly, after all the screaming, she just stood there and no baby popped out... Like it has been posted for another player, it't not a matter of patience, as she's been standing there for days.
I've tried the "resetSim Name Surname" cheat, but won't work. I can't delete her or any objects being used by her (at the moment the give birth action began, she was puting a plate on a table).
Of course my game is modded. I have testingcheatsenabled on. So, this is all I could think of for now. I really did not want to reset my quest. I just want her to have the baby so I can carry on.
Thank you.
Test Subject
#16 Old 19th Apr 2011 at 7:03 AM
i had the queen get pregnant but before the baby was born i had finished that quest had a pop up saying baby boy is born what do you want to name it, Ill check this out didn't relieve they had cheats in this
Lab Assistant
#17 Old 21st Apr 2011 at 5:22 PM
My monarch did the quest about the witch and he married her and she got pregnant and I finished the quest and it let me go on and save and... I'm pretty sure I added her to the family at some point but I must have removed her. Several quests later, I played the monarch again and now it's telling me I can't save during the birth of a Sim. I've finished some quests and moved on and she's not in anyone's family but I still can't save and this is driving me crazy. I've accomplished so much but I can't save my progress.

Someone said divorce worked for them but my only option when clicking on her is call over. How can I divorce her if she's stuck? Is there any kind of mod that would let me outright kill her? I thought maybe I could get her to jump in the pit but pregnant Sims can't do that. ):
Instructor
#18 Old 21st Apr 2011 at 6:50 PM
Did you try inviting her over from the mail box?

"Deep down I'm pretty superficial"

Lab Assistant
#19 Old 22nd Apr 2011 at 6:32 AM Last edited by thepantherprincess : 22nd Apr 2011 at 7:20 PM.
She says, "I need to take care of something else right now. Sorry!" :/

I used up all my quest points, achieved my platinum ambition, and did the new kingdom quest. I still couldn't save but when I went to the main menu, it had counted my achievements and stuff. When I started a new ambition, the hero I did the new kingdom quest with was there and waiting and I was able to save in that kingdom. And now I'm using the no pregnancy quest so I shouldn't have to worry about this again. ]:
Back to top

Section jump