Home | Download | Discussion | Help | Site Map | New Posts | Sign in
Replies: 3 (Who?), Viewed: 9107 times.
Test Subject
Original Poster
#1 Old 28th Sep 2010 at 2:42 AM

This user has the following games installed:

Sims 3, World Adventures
Default Sims 3 Black Screen after Launch - Task Manager "Not Responding"
Hi - I am at my wits end. I have read through tons of forums, and tried a billion things. Please help..

I was running Sim 3 w/ World Adven, High-End Loft, & Ambitions (installed in that order) with loads of downloaded mods, .package, and CC - no problems.

While downloading CC yesterday - I went to install a batch via the Launch screen (downloads > select all > install) and instead of running the Sims 3 logo before the install window, I got a black window with an hour glass. Opened task manager and saw : Sims 3 Not Responding. So I shut it down, and shut down the Launcher (which WAS responding). Restarted the Launcher and attempted to just Start the game. Launched the window to open the game, but now entire black screen & hour glass. NO Sims 3 logo, no crash to desktop, opened task manager : Sims 3 Not Responding. So I shut it all down.

Now being no stranger to PC's and Sims functionality - I updated DirectX to version 11 - installed latest Nvidia graphics and tried again with the same outcome. Next - I removed all CC, .package, and mods from the game - same outcome. Finally - I uninstalled all Sims 3 games/expansions and just installed the Sims 3 base game and patch to current version: 1.15.34.008001. Same outcome - black screen, shows "Not Responding" in task manager.

I do not know what else to do - yes, my PC can handle the game. I bought the PC with Sims 3 requirements in mind, but in case you ask DxDiag attached - I had to remove some of the info to cut the document size, but all the important stuff should be there.

What else can I do?

Thanks - any suggestions are appreciated.
Download - please read all instructions before downloading any files!
File Type: txt DxDiag.txt (6.7 KB, 42 downloads) - View custom content
Advertisement
In the Arena
staff: senior moderator
#2 Old 28th Sep 2010 at 11:56 AM
Default MTS2 Staff Reply
  • Sims 3 - EADM Issues
    If you encounter issues while downloading Store/Exchange items or when trying to patch or Launcher won't even start, then maybe the issues is not the Launcher but EADM. Please try the suggestions on this FAQ article:

If you have disc version of Ambitions as well, let's try to isolate if the issue is with EADM/Launcher or the game. Try Game_Help:TS3_Bypassing_the_Launcherwiki.

If you get an error, post back here with the error. If no error and get an unresponsive program, try the above suggestions for EADM issues. Or you could even try bypassing Launcher again with no EADM installed.

You remembered to remove caches when you removed CC?
And that troubleshooting after the reinstall (with registry and leftover folders cleanup after uninstalling?) - is with a new set of user folders and a new game or a save game with user folders intact?

Spec-wise: CPU+RAM combo is good. The GPU might be OK in its day (for a midrange card), but it may be showing its age when more packs are added; as at this time it is 6 generations away from the current GTX 4xx series.
What settings are you playing on? Have you checked for overheating, cleanup dust from around the fans/inside casing, etc?
Test Subject
Original Poster
#3 Old 2nd Oct 2010 at 12:12 AM
Hello - I have actually uninstalled the EADM and get the same result from the game (black screen w/ hourglass "not responding" in task manager).

In response to the "Ambitions" I have uninstalled it and removed all of it's cache/content/folders - ALL of it. No change in the game's response.

Good call, because I absolutely forgot about cache files. I have removed all of the caches, everything from C:\Program Files\Electronic Arts\The Sims 3\Mods\Packages and C:\Program Files\Electronic Arts\The Sims 3\Downloads. When I tested the game after deleting all of that - VOILA! Started up with only a short delay.

Now - I can only assume the CC somewhere along the line caused the problem, so I have decided to troubleshoot backwards by reinstalling little chunks of CC until I find the culprit(s). This will take a while as I have nearly 1000 .package files and perhaps more Sims 3 Packs.

Can you tell me - is it safe to assume that one of the .package files caused the meltdown? I have never had any game issues with the Sims 3 Packs. If so - it would cut my troubleshooting time/effort in half.

I can promise, the GPU is just fine, I've been playing on it and steadily adding packs without a single issue. I keep my PC clean (as to the dust) and cool because I work in IT and know heat is never technology's friend.

Looks like the CC cache was the issue after all - I will post what specifically caused the issue if/when I find it.

Please let me know your opinion/knowledge regarding .package vs. Sims3Packs causing errors.

Thanks so much!!!
Moderator
staff: moderator
#4 Old 3rd Oct 2010 at 6:08 AM
Issues can be caused by either sims3packs or package files. If the issue was resolved by deleting the cache files, then it is rather likely that a package file was originally at fault. Have you tried Delphy's Dashboard Tool?
Back to top

Section jump