Home | Download | Discussion | Help | Site Map | New Posts | Sign in
Replies: 4 (Who?), Viewed: 3010 times.
Test Subject
Original Poster
#1 Old 1st Oct 2010 at 3:45 AM
Default Game running slow.
Yesterday I installed Sims 3, was playing it and it worked fine. However, when I installed it, I used the advanced option thing and placed the files on the desktop. Then it worked, but something went wrong and mods were not working. So I re-installed it and I then placed it in my Program Files.

NOW I can add mods, but the game does not load fast at all, if it does.
I went through all your troubleshooting processes, deleted cache and mods and such. Still is loading slow.

It takes about 5min for it to load the open video, the load screen is another 5mins. Then I click my town and it takes I don't know how long...but very long then. HELP!
Advertisement
Banned
#2 Old 1st Oct 2010 at 5:32 PM
Custom content / mods make any game load slower... but although I have 2GB of CC I haven't noticed my game to load slower (The Sims 3 that is, The Sims 2 loads incredibly slow due to CC).

May I ask what are your system requirements? (CPU, GPU, RAM, OS, HDD)

In the Arena
staff: retired moderator
#3 Old 1st Oct 2010 at 5:40 PM
Default MTS2 Staff Reply
  • Sims 3 - Game lags or fails to load or is glitchy
    Issues
    1. Have you just updated to a newer patch or installed a new Expansion Pack and/or Stuff Pack?
    2. Do you suddenly find your game is failing to load past the loading bar or after selecting your save game? Or does it take hours to load when previously it only took minutes?
    3. Do you experience glitches like
      • missing books, traits, cannot carry out skill-related activities, etc
      • have long strings name with paths instead of the objects' names
      • missing previously installed content
      • missing interactions with objects and Sims
      • and many more


    Causes
    Then, you have custom content that is not compatible with this new game version or is broken/corrupted by the patching/installing.
    If you have a core mod that is not compatible, the game would simply crash back to Desktop.


    Solution
    Remove ALL custom content, not just selective content! Do the steps in Game_Help:Sims_3_Game_Problemwiki.


    Fixing your game
    • If the problem is with .packages CC (ie. you needed only to move the \Mods\Packages\)
      • If the new game can load, then read this FAQ on how to rectify the Lag issue and to find the problem content: Game_Help:Package_File_Lagwiki.
      • Identifying the problem content - Game_Help:TS3_Finding_Problem_Custom_Contentwiki.
      • Once you which know which content caused the glitch, you'd need to revisit the site where you get the .packages from to see if there's a new update or if they need to be discarded as they are no longer compatible.

    • If the problem is with .Sims3Packs CC (ie you needed to rename the user files)
      • Try running Dashboard on the DCBackup folder to see if it can detect anything wrong with those .packages
      • Or if you want to test Sims3Packs one-by-one, you can use CUSTARD (Alpha testing, Windows only) by Delphy in the Modding forum
      • Otherwise, you'd need to revisit the site where you get the Sims3Packs from to see if if there's a new update or they need fixing, etc.

    Remember: during all the above testing, always load a new game to test (you can however load the same new game if you saved that). Never load a pre-patched or pre-EP/SP saved game as removing custom content and caches will reset all the custom content in that world to base-game items and it won't load them back if you happen to Save before you Quit.

Test Subject
Original Poster
#4 Old 1st Oct 2010 at 9:44 PM
Quote:
Originally Posted by TheeCakee
I went through all your troubleshooting processes, deleted cache and mods and such. Still is loading slow.


The only reason I conspired today is that it was the patch. 1.15 or something, after that the game went extroidnarly slow. I deleted all mods including the actual mod folder.
Moderator
staff: moderator
#5 Old 3rd Oct 2010 at 7:14 AM
Default MTS2 Staff Reply
  • Sims 3 - Verify 1.12/AMB Mods folder and resource file
    1. What is your gameversion? Game_Help:TS3_Patching_Find_Gameversionwiki

      Copy and paste the first line of the skuversion.txt from the following locations, for whichever games you have:
      C:\Program Files\Electronic Arts\The Sims 3\Game\Bin
      C:\Program Files\Electronic Arts\The Sims 3 <EP or SP name>\Game\Bin

      Quote:
      BG: GameVersion =
      WA: GameVersion =
      HEL: GameVersion =
      AMB: GameVersion =
      FL: GameVersion =
    2. Take a screenshot of:
      • Documents\Electronic Arts\The Sims 3\
      • Documents\Electronic Arts\The Sims 3\Mods\
      • Documents\Electronic Arts\The Sims 3\Mods\Packages
      ... and attach them to a post on this thread. Click Go Advanced and then Manage Attachments.
      We have a guide on how to do this if you need assistance: Game_Help:Screenshotswiki.

      Make sure you set your folder view to Details mode and expand out the Name and Type columns so they're fully readable.

    3. Open your Documents\Electronic Arts\The Sims 3\Mods\resource.cfg file in Notepad and copy-paste its contents here.

    4. Right-click on Resource.cfg and check Properties. Is the file name Resource.cfg or Resource.cfg.txt or something else?

post the information above for each of the games you have installed. Clearly you have some sort of issue, not sure though if it's an installation issue or not.
Back to top

Section jump