Home | Download | Discussion | Help | Site Map | New Posts | Sign in

Latest Site News

MTS Speed-Building Challenge - posted on 17th Oct 2018 at 7:25 PM
Replies: 31 (Who?), Viewed: 28272 times.
Page 1 of 2
Test Subject
Original Poster
#1 Old 4th Nov 2013 at 6:46 AM
Default Zephyr Monorail on CAW: How to make it work on custom worlds?
Since I installed Into the Future, I notice that the Zephyr pillar was showing in the CAW list, HOWEVER, the Station (Zephyr Stop) itself in not on the game catalog (even with buydebug activated) nor CAW object list (I may have overseen it, but I believe it isn't).

Thinking that the monorail would be a great add to any custom world, I tried to make it work on mine and I did several things:
1)Save on the catalog the Zephyr Stations from Oasis Landing (after unlocking them with enablelotlocking true).
2)Place several stations on CAW and connected each one with the pillars.
3)Note: each station has specific names to them that derive from the lot's name, or you can rename them (I was with testingcheatsenabled true).
4)Open the world ingame and the Stations AREN'T SELECTABLE AT ALL. None option is showed upon clicking them.

I thought that there was some codding behind the pillars that enabled then to connect,with each other, but it seems it isn't the case and some hidden tool must be behind it. Can anyone check it or has the stations working by any other means? Maybe NRaas shows some hidden option to connect the stations, but what about the pillars?

Thanks in advance
(sorry if this isn't the correct fórum to ask this stuff, but even if I'm a member since 2006, I'm relatively new to the fórum área and things have changed pretty much since my join date, thanks again)
Advertisement
Test Subject
Original Poster
#2 Old 4th Nov 2013 at 7:18 AM
I'm starting to think that the Train's route itself has nothing to do with the pillars (as they seem to be decorative only by the way you can mess with them in edit town and, in CaW, you can alter their X Y Z values, making me doubtifully think that placing any pillar sideways would make the train go crazy), so, there must certainly be a hidden tool that would enable you to work it out just as an invisible sidewalk (but I guess it could be place in any height, or it just has a pre-estabilished height and all you do is place the path on the ground, as Oasis Landing path looks pretty plain to me except the one that goes over the water).

Maybe a point and click tool linked to the pillars? Maybe an invisible object placed on the ground? Can someone check it out, please?

You can't believe anything I say... specially what I just said...
dodgy builder
#3 Old 4th Nov 2013 at 8:21 AM
You need to go to create/create-a-world in the top menu. There is a start on a thread there. I don't have ITF, but I think it's the same subject so just post there.
Mad Poster
#4 Old 4th Nov 2013 at 9:39 AM
Skimming through the CAW forum, I found this interesting thread http://www.modthesims.info/showthread.php?t=514432

Quote:
Originally Posted by ellacharmed
The Train Station shell is not enabled for CAW. In s3oc/s3pe shows the BuyDebug setting has an "unused44" in the flags, and I suppose it is newly added as the Wiki does not have this category documented. Which would explain why this shell does not show up when other shells (the gallery and lounge shelIs) do. I was playing around with it as I was poking around the world in CAW to check routing, how the states are triggered and stuff, so I have done some edits.

If you guys want I'll share it in the In-Game CAW enabled objects thread. I was reluctant to do so as I had also edited the STBL for the White Fence (which is duplicated, as Riverview fences had the same names). And this would cause a conflict if other users have STBL mods in their games. But then, I suppose CAW-users would know what to look out for to start troubleshooting, especially if I mentioned this fact up front. I just need to do a couple more quick tests first.

I don't know if removing that "unused44" flag would have any impact? Ideas, anyone? On how to test for this?

Resident member of The Receptacle Refugees
Let's help fund mammograms for everyone. If you want to help, Click To Give @ The Breast Cancer Site Your click is free. Thank you.
One horse disagreer of the Apocalypse
#5 Old 4th Nov 2013 at 10:03 AM
I would imagine you may have to lay some sort of invisible route for the carriage as well. And if that's not available to us in CAW laying the stations may be a waste of time.

"You can do refraction by raymarching through the depth buffer" (c. Reddeyfish 2017)
Alchemist
#6 Old 4th Nov 2013 at 2:19 PM
According to Twallan's GoHere Revision Note version 39, "Routing by hover train has been unlocked for any type of world, not just the Future World, provided you have the objects in town".

Could it mean anything to the ZEPHYR?

Just call me Nikel
Test Subject
Original Poster
#7 Old 4th Nov 2013 at 3:04 PM
Quote:
Originally Posted by nikel23
According to Twallan's GoHere Revision Note version 39, "Routing by hover train has been unlocked for any type of world, not just the Future World, provided you have the objects in town"


Hope restored... it could be! Where are mah damn testahs!

You can't believe anything I say... specially what I just said...
Lab Assistant
#8 Old 4th Nov 2013 at 5:04 PM Last edited by PWN9483 : 7th Nov 2013 at 5:55 PM. Reason: added detail
.INI file in Oasis Landing contains the pathing
Here's what I found and it works! Yes it works, without designating your world a Future World that you travel to.
You can do this on any world you like, just add the .ini file with YOUR coordinates.

The .INI file in Oasis Landing contains the pathing to make your "rail" work
S3_1F886EAD_00000000_83E573E2653731B0%%+_INI (file attached to this post below)

From the file
Quote:
;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
;; This file defines spline paths for elevated train travel
;;
;;
;; Each path is defined as a set of control points. Each point
;; has the following format:
;;
;; [I_T]
;; Position = (x, y, z)
;; RollAmount = (x, y, z)
;;
;; I is the integer index of the path.
;;
;; T is the time in seconds at which this point is hit - the first
;; point in the path should have a time of 0.
;; the RollAmount angles are a float format,
;; defined in degrees.
;;
;;
;; Also note that each path *must* contain at least 2 points.
;;
;; The game expects that each path connects to the next and that the final path
;; connects to the first, making a circular track in the world.
;; Stations for elevated train paths also will store an index and that index
;; must match the index of the path with it's starting point at that station,
;; with station 0 connecting the highest numbered path back to path 0.
;;
;; Example, 3 stations:
;; Station 0 - connects paths 0 and 2
;; Station 1 - connects paths 0 and 1
;; Station 2 - connects paths 1 and 2

;; Tunables
[tunables]
VelocityScalar = 1.75

;;First Path
;; Wasteland Station to Neighborhood Station
[0_-1]
Position = (521.7461, 7.0, 1231.30859)
RollAmount = 0.00

[0_0]
Position = (526.7461, 7.0, 1236.30859)
RollAmount = 0.00

et.


The object to search for in CAW is called "Elevated Transport Rail", this is under the Environment section, you place these between stations.

In YOUR .ini file, enter positions X, Y, Z, from each elevated transport rail. Numbering order makes a difference in which direction the train will travel.

Until we can get the Station objects to show in CAW, just open sims3, save the station lot(s) to your bin library then place the lot while in CAW/EIG (Edit in Game).

Note: Placing the pre-made station lots, in CAW when you create the lot to place these on, leave them as Commercial Lot: Community, Lot Type: Community. When you're in CAW and open EIG (Edit in Game) if they are tagged as no visitors allowed or visitors allowed they won't accept placement of the station lot you copied from Oasis Landing.

Open CAW then open your .INI file and basically enter each coordinate from the station, to the next elevated transport rail, then the next, et.
For your station, use the LOT coordinates, you don't need to enter the coordinates of the building in the lot, just the lot itself.

Just replace the coordinates in the attached file with your coordinates, then use S3PE , open your world from S3PE, then import resource from file (the .INI with your coordinates) and save the world from S3PE. Then export your world from CAW. That's all you need to do to make your rail work, it's really that easy!

In my test, I crossed over roads and had no issue with the use of the train or the cars that drive on the road below. Have connected 5 stations and elevated transport rails between. Have
elevated transport rails at unequal distances such as one segment that crosses over water and that works.

Reading comments below, I too wait until just before export to use S3PE to import the various .INI files. My process is a bit more complicated, in brief, I clean the global layer, open CAW, then Edit in Game, add my custom Sims back in (makesim and NRaas porter), with testing cheats enabled type, "restartmotives" for the added sims, check that lot names are as intended, check that any custom debug settings on effects such as pigeons remain, then save, exit edit in game which drops it back into CAW, rebuild routing data, save, quit. Then use SP3E to import various .INI files and save. Then open CAW without opening the world and export it. I have yet to try the following with this build, still waiting on SuperCAW for this release but here's a post on using SuperCAW and having the .INI files save with the game.

Regarding station and the two nearest elevated transport rail alignment. If these aren't aligned, the train basically seems to skip past the station, still works, just looks weird.

Note: Routing data must be complete
If your .INI file in your exported world isn't complete, if a Sim attempts to use the train - for me - the game locks up, so make sure all your train station to elevated transport rail connection data is accurate.

When you're testing, I've found that setting the Velocity to around 0.75 helps, otherwise the default speed the train goes so fast it's hard to judge how well you positioned the elevated transport rails.

Note: Non-Routing effects rail
I did an experiment, created a station and house, enclosed it with non routable paint, created another station and market for the sim trapped in the non routable area to go. The sim wouldn't even enter the train station, it gave the tapping foot non route emote. I removed the non routable paint, retried and the sim went in the station and to the next to get to the market. I also had to do a pass through on my over all non routable paint areas, I found that leaving about a 15 paint brush size around the elevated transport rail pylons and their pathing seems to work fine.

> > > Modders a challenge for you < < < - Hoping to see a mod that enables and pushes townies to use the train.
Download - please read all instructions before downloading any files!
File Type: zip S3_1F886EAD_00000000_83E573E2653731B0%%+_INI.zip (2.1 KB, 218 downloads) - View custom content
Description: Oasis Landing Elevated Transport Rail .INI file
Alchemist
#9 Old 4th Nov 2013 at 5:20 PM
Why do they always have to lock features and make it exclusive to one world only? Where's the modularity? Remember the shallow water level that's not suitable for dive lots? Remember the hidden islands? Remember the lot surrounded by lake instead of sea level, so boats are practically worthless in Twinbrook?

Sorry, I ranted.

Just call me Nikel
Test Subject
Original Poster
#10 Old 4th Nov 2013 at 6:36 PM Last edited by lucashc : 4th Nov 2013 at 7:04 PM.
Quote:
Originally Posted by PWN9483
Here's what I found and it works! Yes it works, without designating your world a Future World that you travel to.
You can do this on any world you like, just add the .ini file with YOUR coordinates.


God among man is what you are, my friend!
(its going to be a hell of a work, but Imma gonna do it, thanks)

How can I get that INI file? Or is it the entire file you "guoted"?

Another question: do you think the lot must be a station lot, or it can be any type of lot (like the subway stations, tha can be placed on any lot)? I had made this buildings with the Zephyr on its top floor you see...

You can't believe anything I say... specially what I just said...
Lab Assistant
#11 Old 4th Nov 2013 at 6:44 PM Last edited by PWN9483 : 4th Nov 2013 at 6:58 PM.
Quote:
Originally Posted by lucashc
God among man is what you are, my friend!
(its going to be a hell of a work, but Imma gonna do it, thanks)

How can I get that INI file? Or is it the entire file you "guoted"?

Attached the file to my post above for you

Just replace the coordinates in the file with yours, then use S3PE , open your world from S3PE, then import resource from file (the .INI with your coordinates) and save the world from S3PE. Then export your world from CAW. That's all you need to do to make your rail work, it's really that easy!

Easy comes with options, RollAmount really means will the train bank at an angle when on a turn et.
Direction is set by your numbering order, [0_-1] is the start from your first station, [0_0] is the first elevated rail, [0_1] the second, et.
Theorist
#12 Old 4th Nov 2013 at 7:55 PM
Hmm. good work. If we can set the roll amount, then possibly we can alter the height of the vehicle too? Rail trains!

#BlairWitchPetition
TS3 NEEDS: TENNIS COURTS > BUSES > PIGS/SHEEP
Can't find stuff in build and buy mode? http://www.nexusmods.com/thesims3/mods/1/?
Test Subject
Original Poster
#13 Old 5th Nov 2013 at 2:15 AM
Quote:
Originally Posted by PWN9483
Attached the file to my post above for you

Just replace the coordinates in the file with yours, then use S3PE , open your world from S3PE, then import resource from file (the .INI with your coordinates) and save the world from S3PE. Then export your world from CAW. That's all you need to do to make your rail work, it's really that easy!


I may have got something wrong... my Zephyr stations aren't working at all... first I discovered that even if you put the INI file into your world before exporting it in CaW, the INI vanishes after the exporting is done, which means that before installing tha world I need to re-import the INI file. Besides that, I should have experienced success. All Zephyr lot were tested both in "Visitors Allowed" and "Station Lot" (last one only avaiable in CaW). Please, take a look at my INI to see if I got something wrong:

Tunables
[tunables]
VelocityScalar = 1.75

;;First Path
;; Chinatown Stop to Park Stop ->((these are 2 lots actually named "Zephyr Station - Chinatown" and "Zephyr Station - Park", both station also have the same name as the lot))
[0_-1]
Position = (1016, 57.01674, 1542.99988) ->((the actual Chinatown station lot coordinates, not the station itself))
RollAmount = 0.00

[0_0]
Position = (1071.39661, 61.27175, 1568.28577) ->((bellow here are the pillars))
RollAmount = 10.00

[0_1]
Position = (1123.43164, 63.60906, 1602.20239)
RollAmount = 0.00

[0_2]
Position = (1172.52942, 70.09317, 1635.75415)
RollAmount = 0.00

[0_3]
Position = (1205.51892, 70.649, 1660.81482)
RollAmount = 10.00

[0_4]
Position = (1229.66028, 64.80995, 1682.541)
RollAmount = 0.00

[0_5]
Position = (1258.14026, 63.7642937, 1707.87268)
RollAmount = 0.00

[0_6]
Position = (1281.005, 64.85544, 1727.438)
RollAmount = 0.00

[0_7]
Position = (1309.3125, 70.10855, 1739.79138)
RollAmount = -10.00

[0_8]
Position = (1336.506, 79.6045, 1746.44043)
RollAmount = -20.00

[0_9]
Position = (1360.5, 76.9119, 1748.20178)
RollAmount = -15.00

[0_10]
Position = (1386.45239, 65.38763, 1750.8147)
RollAmount = -8.00

[0_11]
Position = (1416.6156, 59.2553062, 1752.62524)
RollAmount = 0.00


;;Next path
;; Park Stop to Light Stop ->((the Light Stop is actually named "Zephyr Station - Light District" and the station also have the same name as the lot))

[1_-1]
Position = (1436, 58.9691162, 1718) ->((the actual Park station lot coordinates))
RollAmount = 0.00

[1_0]
Position = (1479.0321, 59.1792946, 1758.91858) ->((bellow here are the pillars))
RollAmount = 5.00

[1_1]
Position = (1497.22778, 59.1792946, 1769.3927)
RollAmount = 10.00

[1_2]
Position = (1554.18176, 59.1792946, 1813.21716)
RollAmount = -10.00

The route finishes here as I didn't created more stations for them to form a circle, nor I connected the last one to the first one. Maybe that's the problem? I dunno...

You can't believe anything I say... specially what I just said...
One horse disagreer of the Apocalypse
#14 Old 5th Nov 2013 at 8:12 AM
The custom inis always get deleted when you export from caw and need adding back to the package afterwards. Also you do have to make a complete circuit for it to work. I don't think you need more than two stations but the route you write does have to end up by joining up to the first station again,

"You can do refraction by raymarching through the depth buffer" (c. Reddeyfish 2017)
Test Subject
Original Poster
#15 Old 5th Nov 2013 at 7:17 PM
Quote:
Originally Posted by Inge Jones
The custom inis always get deleted when you export from caw and need adding back to the package afterwards. Also you do have to make a complete circuit for it to work. I don't think you need more than two stations but the route you write does have to end up by joining up to the first station again,


The x_-1 coodinate is the last pillar from the previous path or it is the Station lot location? I presumed (maybe wrongly) that the X_0 coodinate was the first pillar but now I have doubts and I'm beginning to think it was actually the Station location... I'm confused...

You can't believe anything I say... specially what I just said...
One horse disagreer of the Apocalypse
#16 Old 5th Nov 2013 at 7:57 PM
the -1 bit is the time. I guess you have to make the last entry have the highest time, even though it will be the same point as the starting point which has the time of -1. I am pretty confused by why the time doesn't start at 0 though.

It looks to me like in the oasis landing one, the last three points overlap the first three.


x is the path index. A path appears to be the route between two stations. So between the first two stations, x is 0, between the next two it's 1.

"You can do refraction by raymarching through the depth buffer" (c. Reddeyfish 2017)
Top Secret Researcher
#17 Old 5th Nov 2013 at 11:41 PM
Excellent information PWN, thanks!

As to the disappearing INIs, that's long been a problem in CAW, as Inge said. After a final save of my world, I then would import the INIs via s3pe, then open CAW again *without opening the world* and Export. At least, that used to be the way around it.
Test Subject
Original Poster
#18 Old 6th Nov 2013 at 1:55 AM
Quote:
Originally Posted by Inge Jones
the -1 bit is the time. I guess you have to make the last entry have the highest time, even though it will be the same point as the starting point which has the time of -1. I am pretty confused by why the time doesn't start at 0 though.

It looks to me like in the oasis landing one, the last three points overlap the first three.


x is the path index. A path appears to be the route between two stations. So between the first two stations, x is 0, between the next two it's 1.


What I meant was... what coordinate is what?
In the original INI we have:

;;First Path
;; Wasteland Station to Neighborhood Station
[0_-1]
Position = (521.7461, 7.0, 1231.30859)
RollAmount = 0.00

[0_0]
Position = (526.7461, 7.0, 1236.30859)
RollAmount = 0.00

[0_1]
Position = (530.749, 7.0, 1240.3859)
RollAmount = 0.00

The first three coordinates, which is the last pillar of the last path, which is the first Zephyr Station and which is the first path pillar?
I suspect:

[0_-1]: last path last pillar

[0_0]: staion coordinate

[0_1]: first path pillar

And maybe the three overlapping coordinates are just a way to tell the game "Hey, this thing is a freaking circle, OK?"

Would that work? Because everything I tried so far failed... If this do the trick, I might do a Guide for CaW builder about Monorails, because this stuff is maddening...

You can't believe anything I say... specially what I just said...
Eminence Grise
#19 Old 6th Nov 2013 at 3:47 AM
Very helpful! Thanks for all the info!

Moved to CAW forum
One horse disagreer of the Apocalypse
#20 Old 6th Nov 2013 at 8:48 AM
Yes lucashc that is what I was trying to say. So you put the same last three coordinates at the end making a circle. But you do need to have a different index and time (the [index_time] in the square brackets) that belongs to the end leg of the journey. Don't copy the [index_time] numbers from the start, just the positional and roll values.

"You can do refraction by raymarching through the depth buffer" (c. Reddeyfish 2017)
Lab Assistant
#21 Old 6th Nov 2013 at 11:28 AM
Awesome information. Was dreading that it would be something coded into the object and not the world, Definitely going to finish off my monorail set now cause I'm less then impressed by hovering carriages.
Now to figure out how to go from sketchup to sims 3...

I haven't installed the expansion yet and won't be able to for another week or two but do the carriages turn between the posts or at the posts?
One horse disagreer of the Apocalypse
#22 Old 6th Nov 2013 at 11:41 AM
From looking at it in the xml, as it appears to be one second granularity, I reckon it probably does it each time it reaches one of those entries, orientates itself pointing to the next target coordinate (it's how sims do it when routing). That would explain why the list begins at the coordinate before the beginning station, so that it arrives at the platform straight. I didn't look at the coordinates very closely but if my theory is correct, the one before and after the station should be in a straight line with it to prepare the train to be lined up straight.

"You can do refraction by raymarching through the depth buffer" (c. Reddeyfish 2017)
Test Subject
Original Poster
#23 Old 7th Nov 2013 at 3:48 AM
I'm still struggling to make this monorails stuff Works, but after hours I can't seem to make it work at all...

Every path has the last 3 coordinates exactely the same as the next path's first 3 coordinates
Last path has the last 3 coordinates exactely the same as the first path's first 3 coordinates
[0_-1], [1_-1], [2_-1], [3_-1], [4_-1] and [5_-1] are the Zephyr Station lots coordinates (used to be the last Elevated Transport Rail from the previous path, didn't work)
[0_0], [1_0], [2_0], [3_0], [4_0] and [5_0] are the first Elevated Transport Rail in each path (used to be the Zephyr Station lots coordinates , didn't work)
"X"_1, "X"_2," X"_3 and beyond are all Elevated Transport Rails
The route is both aesthetically and a functional circle route
None Elevated Transport Rail is inside any lot

The Zephyr Stations are still not selectable at all and I can't imagine why this isn't working... can anyone take a look at my INI file to see if the problems lies anywhere else?
Losing my sleep by now...
Download - please read all instructions before downloading any files!
File Type: rar Nova Lindalva monorail.rar (2.3 KB, 63 downloads) - View custom content

You can't believe anything I say... specially what I just said...
One horse disagreer of the Apocalypse
#24 Old 7th Nov 2013 at 7:57 AM
You have the overlap as I understand it should be, but the roll amount should maybe be 0 at the station. I am undecided now whether the station should be the _-1 or the _0 you could try both and see if it makes a difference.

"You can do refraction by raymarching through the depth buffer" (c. Reddeyfish 2017)
Lab Assistant
#25 Old 7th Nov 2013 at 3:23 PM
Quote:
Originally Posted by lucashc
The Zephyr Stations are still not selectable at all and I can't imagine why this isn't working... can anyone take a look at my INI file to see if the problems lies anywhere else?
Losing my sleep by now...


I find that selecting something nearby, the place you want to go works. My sims will use the rail to get there, I just can't select to go to a station directly. Perhaps something the GoTo feature of NRaas will eventually accommodate?
Page 1 of 2
Back to top