Locked thread | Replies: 19 (Who?), Viewed: 30778 times. | Locked by: joandsarah77 Reason: Old and solved
Lab Assistant
Original Poster
#1 Old 24th Jul 2014 at 9:38 PM
Default Black square under Sim?
I get this graphical bug:


What causes this, and how do I get rid of it? :/
Advertisement
Top Secret Researcher
#2 Old 24th Jul 2014 at 9:39 PM
Go to Options, Graphics/Performance Options, and change "Shadows" to either Medium or High.

If that doesn't help, try updating your graphics drivers. See here for more info.
Alchemist
#3 Old 24th Jul 2014 at 9:46 PM
It's fun to see a Swedish player! // Swede
Lab Assistant
Original Poster
#4 Old 24th Jul 2014 at 9:54 PM
Quote:
Originally Posted by k6ka
Go to Options, Graphics/Performance Options, and change "Shadows" to either Medium or High.

If that doesn't help, try updating your graphics drivers. See here for more info.


Its already on high.
Tried to change it to all settings, didnt remove/change it at all.

And please dont come here trying to say to upgrade drivers. I am far more advanced user than that.


Quote:
Originally Posted by ZenGarden
It's fun to see a Swedish player! // Swede


Gött
Field Researcher
#5 Old 24th Jul 2014 at 10:06 PM
Quote:
Originally Posted by totte1015
Its already on high.
And please dont come here trying to say to upgrade drivers. I am far more advanced user than that.


No need for all that snarkiness, you came here to ask help and you got it. If you're such an advanced user then why didn't you try to lower the settings to medium or read the link?
Here's two solutions.
Lab Assistant
Original Poster
#6 Old 24th Jul 2014 at 10:08 PM
Problem is that current driver version is "340.43"

And they want me to downgrade to "320.49"???

Thats like... several years of updates, and it may not even work on my 780 :/
And it will certinally screw up other games :/
Undead Molten Llama
#7 Old 24th Jul 2014 at 10:12 PM
Quote:
Originally Posted by totte1015
Its already on high.
Tried to change it to all settings, didnt remove/change it at all.

And please dont come here trying to say to upgrade drivers. I am far more advanced user than that.


You asked for help; don't be rude when people try to give it to you. They have no idea how "advanced" of a user you are or aren't.

The fact of the matter is that a graphics card driver update is what caused this issue in the game, which was never designed to work with the sort of graphics detail that is possible now.. Usually, changing your shadow settings to medium rather than high fixes the issue. If not, you may need to change your driver to an older version or...I believe HystericalParoxysm gave someone else a link to other information about this issue recently. Have a look in other fairly recent threads.

I'm mostly found on (and mostly upload to) Tumblr these days because, alas, there are only 24 hours in a day.
Muh Simblr! | An index of my downloads on Tumblr.
Needs Coffee
retired moderator
#8 Old 24th Jul 2014 at 10:14 PM
Quote:
Originally Posted by totte1015
Its already on high.
Tried to change it to all settings, didnt remove/change it at all.

And please dont come here trying to say to upgrade drivers. I am far more advanced user than that.


if you want to be rude, go fix it yourself. She probably meant medium to low as that fixes most.

"I dream of a better tomorrow, where chickens can cross the road and not be questioned about their motives." - Unknown
~Call me Jo~
Meet Me In My Next Life
#9 Old 24th Jul 2014 at 10:49 PM
@ >> Totte1015 >> I had the same problem ( I send you a PM as to what to do ) I will say what need to be done here as well, incase other members have this problems.
Very simple go into your game enter a household go to "Graphic / Performance Options" go to "Shadows" place it in medium.
Then at the bottom you will notice a count down of numbers ( click on the save option there below the number ) before the count down end. That it finish. Black Square will be gone.

NOTE: You can also turn your Shadows off if you want, but placing in medium will do the job.

"Nothing in life is a Surprise it just happen to come your way at the time".
Lab Assistant
#10 Old 24th Jul 2014 at 11:14 PM
Turn the Shadows off.
Top Secret Researcher
#11 Old 25th Jul 2014 at 10:52 PM
Shouldn't this have been under Help?
Née whiterider
retired moderator
#12 Old 25th Jul 2014 at 11:49 PM
yeah, that probably would have avoided the snarkfest.

What I lack in decorum, I make up for with an absence of tact.
Lab Assistant
Original Poster
#13 Old 26th Jul 2014 at 11:40 PM
I do not know what is going on here, I changed all my graphic settings to Low and it did NO difference impact on game at all

Turning shadows off didnt even turn the shadows off...

Why is the graphic settings not applying even tho I press apply, and i press Yes on keep settings?
Field Researcher
#14 Old 26th Jul 2014 at 11:51 PM
You can edit the GraphicsRules.sgr file, I think. I'm not sure what you change but it should be somewhere on the internet.

Edit: If you go here and scroll down a bit you'll see another solution.
Meet Me In My Next Life
#15 Old 27th Jul 2014 at 12:07 AM
@>> Totte1015>> There is a "Game Help" section you really need to post there for help. I do not know what going on in your game as I said when I had this Black square problem it was only the shadow it was too high.

"Nothing in life is a Surprise it just happen to come your way at the time".
Lab Assistant
DELETED POST
27th Jul 2014 at 11:14 AM
This message has been deleted by sims 1.
world renowned whogivesafuckologist
retired moderator
#16 Old 27th Jul 2014 at 11:22 AM
Quote:
Originally Posted by sims 1
always use the newest driver for your card to ensure all games work. but as far as drivers go you may need to try to plug your monitor into the motherboard default video source on the back of the computer and pull your video card out before you play the sims to stop the shadow sorry but you will have to take the computer case off to do that or


What? No! NO! Do not do this - there is NO REASON AT ALL to pull your video card physically out before playing TS2. Do not do this.


Fix black shadows under your sims' feet

This works even with brand spankin' new graphics cards not recognized by TS2!

1) Easy solution: Turn your in-game graphics settings for shadows to Medium.

2) Almost as easy (like, 2 minutes) but better solution: Edit your GraphicsRules.sgr files to change shadows just on sims. Instructions are here, under "Windows 8: Black Shadows Box Issue" - it says "Windows 8" but this is not just a W8 issue so if you have something other than W8, do it anyway. The path for what you need to change is above that, in step 2. If you have all EPs/UC, you'll need to edit the file in the Mansion & Garden Stuff folders.

my simblr (sometimes nsfw)

“Dude, suckin’ at something is the first step to being sorta good at something.”
Panquecas, panquecas e mais panquecas.
Inventor
#17 Old 27th Jul 2014 at 11:45 AM
I have the same problem, and the only fix I've found is the one HP posted above; change shadow settings to either medium or less.
Test Subject
#18 Old 13th Sep 2017 at 2:31 AM
Default Yep
Quote:
Originally Posted by totte1015
I get this graphical bug:


What causes this, and how do I get rid of it? :/
I get this isue Too the comments helped tho
Forum Resident
#19 Old 13th Sep 2017 at 2:37 AM
*sigh* http://modthesims.info/download.php?t=569585
Don't resurrect three year old threads, especially when there's already a solution for that problem!

"Exijo una explicacion!"
Needs Coffee
retired moderator
#20 Old 13th Sep 2017 at 2:40 AM
@Moiyalilly please don't resurrect old threads unless you have some new information to add to it that others will want to know about.

"I dream of a better tomorrow, where chickens can cross the road and not be questioned about their motives." - Unknown
~Call me Jo~
Locked thread | Locked by: joandsarah77 Reason: Old and solved
Back to top