Replies: 16 (Who?), Viewed: 4525 times.
Lab Assistant
Original Poster
#1 Old 30th Dec 2015 at 3:34 PM

This user has the following games installed:

Sims 2, University, Nightlife, Open for Business, Pets, Seasons, Bon Voyage, Free Time, Apartment Life
Default direct 3d returned an error: d3derr_outofvideomemory! the application will now terminate
Hi! I've googled this problem, and I found one solution that was deleting some userprops file. Well, I did that, but Sims 2 still crashes sometimes when I go to buy new clothes and browse through the catalog, or when I just browse through hairstyles etc with the mirror (changing appearence). Did anyone else have this problem and maybe managed to fix it, or do I just have to accept that windows 10 and Sims 2 will never be friends?
Advertisement
Test Subject
#2 Old 30th Dec 2015 at 10:03 PM
Have you tried the graphics fix?

If you're Dirk, I want to be your Lilith. <3
Top Secret Researcher
#3 Old 30th Dec 2015 at 10:18 PM
Remove your Downloads folder (if there is anything that shouldn't be removed, like the epcheck mod, custom food, or nosimloaded, leave those there). Clear your cache files. I second bb18's post, have you tried the graphics fix with the graphics rules file so it can detect your card?

Info on deleting your cache files here:
http://modthesims.info/wiki.php?tit...ete_Cache_Files

Not-so-daily TS2 downloads @ my simblr.
Lab Assistant
Original Poster
#4 Old 31st Dec 2015 at 10:34 AM
Sorry, what graphics fix? I must've missed that.
Lab Assistant
Original Poster
#5 Old 31st Dec 2015 at 2:35 PM
Are you guys talking about "Graphics Rule Maker"? I found some article from simsnetwork.
The Great AntiJen
retired moderator
#6 Old 31st Dec 2015 at 4:27 PM
Quote:
Originally Posted by Vermin
Are you guys talking about "Graphics Rule Maker"? I found some article from simsnetwork.

Yes, though there are some ready-made fixes as well as that programme (which is very useful btw).

Have a look at this page too:
http://www.leefish.nl/mybb/showthread.php?tid=5446

tflc is my tumblr with uploads not uploaded here: https://www.tumblr.com/blog/tflc
and my site, tflc: https://littlecarping.com/mybb/

Polgannon: Who Murdered Blaise Penhaligan?
(3rd ed. neighbourhood now available with corrections). Poll: http://strawpoll.me/6689876
Lab Assistant
Original Poster
#7 Old 3rd Jan 2016 at 2:38 PM
I don't understand. I used the graphics rule maker and the game was running fine for a few play sessions. Now, while moving in a family, it just crashed. And I spent 2h today filling up my neighborhood, so it isn't related to moving in new families since it worked 90% of the time. I got the usual outofmemory-error. Do I run graphics rule maker again and remove userprops?
Mad Poster
#8 Old 3rd Jan 2016 at 3:17 PM
We need your computer spec, what cpu you have, how much ram and what video card you are using.

If you don't know how to find out what you have then please run a DirectX to gen up a report and attach a copy here.

To run DirectX Diagnostic Tool
Open DirectX Diagnostic Tool by clicking the Start button Picture of the Start button, typing dxdiag in the Search box, and then pressing ENTER.

All my Beginning Hoods here at MTS. http://www.modthesims.info/member.php?u=7749491
All my Beginning Hoods as Shopping Districts plus Old Town. http://www.modthesims.info/download.php?t=523417
MooVille, a tribute to Mootilda and her fabulous lots http://www.modthesims.info/download.php?t=534158
Lab Assistant
Original Poster
#9 Old 3rd Jan 2016 at 3:35 PM
I hope this is what you're after

Time of this report: 1/3/2016, 16:33:48
Machine name: HANNA
Operating System: Windows 10 Pro 64-bit (10.0, Build 10586) (10586.th2_release.151121-2308)
Language: Swedish (Regional Setting: Swedish)
System Manufacturer: MSI
System Model: MS-7821
BIOS: V10.3
Processor: Intel(R) Core(TM) i5-4670K CPU @ 3.40GHz (4 CPUs), ~3.4GHz
Memory: 8192MB RAM
Available OS Memory: 8126MB RAM
Page File: 3483MB used, 5922MB available
Windows Dir: C:\WINDOWS
DirectX Version: 12
DX Setup Parameters: Not found
User DPI Setting: Using System DPI
System DPI Setting: 96 DPI (100 percent)
DWM DPI Scaling: Disabled
Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Not Supported
DxDiag Version: 10.00.10586.0000 64bit Unicode
Mad Poster
#10 Old 3rd Jan 2016 at 6:46 PM
That is only part of it.
If you run the DirectX there should be a report that you can attach here.

We still need to know what video card/onboard you have for this computer.

Your cpu and ram is great so just need to know what video you are running.

ADD: I think you may be running into the User Account Control problem and you may want to try this.

http://www.simbology.com/smf/index.php?topic=8984.0
Quote:
Originally Posted by marka93 @Simbology
To get mods to work in 8/8.1 some players need to turn off "User Account Control" and change both the programs folder and My Doc. folder for the UC to read and write other wise the OP system will stop mods from working.

1. Disconnect from the internet then turn off "User Account Control". *(Or UAC.)
2. Restart your computer.
3. Check after restart that UAC is turned off.
4. Change Program folder for UC to read and write.
5. Some times it takes a restart for this to take effect.
6. Change My Doc. for UC to read and write.
7. Some times it takes a restart for this to take effect.
8. Now try your mods and if they work then restart your computer.
9. Check again that mods are working, if so then turn back on UAC and reconnect back to the internet..

All my Beginning Hoods here at MTS. http://www.modthesims.info/member.php?u=7749491
All my Beginning Hoods as Shopping Districts plus Old Town. http://www.modthesims.info/download.php?t=523417
MooVille, a tribute to Mootilda and her fabulous lots http://www.modthesims.info/download.php?t=534158
Lab Assistant
Original Poster
#11 Old 3rd Jan 2016 at 7:12 PM
AMD Radeon 390!
Quote:
Originally Posted by marka93
That is only part of it.
If you run the DirectX there should be a report that you can attach here.

We still need to know what video card/onboard you have for this computer.

Your cpu and ram is great so just need to know what video you are running.

ADD: I think you may be running into the User Account Control problem and you may want to try this.

http://www.simbology.com/smf/index.php?topic=8984.0
Mad Poster
#12 Old 3rd Jan 2016 at 11:19 PM
It looks like you have a great card so the game should run great so I am now thinking its the Windows 10 problem and following the direction up in post 10 may work for you.

All my Beginning Hoods here at MTS. http://www.modthesims.info/member.php?u=7749491
All my Beginning Hoods as Shopping Districts plus Old Town. http://www.modthesims.info/download.php?t=523417
MooVille, a tribute to Mootilda and her fabulous lots http://www.modthesims.info/download.php?t=534158
Lab Assistant
Original Poster
#13 Old 3rd Jan 2016 at 11:33 PM
Okay, I will try that. Thank you!
Edit: I don't have any issues with mods but I guess that fix fixes other stuff too? :S
Top Secret Researcher
#14 Old 4th Jan 2016 at 7:18 AM
I have Windows 7 not Windows 10 but I do have a AMD Radeon HD 6570 Graphics Card and did have the same problem recently, after updating my drivers. Ended up getting a computer tech friend to take a look, just rang him and asked how he fixed it, he said he set the graphics driver back to a previous restore point. Can't guarantee it will work but I have had no problems since.

Whenever you see a "Say Thanks" button show the creator you appreciate their work...click on it.
You can also find more of my work at Leefish and Plumb Bob Keep
Lab Assistant
Original Poster
#15 Old 4th Jan 2016 at 8:00 AM
Yeah, it might explain it. I got a new video card in november and then I also upgraded to Win 10, and while doing all of that I went ahead and updated all my drivers too. It's just so hard to see if I've fixed the problem cause I can play for hours without any issue, and then all of a sudden while I'm not doing anything special ingame it just crashes.
Lab Assistant
Original Poster
#16 Old 4th Jan 2016 at 7:54 PM
I still don't quite understand how the User Account Control thing would help - I don't have any issues with mods, I have issues with the outofvideomemory-error and idk how those would be related.
Mad Poster
#17 Old 4th Jan 2016 at 8:32 PM
The game needs to be able to both read and write to the My Doc folder but Windows 8 and 10 have my doc set to read only, Windows 7 had an update that did the same.

Are you running any other programs and or games at the same time, IE: youtube, facebook or any other internet item?

Try this.
I would double the size of your page file: http://windows.microsoft.com/en-us/...e#1TC=windows-7

All my Beginning Hoods here at MTS. http://www.modthesims.info/member.php?u=7749491
All my Beginning Hoods as Shopping Districts plus Old Town. http://www.modthesims.info/download.php?t=523417
MooVille, a tribute to Mootilda and her fabulous lots http://www.modthesims.info/download.php?t=534158
Back to top