Mod The Sims
Page 1 of 2

Mod The Sims (
-   Archive (
-   -   .NET installation error (

UNoeMe 8th Oct 2009 9:24 PM

Error cant fix need help
for some reason when i run the the sims 3 launcher or the mod installer it give me an error that says

.NET Framework Installation Error

Please set registry key HKLM\Software\Microsoft\.NETFramework\InstallRoot to point to the .NET Framework install location. i cant figure out what to do ive tryed to look for this file but i cant find it can anyone help me

Nysha 8th Oct 2009 9:44 PM

First, go into Control Panel > Add or Remove Programs, find everything called "Microsoft .NET Framework ...", and uninstall it. Then download and install the latest .NET Framework from Microsoft, here. You should then be able to install.

UNoeMe 9th Oct 2009 12:26 AM

i deleted the microsoft .net file and i when i tryed to intsall it it didnt work

ellacharmed 9th Oct 2009 4:47 AM

You cannot delete, you have to Uninstall.

UNoeMe 9th Oct 2009 10:03 PM

thats what i ment but do you think wiping my HDD would fix it?

ellacharmed 9th Oct 2009 10:19 PM

That HKLM error means your registry is messed up and new installations will be blocked unless that key is fixed/removed.

Any registry cleaner should theoretically be able to help you, unless there are more things wrong with the system.
Some e.g. are CCleaner or Advanced SystemCare Free; both are freeware.

UNoeMe 10th Oct 2009 12:19 AM

thanks but its still not working any other suggestions?

Nysha 10th Oct 2009 12:32 AM

You need to give us more information than "It's not working". Why is it not working? Is there an error message? If so, what does it say? When does it occur? I'm afraid the dog ate my crystal ball.

UNoeMe 10th Oct 2009 2:14 AM

ok i found a solution i can put my package files into the right folder and they work all i need to know is how to convert the .sims3pack files into package files without something that needs the .net framework thing so i can have the online store things

plasticbox 10th Oct 2009 3:02 AM

Originally Posted by UNoeMe
ok i found a solution i can put my package files into the right folder and they work

That is not a solution .. that doesn't even have anything to do with your problem.

If by "its not working" you mean that you still have that broken registry key, please try ellacharm3d's advice. If you mean something else, please elaborate.

UNoeMe 10th Oct 2009 3:28 AM

ok my problem is still there
i tried ellacharm3d's advice it didnt work
what im saying is......
the mods work
but i cant get stuff from the oonline store
and i need someway to make them work without the sims3 launcher
this problem wont go away i probably need to wipe the HDD
but my dad wont
so is there a way to install online store items without the launcher

haylz320 10th Oct 2009 3:59 AM

Once again, Unoeme, you've failed to go into enough detail. Nobody can help you if you continually just say "it didn't work". Please explain HOW it didn't work - error messages, it wouldn't download, it seemed to install properly but the problem is still there etc. Wiping the harddrive is about the last thing you want to do, especially if it's going to interfere with other people who also use the computer. It may have to be done, however if you go into more detail, there may be other ways about it that we can get you to try first.

UNoeMe 10th Oct 2009 6:19 AM

ok so i uninstalled microsoft .Net programs in add and remove programs the installed those 2 programs to cleanup my comp and ran them they fixed everything they found then i ran the setup for the .net thing and at the part where it says you can diconnect from the internet it says it got an error and it undoes everything it did there you go

ellacharmed 10th Oct 2009 7:57 AM

Do you want help fixing the error, then? So what does the error says?

Like whiterider, whose dog ate her crystal ball, mine is my cat who detest my looking glass (cos I'm always peering into it to look for my prince charming) - he(the cat, the prince is still over the rainbow) shattered it just this evening

ps: I believe launcher also needs flash to work.

DocHolladay 10th Oct 2009 8:08 AM

Originally Posted by UNoeMe
i deleted the microsoft .net file and i when i tryed to intsall it it didnt work

One potential fix here is to go and re-install that version of .net directly from Microsoft's download site (I don't remember exactly but it might be nice enough to have a repair installation option). This should repair that outdated versions settings if it works.

UNoeMe 10th Oct 2009 3:43 PM

that didnt work either

plasticbox 10th Oct 2009 7:29 PM

This is getting old now.

UNoeMe, you have been asked by four different people to state exactly WHAT doesn't work and what errors you are getting, so please answer those questions now if you want help. Repeating "doesn't work" is not going to lead anywhere if you continue this, I'm going to lock this thread since all that acheives is waste other people's time.

In post #13 you state "i ran the setup for the .net thing and (..) it says it got an error" -- please take a screenshot of that error message, or write down what it says, and post that here.

In post #16 you state "that didnt work" please state exactly what you did, what steps failed, and what error messages you got (if any).

I'm also moving this to tech help since it's got nothing to do with your actual game.

UNoeMe 14th Oct 2009 12:46 AM

lets start over

whenever i try to run the sims 3 launcher it gives me an error message (see first post)

i uninstalled the microsoft .net program in add&remove programs

i tryed to install the latest microsoft .net framework (3.5) and i got this

during the middle of the installation

error occured during setup. Setup is removing all installed files
(then it said the same thing in a paragraph and gave me a problem popup thing with the error report stuff)

i installed the 2 programs ellacharm3d recommended and got the same thing

then DocHolladay recommended to install the 2.0 to "repair" it and got this

in the middle of the installation it said
error occured during setup. setup removed all installed files
(basically the same thing with the error report popup)

im sorry for being unhelpful this is just pissing me off

ellacharmed 14th Oct 2009 2:07 AM

<sigh> "gave me a problem popup thing with the error report stuff"
you still didn't post the error report stuff
  1. What OS version, please?
  2. Did you download the correct version for your OS? (x86 is for 32 bit CPU's and x64 is for 64 bit CPU's)
  3. And did you restart the computer after the uninstall (successful? no error msg?) before you attempted to reinstall?
  4. Does the PC have this folder?

Read this through carefully and try the Method 1: Manually remove and reinstall .NET Framework

There is a lot of info on this error on the web (I just searched with your error msg from post#1) but all the solutions are very technical and you need to Read carefully and Follow Instructions exactly as stated in the order it was stated.

UNoeMe 14th Oct 2009 2:50 AM

thanks but idk how you dont know what i mean about
<sigh> "gave me a problem popup thing with the error report stuff"

if you have a windows you know whenever a program crashs it gives you the same BS everytime and you can send an error report or not nothing special

i have a windows XP service pack 3

ellacharmed 14th Oct 2009 7:00 AM

Do you mean you get "the system recovered from a crash and would you like to send the debug info to MS"? that one?

That might mean you have other problems with the PC than just not being able to install .NET Framework

If you get a specific error while installing .NET that might means something else and the solution will be different.

you haven't answered qns 2, 3, & 4

I am actually hesitant to give you instructions to mess about with the registry and Windows system files when time & again you have not followed instructions/answered questions posted here...

UNoeMe 14th Oct 2009 5:11 PM

no i didnt restart after install
it doesnt have that folder
i downloaded the right version

the error says: (for downloading v2.0 redistributal (x86))

Error 25007. error occured while initializing fusion. Setup could not load fusion with LoadLibraryShim(). Error 0x80131702

i pressed retry many times but it didnt work so i pressed cancel

and the popup that ive been talking about says: (after i pressed cancel)

microsoft .NET framework 2.0 has encountered a problem during setup. Setup did not complete correctly

and it give you 2 choices: send report, dont send report
i sent it

how do i get to the HKLM folder?

ellacharmed 14th Oct 2009 6:05 PM

have you tried the cleanup utility in the link in post#19?

UNoeMe 14th Oct 2009 8:42 PM

yea but idk what versions i had on before i uninstalled them

ellacharmed 15th Oct 2009 12:47 AM

start with 2.0 - the most used one

or start the program that triggered all this in the first place and the error will tell you which version you need

All times are GMT +1. The time now is 2:23 PM.
Page 1 of 2

Powered by: vBulletin Version 3.0.14
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.