PDA

View Full Version : Sims Medieval keeps Switching (not crashing) to desktop repeatedly


Kelibath
12th Nov 2014, 2:14 AM
The Sims Medieval keeps SWITCHING to desktop on load, directly after starting it from the launcher. It isn't crashing or freezing and seems to be playing perfectly in the background, but every time I switch over to it, it minimises itself again!
I've been running the game perfectly capably for over a fortnight on the same computer setup and this randomly started happening today (11/11/2014).
There aren't any tasks in the background large enough to be taking up GPU or RAM dedicated memory.
I click the play icon in the launcher, the game loads and switches to desktop at the same time. I try switching to it, tabbing, bringing it to front, and it switches randomly back again and again. It just keeps minimising. When I tab to it the sound turns on, and turns back off again the moment it minimises back out.
I'd much rather not have to run this game in compatibility for Win95, and the game used to run perfectly without minimising itself or switching.
Win7 SP1 Ultimate 64bit, and tons of memory..
Any ideas? :)

Xeny
12th Dec 2014, 11:00 AM
The Sims Medieval keeps SWITCHING to desktop on load, directly after starting it from the launcher. It isn't crashing or freezing and seems to be playing perfectly in the background, but every time I switch over to it, it minimises itself again!
I've been running the game perfectly capably for over a fortnight on the same computer setup and this randomly started happening today (11/11/2014).
There aren't any tasks in the background large enough to be taking up GPU or RAM dedicated memory.
I click the play icon in the launcher, the game loads and switches to desktop at the same time. I try switching to it, tabbing, bringing it to front, and it switches randomly back again and again. It just keeps minimising. When I tab to it the sound turns on, and turns back off again the moment it minimises back out.
I'd much rather not have to run this game in compatibility for Win95, and the game used to run perfectly without minimising itself or switching.
Win7 SP1 Ultimate 64bit, and tons of memory..
Any ideas? :)

Are you running any Windows 7 themes? If so, go to Personalize and select Windows Basic theme and run the game. You can change the theme back to whichever you had or like after gaming. Check and see if that stops the minimizing.

You might also consider turning off Windows Error Reporting during game play. Sometimes other applications running in the background report errors to WER, and Windows will lower any running app to the taskbar. Or if you have automatic updates for Windows Update, which runs all the time, and is a Windows Start Up Program, you can disable it as well, since WU is always checking for updates, and when it is actually updating, when it has completed installing an update it lowers the app running on the desktop. Remember to re-enable these programs when you have finished your game sessions. Any updating program can lower a desktop game, so this suggestion applies to anti-virus' and other software programs.

Have you updated your graphics card driver lately? Go to the manufacturer of your video card's web site and update the driver to the latest. Some gamers have in the past experienced your issue with nVidia graphics cards. Turn off any processes running that the system does not need in order to function while gaming, and you are more likely to discover if it is indeed another program running that is the cause of your game screen lowering to desktop.

Good Luck, Gamer!

Xeny :king: