MTS has all free content, all the time. Find out how YOU can help to keep it running. Tell me how...

LotExpander for Free Time (Obsolete)

by Mootilda Posted 21st Aug 2007 at 2:43 AM - Updated 27th Nov 2013 at 10:09 PM by Nysha
284 Comments / replies (Who?) - 25 Feedback Posts
This is a featured upload! It showcases the best talent and creativity available on MTS and in the community.

The LotExpander will not be updated for Apartment Life.

LotExpander 1.2.10.1

This is the final version of the LotExpander. It has been superceeded by the LotAdjuster:
http://www.modthesims2.com/showthread.php?t=282409

This version of the LotExpander works with all expansion and stuff packs, up to and including The Sims 2 Free Time. The latest release resolves an issue with continuing after an abort. Please see "Known Issues" below.

Description:
The LotExpander allows you to expand "The Sims 2" lots up to a size of 6 x 6 with a few mouse clicks.

Installation:
To install, just download LotExpander12A1.zip and unzip it. Run the EXE from the unzipped location. This is "alpha" software and is still in development; it is not guaranteed to work and may corrupt your lot. Be sure to backup your game before using this tool.

I have included the source code in LotExpander12A1Source.zip. There is no need to download this file unless you are a C# programmer who wishes to look at or modify the code.

Requirements:
- The program uses some DLLs from SimPE; they are included in the zip file.
- LotExpander is released under the GNU General Public License.
- You need the Microsoft .NET Framework 2.0 to run the LotExpander: http://www.microsoft.com/downloads/...dd-aab15c5e04f5

Known Issues:
1) The LotExpander sometimes does not work with Vista. There is no known solution at this time.

2) When moving a pool with rounded edges, the rounded edges will not move. For now, just delete the rounded edges before expanding the lot and add them back to the pool in the new location once the expansion is complete. If you accidently expand a lot without removing the rounded edges, the lot can be fixed using the normal build tools; however, it is more difficult than just removing them beforehand.

3) The expanded terrain takes its form from the terrain at the edges of the existing lot. This does not always produce the desired result, especially for hilly terrain and beach lots. I am investigating whether the LotExpander can use the actual neighborhood terrain for the additional land.

Instructions:
Please see the LotExpander tutorial at: http://www.modthesims2.com/showpost...3&postcount=410

If you have any problems with the LotExpander, please let me know.

Error and Warning Messages: http://www.modthesims2.com/showpost...7&postcount=422

Recovering from Problems: http://www.modthesims2.com/showpost...5&postcount=411

General discussion about modding lots: http://www.modthesims2.com/showthread.php?t=250693

Current To-Do List: http://www.modthesims2.com/showpost...6&postcount=412

Release History: http://www.modthesims2.com/showpost...7&postcount=413

Portal Revealer:
This tool allows you to see, move and rotate portals on your lot: http://www.modthesims2.com/showthread.php?t=251392

Small Lots:
Now everyone can create lots of whatever size they wish with LotExpander. Here are links to expandable lots which are 1 wide or 1 deep, and which have the sun shining on the back of the lot:

Residential: http://www.modthesims2.com/showthread.php?t=195469
Community: http://www.modthesims2.com/showthread.php?t=195467

If you prefer the sun to shine from the front of the lot, take a look at aelflaed's brand new sunnyside lots:

Residential: http://www.modthesims2.com/showthread.php?t=251798
Community: http://www.modthesims2.com/showthread.php?t=251800

And here are some North- and South- facing 2XN lots: http://www.modthesims2.com/showthread.php?t=250096

Thanks:
This program was designed and developed by Andi8104. He really deserves most of the credit for the LotExpander. I have been making minor changes to the tool since Andi died. The original tool is still available at:
http://www.modthesims2.com/showthread.php?t=250686

Operating System: Windows Mac OS X
Utility Type: Save Editors
Plugin Type: Not Applicable

You must have the expansion or stuff packs listed below installed to use this custom content. Please see the post text for any exceptions.

Sims 2
Key: - File was updated after upload was posted
Filename - Tip: You can click the magnifying glass to see the archive contents Size Downloads Date
LotExpander12A1Source.zip

Size: 135.3 KB · Downloads: 5,100 · 21st Mar 2008
135.3 KB 5,100 21st Mar 2008
LotExpander12A1.zip

Size: 700.9 KB · Downloads: 12,178 · 21st Mar 2008
700.9 KB 12,178 21st Mar 2008
Don't forget to Thank the creator after downloading! Use the Thanks button located above the screenshots above.
Basic Download and Install Instructions:

1. Download: Click the download link to save the .rar or .zip file(s) to your computer.

2. Extract the zip, rar, or 7z file.

3. Place in Downloads Folder: Cut and paste the .package file(s) into your Downloads folder:
  • Origin (Ultimate Collection): Users\(Current User Account)\Documents\EA Games\The Sims™ 2 Ultimate Collection\Downloads\
  • Non-Origin, Windows Vista/7/8/10: Users\(Current User Account)\Documents\EA Games\The Sims 2\Downloads\
  • Non-Origin, Windows XP: Documents and Settings\(Current User Account)\My Documents\EA Games\The Sims 2\Downloads\
  • Mac: Users\(Current User Account)\Documents\EA Games\The Sims 2\Downloads
  • Mac x64: /Library/Containers/com.aspyr.sims2.appstore/Data/Library/Application Support/Aspyr/The Sims 2/Downloads
Need more information?
 
284 Comments / Replies (Who?) - 275 Feedback Posts, 3 Thanks Posts
Hide Thanks Posts for this thread (Show only feedback)
Page 8 of 12
Site Helper
Original Poster
#176 Old 2nd Mar 2008 at 11:56 PM
Quote:
Originally Posted by lordtopcat
Any idea on when an update will be made for Free Time? Cheers. LTC
Well, first I have to get Free Time. That happens when the EA company store finally bothers to get some in... usually a week or two after the general release.

Then I need to do some testing to determine what kind of problems are occuring. Finally, I need to find solutions to the problems. Finding and fixing the problems for Pets only took a week or so, but Seasons was more difficult and took about a month.

So, my best guess is another month, give or take. Sorry that it takes so long.
Test Subject
#177 Old 3rd Mar 2008 at 2:35 AM
Anyway I can manually do it via SimPE? LOL
Site Helper
Original Poster
#178 Old 3rd Mar 2008 at 5:34 PM Last edited by Mootilda : 5th Mar 2008 at 1:54 AM.
Quote:
Originally Posted by lordtopcat
Anyway I can manually do it via SimPE? LOL
I don't believe that you can. If I remember correctly, SimPE doesn't allow you to add or delete fields. You'd need a more powerful hex editor.

Update: New Free Time version 1.2.10 now available. Luckily, there were very few changes required.
Test Subject
#179 Old 9th Mar 2008 at 11:33 PM
I see that there is alot of development with the lot expander, I'm now waiting till the end of this month so I can buy myself a new computer and going to test the lot expander out (again) ass I'm installing the sims again till Pet's (I have to buy the last 6 expandsions) Also I've read the the schrinking possibility isn't up and running anymore, that's to bad, but maybe on some day that it will come back (I sure hope so) For now keep up the good work Mootilda, and thanks for all the hard work you have done with the lot expander.

Best regards,
at Mike's

Welcome at Mike's
A whole new world for you...
Site Helper
Original Poster
#180 Old 10th Mar 2008 at 1:26 AM
I'm still working on the shrinking code... trying to make sure that it won't corrupt lots and possibly the neighborhoods.
Lab Assistant
#181 Old 10th Mar 2008 at 4:28 AM
For some reason, the program won't expand the Ottomas' house. I only wanted to extend it from 3x3 to 3x4 in the back. I'm attaching the file. I have the latest version since I have FT and all EPs & stuff packs.
Download - please read all instructions before downloading any files!
File Type: rar N001_Lot256.rar (1.61 MB, 9 downloads)
Site Helper
Original Poster
#182 Old 10th Mar 2008 at 7:48 AM
A preliminary look at the lot shows a problem with one of the strings associated with the trashCompactor object... the string length seems to be much bigger than the actual string, so the LotExpander is trying to read off the end of the record.

I'll need some time to investigate what's actually happening.

Thanks for reporting this.
Lab Assistant
#183 Old 12th Mar 2008 at 1:45 PM
Thank you, thank you, for the FreeTime update. I know it must have taken a lot of work to get this done so quickly. So, Thanks again.
Instructor
#184 Old 20th Mar 2008 at 2:17 AM
After installing FT and the newest SimPE I eagerly launched your new lot expander. I did not work at all. I got an exeption handle............. As the game is on another machine then the one I use the internet it is always a lot of hassle to copy the message. Before I do that I thought I ask you if you could do the same version as before (1292) just for FT. I worked so well. Thank you in advance.
Site Helper
Original Poster
#185 Old 20th Mar 2008 at 4:38 AM Last edited by Mootilda : 21st Mar 2008 at 11:59 PM.
There were only two changes from 1.2.9.2 to 1.2.10:
- Fix FreeTime issues
- Use newest SimPE DLLs

Are you asking me to provide you a version which uses the old SimPE DLLs?
Field Researcher
#186 Old 20th Mar 2008 at 7:11 PM
please don't take this as a whine, i'm just interested in knowing lol

but what exactly changed with the bon voyage expander and the freetime expander to not make it compatible with vista? i've had vista for a while, with the bon voyage version and it worked fine...is it coding? how does that work?
Site Helper
Original Poster
#187 Old 20th Mar 2008 at 9:34 PM Last edited by Mootilda : 20th Mar 2008 at 11:33 PM.
I don't know why the current LotExpander sometimes doesn't work with Vista. If I knew what was wrong, I'd certainly try to fix it. Unfortunately, I don't have access to a Vista machine, and even if I did there is no guarantee that I would have this problem (not everyone does), so it's difficult for me to debug.

If someone was willing to help me, I could create a test version of the LotExpander which would create a debug log while running. By looking at this log, I might be able to come up with a theory as to what is going wrong and create a new test version. However, this could be a long involved process with many new test versions, so I'd need someone who was committed to finding a solution to the Vista issue(s).

This is probably a bad time for me to start such a process, though, since it's income tax time in the U.S. and Canada. I really need to spend some time doing my family's taxes... Sigh.

If someone is interested in helping me to track down this problem, please let me know.
Site Helper
Original Poster
#188 Old 21st Mar 2008 at 11:38 PM
Quote:
Originally Posted by Qwigqwag
For some reason, the program won't expand the Ottomas' house. I only wanted to extend it from 3x3 to 3x4 in the back. I'm attaching the file. I have the latest version since I have FT and all EPs & stuff packs.
As far as I can tell, this is not an issue with the LotExpander.

I found a couple of records in the lot which seem to be corrupt: at the very least, your trash compactor and 3x1 runner rug. There may be other corrupt custom content on this lot as well.

Have you actually been playing a family successfully on this lot? Could you try to package this lot with the custom content, to see whether the game has problems?
Lab Assistant
#189 Old 22nd Mar 2008 at 1:17 AM
Yeah, I've had the Ottomas live here since, what, Seasons?, when they first came out. I've had no problems with the house or the family so far. All the kids are grown, 2 in college, and 3 teens waiting to go to college. I'll move the family to a new house because this one really doesn't have any back yard. Once I do that and the house is left empty, maybe I can expand it. Thanks for looking into it.
Site Helper
Original Poster
#190 Old 22nd Mar 2008 at 6:16 AM Last edited by Mootilda : 22nd Mar 2008 at 6:37 PM.
Let me know how that goes. I've still got your original house, in case I come up with a theory about what's happening. The string lengths are way off and I haven't been able to find any way to parse those records which makes any sense.
Test Subject
#191 Old 30th Mar 2008 at 12:33 AM
But... But.. Is there a Mac version. *Cringe from Macintosh hate*
Site Helper
Original Poster
#192 Old 30th Mar 2008 at 4:19 AM
No, I don't believe that there is a .Net 2.0 for the Mac, so I don't believe that this will port to the Mac.
Test Subject
#193 Old 18th Apr 2008 at 8:05 AM
Question, i know it says max lot size is 6x6 but is there any way I can tweak the lot expander to increase the lot's size to 10+ both directions?(I'm building a massive airport to upload but it looks weird as it is 7 different sized lots not one massve thing)
Site Helper
Original Poster
#194 Old 18th Apr 2008 at 1:29 PM
No, the game doesn't support lots which are over 6x6. I could change the LotExpander so that you could create such a lot, but the game couldn't handle it.

There's some evidence that EA may remove this restriction, since Castaway Stories has a much larger limit - I believe that they have lots which are 10 big.
Test Subject
#195 Old 18th Apr 2008 at 4:01 PM
I regret it doesn't work with my Vista. It crashes after hitting start :-(
Site Helper
Original Poster
#196 Old 19th Apr 2008 at 6:38 AM
I'm not sure why it doesn't work for some people under Vista. If anyone had any thoughts on this, I would appreciate any help. I don't have access to Vista, so it's difficult for me to debug.
Site Helper
Original Poster
#197 Old 20th Apr 2008 at 6:14 PM
Default Announcement: The LotAdjuster is Now Available
The LotAdjuster, which is the successor to the LotExpander and supports shrinking of lots, is now available. The LotExpander has been superceeded by this new program:
http://www.modthesims2.com/showthread.php?t=282409
Test Subject
#198 Old 23rd Apr 2008 at 7:12 AM
Hi~
First let me say I love this...and in my XP it worked beautifully...didn't even crash my game w/Seasons...but alas..I've gone to a bigger more powerful 64/32 bit computer (yes, unfortunately, w/Vista *sigh*). The game runs like a dream & doesn't care what I put in it...so I finally got around to redowloading your lastest LotExpander...both models...but when I try to run it...this is the detail error I'm getting:

************** Exception Text **************
System.BadImageFormatException: Could not load file or assembly 'simpe.package, Version=1.0.2909.39936, Culture=neutral, PublicKeyToken=null' or one of its dependencies. An attempt was made to load a program with an incorrect format.
File name: 'simpe.package, Version=1.0.2909.39936, Culture=neutral, PublicKeyToken=null'
at LotExpander.LotExpander.NeighborhoodScreen()
at LotExpander.LotExpander.NextButton_Click(Object sender, EventArgs e) in G:\Source\LotExpander\Source\ALE12A\12A1\LotExpander.cs:line 120
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].



************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll
----------------------------------------
LotExpander
Assembly Version: 1.2.10.1
Win32 Version: 1.2.10.1
CodeBase: file:///C:/Users/Luvs/Desktop/RichShared2/LotExpander.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
Accessibility
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Accessibility/2.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------
System.Configuration
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll

The part that I found most interesting was this one:
WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value


Does this mean anything to you? or anyone...is this fixable? would this fix the problem..
it seems to be looking for a 'debugging' log of some kind.

Anyway...if this doesn't help, or none of it does...I'm going to be very disappointed...and have to resort to using my old system to change the lots as this has become a norm for me...it was nice not having to worry if the size of a lot was too small...

Thanks again for your hard work...you have no idea how this changed my game...for
the better :D
Luvs
Sandy
btw: I have the 64 bit NETFRAME 2.0 already installed..came w/the computer...any of my other programs that require this run fine...so I know that's not causing the problem...
Site Helper
Original Poster
#199 Old 23rd Apr 2008 at 6:10 PM
Quote:
Originally Posted by Luvs
The part that I found most interesting was this one:
WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
Note: There is some performance penalty associated with assembly bind failure logging.
To turn this feature off, remove the registry value

Would you be willing to try turning "assembly binding logging" on and see what happens? Remember that editing your registry can be dangerous and can make it so that your machine is unable to boot; I will understand if you don't feel comfortable doing this.

To do this on XP (no idea how to do this with Vista), I would choose Run... from the start menu, then type "regedit" (without the quotes) into the Open text box on the Run window. You'll probably need to be logged on as an Administrator.

In the left pane of the Registry Editor, you want to navigate to:

My Computer
- HKEY_LOCAL_MACHINE
- - Software
- - -Microsoft
- - - Fusion

Now, look for EnableLog in the right pane.

If it's not there:
- open the Edit menu, choose New, and then DWORD Value
- type "EnableLog" (without the quotes) into the Name area

Now that EnableLog exists in the right pane:
- double click on EnableLog to bring up an edit window
- type "1" (without the quotes) into the Value Data text box
- click OK

Finally, exit the Registry Editor and try running the LotExpander again.

At this point, you're on your own. I assume that Vista will give you better information about what's wrong, but I have no idea whether this will come up as a window, or will appear somewhere on your hard drive.

If you can find the log, copy it here and I'll see whether it helps.

Don't forget to turn off logging when you're done, so that it doesn't bog down your machine. Follow the instructions to enable logging, but type "0" (without the quotes) in the Value Data text box instead.

In the interim, I may have finally found someone who can help me with .NET DLL versioning problems. With any luck, he'll be able to take a look at this today.
Test Subject
#200 Old 23rd Apr 2008 at 10:59 PM
Mootilda~

Piece of cake I never fear ruining my computer...I have undying faith in my machine....naive I know..but it's never failed me yet...so here's what came out this time..I did copy the whole thing..though I suspect you don't need the last bit...but wasn't entirely sure:

************* Exception Text **************
System.BadImageFormatException: Could not load file or assembly 'simpe.package, Version=1.0.2990.38590, Culture=neutral, PublicKeyToken=null' or one of its dependencies. An attempt was made to load a program with an incorrect format.
File name: 'simpe.package, Version=1.0.2990.38590, Culture=neutral, PublicKeyToken=null'
at LotExpander.LotExpander.NeighborhoodScreen()
at LotExpander.LotExpander.NextButton_Click(Object sender, EventArgs e) in G:\Source\LotAdjuster\Source\100\100\LotExpander.cs:line 138
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

=== Pre-bind state information ===
LOG: User = Luvs-PC\Luvs
LOG: DisplayName = simpe.package, Version=1.0.2990.38590, Culture=neutral, PublicKeyToken=null
(Fully-specified)
LOG: Appbase = file:///C:/Users/Luvs/Desktop/TS2Programs/LotAdjuster/
LOG: Initial PrivatePath = NULL
Calling assembly : LotAdjuster, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null.
===
LOG: This bind starts in default load context.
LOG: No application configuration file found.
LOG: Using machine configuration file from C:\Windows\Microsoft.NET\Framework64\v2.0.50727\config\machine.config.
LOG: Policy not being applied to reference at this time (private, custom, partial, or location-based assembly bind).
LOG: Attempting download of new URL file:///C:/Users/Luvs/Desktop/TS2Programs/LotAdjuster/simpe.package.DLL.
ERR: Failed to complete setup of assembly (hr = 0x8007000b). Probing terminated.




************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework64/v2.0.50727/mscorlib.dll
----------------------------------------
LotAdjuster
Assembly Version: 1.0.0.0
Win32 Version: 1.0.0.0
CodeBase: file:///C:/Users/Luvs/Desktop/TS2Programs/LotAdjuster/LotAdjuster.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
Accessibility
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.1434 (REDBITS.050727-1400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/Accessibility/2.0.0.0__b03f5f7f11d50a3a/Accessibility.dll
----------------------------------------

I'll leave the log running for a bit in case you'd like to me to try anything else. Don't worry about lagging my machine...it's got 4g individual ram & 512 on the graphics card..I think a little registry won't hurt much.

Thank you sooo much for looking into this for me...even if it doesn't get you far...I was glad to give a little back.

Thanks again~
Luvs
Sandy
:D
Page 8 of 12