MTS has all free content, all the time. Find out how YOU can help to keep it running. Tell me how...

No NPC Revert UPDATED 2006-05-08

by jaxad0127 Posted 14th Sep 2005 at 2:53 AM - Updated 22nd May 2006 at 8:07 PM by jaxad0127 : New package
80 Comments / replies (Who?) - 25 Feedback Posts
This hack address the problem found in http://www.modthesims2.com/showthread.php?t=74939 and based on the fix in http://www.modthesims2.com/showthre...5375#post395375. It is a global hack that replaces the original BHAV in game. So your custom npcs wont revert to their original clothing, etc. :D

This will conflict with Dizzy2's Casual NPC mod.

I do not want people to have to pay for this. If you put it on another site, please give credit to me and link to this thread. Thanks.
Tags: #npc, #revert, #reversion, #fix

You must have the expansion or stuff packs listed below installed to use this custom content. Please see the post text for any exceptions.

Key: - File was updated after upload was posted
Filename - Tip: You can click the magnifying glass to see the archive contents Size Downloads Date
jaxad0127_NoNPCRevert.zip

Size: 260 Bytes · Downloads: 3,298 · 19th Apr 2006
260 Bytes 3,298 19th Apr 2006
Don't forget to Thank the creator after downloading! Use the Thanks button located above the screenshots above.
Basic Download and Install Instructions:

1. Download: Click the download link to save the .rar or .zip file(s) to your computer.

2. Extract the zip, rar, or 7z file.

3. Place in Downloads Folder: Cut and paste the .package file(s) into your Downloads folder:
  • Origin (Ultimate Collection): Users\(Current User Account)\Documents\EA Games\The Sims™ 2 Ultimate Collection\Downloads\
  • Non-Origin, Windows Vista/7/8/10: Users\(Current User Account)\Documents\EA Games\The Sims 2\Downloads\
  • Non-Origin, Windows XP: Documents and Settings\(Current User Account)\My Documents\EA Games\The Sims 2\Downloads\
  • Mac: Users\(Current User Account)\Documents\EA Games\The Sims 2\Downloads
  • Mac x64: /Library/Containers/com.aspyr.sims2.appstore/Data/Library/Application Support/Aspyr/The Sims 2/Downloads
Need more information?
 
80 Comments / Replies (Who?) - 78 Feedback Posts
Page 2 of 4
Test Subject
#26 Old 11th Apr 2006 at 4:57 PM
Just wanted to let you know I had the same problem yesterday, after I installed the newest mod with allEPs at the end. the school bus would show up disappear every five seconds. None of the NPC's showed in the car pool cars or the bus. Also noticed poor remington lost the lower half of his legs too!

So I took the mod out and replayed and everything was back to normal.
Object(ive) Investigator
retired moderator
Original Poster
#27 Old 11th Apr 2006 at 5:16 PM
I think I may know whats causing this. I'll do some testing later.

Please don't PM me with questions. Post them in the appropriate thread.
Test Subject
#28 Old 17th Apr 2006 at 7:00 PM
HI Jaxad, could you possible repost some of the older versions of your NPC no revert. I stupidly deleted my older one which worked fine with OFB before the NPC no revert all EPs.

If you could, that would be awesome as now all my now playable NPC's are keeping their uniform on all the time.

Thank you very much
Object(ive) Investigator
retired moderator
Original Poster
#29 Old 19th Apr 2006 at 5:55 PM
Ok, I've uploaded an older version. Make sure that you only have one copy in your downloads folder (the name has changed a bit over time). This version should not cause any problems. The reason I change it was because some users were reporting that NPCs were reverting even with this installed. This is almost identical to the very first version I uploaded (small change for saftey).

Please don't PM me with questions. Post them in the appropriate thread.
Test Subject
#31 Old 2nd May 2006 at 12:41 AM
Disappeared carpools and sims
I am not sure if all of the information that is talked about in my issue. I have the original and since I fixed one of my sims from SimPE I got an error that stated something about the maid mobile. When the game opened up the carpools were gone and the school bus is gone that had a few of my sims on board. The maid ended up losing its legs and just standing on the ground doing nothing. I deleted the maid but however more NPC characters every three seconds came out of no where in the same spot where the maid was.The two sims that were suspose to go to work either called in sick or took a vacation day.

The other strange thing is that the school bus was suspose to come back around 1 p.m. for the two teens and it never came back to the house as well as the child at 3 p.m. Now I keep getting all of these messages from service NPC sims that I never seen in my game before saying "bye" or "see you later" every three seconds.

This is really hurting my game, nothing else is wrong with it.. it could be normal if the carpools come back and my sims to come back. If anyone has any suggestions what I need to do, it would really help a lot.
Object(ive) Investigator
retired moderator
Original Poster
#32 Old 2nd May 2006 at 5:31 AM
I really don't think my mod is causing that if using the current version. What you are describing happened to several people before I created this hack.

Please don't PM me with questions. Post them in the appropriate thread.
Test Subject
#33 Old 2nd May 2006 at 3:09 PM
How do I fix it? I already have your file and I have no clue what else to do.
Object(ive) Investigator
retired moderator
Original Poster
#34 Old 2nd May 2006 at 5:10 PM
If I remember correctly, the lot itself is the problem. You need to move the family out and into a new lot.

Please don't PM me with questions. Post them in the appropriate thread.
Test Subject
#35 Old 2nd May 2006 at 7:24 PM
Thanks for the info, but one more question.. do I have to refurnish the whole house again when I move them out or is there some kind of way to keep the furniture? the rewards are not a big issue for me...
Object(ive) Investigator
retired moderator
Original Poster
#36 Old 2nd May 2006 at 9:57 PM
You need to put them on a NEW lot. The old one is bugged.

Please don't PM me with questions. Post them in the appropriate thread.
Test Subject
#37 Old 3rd May 2006 at 4:45 AM
Your info worked when I moved my family to a new lot however a half hour later into the game an a service NPC that I never came in contact with showed up on the same spot as it was in the old lot, half body stuck on the ground.

What can I do now? I'm thinking if I move my family again it will come back again.
Object(ive) Investigator
retired moderator
Original Poster
#38 Old 3rd May 2006 at 5:57 AM
Does it happen without any downloads?

Please don't PM me with questions. Post them in the appropriate thread.
Test Subject
#39 Old 4th May 2006 at 7:50 PM
No, It works fine.. what do you recommend I should do?
Object(ive) Investigator
retired moderator
Original Poster
#40 Old 4th May 2006 at 8:02 PM
Please see this article: http://www.modthesims2.com/article.php?p=1110007.

Please don't PM me with questions. Post them in the appropriate thread.
Lab Assistant
#41 Old 5th May 2006 at 9:55 AM
Hmm...it seems the old, trusty version I kept backed-up saved the day once again. The moment I replaced it with the new version an error message regarding the maid's vehicle popped up. Unfortunately, I forgot to bring it along (I play at home and don't have an internet connection there) so you could take a look at it, but the point is that, when I reverted to the old version (timestamped Sept. 05 IIRC) everything worked fine again. I have all the EPs BTW except Family Fun.

Edit: I'll try and bring the error log tomorrow.

Let the Beast inside you free!
Test Subject
#42 Old 5th May 2006 at 1:30 PM
Thanks, jaxad0127 it solved my problem when I disabled a few of my hacks, so far I have not seen any service NPC without their cars..
Object(ive) Investigator
retired moderator
Original Poster
#43 Old 5th May 2006 at 4:54 PM
DrBeast, the current version is the old version.

Please don't PM me with questions. Post them in the appropriate thread.
Lab Assistant
#44 Old 6th May 2006 at 4:27 PM
Quote:
Originally Posted by jaxad0127
DrBeast, the current version is the old version.


Eh?! The old, Sept. '05 version?! WTF? Now I'm baffled! Why are the timestamps different then? The old was timestamped 12th Sept 05, the "new" is 4th April '06.
Anyway, I brought the error log with me, I've attached it below.
Download - please read all instructions before downloading any files!
File Type: zip ObjectError_N004_t1171983.zip (13.4 KB, 7 downloads)

Let the Beast inside you free!
Object(ive) Investigator
retired moderator
Original Poster
#45 Old 6th May 2006 at 8:44 PM
I re-uploaded the (mostly) original version.

Please try the newly uploaded version. It should be more stable than the very first upload.

EDIT: The error was with the maid, not her vehicle.

Please don't PM me with questions. Post them in the appropriate thread.
Lab Assistant
#46 Old 7th May 2006 at 3:18 PM
Yes, the error was indeed on the maid. My bad. I'll try the version you uploaded, though the one I use is error-free as is. It goes without saying that I can send it over to you if you'd like.

Let the Beast inside you free!
Object(ive) Investigator
retired moderator
Original Poster
#47 Old 7th May 2006 at 6:56 PM
The only difference between them is that in the original, I just removed all but the first statement, which still does some, albeit not much. In the new version, I changed it to do nothing, literally.

Please don't PM me with questions. Post them in the appropriate thread.
Lab Assistant
#48 Old 8th May 2006 at 9:11 AM
Heh, whatever you did, it seems the one I have is the only one that's working for me! Again, I replaced it with the one you just uploaded and surprise...another nice little error report! Here's a thing I noticed though: I was right about the error report being on the vehicle. The FIRST error report that pops up is about the vehicle. When I reset, another one pops up, this one concerning the maid. The only procurable error log though, is the one about the maid, which I have attached below. It's a pity our times don't match, it feels like old news when I'm reporting in about a day after you've posted your reply and vice versa...

Edit: I must admit I didn't test this version out in a hack-free environment to see if it's a hack incompatibility or not. My bad. But then again, the one I have works just fine with all the other hacks I have.
Download - please read all instructions before downloading any files!
File Type: zip ObjectError_N004_t1560927.zip (13.8 KB, 9 downloads)

Let the Beast inside you free!
Object(ive) Investigator
retired moderator
Original Poster
#49 Old 8th May 2006 at 8:20 PM
Thank you for the report. I've uploaded a fixed package.

Please don't PM me with questions. Post them in the appropriate thread.
Lab Assistant
#50 Old 9th May 2006 at 9:49 AM
'k, will try this out too. Am I the only one who's having problems by the way? It feels like we've turned this thread into a private "DrBeast and jaxad's troubleshooting section"!
Heh, anyway, the usual: you'll have my report tomorrow...

Let the Beast inside you free!
Page 2 of 4