MTS has all free content, all the time. Find out how YOU can help to keep it running. Tell me how...

Featured upload! TS4 MorphMaker - updated to V4.3 on 6/9/2020

by CmarNYC Posted 4th Jun 2018 at 6:41 PM - Updated 9th Jun 2020 at 12:09 PM by CmarNYC : Update
326 Comments / replies (Who?) - 21 Feedback Posts, 3 Thanks Posts
This is a featured upload! It showcases the best talent and creativity available on MTS and in the community.
This tool makes custom TS4 morphs from base and morphed meshes and packages them in CAS sliders and presets.

Supports all species/ages/genders/frames/occults.

Meshing can be done using any 3D editor that will import and export OBJ without changing the vertex order or the face sequence or the group/object names. Tested with Milkshape and Blender.

To use: Download the TS4MorphMaker program zip file, extract, open the folder and run TS4MorphMaker.exe


There are three tutorials posted which have much more complete information and instructions:
Making a CAS slider with TS4MorphMaker using a DeformerMap
Making a CAS preset with TS4MorphMaker using a BGEO
Making a Cat Body Preset and Fur Preset with TS4 MorphMaker using EA Morphs and a Deformer Map

Check back for updates - now that people are using the tool I'm fixing bugs and updating often.

If something doesn't work, please check to see if an update has fixed it. If not, please report any bugs in the comments, giving as much information as possible. Please upload your meshes if you're having trouble making a BGEO or DMap. Please upload your package if it's not working as expected in CAS or the game. If you'd rather not upload, pm me with a link.

Note that the bone delta editor hasn't had much testing, and that support for morphs of custom meshes is mostly untested.

Additional Credits:
s4pe/s4pi is used by MorphMaker for package and image handling. s4pi/s4pe and MorphMaker are open source.
s4pe download: https://github.com/s4ptacle/Sims4Tools/releases
Latest working s4pi source: https://github.com/s4ptacle/Sims4Tools/tree/develop

With thanks to lumialover8 for encouragement and lots and lots of testing. His beautiful sets of ear and hand sliders and presets made with MorphMaker are here: https://luumiasims.com/post/1740062...headed-toward-a

Updates:
V4.3
Head distortion in DMap preview of certain morphs is fixed.
Bone morphs for preview have been reworked, but animal meshes are still distorting so it needs more work.

V4.2
Support added for mermaids and witches.

V4.1
Corrections to the bone delta editor which hopefully will fix the issue of numbers randomly changing for some users, probably affecting users in countries that use a comma instead of a period as the decimal marker. I can't test this myself, however.
Improvement to the accuracy of bone morph previews.

Updates:
V4.0-beta
Bone Delta Editor (this part is still beta):
  • Will now interactively show you the effect of bone morphs as you change values.
  • Now allows values to be edited using either global/world or local coordinate system.
All previews now include bone morphs.
Exports of morphed meshes from previews now include bone morphs.
Preset regions which are not supported by the game have been removed from the preset options.

V3.0-beta
This is a beta since there are a lot of changes, and the previous version is still available until this one is final.
Enhancements:
  • Full support for cat and dog sliders and presets added.
  • The DeformerMap creation has been substantially rewritten to produce smoother and more accurate maps which are also a bit faster to make. The problem of morphs 'smearing' into the wrong areas and causing distortion should now be gone. Any bumpiness in very high poly meshes should be gone.
  • *Note this exception: In human sims the fingers and inner mouth are mapped onto the same area of the uv1 so DMap morphs cannot be used for either part without distorting the other.
  • Sculpts now include the full set of textures (material, normalmap, specular) and bone deltas.
  • Small fixes and changes.
Bugfix: Export of morphs included tiny inaccuracies due to rounding error causing distortion when exported whole body morphs were used as a morph mesh. This has been corrected.

V2.3.2
Bugfix: Corrected bug causing body preset custom thumbnails to not show up. (Use this version to open and save a package with body preset thumbs to fix it.)
Changes: The thumbnail import/export window will now resize correctly. The preset sort order will display as a decimal number.

V2.3.1
Bugfix: Correction of bug in HotSpotControl display causing gender restriction flags to be incorrectly checked in some conditions.
Changes: Addition of custom regions for Sim Modifiers, for use in body presets meant to affect only one body part. Choice of regions in presets restricted to regions that can have presets. Cosmetic and informational changes to screens.

V2.3.0
Bugfix: Correction of bug in the Tight Boundaries option of DMap creation which caused erroring out.
Changes: Addition of mesh export from all previews, including previews of presets, sculpts, and sim modifiers. Exported meshes can now be modified and used as a morph mesh with the correct standard base mesh for the age/gender.

V2.2.7
Bugfix: Correction of DMap compression bug introduced in previous fix, affecting base/morph pairs of any size with areas of unchanged normals. Anyone using V2.2.6 should update immediately.
Change: Body meshes exported from the Previewer tab will now include the head.

V2.2.6
Bugfix: Correction of bug in whole body compressed DMap creation, resulting in a DMap with bad data. Anyone working with whole body size DMaps should update.
Change: A few user error checks added.

Operating System: Windows
Utility Type: CC Editors
Plugin Type: Not Applicable

You must have the expansion or stuff packs listed below installed to use this custom content. Please see the post text for any exceptions.

Sims 4
Key: - File was updated after upload was posted
Filename - Tip: You can click the magnifying glass to see the archive contents Size Downloads Date
TS4MorphMaker_4_3_0_0.zip | Extract folder and run TS4MorphMaker.exe

Size: 8.96 MB · Downloads: 8,272 · 9th Jun 2020
8.96 MB 8,272 9th Jun 2020
TS4MorphMakerSource_6_8_20.zip | Source files, not needed to use the tool

Size: 8.88 MB · Downloads: 2,862 · 9th Jun 2020
8.88 MB 2,862 9th Jun 2020
Don't forget to Thank the creator after downloading! Use the Thanks button located above the screenshots above.
Basic Download and Install Instructions:

1. Download: Click the download link to save the .rar or .zip file(s) to your computer.

2. Extract: Use 7zip (recommended), WinRAR (Windows) or Stuffit (OS X) to extract the file(s) from the .rar or .zip file(s). OS X also has a built-in utility for that (just rightclick).

3. Download the TS4MorphMaker program zip file, extract, and run TS4MorphMaker.exe

Need more information?
 
326 Comments / Replies (Who?) - 268 Feedback Posts, 44 Thanks Posts
Hide Thanks Posts for this thread (Show only feedback)
Page 10 of 14
Ms. Byte
Original Poster
#226 Old 15th Nov 2019 at 10:43 PM
Quote:
Originally Posted by thiagomichel

unfortunately still the same way: /


Sorry this is still happening. I think now it's probably caused by the tool converting from global to local coordinates to save the bone adjustment, then converting it back when you click to another bone and back. When there are multiple adjustments to a chain of bones it gets a bigger error in the conversion, or that's what it looks like to me. I'll fiddle with it, and thanks.

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Test Subject
#227 Old 16th Nov 2019 at 7:21 PM
Quote:
Originally Posted by CmarNYC
Sorry this is still happening. I think now it's probably caused by the tool converting from global to local coordinates to save the bone adjustment, then converting it back when you click to another bone and back. When there are multiple adjustments to a chain of bones it gets a bigger error in the conversion, or that's what it looks like to me. I'll fiddle with it, and thanks.

If it happens to be fixed, I don't even know if what I intend to do will work out fine! but in any case, it's always good to warn you, isn't it? thanks again.
Test Subject
#228 Old 17th Nov 2019 at 4:13 AM
Default Messy normals
Hello. I investigated the comments above and understood that my problem is messy meshes. But I can't fix it. Can you help me?

Thankful.
https://ibb.co/hDXwsjm
http://www.mediafire.com/file/cltec...malhas.rar/file
Ms. Byte
Original Poster
#229 Old 17th Nov 2019 at 1:24 PM
Quote:
Originally Posted by arianegreen
Hello. I investigated the comments above and understood that my problem is messy meshes. But I can't fix it. Can you help me?

Thankful.
https://ibb.co/hDXwsjm
http://www.mediafire.com/file/cltec...malhas.rar/file


I can't examine the mesh right now, but from the pic it looks like the normals are messed up. You may not have exported the normals correctly. The easiest way to fix it is to check 'Ignore normals' when you make the DMap.

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Test Subject
DELETED POST
18th Nov 2019 at 10:38 PM
This message has been deleted by arianegreen.
Test Subject
#230 Old 18th Nov 2019 at 11:44 PM
Quote:
Originally Posted by CmarNYC
I can't examine the mesh right now, but from the pic it looks like the normals are messed up. You may not have exported the normals correctly. The easiest way to fix it is to check 'Ignore normals' when you make the DMap.


Hi. I couldnt found the 'Ignore normals', but I found this now, its in 'Create shapes and normal DMaps'.
My preset its awesome! Thank you so much!
Test Subject
#231 Old 24th Nov 2019 at 4:20 PM
Hi! Does anyone know how to fix the "you have not entered a valid display index value" that appears when I click on 'save preset' right before saving a face preset as new package?

Ms. Byte
Original Poster
#232 Old 25th Nov 2019 at 9:25 PM
Quote:
Originally Posted by gnani
Hi! Does anyone know how to fix the "you have not entered a valid display index value" that appears when I click on 'save preset' right before saving a face preset as new package?



Since I can't see what you entered in the display index field behind the error message, it's hard to say. The display index has to be a number. If you put a comma in it, try a period instead.

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Test Subject
#233 Old 5th Dec 2019 at 6:43 PM
Quote:
Originally Posted by CmarNYC
Since I can't see what you entered in the display index field behind the error message, it's hard to say. The display index has to be a number. If you put a comma in it, try a period instead.

The number in it is the default one '0.00'. Do I need to change it to another one?
Ms. Byte
Original Poster
#234 Old 5th Dec 2019 at 8:09 PM
Quote:
Originally Posted by gnani
The number in it is the default one '0.00'. Do I need to change it to another one?


Try just 0

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Test Subject
#235 Old 6th Dec 2019 at 6:57 PM
Hey, I got the same issue like gnani. There's a super easy fix. You need to delete the comma "," and use a dot "." instead of it in the Display Item field or just a 0 without anything behind. Seems like this gets broken because of the comma and dot difference in the different countries... :/

I'm having also the issue with changing numbers by switching between the bones/slots which drives me crazy because with some clicks the difference gets more and more (in my case I had the feeling that the values get smaller each time) but this doesn't happend to all fields which makes it even look more weird. Btw. I like it a lot that I can change between degree and radians (I usually use degrees and so I needed an online tool to calc the radians xD). I also like it that it seems like the orientation of x, y and z works right though I've no idea what's the exact difference between the local and global coordinates. I could imagine it from mathematics but Idk what it exactly means in TS4. XD Right now I just switched to an old MM version to create the BOND files.

Using the ROOT__ slot works again. That was an issue I had with an earlier version.
I'm still working on the dog sliders - or in the meanwhile I'm trying it with (body) presets instead of sliders. It seems like it'd be only by this way possible for me to create taller/smaller dogs additional with shorter legs. When using sliders both sliders works pretty fine but together they look sadly ugly. :/ These bone adjustments by EA are horrible or crazy... It seems like they worked much easier in TS3... Btw. sorry for the veeeery late response, CmarNYC!

EDIT: This is feedback to version 4.1.0.0.
Ms. Byte
Original Poster
#236 Old 6th Dec 2019 at 8:26 PM
Quote:
Originally Posted by SonnyRex
Hey, I got the same issue like gnani. There's a super easy fix. You need to delete the comma "," and use a dot "." instead of it in the Display Item field or just a 0 without anything behind. Seems like this gets broken because of the comma and dot difference in the different countries... :/

I'm having also the issue with changing numbers by switching between the bones/slots which drives me crazy because with some clicks the difference gets more and more (in my case I had the feeling that the values get smaller each time) but this doesn't happend to all fields which makes it even look more weird. Btw. I like it a lot that I can change between degree and radians (I usually use degrees and so I needed an online tool to calc the radians xD). I also like it that it seems like the orientation of x, y and z works right though I've no idea what's the exact difference between the local and global coordinates. I could imagine it from mathematics but Idk what it exactly means in TS4. XD Right now I just switched to an old MM version to create the BOND files.

Using the ROOT__ slot works again. That was an issue I had with an earlier version.
I'm still working on the dog sliders - or in the meanwhile I'm trying it with (body) presets instead of sliders. It seems like it'd be only by this way possible for me to create taller/smaller dogs additional with shorter legs. When using sliders both sliders works pretty fine but together they look sadly ugly. :/ These bone adjustments by EA are horrible or crazy... It seems like they worked much easier in TS3... Btw. sorry for the veeeery late response, CmarNYC!

EDIT: This is feedback to version 4.1.0.0.


Yes, the . vs , is due to me not allowing for different countries, which I will fix. And yes, bone adjustments in TS4 clearly have complications.

I looked at the changing numbers problem and figured out the cause, but still have to find a solution.

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Test Subject
#237 Old 23rd Dec 2019 at 2:42 AM
Is anyone having trouble actually downloading the morphmaker? looks like the file is corrupt? are there anymore download links that work?
Test Subject
#238 Old 30th Dec 2019 at 10:57 PM
You've probs already been asked this like a thousand times, but is there a version of this for mac? If not, do you have plans to make one?
Ms. Byte
Original Poster
#239 Old 1st Jan 2020 at 4:26 PM
Quote:
Originally Posted by Simgirl10
You've probs already been asked this like a thousand times, but is there a version of this for mac? If not, do you have plans to make one?


Sorry, no to both. Anyone who wants to make a Mac version is welcome to.

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Test Subject
THANKS POST
#240 Old 5th Jan 2020 at 10:29 AM
Do you plan to add spellcaster options so that presets (Body ones for example) show up on spellcaster Sims in CAS? Presets aren't showing up on spellcaster Sims atm.
Ms. Byte
Original Poster
#241 Old 5th Jan 2020 at 4:41 PM
Quote:
Originally Posted by jengelbart
Do you plan to add spellcaster options so that presets (Body ones for example) show up on spellcaster Sims in CAS? Presets aren't showing up on spellcaster Sims atm.


Thanks for letting me know - update uploaded.

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Test Subject
#242 Old 6th Jan 2020 at 1:04 AM Last edited by {XEX} : 6th Jan 2020 at 3:01 AM.
I'm not new to making presets, but i stumbled across the problem i cant fix: a made a face preset for children and it shows up fine in cas, but not in game mode. Other presets (both mine and other creators) are working except for this new one and two others i made just for checking (child and adult). Am i missing something?
Ms. Byte
Original Poster
#243 Old 6th Jan 2020 at 6:20 AM
Quote:
Originally Posted by {XEX}
I'm not new to making presets, but i stumbled across the problem i cant fix: a made a face preset for children and it shows up fine in cas, but not in game mode. Other presets (both mine and other creators) are working except for this new one and two others i made just for checking (child and adult). Am i missing something?


What does that mean, it doesn't show up in game mode? The changes made in CAS disappear in live mode? And did this happen with the new version of MorphMaker?

There's no way I can tell what's wrong without seeing the package. Please upload it so I can take a look.

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Test Subject
#244 Old 6th Jan 2020 at 2:15 PM
I tried with 4.0, 4.1 and 4.2 and it doesn't work. I tried to compare my new presets with my old ones (that are working) in MorphMaker to see if i missed something, but there's no difference. I tried with and without cc, tried another EA folder, nothing worked.
Once i'm on a lot, my sims lose new presets i made and that are visible in cas. Again, to be clear, everything old is working fine, but the ones i made yesterday doesnt work.
Another thing is that the Add/Edit Sculpts window in MorphMaker doesn't have a proper gender window, dont know if that's important.

I dont know how to add packages, so i uploaded em on mediafire:
http://www.mediafire.com/file/jq00d...se.package/file
http://www.mediafire.com/file/nckss...se.package/file
Screenshots
Ms. Byte
Original Poster
#245 Old 6th Jan 2020 at 3:06 PM
You don't have either gender enabled in the sculpt settings. With that fixed, it works fine. I can see that the gender options aren't showing correctly for you in MorphMaker, possibly because you seem to have your text sized up a little. Try making the window bigger - if that doesn't work I can rearrange the screen a bit.
Screenshots

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Test Subject
#246 Old 6th Jan 2020 at 5:14 PM
Quote:
Originally Posted by CmarNYC
You don't have either gender enabled in the sculpt settings. With that fixed, it works fine. I can see that the gender options aren't showing correctly for you in MorphMaker, possibly because you seem to have your text sized up a little. Try making the window bigger - if that doesn't work I can rearrange the screen a bit.


Yes, it is definitely my messed up screen settings/graphics card update i'm struggling with currently that caused the problem. Solved by using a different computer. Thank you so much for your help!
Test Subject
THANKS POST
#247 Old 12th Jan 2020 at 2:04 AM
Muito Obrigada por compartilhar seu trabalho. Esta fazendo muito sucesso entre os Simmers!
Lab Assistant
THANKS POST
#248 Old 17th Jan 2020 at 6:33 PM
thanks
Test Subject
#249 Old 22nd Jan 2020 at 9:35 PM
Hello I want to create a body preset. But morph maker gives me an error. The error is: "Index out of range". (I translated it) My morphed file is here. Please help

https://drive.google.com/open?id=1M...ld6_8LcZXPtNM95
Page 10 of 14