MTS has all free content, all the time. Find out how YOU can help to keep it running. Tell me how...

Inventor's Workbench fix for Bridgeport.

by dividingbyzero Posted 22nd Mar 2011 at 6:09 PM
46 Comments / replies (Who?) - 11 Feedback Posts, 11 Thanks Posts
This small tuning mod enables the ability to create SimBots on the Inventors Workbench in Bridgeport. This is accomplished by overriding the tuning "MakeFrankensim_InventionWorkbench" in the GameplayData.Package. Specifically, this tuning only modifies the line in the tuning that (originally) reads:

Code:
<World RestrictionType="Allow" Types="Base" Names=""/>

by changing it to:

Code:
<World RestrictionType="Disallow" Types="Vacation" Names=""/>


This tuning was made in base game version 1.19, with WA, Amb, and LN all fully patched to that point, but as this interaction has apparently been disabled in all LN installations, it should work in older versions. I'm unsure as to whether or not WA is actually required for the replacement tuning to be properly recognized, so if you have Ambitions and Late Night but not World Adventures, use at your own risk.

Side note--I chose to use "Disallow" on "Vacation" worlds because it enabled the interactions for Bridgeport while still keeping with the spirit of the original line, which was to only permit building SimBots in your "home" world.

You must have the expansion, game version or stuff packs listed below installed to use this custom content. Please see the post text for any exceptions.

Sims 3 World Adventures Ambitions Late Night
Built with Game Version: 1.19.44.01
Key: - File was updated after upload was posted
Filename - Tip: You can click the magnifying glass to see the archive contents Size Downloads Date
Bridgeport Workbench Fix.zip

Size: 1.3 KB · Downloads: 11,648 · 22nd Mar 2011
1.3 KB 11,648 22nd Mar 2011
Don't forget to Thank the creator after downloading! Use the Thanks button located above the screenshots above.
Basic Download and Install Instructions:

See: Game Help:TS3 CC Basicswiki for a full guide!
 
46 Comments / Replies (Who?) - 14 Feedback Posts, 30 Thanks Posts
Hide Thanks Posts for this thread (Show only feedback)
Page 2 of 2
Test Subject
THANKS POST
#26 Old 27th Oct 2011 at 4:13 AM
I can confirm this tweak works under the following conditions:

- version 1.26
- Adventures, Ambitions, Late Night, Generations, and Pets all installed
- High End Loft and Fast Lane
- Bridgeport
- A sim who had already turned in the 100 scrap and was prevented from performing the last task, pre-tweak

This tweak saved my game. Big Kudos to the maker. Now if only I can get the game to spit out a 'female' simbot on the first attempt... I don't wanna have to go find yet ANOTHER pink diamond! : /
Test Subject
#27 Old 10th Dec 2011 at 10:32 PM
This works for me with Ambitions, Late Night, and all the stuff packs installed (FL, HEL, OL, TL)
Thanks!
Test Subject
THANKS POST
#28 Old 19th Dec 2011 at 5:58 PM
This mod is amazing!!Work fine on 1.29 patch and bridgeport thank you!!
Test Subject
#29 Old 19th Jan 2012 at 5:11 PM
I am having trouble getting this to work. Every time I click to download it tells me that no valid mts login found. Any help would be great.

I have all EPs and all SPs downloaded.
Be like the 22nd elephant with heated value in space- Bark!
retired moderator
#30 Old 19th Jan 2012 at 5:46 PM
GableDan87, check the URL- if it says 'www.modthesims2.com' at the top of the page (or anything else), then change that bit to say 'www.modthesims.info'.
Test Subject
#31 Old 19th Jan 2012 at 6:27 PM Last edited by GableDan87 : 20th Jan 2012 at 1:09 AM.
After waiting 7 hours, the download finally started working. And so now I am very pleased that I can make my Simbot.
Test Subject
#32 Old 2nd Feb 2012 at 5:01 PM
where i should put the file after download? please help me
Test Subject
THANKS POST
#33 Old 7th Feb 2012 at 4:01 PM
Exactly what I needed. It totally saved my game!
Test Subject
THANKS POST
#34 Old 19th Mar 2012 at 9:57 PM
I'm very confused on how to download this!!! I have a Mac OS X and this is so confusing and frustrating!!! I'm new here so someone please help me.
Test Subject
#35 Old 11th May 2012 at 2:20 AM Last edited by PolychromeKitty : 12th May 2012 at 4:50 AM.
Quote:
Originally Posted by lufflyninja
The mod didn't work for me, but then again I don't know if it was going to fix it in the first place.

My sim is in Sunset Valley and had everything to build the simbot, even the option to build the "mystery invention" is popping up. It's just when my sim is done making it nothing happens, no simbot, it just starts the invention over again. I thought this would help because I do have Late Night installed and everything, just not using Bridgeport.

Any idea what could be causing this?


Same thing for me...I'm playing in Appaloosa Plains, Late Night installed, and like what happened to Luffly, I complete the whole quest, go through the invention process, but then no Simbot appears after I complete it. :/ Anyone have a fix for THAT yet? I don't even know what causes it...sadly, this mod didn't fix it, since it seems to be a different problem.
Test Subject
THANKS POST
#36 Old 12th Jul 2012 at 3:46 PM
Anyone knows where I should extract the file to?
Test Subject
THANKS POST
#37 Old 15th Sep 2012 at 6:11 AM
OMG!!! I cannot thank you enough. My sims can finally finish!! Wheeee!
Test Subject
#38 Old 15th Sep 2012 at 6:15 AM
Quote:
Originally Posted by GrimRATS
Anyone knows where I should extract the file to?


You should put it in your Mods folder like this:
C:\Users\(your name)\Documents\Electronic Arts\The Sims 3\Mods\Packages
Test Subject
#39 Old 25th Sep 2012 at 3:38 AM
Quote:
Originally Posted by PolychromeKitty
Same thing for me...I'm playing in Appaloosa Plains, Late Night installed, and like what happened to Luffly, I complete the whole quest, go through the invention process, but then no Simbot appears after I complete it. :/ Anyone have a fix for THAT yet? I don't even know what causes it...sadly, this mod didn't fix it, since it seems to be a different problem.


have you tried checking the family inventory? that happened to me with the time machine and it was put in to the family inventory.
Test Subject
#40 Old 12th Apr 2013 at 8:09 AM
I know I'm late to the party on this but I just wanted to confirm that this fix worked for me and I DON'T have world adventures installed. Thank you so much!!
Lab Assistant
#41 Old 15th Jun 2013 at 5:55 PM
Thanks! I don't have World Adventures and I'm patched to 1.50 and it works perfectly. If I uninstall this, will it break my game?

The Sims Forever
Test Subject
#42 Old 20th Dec 2013 at 1:30 PM
why this doesnt work with my game? i have ambitions, late night, and seasons installed.. my sims reach all things that can be invented from the workbench, but theres no option to create the simbot.. is there any way to fix that?? im using nraas mastercontroller mod and potrait panel to make my household over than 8 people, is that can be a problem that cause simbot cannot be created???
Guest
THANKS POST
#43 Old 28th Jun 2014 at 6:13 AM
Hi! Please help me! My workbench dosn't work! I can't invent anything in it, I just gain skills but dont invent anything. I'm already in level 9 of inventing! I tried fix it by installing youre fix but it didn't work either, Can you help me? :(
Test Subject
THANKS POST
#44 Old 22nd Jul 2014 at 4:30 PM
thank you
Test Subject
THANKS POST
#45 Old 2nd Sep 2014 at 5:47 AM
This did the job, and I just downloaded it today (and don't have WA). Now, what to name the bot...
Test Subject
THANKS POST
#46 Old 3rd Feb 2017 at 10:43 AM Last edited by SimsKtar : 3rd Feb 2017 at 10:45 AM. Reason: Adding Info about Ep's, etc.
Hurrah! This allowed me to finish the opportunity, without needing to move to a new town. Thank you so much!

Edited to add: For the record, I have all EP's, SP's, and Store content, and my game is patched to the latest patch.
Test Subject
THANKS POST
#47 Old 5th Aug 2017 at 5:47 AM
Thanks
Page 2 of 2