MTS has all free content, all the time. Find out how YOU can help to keep it running. Tell me how...

Less/More Expensive Plastic Surgery + No Fail! 4 FLAVORS

by WTFeathers Posted 26th May 2012 at 8:27 PM - Updated 4th Jul 2014 at 12:21 PM by WTFeathers
15 Comments / replies (Who?) - 13 Feedback Posts, 1 Thanks Posts
This Mod was made with game version 1.33 and will NOT work with any game version below 1.26, as this mod requires Pets and Pets requires patch 1.26 to play.

working with patch 1.67

Compatible patches: 1.26 and up (1.26 ----> 1.63)

What does this mod do?

This mod changes the prices of Plastic Surgery that can be done at the hospital, and it also guarantees 100% success of the surgery. [optional]

There are 4 flavors available.

Less Expensive Plastic Surgery:

Default Cheap Facial Beautification §950 ---> Changed into §475
Default Expensive Facial Beautification §2800 ---> Changed into §1400
Default Cheap Body Modification §1100 ---> Changed into into §550
Default Expensive Body Modification §3250 ---> Changed into §1625
Default Corrective Facial Surgery §2050 ---> Changed into §1025
Defualt Corrective Body Surgery §2275 ---> Changed into §1137

More Expensive Plastic Surgery :

Default Cheap Facial Beautification §950 ---> Changed into §1900
Default Expensive Facial Beautification §2800 ---> Changed into §5600
Default Cheap Body Modification §1100 ---> Changed into into §2200
Default Expensive Body Modification §3250 ---> Changed into §6500
Default Corrective Facial Surgery §2050 ---> Changed into §4100
Defualt Corrective Body Surgery §2275 ---> Changed into §4500

Less Expensive Surgery + No Fail :
This applies the changes of the "Less expensive Surgery" flavor + guarantees success of every surgery.
To do this, I changed the EA default values from 0.4 (40%) chance of failure for cheap plastic surgery and 0.1 (10%) for expensive plastic surgery to 0.0 (0%) for both.

More Expensive Surgery + No Fail :
This applies the changes of the "More expensive Surgery" flavor + guarantees success of every surgery.
To do this, I changed the EA default values from 0.4 (40%) chance of failure for cheap plastic surgery and 0.1 (10%) for expensive plastic surgery to 0.0 (0%) for both.

Conflicts:

This mod is not compatible with any other mods that edit the Hospital_XML file, if you install mods as such at the same time as this mod, you may experience problems in your game.

THIS IS NOT A CORE MOD, therefore it shall not interfere with any core mods installed.

Installation:

Extract the downloaded file and put the contents in: MyDocuments/ElectronicArts/TheSims3/Mods/Packages

Choose ONE flavor only
------------------------------------------------------------

This is my first upload, so any feedback would be much appreciated

Happy Simming
Cheers

Additional Credits: S3PE Utility

Type: Other

You must have the expansion, game version or stuff packs listed below installed to use this custom content. Please see the post text for any exceptions.

Sims 3 Pets
Built with Game Version: 1.33
Key: - File was updated after upload was posted
Filename - Tip: You can click the magnifying glass to see the archive contents Size Downloads Date
More Expensive No Fail Surgery.rar

Size: 2.5 KB · Downloads: 1,797 · 26th May 2012
2.5 KB 1,797 26th May 2012
Less Expensive No Fail Surgery.rar

Size: 2.5 KB · Downloads: 1,567 · 26th May 2012
2.5 KB 1,567 26th May 2012
More Expensive Surgery.rar

Size: 2.5 KB · Downloads: 1,376 · 26th May 2012
2.5 KB 1,376 26th May 2012
Less Expensive Surgery.rar

Size: 2.5 KB · Downloads: 721 · 26th May 2012
2.5 KB 721 26th May 2012
Don't forget to Thank the creator after downloading! Use the Thanks button located above the screenshots above.
Basic Download and Install Instructions:

See: Game Help:TS3 CC Basicswiki for a full guide!
 
15 Comments / Replies (Who?) - 12 Feedback Posts, 1 Thanks Posts
Hide Thanks Posts for this thread (Show only feedback)
Lab Assistant
#2 Old 7th Sep 2012 at 5:56 PM
I am assuming this is still compatible with 1.38 ?
Instructor
#3 Old 21st Sep 2012 at 8:10 PM
Great job

Knight Of The Moon
Test Subject
Original Poster
#4 Old 22nd Sep 2012 at 4:19 PM
Quote:
Originally Posted by Lunararc
Great job


Thank you Lunar I appreciate it

SUCKER
Test Subject
Original Poster
#5 Old 22nd Sep 2012 at 4:25 PM
Quote:
Originally Posted by TammyLin Saphir
I am assuming this is still compatible with 1.38 ?


Sorry for the late reply, but yes it is

SUCKER
Lab Assistant
#6 Old 30th Oct 2012 at 3:29 PM
is this compatible with patch v1.42/Seasons?
Lab Assistant
#7 Old 18th Nov 2012 at 9:22 PM
I assume this code hasn't been altered by the most recent patch (1.42), but confirmation would be great.
Test Subject
Original Poster
#8 Old 24th Nov 2012 at 9:17 PM
For everyone wondering, yes this is patch 1.42-compatible

SUCKER
Lab Assistant
#9 Old 27th Nov 2012 at 11:30 PM
Thanks.
Test Subject
#10 Old 5th Mar 2013 at 7:10 PM
Is this compatible with 1.50? I hope so because I have already pre-ordered University and I downloading most likely either tonight or tomorrow.
Field Researcher
#11 Old 12th Mar 2013 at 8:29 PM
Is this compatible with patch 1.50?
Lab Assistant
#12 Old 18th Jun 2013 at 5:32 PM
Quote:
Originally Posted by Mera Benzema
Is this compatible with patch 1.50?


Yes, worked at my side...

-----------

The cheap No-Fail surgery is 0.0 at my side, not the 0.1 (10%) as described in the description - I opened the XML to edit the prices to make it even cheaper...

Code:
<kCheapSurgeryFailureChance value="0.0"> <!--Range: 0.0f - 1.0f Description: The chance of failure in a cheap surgery--> </kCheapSurgeryFailureChance>
 <kExpensiveSurgeryFailureChance value="0.0"> <!--Range: 0.0f - 1.0f Description: The chance of failure in an expensive surgery--> </kExpensiveSurgeryFailureChance>
Lab Assistant
#13 Old 22nd Jun 2013 at 11:03 PM
Just wanted to say:
No compatibility problems with Basegame-Patchlevel 1.55.x

Tested in MonteVista (Store-World) with all EP's an SP's available (22nd June 2013) installed.
Field Researcher
#14 Old 24th Jan 2014 at 8:10 PM
Did anyone test with 1.66 yet?
Test Subject
DELETED POST
22nd Jul 2014 at 4:23 AM
This message has been deleted by aman2499. Reason: How Do I Get It To Work With 1.67
Lab Assistant
THANKS POST
#15 Old 27th Dec 2016 at 1:10 AM
Did you watch "Repo! The Genetic Opera" to much?