LOTS NOT SHOWING IN THE LOTS BINS (EDITED)
Date Posted: 19th Mar 2008 at 5:54 AM Views: 153
DIARY ENTRY 11: LOTS NOT SHOWING IN THE LOTS BINS

Note: For anyone loading a lot or downloading a lot with this issue.

THE PROBLEM: (Lots Not Showing In The Lots Bin)
Someone downloads a lot. They click on the Sims2Pack Clean Installer file and install the lot. When they enter the game, the lot is not in the lots bin. If any file in your Downloads Folder has a non-basic English character (other than A-Z, 0-9, underscore, etc.) then Sims2Pack has trouble reading those characters so the lot never shows up in the game but the objects do.

THE SOLUTION:
Install everything in the lot package ( Sims2Pack Clean Installer). Go into your Downloads Folder and rename the download files (walls, floors, terrains, objects) that have Non-Standard English characters. Go into your Teleport Folder, delete the file(s) in there.
Read Carefully:
Install the lot file AGAIN (Sims2Pack Clean Installer) BUT this time, uncheck the PREVIEW BOX and CLICK on the icon of the LOT ONLY to install only the lot. (You already have the downloads installed). Then click install. Once you enter the game, the lot should now be in your lots bin!

PERSONAL EXPERIENCE
Here is a step-by-step account of what happens from my end just to make sure I am explaining it right and hopefully everyone can see what happens or where the problem comes in.

I attempt to load the original version of my Shell Cottage lot (because I KNOW that it will NOT SHOW in the Lots bin). I created a set of floor textures and used an "&" in the floor texture package name. They have names like "floor_sb08redmulch&grass2". The Sims 2 lot package is called sb08HPCShellCottage. The lot package has a regular name.

1. I have nothing in my Downloads Folder except the Enabler Color Options file. The Teleport Folder is empty.

2. I click on the ShellCottage Sims2Pack. Clean Installer opens the file. I change nothing. The Preview box is checked. I click install! The default is set to go to the Teleport Folder. I click install again.

3. BEFORE ENTERING THE GAME. The files all show up in the downloads folder. I have 8 floors that use the & in my Downloads Folder. The Teleport Folder is still empty.

4. I load The Sims 2 game. The lot is NOT in the Lots Bin. I minimize the game. The Downloads Folder is the same. The Teleport Folder now has a Sim2 Temp File named 44ec0bdc623eda3936c3f102f40521b3.

5. I exit the game. THINKING ALOUD: OMG! Here's how "I" created empty packages. The first time I did this, I reloaded the lot package again immediately after exiting the game! (You know gotta try it 1 more time just in case I didn't do something correct the first time.) I'll do that...This is where the Empty Packages came in BECAUSE (DUH!). There are now duplicates of the same file which is probably very confusing for the installer! There are now 2 files in the Teleport Folder. 1 File opens and it has the lot and a few of the download objects labeled as "empty packages" (a Sims Import File) and a 2nd file with the same name and absolutely nothing in it (a Sims2 Temp File)!

6. I will enter the game again (as that is what I did the very first time this happened before trying something new). Of course, the lot is STILL not in the Lots Bin. I exit the game. Now there is only the Sims 2 Temp File in the Teleport Folder with nothing in it.

7. I clear everything out of the Teleport Folder and the Downloads Folder (except the Color Enabler File). Must start "fresh" to get to the solution.

Solution
8. I click on the Sims2Pack for Shell Cottage again and click install twice to install the lot with objects without changing anything. There are now 2 Files in the Teleport Folder (a Sims2 Temp File and a Sims2ImportFile). The object files are in the Downloads Folder. I go into the Downloads Folder and rename those Non-Standard files (in my case removing the "&"). I also open the Teleport Folder and delete any files in it.

9. I reinstall the LOT ONLY in the Sims by clicking on the Sims2Pack for Shell Cottage since I already have the objects in the game, unchecking the Preview box and clicking on the House Lot to install ONLY the lot. I enter the game. The lot shows! :D

10. I repackage the lot. When I exit, there is nothing in the Teleport Folder. After clearing the Downloads Folder (except the Enabler file), I reinstall the newly packaged lot to make sure it works correctly. It loads properly.

ADDITIONAL TESTS:
1. Unchecking the oddly named files during an install did not work. That was probably because the name you see in Sims2Pack Clean installer is not necessarily the name of the file. The lot didn't show in the lots bin.

2. Of course, installing the Lot Only worked as well. However, the lot looks different without the decorative objects. This is however an option if you prefer not to tinker with files a little. It's painless and actually works!

ORIGINAL INFO I FOUND WHEN I FIRST ENCOUNTERED THIS PROBLEM
Original Info I found when trying to find a solution as to why lots did not show in the lots bin:
http://sumomo.modthesims2.com/showthread.php?t=200668

THINGS TO KEEP IN MIND
- Every once in a while some fluke thing happens and a lot is actually corrupt, but this is indeed rare. As the causes for corrupt files can be numerous, I won't even attempt to understand that. Usually, you can identify a corrupt file easily because it often won't open in the Sims2Pack stage or it loads in the lots bin but when you click on it "strange" things happen from brief flashes, returning you to the deskptop while minimizing or crashing and kicking you out of the game. Don't try to fix these files, but get rid of them.

- The Sims 2 is much more stable with lots and having custom content than Sims 1. I have found that it is rarely the custom content that causes problems as it is simple things like how programs read or intrepret custom content. The files themselves were fine, but file names are crucial.

THE SHORT OF IT
File names that use English text A-Z, 0-9, hyphen and the underscore will work best to prevent lots from not showing in the lots bin. Accent marks(ö ü é ï ô) over letters really are difficult for the Sims2Pack (which is a blessing to the Sims community) to read. This is not to dishonor cultural language markings. If you find a file like this in your downloads, be sure to change the file name (WITH PERMISSION FROM THE CREATOR) BEFORE PACKAGING THE LOT if you are uploading the file in a lot. It's also wise to carefully search the files you installed. I originally overlooked the file that caused this error in the Lavender Farm lot. Several of my Harry Potter lots had files with Non-standard English characters as well. The best thing to do is keep the package file names simple and hopefully it will prevent this from happening!

StephSim

END OF DIARY ENTRY 11: LOTS NOT SHOWING IN THE LOTS BINS

Recent Comments for: LOTS NOT SHOWING IN THE LOTS BINS (EDITED)
LOTS NOT SHOWING IN THE LOTS BINS (EDITED)
By StephSim (8th Mar 2012 at 10:11 PM)
Update:

Thanks to the October 26th Update of the Clean Installer, Mootilda has fix this non-standard character issue, which was why lots were not showing in the lots bin! Thanks Mootilda. I appreciate your looking into this!
LOTS NOT SHOWING IN THE LOTS BINS (EDITED)
By StephSim (31st Mar 2008 at 1:22 AM)
Touché! I suspect you are correct! Loading the lot only will allow the lot to show. Of course, that will be one sad looking lot if it were one of mine with custom walls, windows and doors!

Curiousity? When you used the non-standard characters...did you rename the lot package or a file contained in the lot package before packaging the lot? If it was the lot package, I guess it wouldn't open at all.

I did a technical check for you and I have EDITED my Journal Entry to reflect this. Strange stuff here just because of the characters in an object package name. Thanks again for your input!
LOT BUILDER PLEA TO CUSTOM CONTENT CREATORS
By Delphy (30th Mar 2008 at 7:02 PM)
Hi Steph, thanks for the reply. I have to admit I am confused between your description of what happens with your teleport folder and what should actually happen based on the way Sims2Packs get installed by various tools (including S2PCI and Q-Xpress).

Essentially, the Sims2Pack consists of 2 components. The XML header and the actual Packages themselves. The header tells the various install tools what is contained in this Sims2Pack as well as an md5/crc version of the filename (ie the dc5baf73c.package). It is this version of the filename that S2PCI should create inside the Teleport folder.

Let me restate this: The crc value found in the header XML of the Sims2Pack is what is used to create the files within the Teleport folder. You should (technically, unless you are using Q-Xpress), never see any other files with different names inside the Teleport folder.

I just did a test with a lot and made a package have all kinds of stupid characters and S2PCI couldn't even open the Sims2Pack let alone install anything from it.

I suspect that if you select to only install the lotSegmentForSims and nothing else, everything would work fine and the lot would appear in the Bin.
Re: LOT BUILDER PLEA TO CUSTOM CONTENT CREATORS
By StephSim (30th Mar 2008 at 1:11 AM)
Thanks for sharing that Delphy. I responded above due to the 1000 character limit! :D
Re: LOT BUILDER PLEA TO CUSTOM CONTENT CREATORS
By Delphy (29th Mar 2008 at 7:03 PM)
The empty package problem has nothing to do with the Teleport folder. In fact, the packages that get installed into Teleport contain the md5 (or crc32, I forget which) version of the filename (ie dc5ef7b.package). Using the teleport folder, it should not put the normal download also in the downloads folder. Why? Becuase they you have duplicates and the game doesn't like it.

The empty package thing actually isn't an empty package, btw, it's simply a non existant package within the Sims2Pack but the XML header still exists so it *thinks* it's empty but in fact isn't there at all (which is slightly different).

The actual content that exists on the lot when you package it should have absolutely no bearing on whether on not that lot appears in the lot bin. It might have an effect if you install it via Clean Installer and it screws up the XML in the Teleport folder, but this is a seperate issue specifically for that one program.
LOT BUILDER PLEA TO CUSTOM CONTENT CREATORS
By fanseelamb (20th Mar 2008 at 7:43 PM)
Very interesting, StephSim. Thanks for the info!
LOT BUILDER PLEA TO CUSTOM CONTENT CREATORS
By StephSim (20th Mar 2008 at 4:59 AM)
Fresh-Prince (with a dash)...The dash actually is fine. Lots of people use them and I haven't had any trouble with them at all. It would be interesting to compile a list, but I figure the easiest way to avoid it all is to use the old standard English letters and numbers! I know for certain that the ampersand "&" cannot be used. If you know for sure of others, feel free to post it here!
LOT BUILDER PLEA TO CUSTOM CONTENT CREATORS
By Fresh-Prince (19th Mar 2008 at 10:14 PM)
Do you know if the dash(-) affected this too? It'd be interesting to know cause I use a dash in all my file names.

But thanks for letting us know!

vB Journal Version 1.5.0 Beta 3
vB Journal Copyright Anthony Scudese