Replies: 23 (Who?), Viewed: 2683 times.
Link Ninja
Original Poster
#1 Old 11th Jul 2019 at 1:04 AM Last edited by Charmful : 11th Jul 2019 at 2:31 AM. Reason: adding pic
Default Special characters appearing wonky
Hello, this was not an issue as recent as yesterday (CST time) but I noticed that text with special characters like apostrophes, quotations, commas, etc are now looking really funky in the story forum especially. I know that going in and replacing them and saving will render them normal-looking again but that can be a hassle especially on multi-chapter stories in the forum. I originally saw this in the TS2 story forum on my recent story and then saw it on older stories. Was there a recent code change that would cause this?
Screenshots

Uh oh! My social bar is low - that's why I posted today.

Advertisement
Scholar
#2 Old 11th Jul 2019 at 1:20 AM
I've been seeing those too, but on the Classic version of the website. If it's the case, then I don't think staff would be inclined to fix it.

Check out my latest version of Superman's Classic Uniform for The Sims 2.
See what images I have posted on DeviantArt as well related to The Sims 2 and designs.
Also check out My Website to see my superhero uniform creations for The Sims 2. THANKS!!!
Link Ninja
Original Poster
#3 Old 11th Jul 2019 at 2:30 AM
I'm using the newer version with the dark blue backgorund unless there's a newer new version? I'm also on Chrome and had someone else check just to be sure.

Uh oh! My social bar is low - that's why I posted today.

Scholar
#4 Old 11th Jul 2019 at 4:28 AM
Did you purchase a new keyboard lately? Or are using a different language setting on the keyboard?

Maybe the quotation marks and apostrophes on your keyboard are not the same as those from other ones?

Do you see the quotation marks around the word Here below?

"Here"

And do you see the two pairs of apostrophes around the work Here below?

''Here''


Doesn't make sense what i wrote above, the special characters are working fine in this thread. Nevermind.

Check out my latest version of Superman's Classic Uniform for The Sims 2.
See what images I have posted on DeviantArt as well related to The Sims 2 and designs.
Also check out My Website to see my superhero uniform creations for The Sims 2. THANKS!!!
Link Ninja
Original Poster
#5 Old 11th Jul 2019 at 5:03 AM
Ah okay let me clarify, text, that was pasted in from a different part of the internet was fine until yesterday. If I paste it in, from let's say tumblr (where I pasted in my story text), it looks like this:

“Sunlight”

I’d love to get your feedback

Made for the MTS 2019 Calendar contest. If you want to enter a picture, click here for more info.

Edit: Well damn, WTF - That pasted in text looks fine in this thread too - so why are all my stories all of a sudden being wonky with characters??

Uh oh! My social bar is low - that's why I posted today.

Link Ninja
DELETED POST
Original Poster
11th Jul 2019 at 5:04 AM
This message has been deleted by Charmful. Reason: double post
Warrior Gryphon
site owner
#6 Old 11th Jul 2019 at 9:51 AM
I updated the site yesterday to have full UTF8 (specifically utf8_general_ci collation) so that means that from yesterday all special characters will work. (Even Japanese, Russian, French, Spanish, Portuguese, whatever)

However, it means that older characters (like curly quotes, windows-1290 and windows-1292 encoded characters) need conversion to UTF8 since they are stored in the database as corrupted characters now.

I'll be working on this over the next few days to convert everything, so please hold tight.

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Link Ninja
Original Poster
#7 Old 11th Jul 2019 at 10:13 PM
Thank you for the response Tash, I'll keep an eye out

Uh oh! My social bar is low - that's why I posted today.

Warrior Gryphon
site owner
#8 Old 14th Jul 2019 at 11:31 AM
Okay everything *should* be converted now.

Specifically:

Code:
  3 $find = array(
  4     '’' => '’',
  5     '“' => '“',
  6     'â€<9d>' => '”',
  7     '‘' => '‘',
  8     '—' => '–',
  9     '–' => '—',
 10     '•' => '-',
 11     '…' => '…',
 12 );


Please let me know if I've missed any special characters. (Specifically a link to the post would be great)

Thanks!

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Mad Poster
#9 Old 14th Jul 2019 at 5:13 PM
The accented lowercase "a" in my Cárdenas Rail Station is still displaying weird as I see it...

ETA - the character appears correctly in this post, it's just the upload post and description itself that looks off.

Welcome to the Dark Side...
We lied about having cookies.
Site Helper
#10 Old 15th Jul 2019 at 3:51 PM
Now the accented "a" is displaying as a capital A with a ~ over it.

I am Ghost. My husband is sidneydoj. I post, he downloads, and I wanted to keep my post count.
Group for Avatar Makers* Funny Stories *2017 Yearbook
Warrior Gryphon
site owner
#11 Old 16th Jul 2019 at 12:45 PM
Ghost, please link to a specific post that has the issue, as requested. Thanks.

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Mad Poster
#12 Old 16th Jul 2019 at 8:49 PM
Quote:
Originally Posted by Tashiketh
Ghost, please link to a specific post that has the issue, as requested. Thanks.


I think Ghost is actually referring to my post... At least that's the error I'm seeing on it.

Welcome to the Dark Side...
We lied about having cookies.
Warrior Gryphon
site owner
#13 Old 16th Jul 2019 at 9:22 PM
I don't see any issues. All instances of Cárdenas should appear correctly now.

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Test Subject
#14 Old 19th Jul 2019 at 11:18 PM
Hello, my name is still showing as "Velcósitro" instead of "Velcósitro"

My mods: Tumblr
My family trees: Midocaito
dodgy builder
#15 Old 20th Jul 2019 at 1:51 PM Last edited by Volvenom : 20th Jul 2019 at 2:06 PM.
Quote:
Originally Posted by Velcósitro
Hello, my name is still showing as "Velcósitro" instead of "Velcósitro"


Yes, I can confirm that. Just testing: æ ø å Æ Ø Å these are letters from the scandinavian languages.

Edit: Our local letters seems right.

Is this working: http://modthesims.info/showthread.p...763#post5551763

It doesn't seem to link only the post even though it says so in the link.

I tried uploading a screen caption on my mobile phone, but it says it's too big. It's not, and the filetype is jpg.
Mad Poster
#16 Old 20th Jul 2019 at 4:36 PM
Strangely now, some but not all of the hyphens in the links to the "also recommended" lots are appearing wonky from my Cárdenas lot http://www.modthesims.info/download.php?t=580199 (and only from that page- the same links appear fine from everywhere else). Hardly a major thing, but since it's still off, it might be indicative of... something?

Welcome to the Dark Side...
We lied about having cookies.
Warrior Gryphon
site owner
#17 Old 20th Jul 2019 at 8:44 PM
@Zarathrusta - what *should* the hyphens be? emdash — or endash – ?

@Volvenom what's wrong with that link? It works fine for me.

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Mad Poster
#18 Old 21st Jul 2019 at 12:08 AM
Quote:
Originally Posted by Tashiketh
@Zarathrusta - what *should* the hyphens be? emdash — or endash – ?


It should be an endash - , like I always put between the lot title and "NO CC" on my uploads... but it only seems to be wonky when viewed from that one source, nowhere else... so I have no idea why.

Welcome to the Dark Side...
We lied about having cookies.
Test Subject
#19 Old 21st Mar 2020 at 1:57 AM
Quote:
Originally Posted by Velcósitro
Hello, my name is still showing as "Velcósitro" instead of "Velcósitro"


Hello. This is still happening, any info about it?

My mods: Tumblr
My family trees: Midocaito
Warrior Gryphon
site owner
#20 Old 21st Mar 2020 at 1:49 PM
This should be fixed now. You'll need to make sure to login with the right characters now.

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Test Subject
#21 Old 21st Mar 2020 at 6:53 PM
Quote:
Originally Posted by Tashiketh
This should be fixed now. You'll need to make sure to login with the right characters now.


Yes it is! Thanks!

My mods: Tumblr
My family trees: Midocaito
Field Researcher
#22 Old 29th Mar 2020 at 3:29 AM
Apologies if this is the wrong place to post, but I seem to be having a related issue: I'm noticing that apostrophes, em dashes, and section symbols (for simoleons) are showing up as question marks. I've noticed this in my most recent upload posts, but I'm certain they used to show up just fine. I used several apostrophes in the description section of this post, and they're all showing up as question marks: http://www.modthesims.info/d/639793...-3-bd-2-ba.html Anyone else seeing this?

My Simblr is FakeHouses|RealAwesome
Check out my Sim re-creations of 1920s kit homes:
The Shadow Lawn ||| The Plaza ||| The Trenton
Virtual gardener
staff: administrator
#23 Old 29th Mar 2020 at 4:42 PM
Hey @FakeHouses|RealAwesome !

Did you by any chance copy/pasted the text (or part of it) from your tumblr post? I noticed sometimes that could break the encoding for me 
Field Researcher
#24 Old 29th Mar 2020 at 6:42 PM
@Lyralei Ah yeah, that must be what it is! I hadn't thought of that. I edited the post and re-typed those characters, and that seems to do the trick. Thanks!

My Simblr is FakeHouses|RealAwesome
Check out my Sim re-creations of 1920s kit homes:
The Shadow Lawn ||| The Plaza ||| The Trenton
Back to top