Replies: 10 (Who?), Viewed: 431 times.
Scholar
Original Poster
#1 Old 10th Mar 2021 at 10:18 PM
Default Error 'The Look and Feel of SimPE was changed to "modern"... please help
Hello
Sorry for starting a new thread, I wasn't sure if it was worse to reply to the old thread here https://modthesims.info/showthread.php?t=638769 as that one is over a year old?

If it's better to reply to the old thread, please let me know and I will do that instead.

Yesterday I started getting an error message whenever I open SimPE, it says 'The Look and Feel of SimPE was changed to "modern". Do you want to start SimPE now?' (I have attached a screenshot).

Build DXT is also greyed out.

After a bit of googling, I found that SimPE is somehow losing the filepath to the DDS Nvidia utilities (C:\Program Files (x86)\NVIDIA Corporation\DDS Utilities), if I add it back in Extra > Preferences, it works as a workaround whilst I finish what I'm doing.

But then as soon as I open SimPE again, the problem comes back.

This has only been happening yesterday and today, but I have been using SimPE again since about August last year, more or less every day, with no problems.

Does anyone know what is causing the issue please, and how to fix it permanently?

Is it something to do with Windows 10, or something else?

I notice HugeLunatic gave some advice in the other thread, but the original poster didn't reply, so I don't know if it worked for them or not. I'm not sure what they mean by installing to somewhere other than Program Files, as I don't know where else I could install to? Sorry, I don't know much about computers really.

Thanks to anyone who can help
Screenshots
Advertisement
Mad Poster
#2 Old 10th Mar 2021 at 11:16 PM
Are you sure it's not your antivirus program messing about with quarantining files?
Is SimPE set to Advanced Mode in the Preferences? (Not sure if it would help, but just in case)

I have my version of DDS installed in ProgramFiles (x86) and haven't had any issues with it being there. Win10 can occasionally be annoying with programs in the ProgramFiles locations. If they're put in there with admin privilegies they should work, but if they're edited or changed without sufficient permission they could end up being changed back to the original state without warning.

The SimPE files - I guess it could depend how you've installed it (zip or installer) and whether you've done anything to the files, but there are 5 files that get changed every time you open SimPE, in the Data folder inside the install files (Layout2, mru, Simpe.layout, SimPE and vport.set). These would hold information about preferences, etc. It could be they're not saving the info properly.
There's also some cache files that change when you load objects or scan neighborhoods or similar.
The Camera Eye
retired moderator
#3 Old 10th Mar 2021 at 11:30 PM
Could be that your virtual store has something stuck- check C:\Users\[username]\AppData\Local\VirtualStore for any SimPE files and delete if they are there.
Scholar
Original Poster
#4 Old 13th Mar 2021 at 1:57 PM
Thanks both of you for the suggestions. I don't understand why it has been working fine until now, I have no idea what has changed, which is why I suspect Windows 10 might be doing something weird in the background.

I don't think so, I had a look at my Avast, I couldn't see anything in the Virus Chest, or in the Blocked Apps list. I checked my Malwarebytes but there wasn't anyting in Quarantine.

I tried ticking the Advanced Mode box in SimPE, but the next time I opened it, it was unticked again, just the same as it keeps losing the DDS Nvidia filepath (I keep putting that back in and then it's gone next time I open it). I always click OK, but it doesn't seem to be saving my changes for some reason.

Do you know how to change the SimPE files in ProgramFiles (x86) to having admin privileges please? I think I just installed them there in the normal way, by double clicking the downloaded file and then following the install wizard instructions - I'm not very computer savvy, so I just do everything the standard way.

I had a look in the virtual store files (I have attached a screenshot), there are some SimPE files, is it safe to delete these please?

Sorry for all the questions, thanks for helping me
Screenshots
Inventor
#5 Old 16th Mar 2021 at 7:47 AM Last edited by annachibi : 16th Mar 2021 at 8:25 AM.
This just started happening to me as well while I was in the middle of a project. I deleted everything in the SimPE folder in my appdata folder, which makes the error go away, but when I put the DDS Utilities back in settings, the Build DXT option doesn't seem to do anything (it pulls up the box to process the image, but the texture doesn't change). If I then quit and go back in, the error is back. I'm going to try reinstalling the DDS Utilities and see if that helps at all.

edit: Okay that didn't do anything, so I'll try reinstalling SimPE now.

edit: Fixed it! Reinstalling SimPE (this time into a different folder) worked!
The Camera Eye
retired moderator
#6 Old 16th Mar 2021 at 10:48 AM
Quote:
Originally Posted by Dizzy-noodles
Do you know how to change the SimPE files in ProgramFiles (x86) to having admin privileges please? I think I just installed them there in the normal way, by double clicking the downloaded file and then following the install wizard instructions - I'm not very computer savvy, so I just do everything the standard way.
Not possible unless you turn off UAC, which I wouldn't recommend. Far better to reinstall as annachibi has, but this time don't install to the C:\Windows or C:\Program Files folders. Instead, make a new folder in the root of your hard drive, for example C:\Games, and install SimPE and your Sims games there.
Scholar
Original Poster
#7 Old 26th Mar 2021 at 12:11 PM
Thanks both of you.

I have not done anything differently, but now my SimPE works fine sometimes, then other times I still get the error. It is very strange. My Build DXT always works once I put the DDS Utilities back in settings, but it still isn't saving somehow and I have to put it in every time.

I will try reinstalling and making a new folder, thanks. Just out of interest, do you know why that works please? Is it making it so that Windows 10 can't find it and make changes without your knowledge? Or something else?
The Camera Eye
retired moderator
#8 Old 26th Mar 2021 at 7:00 PM
It's because Windows 10 uses User Account Control and file virtualization- which means that all files installed to the system (C:\ Windows, C:\Program Files) are protected and require administrator permissions to access/ write to, and that any changes made are virtualized to the virtual store location of your user account. It would take me a long time to give a full explanation of this; I have described it before somewhere on this site with a bunch of links but what's probably easier now is if you just do an internet search of 'how does UAC work' or something. Installing to a location outside of the protected areas means that you have full control to read and write to those locations, which is what you really want for when you are installing games you want to mod. However, if you install antivirus programs or browsers or any software that plugs into the shell or adds context menus to the operating system, you should really install those to the default location, as then those files are protected from malicious attack by the UAC.
Scholar
Original Poster
#9 Old 28th Mar 2021 at 2:23 AM
Thanks, that makes sense I think - I'll look it up as you've suggested, to get a better understanding.

It's always very strange to me that computers can do these things behind my back, without me knowing, but everyone here is very knowledgeable and helpful, thanks for your advice and help
The Camera Eye
retired moderator
#10 Old 28th Mar 2021 at 2:36 AM
UAC is to prevent malicious programs from doing anything behind your back! It's one of the main security features of recent versions of Windows; before UAC you would have had no warning at all if a malicious script or program was changing your system files or registry. But it's not really vital for Sims 2 and its tools to be protected in this way.
Scholar
Original Poster
#11 Old 30th Mar 2021 at 10:48 PM
I see, thanks, that makes sense
Back to top