Replies: 11 (Who?), Viewed: 5614 times.
Test Subject
Original Poster
#1 Old 30th Dec 2006 at 8:01 AM
Default Milkshape crashing when vertex at 100%
I'm trying to assign the vertex to 100% in my mesh, but every time I get to 100% milkshape crashes. I leave it at 99% and I get weird results in the mesh, but it works find. Though the moment I click it up at 100 it always crashes. Has anyone had this problem before? How do I fix it?
world renowned whogivesafuckologist
retired moderator
#2 Old 30th Dec 2006 at 10:41 AM
Are you sure you have the latest version of Unimesh and the latest Milkshape installed? Even if you do, try redownloading both. I had a lot of issues with Milkshape crashing when I was using the Unimesh bone tool when I had incompatible versions - I think an older version of Unimesh with new Milkshape, or vice versa.

my simblr (sometimes nsfw)

“Dude, suckin’ at something is the first step to being sorta good at something.”
Panquecas, panquecas e mais panquecas.
Test Subject
Original Poster
#3 Old 31st Dec 2006 at 7:28 AM
Well, I tried uninstalling and reinstalling Milkshape and the plugins. All to no avail. I go to set everything to 100% and it still crashes. Anymore suggestions?
#4 Old 1st Jan 2007 at 9:57 PM
I'm curious if you're running Windows 98?
The only crash issues I am aware of were reported on Win98.
Why I did not try to prevent the BodyTool from working on W98, I am not able to test or debug it except on Windows XP.
<* Wes *>

If you like to say what you think, be sure you know which to do first.
Test Subject
Original Poster
#5 Old 1st Jan 2007 at 11:40 PM Last edited by HeatherMacCloud : 1st Jan 2007 at 11:49 PM.
No, I'm running XP Professional on my computer. I've tried moving it up to 100% and leaving the other two boxes alone, moving them to 0 first then moving the vertex up to 100, any and all combinations there of. The moment it reaches 100, milkshape closes.
#6 Old 2nd Jan 2007 at 1:37 AM
The plugin version is an easy check... start MilkShape, look on the vertex menu and look for "Sims2 UniMesh Bone Tool Vx.xx".

Make sure the x.xx above says 4.06... the first one or two releases I made had problems that would make them blow up easier than bowling with nitroglycerine would.

If the version is right, I would like to know if this is every mesh, or just a particular one you are working on. If a particular one, I'd like to see the mesh here (it can be transferred privately).

I also would like to know if you can type 100 into the box instead of 'clicking up' without getting a crash.

The one other thing that right now pops into my head relates to default font size and the boxes that the numbers go in. '100' is 150% as wide as '99'. If so, then there is some Windows issue because the edit boxes should clip (trim off the extra) text that doesn't fit. It would likely have to be something like this, because increasing the percentage from 98 to 99 uses the same code path as 99 to 100 does... only when you try to click above 100 does soem extra code execute to prevent this.

If you can help figure out if it is this, by experimenting in your windows settings, I could increase the box size in a future release as a work around. I am working on a new release right now, but cannot estimate a date for testing to end quite yet.

<* Wes *>

If you like to say what you think, be sure you know which to do first.
Test Subject
Original Poster
#7 Old 2nd Jan 2007 at 2:27 AM
Yeah, it's done this on every mesh I've tried and it does say 4.06. Typing it does the same thing. Iff it says 100 at all it dies.
#8 Old 2nd Jan 2007 at 4:57 AM
Well, Heather, I am mystified.

Given the way the plugin interface works, the code in the plugin runs as if it was a part of MilkShape, and I have no doubt the crash is due to my work. While I will revisit this section of the code before the next release, I will be shooting in the dark, because this does not happen here.

Nor do I understand what could cause this to happen just as you describe, other than something related to the system font or size.

Sorry I was not of more help,

<* Wes *>

If you like to say what you think, be sure you know which to do first.
#9 Old 3rd Jan 2007 at 3:48 PM Last edited by Dr Pixel : 3rd Jan 2007 at 3:54 PM.
Strange as it may seem, this could be an OpenGL issue.

Have you tried the OpenGL drivers that are posted on the MilkShape site?

I know everybody thinks of OpenGL just being used for 3d (as in MilkShape's 3d preview window) but I think the whole MilkShape window, including menus and the windows of all plugins are sent through OpenGL.

I should add that different releases of MilkShape might require them or not, depending on your video card.

I had to install them with one particular MilkShape release to prevent strange crashing problems (not to do with Wes' plugins at all, but crashing when I would try to use any of the menus at all)

I only had to use the drivers for the one particular release, I never had any problems with earlier or later releases even though my video card and it's drivers were unchanged.

This might not fix it, but the drivers are free and it certainly won't hurt anything to try them - you just unzip them right into the main MilkShape folder, they won't affect anything else on your computer at all.

Look here:

for the Mesa 6.4.1 Software OpenGL Drivers
#10 Old 3rd Jan 2007 at 6:41 PM
Dr. Pixel:

Thank you for the contribution.

I did not know that the OpenGL driver was involved in the windowing aspects of the program. I suspect the problem is related to putting three characters in the editbox.

<* Wes *>

If you like to say what you think, be sure you know which to do first.
Test Subject
Original Poster
#11 Old 5th Jan 2007 at 3:36 AM
Thank you Dr. Pixel! I downloaded those drivers you said to and works now! Thank you also to Wes and HystericalParoxysm for your suggestions. Your help was appreciated!
#12 Old 5th Jan 2007 at 7:01 AM
Thanks for reporting back, Heather. I learned something, too. We can keep this in our collective 'mental file' so if it bites someone else, we can offer suggestions sooner.

Good luck on your meshing projects. We can help you there, too, if you need it.

<* Wes *>
10th Jan 2011 at 7:08 AM
Default hermes replica watches
This message has been deleted by HugeLunatic. Reason: spam
Back to top