Replies: 59 (Who?), Viewed: 47849 times.
Page 3 of 3
Test Subject
#51 Old 30th Dec 2011 at 11:47 PM
I’m trying to add 2 slots to the top of a maxis fridge, I've used the table end slot and although I can achieve adding slots to bookcases, paintings (like for cabinets), I can't get the fridge to work. Yes, yes thank you very much for helping me. Here goes.
Download - please read all instructions before downloading any files!
File Type: zip (123.3 KB, 22 downloads) - View custom content
Gone Fishin'
retired moderator
#52 Old 31st Dec 2011 at 12:57 AM Last edited by NixNivis : 31st Dec 2011 at 4:46 PM.
All right, I haven't tested your fridge in game yet (it's firing up as I type this), but what jumps out to me right away that in your SLOT file, the Int 7 - the one that determines what kind of surface your slot acts as - is set to 0, and according to this post, that isn't a valid value. For the slot to be an end table (so to speak), the Int 7 should be set to 8.

Edit: Also, how come you have two slot files? (At first I thought the original fridge was set up that way, but when I cloned it, I see it only has one.) Since you're only adding slots and aren't also extending the footprint, you should be able to just add your slots to the original slot file.

I'll have a closer look at this tomorrow - it's getting very late here, so I need to hit the sack if I'm going to stand a chance to stay awake until midnight.

Edit II: Now I've had a closer look. There are a few things wrong with the SLOT file that need to be changed for the slots to work.

First of all, you should only have one SLOT file, with an instance (high) of 0x00. (For future reference, if you need to change an instance number manually, it's not the high instance you should change, but the "regular" instance - the one that ends with 80 in this case.) You only need to add a SLOT file if you're extending the footprint or adding slots to a tile of the footprint that hasn't had any previously.

Second, like I said above, the Int 7 needs to be set to 8 if you want your new slot to behave like an end table.

And last but not least, the Int 9 numbers are not the same as the numbers your slots have in the CRES. You see, the CRES numbers are in hex, but just to make things confusing, the numbers in the SLOT file aren't. (I swear, they do this just to keep us modders on our toes. ) Add them sequentially instead.

I've attached an updated version of your fridge, so you can see what I've changed.
Download - please read all instructions before downloading any files!
File Type: zip (122.4 KB, 23 downloads) - View custom content
Test Subject
#53 Old 31st Dec 2011 at 6:16 PM
I uploaded the wrong file (the one with an extra slot file was the last desperate attempt) but, looking at what you did I found where I went wrong. I did come across the problem twice though, that after changing the values in the slot, int 7 would be set to 8, then after checking in game and coming back to the package, int 7 would be set to 0. In any case, thank you for the help and knowledge. I really appreciate it.
Gone Fishin'
retired moderator
#54 Old 31st Dec 2011 at 7:24 PM
You're very welcome, I'm just glad I could help. And it's happened to me more than once that I've uploaded the wrong version of a file somewhere, so don't worry about it.

That's odd about the Int 7 reverting to 0. Did that happen in the version with just one slot file as well? It sounds like something made that value reset, but I don't know if it was just another value somewhere or a combination of things. I do know that, when I was fiddling with it, the fridge didn't recognise the slots (the deco items turned red) until I had deleted the second slot file, even though I'd changed the Int 7, but it wasn't until I had changed the Int 9 as well that the fridge understood what it what it was supposed to do with those slots - before that, I had the slots sitting on top of each other at the bottom of the fridge.

Anyway, glad I could help, and good luck with your fridge!
Test Subject
#55 Old 1st Jan 2012 at 7:30 PM Last edited by auntekay : 1st Jan 2012 at 8:57 PM. Reason: forgot to thank HL for tutorial
No, only reverted with second slot file. My biggest problem was how to add my slots (child nodes) to correct practical and also not getting the numbers right in the slot file int 9 & 10. Somehow those numbers seem to also correspond to number in txt file Model-Bones. After playing around with HugeLunatic's 1-tile desks (I wanted to make the Sims 3 centered desks for Sims 2-and I'm not uploading them-just for personal use-I doubt anyone would want them anyhow-hope is okay), I saw what you were talking about hex numbers and such. In the resource node, I couldn't enter values such as 0x0000000G but as 0x00000016. I must have something ticked in SimPe, who knows. But following your advice and looking at what you fixed the light bulb came on. Thanks again.

Edit: Forgot to thank HL for her tutorial, I was so nervous when I first got the nerve to try it, when I succeeded you'd think I hit the Lotto! Thank you very much.
Field Researcher
#56 Old 17th Apr 2012 at 5:05 PM
I know I've been frequenting this thread with all kinds of questions, but this time I have a couple of little tips that may be of help to others.

The first one is:

Adding slot to an object cloned from a painting

This has to be done in a specific way in order to work.

1) Clone the existing STR and rename it 'Model - Bones'.

2) Go to the Resource tab and change the instance number to 0x00000090

3) Go back to Plug-in view and add your slots as usual, ONLY LEAVE 0x000 and 0x001 EMPTY and begin adding your slots at 0x0002.

The rest is just like adding slots to any other object clone.

My second tip is:

Always check in-game that your added slots will support sculptures and lamps.

Because I've found that very often they won't. If your slots will only support plants and certain very small deco objects you need to add a BHAV (in the Function - Init). It should be called:

My Support strength Set flag Literal 0x0005

Or you can use the operands 1C 00 05 00 FF 09 03 07

I've been sitting on this information for a while now, so I don't know if it already exists somewhere else. In any case I hope it can be of use to somebody.

Moune's Neighbourhood
If you need a cool place for your sims to chill out.
Former Hamster
retired moderator
#57 Old 17th Apr 2012 at 6:56 PM
Thanks, Moune. The second I knew...the first was something I couldn't figure out before. That's very clear and easy to understand.
Former Hamster
retired moderator
#58 Old 22nd Aug 2012 at 9:12 PM
I've added some slots to a fireplace. One of them won't move no matter what I change the coordinates to in SimPE, it just sits on the floor. I've added the slots to joint0 [fireplacemantle] which is what I've done for other fireplaces. There were 6 slots added altogether, the others are fine. I checked to make sure there are no typos of any kind (there aren't, not even a ",' instead of a "."). Any ideas? Would taking out that slot and just adding another one affect the other 5? I haven't tried that yet because this slot needs to be taught a lesson, lol. Seriously though, I like to find out WHY something isn't working. If it needs to be worked around the way I suggested, that's alright too.

*Sorry for the double post. There's been no posts in this thread for 4 months.
Retired Duck
retired moderator
#59 Old 23rd Aug 2012 at 5:38 AM
It's most likely a problem in your SLOT file, not your CRES. Is that Slot's S2 value set to 2?
Former Hamster
retired moderator
#60 Old 23rd Aug 2012 at 6:52 AM Last edited by mustluvcatz : 23rd Aug 2012 at 9:03 PM.
Yes it is. I went through the SLOT and Model - Bones one more time (also double checked the CRES) for typos or something left out and loaded the game again. I just checked and that slot still stays on the floor. Was kind of hoping it would miraculously fix itself, lol.

edit: Well, there was one thing I didn't notice and that was the I9 values. I didn't notice I was off by one number. Since there was already a 6 (in Model - Bones, but not in the SLOT) that would be the reason that one slot wouldn't work. I haven't checked it in game yet, but I'm sure changing the numbers fixed it.

edit again: Yes, that fixed it. I can't believe I missed that mistake the whole time I was looking at everything.
Page 3 of 3
Back to top