Replies: 27 (Who?), Viewed: 8051 times.
Page 1 of 2
Test Subject
Original Poster
#1 Old 9th Jul 2014 at 3:55 AM

This user has the following games installed:

Sims 2, University, Nightlife, Seasons
Default No neighborhoods on a fresh install from Origin
I'd just newly installed The Sims 2 and EPs from Origin, started up Seasons (the latest EP I own), and... no neighborhoods show up, at all, even though the data is there in the Neighborhoods folder. The only options are to create a custom neighborhood (which doesn't work because the button is greyed out), or to play the tutorial (which crashes). I checked My Documents and I don't even have an /EA Games folder. What is going on here? I only own the Origin version... does it just not work anymore?
Advertisement
Field Researcher
#2 Old 9th Jul 2014 at 6:20 PM
I would reinstall in that case. Something's wrong with your installation if the game doesn't even generate user files.

Quote:
Originally Posted by FenrirWolf
It refuses to run on those IOS's because the earlier versions of cIOScorp scooped out your Wii's innards and turned them into delicious Scrambled IOS Breakfastâ„¢, which confused the crap out of their installer and gave TT all sorts of bizarre errors to scratch their heads over.
Test Subject
Original Poster
#3 Old 9th Jul 2014 at 8:11 PM
Quote:
Originally Posted by Port_A_Build
I would reinstall in that case. Something's wrong with your installation if the game doesn't even generate user files.


I've reinstalled twice and it still isn't working. I install Double Deluxe, then University, then Seasons in that order. I'm not sure at what point the Stuff Packs are installed because Origin doesn't give me that level of control. I'm going reinstall one more time to try bypassing the launcher and running the games without installing Seasons (since the launcher freezes up and Seasons appears to abandon the launcher entirely).
Test Subject
#4 Old 17th Jul 2014 at 7:06 PM
I have this exact same problem, and have had it for over a year. Unfortunately I haven't received any help on how to fix it either. I recently installed the Sims 2 Ultimate Collection from Origin as well but it had the same problem, no EA folder, no neighborhoods, and crashing with the tutorial. I can only hope you'll manage to figure out a solution to this problem.
Field Researcher
#5 Old 17th Jul 2014 at 8:48 PM
Try installing the game in a different location. For example, if you always install to the Program Files (x86) folder, try installing to the Program Files folder or a folder on a different hard drive.

Quote:
Originally Posted by FenrirWolf
It refuses to run on those IOS's because the earlier versions of cIOScorp scooped out your Wii's innards and turned them into delicious Scrambled IOS Breakfastâ„¢, which confused the crap out of their installer and gave TT all sorts of bizarre errors to scratch their heads over.
Field Researcher
#6 Old 18th Jul 2014 at 1:55 AM
Quote:
Originally Posted by Portaller
Try installing the game in a different location. For example, if you always install to the Program Files (x86) folder, try installing to the Program Files folder or a folder on a different hard drive.

I don't think you can specify with Origin though. I'm having this issue as well.

EDIT: I tried to set Origin to install in Program Files instead of Program Files (x86), but it wouldn't let me.
Test Subject
#7 Old 18th Jul 2014 at 7:52 PM
I'm having the same problem. When I start the game up is gives me a warning that says I'm low on disk space, which isn't true at all. Then I start the game up, the intro video doesn't even play and when I get to the main menu there are no neighborhoods. There also isn't a Sims 2 folder under C:\Documents\EA Games which tells me that something is completely wrong with this version of game, Origin might just not be downloading and installing certain required files or something. All I know is that this definitely isn't a problem on my end since The Sims 2 usually works fine, the Ultimate edition just doesn't.
Field Researcher
#8 Old 18th Jul 2014 at 8:46 PM
Maybe it couldn't create the necessary folder for some reason? Is it locked or read-only or something like that?

Quote:
Originally Posted by FenrirWolf
It refuses to run on those IOS's because the earlier versions of cIOScorp scooped out your Wii's innards and turned them into delicious Scrambled IOS Breakfastâ„¢, which confused the crap out of their installer and gave TT all sorts of bizarre errors to scratch their heads over.
Field Researcher
#9 Old 18th Jul 2014 at 11:17 PM
Quote:
Originally Posted by Portaller
Maybe it couldn't create the necessary folder for some reason? Is it locked or read-only or something like that?

No, I have the same issue and my game's not set to read-only. I think the game can't read disk space on 8.1 properly and then won't generate the necessary folders because it thinks there's no room for them.
Field Researcher
#10 Old 19th Jul 2014 at 1:22 AM
Have you tried running it in compatibility mode? Also, are your operating systems fully patched?

Quote:
Originally Posted by FenrirWolf
It refuses to run on those IOS's because the earlier versions of cIOScorp scooped out your Wii's innards and turned them into delicious Scrambled IOS Breakfastâ„¢, which confused the crap out of their installer and gave TT all sorts of bizarre errors to scratch their heads over.
Field Researcher
#11 Old 19th Jul 2014 at 1:41 AM
Quote:
Originally Posted by Portaller
Have you tried running it in compatibility mode? Also, are your operating systems fully patched?


Yes and yes. I've tried XP SP 3 (no option for SP2), Vista, 7, and regular 8. Still won't work. Running as admin doesn't help either.
Top Secret Researcher
#12 Old 19th Jul 2014 at 2:24 AM
Maybe this thread might help you? If not, try getting in contact with EA before they stop officially supporting TS2 on the 22nd.

http://www.moreawesomethanyou.com/s...44496#msg144496
Test Subject
#13 Old 20th Jul 2014 at 5:33 PM
Quote:
Originally Posted by dragonbrad
I'm having the same problem. When I start the game up is gives me a warning that says I'm low on disk space, which isn't true at all. Then I start the game up, the intro video doesn't even play and when I get to the main menu there are no neighborhoods. There also isn't a Sims 2 folder under C:\Documents\EA Games which tells me that something is completely wrong with this version of game, Origin might just not be downloading and installing certain required files or something. All I know is that this definitely isn't a problem on my end since The Sims 2 usually works fine, the Ultimate edition just doesn't.

Im having the same exact problem! I installed Sims Ultimate from origin and it tells me Im low on disc space (not true), there is no sims 2 in my documents folder, and there are no neighborhoods. Im trying to reinstall it right now to see if it fixes anything.
Field Researcher
#14 Old 20th Jul 2014 at 5:47 PM
Try making a "Documents\EA Games\The Sims 2™ Ultimate Collection" directory, start the game, then close the game and remove the folder.

Quote:
Originally Posted by FenrirWolf
It refuses to run on those IOS's because the earlier versions of cIOScorp scooped out your Wii's innards and turned them into delicious Scrambled IOS Breakfastâ„¢, which confused the crap out of their installer and gave TT all sorts of bizarre errors to scratch their heads over.
Test Subject
#15 Old 20th Jul 2014 at 6:06 PM
Quote:
Originally Posted by Portaller
Try making a "Documents\EA Games\The Sims 2™ Ultimate Collection" directory, start the game, then close the game and remove the folder.

Thanks Ill try that when it finishes reinstalling.
Test Subject
#16 Old 20th Jul 2014 at 7:01 PM
Ouch, didn't see this thread before making mine. Sorry!

Quote:
Originally Posted by Portaller
Try making a "Documents\EA Games\The Sims 2™ Ultimate Collection" directory, start the game, then close the game and remove the folder.


I tried this, but my game still doesn't do anything. Buhh.
Theorist
#17 Old 20th Jul 2014 at 7:11 PM
Did you add or change anything to the game before trying to play?

When you forgive, you heal. When you let go, you grow.
Test Subject
#18 Old 20th Jul 2014 at 7:21 PM
Unless the patch from origin counts, nope.
Mad Poster
#19 Old 20th Jul 2014 at 10:20 PM
1 you may need to turn off User Account Control.
2 your antivirus program may be blocking it.
3 is your windows up to date.
4 you may have a virus that is stopping it for working for some of them stops all new stuff.

If 1-3 did not fix your problem then download and run these 2 programs.
http://www.superantispyware.com/ the free one.
https://www.malwarebytes.org/ the free one.

If you like both of these then go ahead and buy them for they are great programs to have.

All my Beginning Hoods here at MTS. http://www.modthesims.info/member.php?u=7749491
All my Beginning Hoods as Shopping Districts plus Old Town. http://www.modthesims.info/download.php?t=523417
MooVille, a tribute to Mootilda and her fabulous lots http://www.modthesims.info/download.php?t=534158
Test Subject
#20 Old 21st Jul 2014 at 1:36 AM
Quote:
Originally Posted by gold163
I'd just newly installed The Sims 2 and EPs from Origin, started up Seasons (the latest EP I own), and... no neighborhoods show up, at all, even though the data is there in the Neighborhoods folder. The only options are to create a custom neighborhood (which doesn't work because the button is greyed out), or to play the tutorial (which crashes). I checked My Documents and I don't even have an /EA Games folder. What is going on here? I only own the Origin version... does it just not work anymore?

Try this! I got it from a different forum at answers.ea.com (credit goes to MMJJSense) with someone who had a similar issue:
you need to open regedit (Window+R) and open HKEY_LOCAL_MACHINE then SOFTWARE

For 32 - Bit : Find EA GAMES folder and open the sims 2... change the Display Name... Delete the ™ out... and the problem is solved...

For 64- Bit : Open Wow6432Node then.. Find EA GAMES folder and open the sims 2... change the Display Name... Delete the ™ out... and the problem is solved...

Before it's should look like this : The Sims 2™ Ultimate Collection

After : The Sims 2 Ultimate Collection
Test Subject
#21 Old 22nd Jul 2014 at 7:31 PM
Quote:
Originally Posted by April_Moon
Try this! I got it from a different forum at answers.ea.com (credit goes to MMJJSense) with someone who had a similar issue:
you need to open regedit (Window+R) and open HKEY_LOCAL_MACHINE then SOFTWARE

For 32 - Bit : Find EA GAMES folder and open the sims 2... change the Display Name... Delete the ™ out... and the problem is solved...

For 64- Bit : Open Wow6432Node then.. Find EA GAMES folder and open the sims 2... change the Display Name... Delete the ™ out... and the problem is solved...

Before it's should look like this : The Sims 2™ Ultimate Collection

After : The Sims 2 Ultimate Collection


Interesting. . . I had that happen this morning, only the "custom neighborhood" available. I didn't think about it, I just backed out of game, removed the EA Games folder, reopened game and the neighborhoods were back. Of course this means I don't have my downloads, but they are safely stored on the external drive anyway. I expect I'll have to do as you suggested though, because I have a feeling it will do the same thing again. LOL
Field Researcher
#22 Old 23rd Jul 2014 at 8:06 PM Last edited by Ketsu_sama : 23rd Jul 2014 at 8:17 PM.
Quote:
Originally Posted by April_Moon
Try this! I got it from a different forum at answers.ea.com (credit goes to MMJJSense) with someone who had a similar issue:
you need to open regedit (Window+R) and open HKEY_LOCAL_MACHINE then SOFTWARE

For 32 - Bit : Find EA GAMES folder and open the sims 2... change the Display Name... Delete the ™ out... and the problem is solved...

For 64- Bit : Open Wow6432Node then.. Find EA GAMES folder and open the sims 2... change the Display Name... Delete the ™ out... and the problem is solved...

Before it's should look like this : The Sims 2™ Ultimate Collection

After : The Sims 2 Ultimate Collection

Ugh, I tried that and it still didn't fix the problem.

EDIT: But someone mentioned issues when in Japanese locale, so I'll try switching back to AE.

EDIT2: Okay, so my issue was locale! That'll suck when I want to use UTAU, but oh well. If the registry doesn't work and you have switched your locale, try switching back. So this problem has been solved for me! Now for some Strangetown...
Test Subject
#23 Old 24th Jul 2014 at 11:32 AM
Quote:
Originally Posted by April_Moon
Try this! I got it from a different forum at answers.ea.com (credit goes to MMJJSense) with someone who had a similar issue:
you need to open regedit (Window+R) and open HKEY_LOCAL_MACHINE then SOFTWARE

For 32 - Bit : Find EA GAMES folder and open the sims 2... change the Display Name... Delete the ™ out... and the problem is solved...

For 64- Bit : Open Wow6432Node then.. Find EA GAMES folder and open the sims 2... change the Display Name... Delete the ™ out... and the problem is solved...

Before it's should look like this : The Sims 2™ Ultimate Collection

After : The Sims 2 Ultimate Collection


I just wanted to say, this worked for me. My neighbourhoods are back, and all is well now.
Test Subject
#24 Old 27th Jul 2014 at 10:17 PM
Quote:
Originally Posted by Edlisse
I just wanted to say, this worked for me. My neighbourhoods are back, and all is well now.


Hi for me this didn't work for me
Field Researcher
#25 Old 27th Jul 2014 at 10:42 PM
Quote:
Originally Posted by April_Moon
Try this! I got it from a different forum at answers.ea.com (credit goes to MMJJSense) with someone who had a similar issue:
you need to open regedit (Window+R) and open HKEY_LOCAL_MACHINE then SOFTWARE

For 32 - Bit : Find EA GAMES folder and open the sims 2... change the Display Name... Delete the ™ out... and the problem is solved...

For 64- Bit : Open Wow6432Node then.. Find EA GAMES folder and open the sims 2... change the Display Name... Delete the ™ out... and the problem is solved...

Before it's should look like this : The Sims 2™ Ultimate Collection

After : The Sims 2 Ultimate Collection


This didn't work for me.
I had the Sims 2 Fun with pets/store addition (on CD) before I got the ultimate collection on origin
my custom neighborhoods STILL aren't showing up.
Page 1 of 2
Back to top