Replies: 15 (Who?), Viewed: 4012 times.
Mad Poster
Original Poster
#1 Old 15th May 2015 at 2:46 PM Last edited by nitromon : 21st May 2015 at 2:05 PM. Reason: Issue has to do with multicores not simply hyperthreading.
Default TS2 and Multicores
Refer to the updated test result here:

Final Test Result


I've been having real laggy issues with my Sims 2 ever since I got it running on my new system. I've read everywhere that it should run smoothly on Win 7, but no matter what I tried it gets terribly laggy especially the more sims you have on the lot. The lag is not merely choppy, but it drops down to minipauses.

I posted for help before and tried every method out there - compatibility setting, DEP, increase LAA, etc.. I even read somewhere that because TS2 is a single core game, multi-core systems might have problem with it. However, even when I disable all the cores except for 1, had no performance increase. In fact it was slower on 1 core.

After some testing this is my result:

Though TS2 is single cored, but your OS multi-core function may still take advantage of it. I notice when I set TS2 on single core, the CPU usage on that core is 100% the whole time. After dividing it to 2 cores, the usage was balanced out to the two cores. This is where it got interesting. I'm running an i7 with hyperthreading, so it simulates 8 cores. I noticed that only cores 0,2,4,6 were running around 30-40%. The other 4, must be the hyperthreaded cores, were mostly around 0-10%. This is a poor way of explaining it as all 8 cores are connected to the CPU. Basically both even and odd cores are shared in execution, disabling 1 will disable the hyperthreading.

This is when I got the idea, perhaps TS2 is not compatible with hyperthreading. I disabled cores 1,3,5,7 and as I had hoped, now the game runs fine, as fine as it should anyways. I played on a huge apartment lot with 50 sims and it runs quite well, at least no minipauses.

Anyhow, I thought I share this and if anyone with the same issue can test it on their systems too and verify, it would be helpful.


Summary:
Sims 2 doesn't seem to work well with hyperthreading. If you have hyperthreading, disable 4 of the cores (1 in every 2).

Edit: I read somewhere that some i5 quad cores are actually dual cores with hyperthreading. You may want to check your specs carefully. If you have an i5 quad cores with similar minipause problems, try disabling 1 of every 2 cores as well.

Edit 2: I did more testing and one slightly bad news for people trying this. Apparently the core assignments differ each time you load the game. This time round, the cores that were running were 0,2,4,7. Only disabling the inactive cores will help the game. This means that you cannot simply add a cmd script to the shortcut to automatically choose 4 cores each time. You have to manually use task manager to turn off the 4 cores.

Nvm, It seems to realign the cores after you load a lot. So theoretically you can actually add a command line in the shortcut to do this automatically.

Nvm again! This was an error caused by setting the priority to "realtime." Do not set the priority to realtime. It nullifies the core assignments.

For people wondering how to do this automatically. Edit the "target" of your TS2 shortcut and change it to

C:\Windows\System32\cmd.exe /C start /high /affinity 55 Sims2EP8.exe

* Change Sims2EP8.exe to whichever executable you are running.
* Affinity 55 is the hex code for 01010101, which runs only cores 0, 2, 4, 6. If you want to turn off other cores you'll have to google for the binary/hex converter.
* This startup command will also set executable priority to high. If you don't want to do that, erase that part.
Advertisement
The Great AntiJen
retired moderator
#2 Old 15th May 2015 at 7:05 PM
You'd probably get more help if you put this in the Help section.

Did you try this stuff?
http://digitalperversion.net/garden...p?topic=21931.0
It's actually meant to stop crashing but I think it helped performance on my old machine a lot. It also addresses the multicore issue.

Also, some people think this helps:
http://digitalperversion.net/garden...p?topic=29930.0

I no longer come over to MTS very often but if you would like to ask me a question then you can find me on tumblr or my own site tflc. TFLC has an archive of all my CC downloads.
I'm here on tumblr and my site, tflc
Mad Poster
Original Poster
#3 Old 15th May 2015 at 7:47 PM
Quote:
Originally Posted by maxon
You'd probably get more help if you put this in the Help section.

Did you try this stuff?
http://digitalperversion.net/garden...p?topic=21931.0
It's actually meant to stop crashing but I think it helped performance on my old machine a lot. It also addresses the multicore issue.

Also, some people think this helps:
http://digitalperversion.net/garden...p?topic=29930.0



When I said I tried everything, I do mean everything.

I have been given those 2 links at least a dozen times, they're not related to my problem. I don't have any crash issue or load time issue.

I originally already suspected it has to do with the multi-core issue. However, following the other links, they merely tell you to turn off all your cores except for 1 core since TS2 is a single core game. That didn't do it for me, especially single core tends to make my TS2 run even slower. From my own testing, though TS2 is a single core, but the Win7 OS can still use multi-core functions to help the game.

Even though I disabled hyperthreading, Win7 OS still uses all 8 cores during loading, changing lots, etc... thus heavily reducing the load time. (I often laugh at TS4 players who keeps saying TS4 loads faster than TS2). During gameplay is where hyperthreading needs to be disabled. Seems the OS gets confused using hyperthreading on TS2, it at most uses only 4, the other 4 were causing conflicts.

Since I've tried so hard to find a solution and finally figured it out myself that it is a hyper-threading issue, I guess it means not many people are actually running TS2 on an i7? I find it hard to believe I'm the only one with this problem. I suspect again that some i5 users might have the same problem as some i5s were sold as quad cores when in reality they're dual cores on hyperthreading.
The Great AntiJen
retired moderator
#4 Old 15th May 2015 at 8:34 PM
Quote:
Originally Posted by nitromon
When I said I tried everything, I do mean everything.

I have been given those 2 links at least a dozen times, they're not related to my problem. I don't have any crash issue or load time issue.

Well you might have said that in your original post

Actually re-reading those again, I thought CFF Explorer was the one where I set the game to address only one core but I must have misremembered because it only talks about addressing system memory. I thought I had read something about that at one point.

I no longer come over to MTS very often but if you would like to ask me a question then you can find me on tumblr or my own site tflc. TFLC has an archive of all my CC downloads.
I'm here on tumblr and my site, tflc
Needs Coffee
retired moderator
#5 Old 15th May 2015 at 11:01 PM
No idea what Hyperthreading is, but did you get the issue fixed or not? Sorry only just got out of bed.

Lot's of us are on Windows 7 but that doesn't mean our set ups are the same as yours. I am on Windows 7 but only have a dual core. I had a similar but opposite problem to you. I wanted to play Dragon Age Inquisition but it wanted a quad core. I found a download that made it run on dual core and turned Origin off as an overlay. If you are running the UC you could also try that last step of turning off Origin overlay in game- if it does that in the UC. I have no idea as my set up is disks.

..Are you saying you are on on dual core? I need to wake up some more.

"I dream of a better tomorrow, where chickens can cross the road and not be questioned about their motives." - Unknown
~Call me Jo~
Field Researcher
#6 Old 15th May 2015 at 11:23 PM
I use Process Lasso to disable hyperthreading for sims. It's a free utility but will give you a nag screen to buy the full version every time you boot your PC. :/ I also set it to run sims in "gaming mode" which allocates more resources to it. I've only play tested it once since doing this and didn't notice any difference in performance. Won't be able to test it more anytime soon but wanted to put it out there incase someone else wants to give it a try.

Myalgic Encephalomyelitis is a severely disabling neurological, cardiac and metabolic disease.
The Hummingbirds' Foundation for M.E. is fighting for patients to be given recognition and appropriate medical care.
Please visit hfme.org for more information.
Meet Me In My Next Life
#7 Old 16th May 2015 at 1:18 AM Last edited by Simonut : 16th May 2015 at 1:40 AM.
I have no ideas what so ever what all this "Hyperthreading or core talk is all about ( Mindless ) so that is why I leave it to my tech man who build my computer at the Store.
All I told him was I wanted a gamer build computer, he ask me what games and the first word that came out of my mouth was Sims 2. , he laugh out loud and told me "Oh for that it don't take much for that game."
I told him I did not care just build me a super computer where I can play all games and not just the Sims, HD, 3D whatever and so he did. Cost me an arm and leg but well worth it, I play Sims 2 on Window 7 64 bit system with no problem.

One thing I found out if you have "save" your Sims game from another system like Window XP and transfer it to a new system like Window 7 you will run into problems ( I know I did ) my game was "always" crashing day and day out.
To stop the problem the tech guy told me to start my game over fresh from the bottom up ( don't use the save Sims 2 game from Window XP ) I was mad to lose all that I had, but starting my game over "fresh" was the best thing ( I did save all my downloads and mods. ) I never had another crash "never" with my Sims 2 also I have so many others games I have on my computer, I love "Hidden Objects" mystery games ,everything work like a clock.

"Nothing in life is a Surprise it just happen to come your way at the time".
Mad Poster
Original Poster
#8 Old 16th May 2015 at 5:57 AM
Quote:
Originally Posted by joandsarah77
No idea what Hyperthreading is, but did you get the issue fixed or not?


It seems to be. It stopped the minipauses, which was making the game unplayable. However, it isn't as direct and specific as I've hoped. Since the multi-core function is OS based, instead of TS2 based, it seems to assign cores base on which ones are less busy when the game booted. That was what confused me earlier. So the initial lot usage may not be on the cores that I set, but it fixes itself after I travel or load another lot. So overall it seems to be working well.

I'm pretty impressed with how the OS is handling it. Even with the hyperthreading disabled for TS2, the OS will still use all 8 cores during loading to speed things up. That is just fantastic!


Quote:
Originally Posted by rielynn71
I use Process Lasso to disable hyperthreading for sims.


I might just give that a try. Right now, I'm simply using the built in affinity setting to disable 4 cores from the list. However, I've been reading it up and not sure this actually disables the hyperthreading for the program. It basically just suppresses the divided core so the physical core is not hyperthreaded.

The only other option is to turn it off via BIOS or boot, but that would turn it off for the whole system, not just TS2.


Quote:
Originally Posted by Simonut
I have no ideas what so ever what all this "Hyperthreading or core talk is all about ( Mindless ) so that is why I leave it to my tech man who build my computer at the Store.


From what I've read, and also experienced, is that at times a super computer may not run TS2 as well as an older system b/c of compatibility issues. I'm quite fortunate, b/c I've read so much about people having crashes and freezes. I don't have those, but what happens in my game is that when the number of sims increase on a lot, it lags significantly to the point it start to have minipauses and freezes.

Now of course the more sims you have, the more it hits the system. But the minifreezes were so severe and with only a minimal increase (around 10 sims on the lot). It turns out hyperthreading was incompatible with the game. In a simple description, if you have a quadcore and your system says you have 8 cpu, it means it is 4 cores hyperthreaded to function as 8. You only have 4 physical cores, but each one is divided and function as 2.

Again, TS2 doesn't use more than 1 core. But the OS can use the multi-core function to run programs, it just seems to have a compatibility issue with hypercores running TS2. By removing the 4 cores, it gives 100% functionality back to the original cores and the OS uses them without conflict with TS2.

Hyperthreading is supposely only an i7 thing. But since some i5s are merely i7s with 2 defective cores or i7 with defective hyperthreading, i5s can be 4 cores with no hyperthreading or 2 cores with hyperthreading. I suspect if someone on an i5 with same minipausing problem may have the same issue as me.
Meet Me In My Next Life
#9 Old 16th May 2015 at 7:11 AM Last edited by Simonut : 16th May 2015 at 8:19 AM.
Quote:
Originally Posted by nitromon




From what I've read, and also experienced, is that at times a super computer may not run TS2 as well as an older system b/c of compatibility issues. I'm quite fortunate, b/c I've read so much about people having crashes and freezes. I don't have those, but what happens in my game is that when the number of sims increase on a lot, it lags significantly to the point it start to have minipauses and freezes.

Now of course the more sims you have, the more it hits the system. But the minifreezes were so severe and with only a minimal increase (around 10 sims on the lot). It turns out hyperthreading was incompatible with the game. In a simple description, if you have a quadcore and your system says you have 8 cpu, it means it is 4 cores hyperthreaded to function as 8. You only have 4 physical cores, but each one is divided and function as 2.

Again, TS2 doesn't use more than 1 core. But the OS can use the multi-core function to run programs, it just seems to have a compatibility issue with hypercores running TS2. By removing the 4 cores, it gives 100% functionality back to the original cores and the OS uses them without conflict with TS2.

Hyperthreading is supposely only an i7 thing. But since some i5s are merely i7s with 2 defective cores or i7 with defective hyperthreading, i5s can be 4 cores with no hyperthreading or 2 cores with hyperthreading. I suspect if someone on an i5 with same minipausing problem may have the same issue as me.


@ nitromon ok I understand just a little bit the core / processor I have at the time my custom computer desktop was build is Intel (R ) core i7 inside of it and still is. Consider at the time as one of the top best and it is still as one of the top core today i7. It run my Sims 2 just fine no problems at all and all other games that I have purchase. The only time I have ever had any problem as I have said above in post #7 was transferring from one OS of Sims save game,
to another OS as I explain in post # 7
If I should ever have a problem with my games or computer here is what I do >> I call the tech

"Nothing in life is a Surprise it just happen to come your way at the time".
Mad Poster
Original Poster
#10 Old 21st May 2015 at 1:57 PM Last edited by nitromon : 21st May 2015 at 2:10 PM.
Final Test Result:

Ok, this is what I finally able to gather.

On the web, you'll read people saying b/c TS2 is a single core game, it is best to run it as a single core. This is absolutely correct. The part that was missing in a lot of these discussion and would vary depend on your system's architecture is that - The game needs to "start" with a single core. If you boot the game in multicores and then disable the other cores in task manager, this won't improve your game as you are turning off cores that were already assigned to certain functions of the program. The program may realign those functions, maybe after you load a new lot.

If you boot the game in multicores, the OS can utilize the multicores even though the game is not programmed that way. However, this may not benefit your game. I notice the game gets extremely jerky when there are a lot of sims on the lot. This is due to the fact each sim requires HDD read to activate their AI and animation. On a single core, these things are prioritized linearly, so it wouldn't burden your HDD. Win 7 OS sense your core being busy and separate those files reads into your other cores --> result? Your HDD is being multi-read and causing the game to jerk.

The reason game improved when I turned off hyperthreading has nothing to do with hyperthreading, it just got better because I turned off 4 cores.

So imagine 1 core with a list of prioritize HDD read. Faster your CPU, faster it reads, better your game runs. Now, imagine the read is split into 4 or 8 cores, all them simutaneously trying to read your HDD. Your HDD cannot keep up with the game, thus you get minipauses and the game becomes jerky. I suspect obviously people with SSD drive may not have this issue or less of it and likewise people with dual core and/or no hyperthreading would have less of an issue. The more cores you have, the worse this becomes. Generally speaking... if you are playing Sims 2 on a HDD and having more than 1 core, disable all your other cores at boot up. (This has nothing to do with your CPU speed. Regardless of your CPU, your HDD only spins so fast. Mine is 7200 RPM and it won't be faster on any other CPU)

To do this, simply change the target area of the Sims 2 shortcut you are using to:

C:\Windows\System32\cmd.exe /C start /high /affinity 1 Sims2EP8.exe

Change Sims2EP8.exe to whatever expansion you are running.

Mad Poster
#11 Old 21st May 2015 at 3:24 PM
I'd like to try this, as I have quad core, and the game does get jerky at times when it really shouldn't. But I'm afraid I don't understand that last bit.

I know I've done something to make it run single core, but I forget what exactly. I seem to recall it being related to task manager, so I wonder if it really is running on a single core.

If you have questions on how to use SimPE or WW, you're welcome to PM me.
The Great AntiJen
retired moderator
#12 Old 21st May 2015 at 5:00 PM
It's weird - and I think it demonstrates the problem with trying to track down this kind of issue - I have a fairly new (less than 6 months) i7 four core hyperthreading combo with heaps of RAM and a good video card (about to become a great one) and I have none of these troubles running the game. It's running better than ever and it wasn't too shabby before on the old system. I'm becoming more and more convinced there's an element of alchemy in there. I went through the CFF Explorer memory addressing routine as detailed on the threads I linked to earlier and that's it. Works just fine.

I no longer come over to MTS very often but if you would like to ask me a question then you can find me on tumblr or my own site tflc. TFLC has an archive of all my CC downloads.
I'm here on tumblr and my site, tflc
Mad Poster
Original Poster
#13 Old 21st May 2015 at 5:30 PM
Quote:
Originally Posted by gummilutt
I'd like to try this, as I have quad core, and the game does get jerky at times when it really shouldn't. But I'm afraid I don't understand that last bit.

I know I've done something to make it run single core, but I forget what exactly. I seem to recall it being related to task manager, so I wonder if it really is running on a single core.


It may or may not work by going through the task manager. It really depends on how your system's architecture is. In my case, I have to disable it right at the start up. If I go to task manager to shutdown the additional cores, it actually slowed the game down b/c those cores are already assigned by the OS.

The last bit is merely running the affinity command (setting CPU cores) with a command line. If you know how to write a .BAT file, you can try that first. The easiest way is simply open the Sims 2 shortcut (or create one if you don't have a shortcut) and change the "target" field.

For example:
The target might say: "C:\program files\electronic arts\the sims 2\tsbin\sims2.exe"

You just change the target to: C:\Windows\System32\cmd.exe /C start /high /affinity 1 sims2.exe

1) Do not use quotes
2) Make sure the "start in" line is not modified. It should say something like "C:\program files\electronic arts\the sims 2\tsbin\"

affinity 1 means it will only use the 1st core (binary 01).


Quote:
Originally Posted by maxon
I'm becoming more and more convinced there's an element of alchemy in there. I went through the CFF Explorer memory addressing routine as detailed on the threads I linked to earlier and that's it. Works just fine.


It depends on several factors, mainly architecture. Not all systems are the same. To be completely honest, when I first got this laptop in 2012, I actually ran TS2 just fine too. But throughout the year I had updated several drivers, even the OS, and I think I even updated the BIOS. I don't play Sims 2 that much so I didn't notice until a while when I ran it and it was laggy and jerky like crap. My Nvidia update even added that black box to the shadows.

The driver updates are doing exactly what they're meant to do, improve the system. So I think one of the update made the multicores utilization much better. TS2 is a single core game and I suspect before the update, the OS simply wouldn't utilize multicores on it. Now the "improved" OS tries to be useful, instead caused me a bunch of headaches.

Most ironically though, now I got the game running without jerkiness etc... I'm going back to Intel HD 4000 (no black box shadows) and the game is actually running smoother on it than my Nvidia. I think it is simply because the game is old and requires a slower GPU. With Intel HD 4000, I can only get around 30-40 FPS, so the FPS drop is smaller and the game runs smoother. With Nvidia the drop is from 60 FPS down to 30, that's 50% drop and causes stutters.
The Great AntiJen
retired moderator
#14 Old 21st May 2015 at 6:55 PM
Sure I get that. The same black playing card thing happened with one of my NVidia updates too. I don't usually play with shadows anyway so it's not much of a problem for me.

I no longer come over to MTS very often but if you would like to ask me a question then you can find me on tumblr or my own site tflc. TFLC has an archive of all my CC downloads.
I'm here on tumblr and my site, tflc
Mad Poster
Original Poster
#15 Old 3rd Jun 2015 at 3:02 AM Last edited by nitromon : 3rd Jun 2015 at 4:29 AM.
I want to update this b/c I discovered something strange lately. Again, this probably only applies to a few people with certain system setups, but hey if it works, it works.

Recently I turned up all the cores after I already booted and was playing the game in single core. Interestingly, the game ran extremely smooth jacking up to 40-60 FPS even with 20-30 sims on the lot. I noticed that only 1 core is at 100% while other cores were sharing certain loads.

I thought at first that I had changed a few things so it works with multi-cores. So I closed the game and boot up with multiple cores and the game started to jerk and lag with just a handful of sims again.

Anyhow, for people who are already booting up with single core, try turning on the other cores after you've boot up the sims and see if that helps you. I don't really have an explanation, it just works in my case.

EDIT: Hmm, not very consistent. Sometimes it works, sometimes it doesn't. I guess it is still just best for those with jerky games to stick to single core.
Mad Poster
#16 Old 3rd Jun 2015 at 10:10 PM
"Sufficiently advanced technology is indistinguishable from magic." Arthur C. Clarke

I think we got there a while back, myself, but my black cauldron, I mean black desktop, says it has dual core and when I load Sims 2 it appears to run the game on one and the operating system and other background things on the other: one goes up to 100% and the other lingers around 50%. When just running operating system and background tasks it's around 25% on each. This is Win 7's doing all on its own. My magic must be similar to Maxon's!

Pics from my game: Sunbee's Simblr Sunbee's Livejournal
"English is a marvelous edged weapon if you know how to wield it." C.J. Cherryh
Back to top