Replies: 10 (Who?), Viewed: 1946 times.
Lab Assistant
Original Poster
#1 Old 8th Dec 2017 at 10:59 AM

This user has the following games installed:

Sims 2, University, Nightlife, Open for Business, Pets, Seasons, Bon Voyage, Free Time, Apartment Life
Default Flashing pink graphic problem
Hello,
I beg you for some advice / help if possible...

I haven't played Sims 2 for quite a long time (I have been busy in life) but I wanted to play today. I launched the game but all I could see was the black screen. Of course I restarted the computer and hoped it would get fixed by itself... it did not. Next time there was blank screen again, so I waited for it to load the neighbourhoods - I guessed where to click and got to the neighbourhood. But the grass in the neighbourhood was flashing in pink colour.

I tried the usual things - deleted Groups.cache, Accessory.cache, I removed the Downloads folder, I even removed Neighbourhoods but nothing worked.

After some searching, I succeeded only in launching the game in a windowed mode. The loading looked normal (no black screen) - I thought the game would load with good graphics at last, but again the grass was flashing pink. I tried CAS and there the walls flashed in red colour (see pictures below)

I searched for this error via Google and found this video where it is recommended to download Graphics Rules Maker. So I immediately installed it, double-clicked the icon to launch the application but it didn't work - nothing happened!
https://www.youtube.com/watch?v=qLkmxAg7r3Y

I read somewhere that it doesn't help to reinstall the game with this glitch.
I suspect my graphic card to be responsible. I have Windows 10, graphic card ATI Radeon HD 4200 Series. It worked perfectly, my Sims 2 game always had beautiful graphics and I have not encountered any problems in this system (only with the installation but after that, the game worked well). Strange - I did not change any setting for the graphic card.
I checked in Device Manager and the graphic card appears there. However, in dxdiag it does not seem to appear. I'm confused as I do not understand technical issues with hardware much - I am not even able to buy a new graphic card so that it is compatible with the motherboard and the system, not to speak of putting it there myself and have noone who could help me with this.

I tried updating the driver but Windows 10 driver update program did not find any drivers for my card.

Here is the graphics info from dxdiag
--------------
Display Devices
---------------
Card name: Microsoft Basic Display Driver
Manufacturer: (Standard display types)
Chip type: ATI ATOMBIOS
DAC type: (C) 1988-2005, ATI Technologies
Device Type: Display-Only Device
Device Key: Enum\ROOT\BASICDISPLAY
Device Status: 4180000B [DN_ROOT_ENUMERATED|DN_DRIVER_LOADED|DN_STARTED|DN_NT_ENUMERATOR|DN_NT_DRIVER|DN_NO_SHOW_IN_DM]
Device Problem Code: No Problem
Driver Problem Code: Unknown
Display Memory: 3839 MB
Dedicated Memory: 0 MB
Shared Memory: 3839 MB
Current Mode: 1024 x 768 (32 bit) (64Hz)
Monitor Name: Generic PnP Monitor
Monitor Model: Philips 150S


This is what the glitch looks like:







I also enclose the picture of graphic settings in the game - I used to play with the graphic settings on max level, reflections on - and as you can see, everything was reset to "low" automatically (I did not change anything) - and now even the 1024x768 resolution is not available here - it used to be there.

I will be grateful for any advice you can give me. As I do not understand HW technical issues, please be patient with me and explain in easy terms, if possible - sorry for this.

I feel very sad and helpless - I wanted to take part in a building contest (Christmas house)... I spent a lot of time downloading many Christmas decorations for my game now I guess I won't be able to play for a very long time
Advertisement
Mad Poster
#2 Old 8th Dec 2017 at 12:08 PM
Deleting the thumbnails folder in my game folder always gets rid of pink flashing.

Having said that: my game has never been that pink. Have a look here on Leefish as well: http://www.leefish.nl/mybb/showthread.php?tid=5446

Using the graphic rule maker (program) does not work on my system for some obscure reason, but downloading the correct files from Leefish and placing them in the program files by hand - that does work. So it may be worth trying to do that.
Lab Assistant
Original Poster
#3 Old 8th Dec 2017 at 2:00 PM
Hi Justpetro,
thank you very much for your advice and link - unfortunately, it did not work for me. It's still flashing brightly.
I followed the tutorial from the link and I was surprised that the game did not recognize my graphic card.

=== Graphics device info ===
Number: 0
Name (driver): Microsoft Basic Render Driver
Name (database): Microsoft Basic Render Driver <<NOT FOUND IN DATABASE!>>
Vendor:
Chipset: Vendor: 1414, Device: 008c, Board: 00000000, Chipset: 0000
Driver: d3d10warp.dll, Version: 10.0.15063.608, GUID: D7B71AF4-43CC-11CF-D061-D71AAFC2C735
Driver version: 608
Monitor: \\.\DISPLAY1
Monitor aspect: 1.334782, 4:3
Screen mode: 1024x768x32BPP,64Hz
Texture memory: 32MB
HW T&L: Fixed function:1 Programmable:3.0
Pixel program: 3.0
Texture stages: 8
AppControlledAA: 1

In Device Manager (Windows 10), the graphic card is shown (ATI Radeon 4200) so I wonder why the dxdiag and config log of the game do not recognize my graphic card?
Mad Poster
#4 Old 8th Dec 2017 at 3:09 PM
IIt looks as if your card does not have a driver.
You can download one from the Radeon site, I should think - I do find it strange, though, because Windows 10 normally finds missing drivers by itself.
The Great AntiJen
retired moderator
#5 Old 8th Dec 2017 at 3:11 PM
It is graphics card related - which version of Windoze are you running? Because the procedure for Win10 is a little different - you might also try the 4GB patch on the exe. When I sorted out my graphic rules last (which was quite a while back now), I only had to download a file, I didn't need to use the graphic rules maker. This was because over at Leefish somewhere, someone had made some ready made files.

I no longer come over to MTS very often but if you would like to ask me a question then you can find me on tumblr or my own site tflc. TFLC has an archive of all my CC downloads.
I'm here on tumblr and my site, tflc
Lab Assistant
Original Poster
#6 Old 8th Dec 2017 at 5:08 PM
This is what I thought, too.
I have Windows 10. I went to the site for my graphic card and it seems that "Driver support for these products under Windows® 8.1 and Windows® 10 is only available via Windows Update. Please enable Windows Update to allow it to automatically detect and install display driver version 8.970.100.9001".
http://support.amd.com/en-us/kb-art...der-Series.aspx

When I go to Device Manager in my Windows 10 and try the Windows Update, it searches for drivers but finds none, it says "The best drivers for your device are already installed. Windows has determined that the best driver for this device is already installed. There may be better drivers on Windows Update or on the device manufacturer's website."

But then I wonder why it worked so well until now? My ATI Radeon worked in Windows 10. I did not change anything in the system, did not update or uninstall any drivers by myself. Though I can't know if some apps did it behind my back or maybe Windows 10 was updated and made it incompatible? I am so disappointed and do not see a way to fix it.
Mad Poster
#7 Old 8th Dec 2017 at 5:28 PM
I doubt if there is a problem with Windows 10 and your card - it should tell you so.

Try to restart your computer and see what happens. Windows 10 picks up dropped drivers with restarting on my pc.

The link maxon refers to is the one on Leefish I posted above.
1001001
retired moderator
#8 Old 8th Dec 2017 at 5:49 PM
That graphics chip isn't supported for Win 10 by the manufacturer:
https://support.amd.com/en-us/kb-ar...der-Series.aspx

What I would suggest is to attempt to uninstall any existing drivers, and have Windows update replace them. Although, I'm not sure how much luck you'll have since your device manager is giving somewhat conflicting information.

I will choose a path that's clear- I will choose free will
-RUSH- -RADIO- -ARCHIVES-
Simpeople and Me Archive- -11Dots Archive- My Sims World Archive
The Great AntiJen
retired moderator
#9 Old 8th Dec 2017 at 6:10 PM
Oh Radeon - sorry didn't see that before. I had to roll back my drivers about a month ago because an update buggered up a lot of things. Might be worth trying that but, as simsample points out, it might be an issue with support because the card is relatively old and the drivers won't have updated for a while anyway.

I no longer come over to MTS very often but if you would like to ask me a question then you can find me on tumblr or my own site tflc. TFLC has an archive of all my CC downloads.
I'm here on tumblr and my site, tflc
Lab Assistant
Original Poster
#10 Old 9th Dec 2017 at 3:10 AM
Thank you all! "Roll back" - that was the right option to correct this issue


I'm posting it here just in case somebody else has a similar issue - you don't know how happy I am to see the green grass again in Sims :D
Many many thanks to you all!!!
1001001
retired moderator
#11 Old 9th Dec 2017 at 8:55 AM
Well done for fixing it!

I will choose a path that's clear- I will choose free will
-RUSH- -RADIO- -ARCHIVES-
Simpeople and Me Archive- -11Dots Archive- My Sims World Archive
Back to top