Replies: 191 (Who?), Viewed: 21272 times.
Page 5 of 8
Lab Assistant
#101 Old 9th Aug 2020 at 12:19 AM
Quote:
Originally Posted by CmarNYC
Yes. Not at this moment since I'm working on the TS4 version right now and can't guarantee I won't get distracted by something else, but I'm definitely coming back to it.


Awesome, thank you for the update!
Lab Assistant
#102 Old 11th Aug 2020 at 3:02 PM
Default Bug report or just my problem
Quote:
See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.DivideByZeroException: Cannot normalize a vector with magnitude of zero!
at TS3SimRipper.Vector3.Normalize(Vector3 v1)
at TS3SimRipper.Vector3.Normalize()
at TS3SimRipper.GEOM.BoneMorpher(Bone bone, Single weight, Vector3 offset, Vector3 scale, Quaternion rotation)
at TS3SimRipper.Form1.LoadBONDMorph(GEOM baseMesh, BOND boneDelta, RIG rig, String& errorMsg)
at TS3SimRipper.Form1.GetCurrentModel()
at TS3SimRipper.Form1.DisplaySim(SimDescription sim)
at TS3SimRipper.Form1.sims_listBox_SelectedIndexChanged(Object sender, EventArgs e)
at System.Windows.Forms.ListBox.OnSelectedIndexChanged(EventArgs e)
at System.Windows.Forms.ListBox.WmReflectCommand(Message& m)
at System.Windows.Forms.ListBox.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


I'm guessing this is because of custom sliders? It creates this error every time i initially select a sim to load and then nothing happens but if i switch too outfit 2 then the sim loads in but the skintone is messed up and the eyebrow texture is on the cheek and lipstick is completely gone but all the sliders look correct
Ms. Byte
Original Poster
#103 Old 11th Aug 2020 at 7:04 PM
Quote:
Originally Posted by THA
I'm guessing this is because of custom sliders? It creates this error every time i initially select a sim to load and then nothing happens but if i switch too outfit 2 then the sim loads in but the skintone is messed up and the eyebrow texture is on the cheek and lipstick is completely gone but all the sliders look correct


That error is happening in the calculation of bone morphed normals. Possibly there's a triangle in a mesh that's not correctly constructed - a zero length side or whatever. Possibly a slider is doing something weird with normals. I can catch the error and just ignore it in the next version.

No idea why skintones and makeup would be affected. I don't know, maybe continuing from that error is messing things up somehow. Also no idea why it would throw an initial error and then (sort of) work on other outfits. Or there could be some unrelated problem.

Are you using any mod or CC that uses non-standard texture dimensions? That could explain the face not being mapped correctly.

I'm trying to wind up work on the TS4 version in a few days and will port what I've done there to this version - automatically linking the textures in the Collada DAE and Milkshape .ms3d and adding an extra light in Blender. That's what's taking so long - it's a finicky process but almost done.

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Lab Assistant
#104 Old 15th Aug 2020 at 12:44 PM
Quote:
Originally Posted by CmarNYC
That error is happening in the calculation of bone morphed normals. Possibly there's a triangle in a mesh that's not correctly constructed - a zero length side or whatever. Possibly a slider is doing something weird with normals. I can catch the error and just ignore it in the next version.

No idea why skintones and makeup would be affected. I don't know, maybe continuing from that error is messing things up somehow. Also no idea why it would throw an initial error and then (sort of) work on other outfits. Or there could be some unrelated problem.

Are you using any mod or CC that uses non-standard texture dimensions? That could explain the face not being mapped correctly.

I'm trying to wind up work on the TS4 version in a few days and will port what I've done there to this version - automatically linking the textures in the Collada DAE and Milkshape .ms3d and adding an extra light in Blender. That's what's taking so long - it's a finicky process but almost done.


Maybe It's because I used nraas to multiply sliders to go above the set limit? and I do have HQ mod or higher texture resolution running but I doubt that's the reason why because the lipstick and eyebrow aren't any different from normal lipstick and eyebrows unless it's a cc hairline that I downloaded that sits in the place of blush but it's not on the sim I'm trying to rip OR maybe it's because I have multiple makeups in the same location with nraas but that doesn't explain why the eyebrow would be on the cheek or the skin and make up being inverted along with the skin being default white/grey but my skin texture is 2k for the face and the body is 4k. But excited for the next update!
Ms. Byte
Original Poster
#105 Old 15th Aug 2020 at 1:07 PM
Quote:
Originally Posted by THA
Maybe It's because I used nraas to multiply sliders to go above the set limit? and I do have HQ mod or higher texture resolution running but I doubt that's the reason why because the lipstick and eyebrow aren't any different from normal lipstick and eyebrows unless it's a cc hairline that I downloaded that sits in the place of blush but it's not on the sim I'm trying to rip OR maybe it's because I have multiple makeups in the same location with nraas but that doesn't explain why the eyebrow would be on the cheek or the skin and make up being inverted along with the skin being default white/grey but my skin texture is 2k for the face and the body is 4k. But excited for the next update!


The error you got is likely to be something about the mesh itself. I asked about texture sizes because if I draw a makeup texture on the face texture and they're not the same size the eyebrows, lipstick, etc will end up in the wrong place. I'll have to check that everything's getting resized before compositing.

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Test Subject
#106 Old 17th Aug 2020 at 9:21 PM
Hey, I'm new to Blender and to CC making in general. I'm trying to make a deco horse for TS3 which I will then hopefully convert to TS4. I've been following this thread and consulting with TS4 and TS3 CC-makers, but we aren't quite sure what "normals" means. Like when you said the .DAE files maintain the UV map and rig, but not the normals.

Thanks for this awesome tool! I'm really looking forward to making some deco horses since EA hasn't given us any for TS4 yet!
Ms. Byte
Original Poster
#107 Old 17th Aug 2020 at 10:41 PM
Quote:
Originally Posted by espresso-yourself
Hey, I'm new to Blender and to CC making in general. I'm trying to make a deco horse for TS3 which I will then hopefully convert to TS4. I've been following this thread and consulting with TS4 and TS3 CC-makers, but we aren't quite sure what "normals" means. Like when you said the .DAE files maintain the UV map and rig, but not the normals.

Thanks for this awesome tool! I'm really looking forward to making some deco horses since EA hasn't given us any for TS4 yet!


Sounds like a great project! The TS3 horse meshes are quite nice.

The normals are vertex/face normals, which are attached to vertices or faces or face corners (depending on the mesh format) and control highlighting and shadowing somewhat like a bump map/ normal map. The normals are what gives a mesh surface a smooth appearance instead of each face looking flat. Most modders don't deal with them much if at all, but they have to be matched at seams or you get a visible line where the shading doesn't match. A lot of 3D editors like to do auto-smoothing, which is calculating normals automatically to smooth the mesh, and can result in seam lines. That's what Blender does - it either doesn't import the normals from DAE or it then auto-smooths. By cleaning the DAE mesh when you export it from SimRipper you can prevent most or all of those normals seam lines.

I hope that makes at least a little sense!

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Test Subject
#108 Old 25th Aug 2020 at 6:30 PM
At the risk of looking completely stupid, I can't load any sim and I don't know why. When I run the .exe, there's a popup saying "Unable to read valid package data from programfiles\TS3 Create a Pattern \shared\package\fullbuild.package", and another popup saying "can't read package files". The ripper loads and I can find my sims names from both the simbin and my saves, but their image don't appear and I only get to export an empty file. When I click on their names, a pop-up error appears
Ms. Byte
Original Poster
#109 Old 25th Aug 2020 at 6:55 PM
Quote:
Originally Posted by lipsonfire
At the risk of looking completely stupid, I can't load any sim and I don't know why. When I run the .exe, there's a popup saying "Unable to read valid package data from programfiles\TS3 Create a Pattern \shared\package\fullbuild.package", and another popup saying "can't read package files". The ripper loads and I can find my sims names from both the simbin and my saves, but their image don't appear and I only get to export an empty file. When I click on their names, a pop-up error appears


Check the game packages path in the setup - it should not be pointing to Create a Pattern but to where the TS3 game is installed.

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Test Subject
#110 Old 26th Aug 2020 at 1:42 AM
Hello Cmar, the path for the game folders look alright!

Ms. Byte
Original Poster
#111 Old 26th Aug 2020 at 8:50 AM
Quote:
Originally Posted by lipsonfire
Hello Cmar, the path for the game folders look alright!



They look correct, but then the error message doesn't make sense. Please post a screenshot or the exact text of all error messages you're getting.

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Test Subject
#112 Old 27th Aug 2020 at 2:41 AM
Quote:
Originally Posted by CmarNYC
They look correct, but then the error message doesn't make sense. Please post a screenshot or the exact text of all error messages you're getting.


Here they are:



The fix was easy, after all: I just deleted the Sims 3 CAP folder path at the setup. Could load a townie successfully. Loading my sims from the simbin failed every time, though: here's the popup:


When I clicked the show errors button, it looks like there's issues with the Brow Thickness slider, the Chin Lenght and the Eye Lenght. I put them on a zip if looking at them will help you in any way.
Download - please read all instructions before downloading any files!
File Type: zip sliders.zip (3.2 KB, 2 downloads)
Ms. Byte
Original Poster
#113 Old 27th Aug 2020 at 2:01 PM
Quote:
Originally Posted by lipsonfire
Here they are:



The fix was easy, after all: I just deleted the Sims 3 CAP folder path at the setup. Could load a townie successfully. Loading my sims from the simbin failed every time, though: here's the popup:


When I clicked the show errors button, it looks like there's issues with the Brow Thickness slider, the Chin Lenght and the Eye Lenght. I put them on a zip if looking at them will help you in any way.


Thanks! Apparently with Create A Pattern installed alongside the game files, SimRipper tried and failed to read the packages in it. I'll have to just skip stuff that can't be read in the next version.

And thanks for the sliders - I'll check them out.

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Test Subject
#114 Old 28th Aug 2020 at 6:38 AM
Quote:
Originally Posted by CmarNYC
Sounds like a great project! The TS3 horse meshes are quite nice.

The normals are vertex/face normals, which are attached to vertices or faces or face corners (depending on the mesh format) and control highlighting and shadowing somewhat like a bump map/ normal map. The normals are what gives a mesh surface a smooth appearance instead of each face looking flat. Most modders don't deal with them much if at all, but they have to be matched at seams or you get a visible line where the shading doesn't match. A lot of 3D editors like to do auto-smoothing, which is calculating normals automatically to smooth the mesh, and can result in seam lines. That's what Blender does - it either doesn't import the normals from DAE or it then auto-smooths. By cleaning the DAE mesh when you export it from SimRipper you can prevent most or all of those normals seam lines.

I hope that makes at least a little sense!


Thanks for the info! If we have any errors at all, should we post them here? I think I'm having trouble generating textures from my horses, both CC-free and CC-inclusive. I think I only get one texture from their outfit if I click the save texture button. I'd be more detailed if I knew what I was supposed to be looking for or what result to expect, but I'm just so new at this that I really struggle. Thanks for your time, though, it's really greatly appreciated!
Ms. Byte
Original Poster
#115 Old 28th Aug 2020 at 2:09 PM
Quote:
Originally Posted by espresso-yourself
Thanks for the info! If we have any errors at all, should we post them here? I think I'm having trouble generating textures from my horses, both CC-free and CC-inclusive. I think I only get one texture from their outfit if I click the save texture button. I'd be more detailed if I knew what I was supposed to be looking for or what result to expect, but I'm just so new at this that I really struggle. Thanks for your time, though, it's really greatly appreciated!


For animals in most cases you should get 4 textures: body, face, hair, and scalp. But I've really just started on handling the textures and they're all grayscale.

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Test Subject
#116 Old 28th Aug 2020 at 9:05 PM
Quote:
Originally Posted by CmarNYC
For animals in most cases you should get 4 textures: body, face, hair, and scalp. But I've really just started on handling the textures and they're all grayscale.

Mine have all been blank so far, I think. I get an error that says a bunch of stuff like this: Can't find PeltLayer CASP 0x034AEECB-0x4800001C-0x551C4ABBA0EF3D7C, but the numbers and letters vary after each one.
Ms. Byte
Original Poster
#117 Old 28th Aug 2020 at 10:33 PM
Quote:
Originally Posted by espresso-yourself
Mine have all been blank so far, I think. I get an error that says a bunch of stuff like this: Can't find PeltLayer CASP 0x034AEECB-0x4800001C-0x551C4ABBA0EF3D7C, but the numbers and letters vary after each one.


That means it can't find some of the meshes and textures in the sim. In this case it can't find a pelt layer, a part that defines the color of an animal's coat. You should try with an EA sim since presumably everything it uses is in the game packages.

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Test Subject
#118 Old 4th Sep 2020 at 1:36 AM
Quote:
Originally Posted by CmarNYC
That means it can't find some of the meshes and textures in the sim. In this case it can't find a pelt layer, a part that defines the color of an animal's coat. You should try with an EA sim since presumably everything it uses is in the game packages.

A regular sim or an EA animal sim? In this case, it's the EA animal sim's textures it's not finding.
Ms. Byte
Original Poster
#119 Old 4th Sep 2020 at 11:33 AM
Quote:
Originally Posted by espresso-yourself
A regular sim or an EA animal sim? In this case, it's the EA animal sim's textures it's not finding.


Which EA animal sim?

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Test Subject
#120 Old 4th Sep 2020 at 5:58 PM
Quote:
Originally Posted by CmarNYC
Which EA animal sim?

I used their base sim for a Shire horse and saved it. Should I have done one from their bin instead?
Ms. Byte
Original Poster
#121 Old 4th Sep 2020 at 6:34 PM
Quote:
Originally Posted by espresso-yourself
I used their base sim for a Shire horse and saved it. Should I have done one from their bin instead?


Sorry, I thought there were ready-made animals in the saves I could test with. I don't know. Actually, at this point I've been working with the TS4 version of SimRipper for a while and need to refresh my memory as I get back into this one plus I'm going to be making extensive changes to the texturing which is just grayscale right now, so I won't have an answer for you for a little while. If you like, you could upload the save you're working with and the horse's name so I can test with it when I get to that point.

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Test Subject
#122 Old 9th Sep 2020 at 8:22 PM
It worked on Windows 8.1 but I upgraded to Windows 10 and I'm getting errors again. The same sims were ripped without any problems on 8.1. Tested without CC.
I can select the folder and the list of sims show up but when I try to select any of them, this show up and the app crashes:

Quote:
************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
at TS3SimRipper.RIG..ctor(RIG other)
at TS3SimRipper.Form1.GetCurrentModel()
at TS3SimRipper.Form1.DisplaySim(SimDescription sim)
at TS3SimRipper.Form1.sims_listBox_SelectedIndexChanged(Object sender, EventArgs e)
at System.Windows.Forms.ListBox.OnSelectedIndexChanged(EventArgs e)
at System.Windows.Forms.ListBox.WmReflectCommand(Message& m)
at System.Windows.Forms.ListBox.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)
Download - please read all instructions before downloading any files!
File Type: txt exception2.txt (6.9 KB, 2 downloads)
Ms. Byte
Original Poster
#123 Old 9th Sep 2020 at 9:07 PM
Quote:
Originally Posted by Vatri
It worked on Windows 8.1 but I upgraded to Windows 10 and I'm getting errors again. The same sims were ripped without any problems on 8.1. Tested without CC.
I can select the folder and the list of sims show up but when I try to select any of them, this show up and the app crashes:


There's no reason I know of that SimRipper would behave any differently in Win 8.1 vs Win 10. That message indicates there's something wrong with the rig. Are you sure you're not using any CC or default replacements? Are you sure the game files paths are still correct and you have access to the game packages?

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Test Subject
#124 Old 9th Sep 2020 at 10:01 PM
Quote:
Originally Posted by CmarNYC
There's no reason I know of that SimRipper would behave any differently in Win 8.1 vs Win 10. That message indicates there's something wrong with the rig. Are you sure you're not using any CC or default replacements? Are you sure the game files paths are still correct and you have access to the game packages?

Nevermind, it works now. Turned out I forgot to update the game. It's been so long since the last time I installed it I kinda forgot how to do it.
Test Subject
#125 Old 10th Sep 2020 at 7:35 PM
Quote:
Originally Posted by CmarNYC
Sorry, I thought there were ready-made animals in the saves I could test with. I don't know. Actually, at this point I've been working with the TS4 version of SimRipper for a while and need to refresh my memory as I get back into this one plus I'm going to be making extensive changes to the texturing which is just grayscale right now, so I won't have an answer for you for a little while. If you like, you could upload the save you're working with and the horse's name so I can test with it when I get to that point.


https://drive.google.com/drive/fold...zEt?usp=sharing Here's my save and the sim I'm using. I named it Thornalia V1 for the person I'm making it for. It's just the standard EA Shire breed horse that I saved to my bin in order to use the program. Let me know if I need to upload anything else, it's my first time doing it so I wasn't sure exactly which files you'd need. I really do appreciate your dedication and help!
Page 5 of 8
Back to top