Replies: 20 (Who?), Viewed: 7475 times.
Test Subject
Original Poster
#1 Old 23rd Oct 2010 at 6:15 AM
Default can't uninstall
i think it was something that was carried from my old computer. i tried the registry steps but that didn't work. so i tried to reinstall it using the version i thought it was and then uninstall it that way but it's not even in the start menu, add and delete programes and youruninstaller. don't know what to try next.
it's version and i'm running windows 7 home edition 64bit.
any ideas?
Test Subject
#2 Old 28th Oct 2010 at 6:20 PM
I have the same exact problem! I hope someone is able to help...
Site Helper
#3 Old 29th Oct 2010 at 1:27 AM
By "the registry steps", do you mean this?

Do you still have the "Sims2Pack Clean Installer" folder in one of your "Program Files" folders? If so, you should be able to run the uninstall.exe from there.
Test Subject
Original Poster
#4 Old 29th Oct 2010 at 2:42 AM
yeah thats what i meant.
the folder is there but i don't see any uninstall.exe.
this is all i see.
Site Helper
#5 Old 29th Oct 2010 at 5:24 AM
What happens when you try to install a new version? Do you get an error? If so, could you attach a snapshot of the error that you receive?
Test Subject
Original Poster
#6 Old 29th Oct 2010 at 5:54 AM
i get this when ever i try to install any version later than the one i mentioned in the first post.
this pop up is from the latest release 1.6.11

i click yes then nothing happens.
Site Helper
#7 Old 29th Oct 2010 at 5:02 PM
Are you logged in as an administrator? If not, log on as an administrator and try the link that I gave you again.

Have you tried turning off UAC (user access control)? If not, try turning it off (at least temporarily), since it may be preventing you from manually uninstalling.
Test Subject
Original Poster
#8 Old 29th Oct 2010 at 6:03 PM
i'm the only one that uses this pc so yeah i'm the administrator. uac is always off.
i just clicked on the version icon in the folder and it says it's version 1.0. looks like i said the wrong version, sorry about that.
anyway those steps aren't working. i still get the same pop up.
Site Helper
#9 Old 1st Nov 2010 at 1:04 AM
Have you tried removing or renaming the entire folder?
Me? Sarcastic? Never.
staff: administrator
#10 Old 1st Nov 2010 at 3:43 AM
When you get that pop up are you selecint yes to uninstall it? And then running the installer again (if necessary) to actually install it?

Maybe try using a program like ccleaner to fully remove the old version, and then verifying the folders were also removed from Program Files (x86).
Test Subject
Original Poster
#11 Old 1st Nov 2010 at 6:17 AM
i've renamed the folder, the ccleaner didn't have it on the list even after i installed the again.
although when i went into regedit i could only find

My Computer\ HKEY_CLASSES_ROOT\ Sims2PackCleanInstaller

couldn't find.

My Computer\ HKEY_LOCAL_MACHINE\ SOFTWARE\ Sims2PackCleanInstaller

My Computer\ HKEY_CLASSES_ROOT\ APPLICATIONS\ Sims2PackCleanInstaller.exe

any other ideas?
Site Helper
#12 Old 1st Nov 2010 at 6:44 AM
I don't have the source for any of the older versions, which means that I don't have access to the install / uninstall scripts. I've looked at the current install / uninstall scripts, but there's really only two things that have to be uninstalled: the files on the hard drive, and the registry entries. One of the executable files in the current version can be locked, which means that it can be difficult to remove since it may require a delete on reboot; I don't know whether that file existed in the earlier versions.

There may be something odd about the uninstall on Windows 7, or there may be something odd about uninstalling on 64-bit, but I don't have any way to check either of those.

You could try searching your registry for each of "Sims2Pack", "Clean Installer", "S2PCI", and "S2PCISE" individually, although you'll want to be a bit careful about removing entries for "Sims2Pack" which aren't actually related to the clean installer. Also, the spaces are important: you should be checking for "Sims2Pack Clean Installer". Are you searching all of Keys, Values, and Data? Are you searching for partial strings, rather than full strings only?

If you knew for sure which version you have installed, I could try installing it myself to see what's included with that version, to see whether there's anything odd about that particular install. You originally mention version; which seems more likely than that you've been running V1.0. Did you install into the default location?
Test Subject
Original Poster
#13 Old 1st Nov 2010 at 7:32 AM
searched "Sims2Pack Clean Installer" and found a bunch and a few things i must have over looked. anyway i got the old version gone and i just put in the newest release and it works.

thank you everyone especially mootilda for all the help^_^
Site Helper
#14 Old 1st Nov 2010 at 5:14 PM
I'm so glad that you got it working.
Test Subject
#15 Old 4th Nov 2010 at 12:35 AM
i'm having the same problem and i've done everything and it still won't install
Site Helper
#16 Old 4th Nov 2010 at 3:12 AM Last edited by Mootilda : 4th Nov 2010 at 10:23 PM.
lissy10, could you please list everything that you've tried so far? Be sure to tell us which operating system you are using and which version of the Clean Installer you are trying to uninstall.
Test Subject
#17 Old 7th Nov 2010 at 11:24 PM
ok first i uninstalled it with the uninstaller that comes it, i have went through the registry keys and delete all of them, i also searched my c drive and delete all the sims clean pack i found, it's the version before the newest one out i was uninstalling it to install the new one, i'm using windows 7 if you need anything else please let me know
Site Helper
#18 Old 8th Nov 2010 at 2:57 AM
What search strings did you use when searching the registry? Are you searching all of Keys, Values, and Data? Are you searching for partial strings, rather than full strings only?

Are you running on an administrator account? Do you have UAC turned off?
Test Subject
#19 Old 10th Nov 2010 at 4:13 PM
i search all keys values and data and partial string i'm the only one who uses the computer and i did turn the uac off. i was gonna roll back my system but i was getting frustrated. If you have anymore suggestion i will try them thanks
Site Helper
#20 Old 10th Nov 2010 at 5:40 PM
You probably missed one of the search strings. Did you try every search string listed in this thread and the other thread linked above?
Test Subject
#21 Old 13th Nov 2010 at 3:28 AM
I'm also having this same problem. I have windows 7 as well, and I had the version installed. I first uninstalled the version and tried to install the newest version, it was installing fine until I got an error message telling me that the file was corrupt and to "abort" the installation. I clicked "abort" and then "Cancel" and it all cleared out. But then when I went to try to re-install the newest version is where I encountered all the problems. Since then, I tried to use the uninstall through my Program folders (but since it did not finish installing it's not there), checked all instances of anything Sims 2 Pack Clean Installer, etc. and found nothing. I used my CCleaner, analyzed and deleted registry, temporary files, everything numerous times. I've restarted and tried re-downloading the newest version and I still get the same thing. That it says I still have a previous version installed. I'm ready just to throw in the towel because I really do not know where else to look. I've checked every folder on my desktop, downloads, sims, program files, even my documents, music, and video folders (even though I know I did not put it in those originally) I do not know where else to look. Please help! If anybody can fill me in on something I'm missing that would be great. Thank you.
Back to top