Hi there! You are currently browsing as a guest. Why not create an account? Then you get less ads, can thank creators, post feedback, keep a list of your favourites, and more!
Locked thread | Replies: 293 (Who?), Viewed: 176909 times.
Page 12 of 12
retired moderator
#276 Old 4th Jul 2011 at 9:08 AM
That's definitely a UAC error- 'toegang tot het pad is geweigerd' means 'access to path denied'.

Copy the Bridgeport.world file to your desktop and open that instead as hotroxy777 said, as then you are working with a copy which is what you should always do (although, S3PE is clever and will only open system files as read-only).

hotroxy777, I would never advise to disable UAC, as then you are rendering your operating system vulnerable.
Test Subject
#277 Old 4th Jul 2011 at 10:53 AM
@simsample yes you're perfectly right. I should clarify myself. When I mentioned disabling UAC I had in mind temporarily. It shouldn't make any harm to our machines. Am I right?
Test Subject
#278 Old 4th Jul 2011 at 7:28 PM Last edited by Inkantator : 5th Jul 2011 at 4:44 PM.
Hello again
After few months of a break, I've got new complications with Bridgeport. It seems lack of names of buildings is a minor problem. Look at this :

clubby Vampire... known also as Jessica Talon. Moreover, famyli description is gone, as well as relationship with every sim in town.

And this was supposed to be a Fire Station...

I've got CAW v1.10.9 and I think it still has got problems with Ambitions and Late Night. Perhaps this has been fixed it CAW 1.11.4, but I haven't tried yet.
One more thing - I did the same with Sunset Valley. Everything exept for buildings names was fine.
I was planning to create a customized Bridgeport, not ragged Bridgeport clone. Any ideas what can I do about it?
retired moderator
#279 Old 5th Jul 2011 at 2:16 PM
Originally Posted by hotroxy777
@simsample yes you're perfectly right. I should clarify myself. When I mentioned disabling UAC I had in mind temporarily. It shouldn't make any harm to our machines. Am I right?

It would be better to not install your games to a UAC protected area in the first place.

Inkantator, for the naming problem, that is a known issue and is mentioned elsewhere in this (now very long) thread. You need to edit those manually in EIG, as the EA worlds use a reference to the name data. Not sure how you'd go about editing the sim names, has anyone figured out an easy method? I think the family description and relationships problem is related- the sims are imported via an XML file (more information from Kiwi_Tea here) so during the process of editing the world the game no longer identifies it as Bridgeport proper, so the import is not clean.

For the problem with the fire station, is the lot itself actually corrupted? Can you enter it in build mode? I often have lot low LOD textures mess up when opening premade worlds, usually changing something on the lot will cause the game to regenerate the texture.
Test Subject
#280 Old 5th Jul 2011 at 3:30 PM
Thanks Simsample and Hotroxy777 for your help I managed to open the file in S3PE now and followed the steps on importing and exporting and saving as a new .world file. However when I try to open this file in CAW, it tell me firstly that it can't open the file:
Unable to load file. Attempted to read or write protected memory. This is often an indication that other memory is corrupt

and then crashes.

I'm only in the testing stages, testing this out with Twinbrooks and Bridgeport, but if I eventually manage to get it to work, I would love to edit some things in my own Sunset Valley, the one I've been building in for months now. Can anyone tell me where I find the .world file for the world I've already been working with in game? (If that's even possible haha)
retired moderator
#281 Old 5th Jul 2011 at 3:42 PM
That's the error hotroxy777 and myself were finding earlier (post #270 onwards). If you are using my new method, try using the old method (post #1). Otherwise you could try removing the sims from the worlds, which will probably prevent the memory error.

For your Sunset Valley, all of the changes are in the Save file, as opposed to the world. You can save any lots to the library to import them to EIG to include in your new version of Sunset, but any changes you made with the in-game world editor cannot be transferred to CAW. You'll have to do them again, in CAW.
Test Subject
#282 Old 5th Jul 2011 at 3:54 PM
that is a known issue and is mentioned elsewhere

Yes, it was mentionded, inter alia, by me and this is a piece of cake, but a few days before I've seen problems with names and relationschips. So I decided to show them all.

About fire station. Actually this thing is still green in exported world as well as the rest of Ambitions buildings. Eventually I can just delete them and put them back when I start a new game. Just though this issue could be connected to some CAW problems with Ambitions.

The only really problematic thing is corrupted names and cleaned relationship.
As I said in Sunset Valley they are all right, but not in Bridgeport. A bit strange.

I'll look at those XML files and topic you have mentiond.
retired moderator
#283 Old 5th Jul 2011 at 3:57 PM
So do you mean that the problem with the names and relationships has only just occurred in a save you have been playing for a while?
Test Subject
#284 Old 5th Jul 2011 at 4:16 PM
No. The problem has occured in a copy of Bridgeport world created in CAW and exported to game. Created, exported and opened as a New Game several times. The same effect.
retired moderator
#285 Old 5th Jul 2011 at 9:44 PM
Just so that I'm clear, the sims are the original Bridgeport sims and not sims you've added since? If so then again I would assume it's to do with the xml import- we don't really understand much about how the population imports work in the EA worlds, and Bridgeport is more complex than Sunset (with occults and register NPCs).

For the ambitions lots, perhaps try the 1.19 game update with the 1.11.4 CAW version, you can download that here:
Test Subject
#286 Old 5th Jul 2011 at 11:01 PM
You're probably right, but now I have to get that XML file. I can do it using command worldbuilderoutput, right? Unfortunately, I've got v1.18.9 and neither debug console enabler nor awsomemod works.
It seems I have to upload to 1.22. Hope CAW 1.11.4 will work.
#287 Old 6th Jul 2011 at 11:18 AM
Argh, seems I have to go over this thread in a non-busy hour or two. Right now, my ambitions to make the WA destinations playable are thwarted by CAW's "world export failed!" message. But at least I got everything else working which is good. :D
Test Subject
#288 Old 6th Jul 2011 at 2:22 PM
Another Update : using method forum post #266 I've successfully extracted files, saved and exported Egypt.world which is playable now with no issues.
#289 Old 6th Jul 2011 at 3:16 PM
Ohhh that's interesting! I'm going to try that tonight. Did you manage to export Egypt from CAW without incidents or is there something a noob like me should know/keep in mind to get it to work?

Thanks a bunch!
Test Subject
#290 Old 6th Jul 2011 at 5:36 PM
Hi @Rockerduck.

so I've done this like that:

Create a blank test world in CAW- size large, height 300. Call it Test.world.

Go to Documents\ Electronic Arts\ The Sims 3 Create A World Tool\ UserToolData\ Worlds and copy the Test folder to your desktop. Open Documents\ Electronic Arts\ The Sims 3 Create A World Tool\ UserToolData\ Worlds\ Test.world in S3Pe, and find resources UNK 0x0477BD6A and UNK 0x0498DA7E. Right click those, export to file and choose your desktop.

Now you have three files on your desktop, Test folder and the UNK 0x0477BD6A and UNK 0x0498DA7E resources.

Find your packed world file, for example Bridgeport.World. Copy it to your desktop. Now, rename the Test folder to the same name as your world, for example Bridgeport. (Don't put the .world but there, just the name).

Now, open your packed world file, for example Bridgeport.World, in S3Pe. Resource> Import> From file and select your two exported resources, UNK 0x0477BD6A and UNK 0x0498DA7E, from your desktop. Tick the 'overwrite' and 'compress' boxes in the import dialogue box.

... also in this step I've deleted UNKN 0x296A6258 and WPID 0xF609FD60 Resources.

File> Save your world in S3Pe.

Discard the UNK 0x0477BD6A and UNK 0x0498DA7E files from your desktop, we don't need them any more. Also delete the Test.World file from Documents\ Electronic Arts\ The Sims 3 Create A World Tool\ UserToolData\ Worlds.

Put your world file and your world folder, for example Bridgeport.World and Bridgeport folder, into Documents\ Electronic Arts\ The Sims 3 Create A World Tool\ UserToolData\ Worlds.

Open CAW, and see if your world will now open.

I took all these steps using @simsample's method described above (with one exception I've been working with Egypt.world). :D

Now is the next steps I've took:

Save as (in CAW giving a new specific Name) and exit the CAW.

Make sure you've Game and CAW cache are cleared ( I actually do this every single time )

Open CAW go to File-> Open your world again (the new named one) go to EIG,
in EIG mode select edit town option and save it. Exit the CAW and Clear the cache in game and CAW.

Open CAW go to File-> Open your world again, go to 'global layers' and give the new (yes I know again :D) name, description and the thumbnail picture to your world and save it. Exit the CAW.

Open CAW go to File-> and select the export world (I've set the Polish language for my game and CAW so the translation could be not clear enough but I'm pretty sure you understand) option.

I know I do a lot of saving, closing and opening things in here but since I have no issues with it. I'll stick with that.
Also try never interrupt the computer while it extracting, saving, or exporting the files.
#291 Old 6th Jul 2011 at 6:11 PM Last edited by Rockerduck : 6th Jul 2011 at 8:09 PM.
*nods* Thank you, I'll try that! :D

Edit1: Works like a charm so far. I totally owe you a hug or three! Now, let's see if I manage to export it this time ...

Have you tried the reverse, btw? Replacing Egypt.world, France.world or China.world with say, Bridgeport? This game needs more travel destinations.

Edit2: Yaaaay, it's playable! No Sims as of yet but I admit I took the short route and skipped the EIG part. *grins* Thanks so so much! :D
Test Subject
#292 Old 6th Jul 2011 at 8:40 PM
So far i haven't try to swap playable worlds for the vacation ones.

Good to know that there is a shortcut available

Thanks for that info I'll try to skip that part too, but sometimes in worlds like Brigeport for example you need to get rid of all sims in EIG (using awesomemod) and save it (this was advised in the original post and by @simsample)
but I was successfull to save the Bridgeport and Twinbrook with all population of Sims.

so it seems to be working in many other ways
#293 Old 7th Jul 2011 at 5:07 AM
It may or may not be because it's a vacation world. All residential lots are set to "townies only" or "ownable" by default, which is unlikely to work with non-vacation worlds. I suspect everyone got evicted because their lots were townies only and they're no longer townies but residents in a base world. :D
retired moderator
#294 Old 7th Jul 2011 at 2:49 PM Last edited by whiterider : 25th Apr 2013 at 10:41 PM. Reason: Fixing link. :)
Inkantator, the xml file is contained as a resource in the world itself, open any of the EA worlds to see.

hotroxy777 and Rockerduck- great research! Thanks especially for your step by step, hotroxy777.

I've collected what we know into a new thread, to make things easier to find now that we know more. So could you all please continue in that thread, the same as here- posting your findings and questions:

We will keep this thread in case I missed something, if you spot something that should be posted in the new thread please let me know!
Locked thread
Page 12 of 12
Back to top