Replies: 1 (Who?), Viewed: 130 times.
Test Subject
Original Poster
#1 Old 12th May 2021 at 5:18 PM
Default First time trying to make alpha hair using Blender, the hair looks glitched ingame
Oke so I've been all over reddit and a few other places looking for help with this but I can't seem to find a solution, someone sent me here to ask for help

Basically, I am super new to Blender, and I made my first attempt at an alpha hair, the model looks kinda bad cause its my first. I have no experience and there are almost no resources to learn and I only got this far because I followed a few tutorials I found on YouTube.

In Blender and in Sims4Studio, it honestly looks fine, I believe, but in game it seems to have chunks of skin color showing underneath the hair texture, so it's not transparent. All other CC hairs look fine and I have laptop mode off because I know that causes issues with alpha hairs.

Here are some screenshots.

In Game:
https://ibb.co/n0Xc4QR

Blender:
https://ibb.co/S7w72N8

S4S:
https://ibb.co/RbFJZh2

If needed, I'll post the Blender file or the package so it can be diagnosed, just lemme know. I've asked so many different subreddits and looked all over for help, this is literally my last solution :c
Advertisement
Ms. Byte
#2 Old 13th May 2021 at 2:52 PM
Quote:
Originally Posted by snowwyleopard
Oke so I've been all over reddit and a few other places looking for help with this but I can't seem to find a solution, someone sent me here to ask for help

Basically, I am super new to Blender, and I made my first attempt at an alpha hair, the model looks kinda bad cause its my first. I have no experience and there are almost no resources to learn and I only got this far because I followed a few tutorials I found on YouTube.

In Blender and in Sims4Studio, it honestly looks fine, I believe, but in game it seems to have chunks of skin color showing underneath the hair texture, so it's not transparent. All other CC hairs look fine and I have laptop mode off because I know that causes issues with alpha hairs.

Here are some screenshots.

In Game:
https://ibb.co/n0Xc4QR

Blender:
https://ibb.co/S7w72N8

S4S:
https://ibb.co/RbFJZh2

If needed, I'll post the Blender file or the package so it can be diagnosed, just lemme know. I've asked so many different subreddits and looked all over for help, this is literally my last solution :c


You need to set the mesh shader to SimGlass for all meshes to enable transparency in game. I've attached pics for CAS Tools and S4S showing where the setting is.
Screenshots

Please do not PM me with mod, tutorial, or general modding questions or problems; post them in the thread for the mod or tutorial or post them in the appropriate forum.

Visit my blogs for other Sims content:
Online Sims - general mods for Sims 3
Offline Sims - adult mods for Sims 3 and Sims 4
Back to top