Replies: 681 (Who?), Viewed: 353214 times.
Page 26 of 28
Lab Assistant
#626 Old 23rd Mar 2013 at 3:41 AM
I couldn’t help but notice that when I opened my game up today, my Neighborhoods files had all completely disappeared. I have DDE, The Best of Business Collection, and recently, Pets. When I open the game, I don’t even have a new Pleasantview/Strangetown/etc, just the New Neighborhood button. Now, when I open up SimPE though, it locates all the files as if nothing has happened and opens them near perfectly; when I save a copy of the SimPE neighborhood back into the Neighborhood file, however, the subhoods associated with the neighborhood aren’t following, which I’m not sure is intended or a system problem. The main hood then appears in-game, though the terrain file thumbnail does not. The main hood loads and seems to play properly, but the subhood and all the families/businesses I had in Bluewater Village are nowhere to be found. The game also re-created the Pets invisible neighborhood, leaving duplicated copies of the Crittur and Roseland families.

I hadn’t touched my game in a few days, since I was messing around with my TS3 families on a different computer. I had not made any changes to the system with TS2 installed, but had downloaded about ten hairs and a default replacement skintone, all local. And as far as I can tell, the last time I played the game saved flawlessly; the SimPE version opens and plays right from where I left it.
Site Helper
#627 Old 23rd Mar 2013 at 3:56 AM
Do you have a recent backup? If so, you might want to consider restoring from your backup. If not, where did you get the neighborhood package which you copied over your existing neighborhood package?
Lab Assistant
#628 Old 23rd Mar 2013 at 4:12 AM Last edited by Spamaccount : 23rd Mar 2013 at 4:25 AM.
The only honest back-up I have is about a month or so old. To be honest, I'm not really sure where the new package came from! I think it has something to do with me opening the EA Games/ The Sims 2/ Storytelling folder and copying a Neighborhood file from there, moving it up a level. Then, when I opened SimPE, the neighborhoods with all the data was present. I'm not sure if that data appeared because I moved the files in Storytelling or not since I hadn't tried SimPE before that. After opening SimPE, I just Saved As...'d and that became the file I tried to run. (Interestingly, when I remove the file that I created using SimPE, the neighborhood still showed up when the game opened, but as the Pets subhood with the Family Bin of the former file. Edit: Actually, just by exiting and re-entering, now when I load the game it's back to not seeing anything)
Test Subject
#629 Old 6th May 2013 at 5:04 PM
I'm glad too see that i'm not the only one this happen too only
I still don't understand what to do to fix the problem--

I had just finished playing a household, I saved the lot and exited to the neighborhood screen. The program stopped responding and the neighborhood screen never loaded. I had to use the task manager to shut down the game (I waited 15 minutes before doing this). That was 3 hours ago. I just started the game and the Neighborhood was missing.

I've tried re-installing my games but I can't install anything after the original sims2 it keeps saying "Can't Copy to disk" or something like that pops up and un-install whatever expansion/stuff I tried to download >< Will I have to buy a new disk or something?
Any help is appreciated! T_T
Site Helper
#630 Old 6th May 2013 at 5:44 PM Last edited by Mootilda : 6th May 2013 at 5:55 PM.
Originally Posted by MissKayasha
I still don't understand what to do to fix the problem--
That's because we don't know how to fix the problem. We don't even understand why it happens, in general. We started the thread to try to gather enough information to find a pattern to this problem, but there doesn't seem to be a pattern.

Instead, individual people have individual problems and some of those problems cannot be solved.

In general, the best solution is to restore from a recent backup, if you have one.

It sounds like you may have several completely different issues:
1) Your CD / DVD may be bad. You could try cleaning your disk. Here's how:

2) Your neighborhood may have become corrupted when you were forced to shut down the game. If you don't have a current backup, there's not much that can be done. We can confirm whether or not your neighborhood is corrupt. We can help you to recreate your neighborhood from scratch.
Lab Assistant
#631 Old 2nd Jun 2013 at 12:47 PM
Hi there, I have the exact same problem now.

I wanted to restore an old backup of Veronaville (N003) I played with a German installation of Sims 2 with all main EPs installed.

Now I have an English installation with all main EPs, restoring it doesn't seem to work!
I moved* the default N003 directory out of the Neighborhood folder, moved my backed up N003 into there - and Veronaville was completely gone in the main menu.

I'm not sure if the language is the problem, but that's the only thing which has changed since the last installment of the game. The German debug menues are messed up which is why I didn't install it in German again.

*I found out that renaming the default neighborhood folder to something like N003_old will mess up, the game probably just checks the first letters of the folder and if they match it will take that folder or even none. I always had to move the N003 folder out of the Neighborhood directory to get my backup work (previously!).
Site Helper
#632 Old 2nd Jun 2013 at 2:16 PM
When you say that you have all main EPs installed, do you have the Store Edition? Did you have the Store Edition on your old computer? If either of those is true, you may not have the correct version of the Store Edition and that would explain why your game is unable to open the neighborhood.

I believe that a German neighborhood will still open with an English game. I've certainly downloaded neighborhoods which were created in a different language and was able to play them, although I couldn't tell you which languages they were made in.

The neighborhood folder name "N003_old" is valid but odd. If you rename the folder, the game will not be able to recognize the neighborhood unless you rename every file within that folder and all subfolders. There are various programs which will help you to rename a large number of files. Here's a post that may help:
Lab Assistant
#633 Old 2nd Jun 2013 at 3:00 PM
Thanks for the response, I "fixed" it by replacing the whole EA Games folder which I had stored... yeah, the language isn't a problem, even though many NPC names are now renamed, but that's ok since the German ones are dull and boring anyways.

(However a business lot was missing, similar to last time when I was restoring my backups, when a residential lot was missing, you helped me there one year ago on SimPE I could restore it already but it's not connected to the business' owner anymore, couldn't link it correctly together in SimPE, but well at least the building is back)
Lab Assistant
14th Jun 2013 at 9:55 AM
This message has been deleted by Sirrah.
Test Subject
#634 Old 19th Jul 2013 at 1:19 PM
Excuse me if you do not belong here I do not know much English and translated with Google translator.For me it's hard to dig through forum

In Sims 2 Nightlife When pollination neighbor and grow abdomen or it's time for birth gives me error. What to do. Neighbor I want to give birth outside marriage child
Test Subject
#635 Old 25th Jul 2013 at 10:51 PM
A few months ago, I installed Sims 2 Double Deluxe edition on my laptop along with the following expansion packs: Family Fun (however, the files did not show up in the system and would not uninstall so I had to delete it but then it came back when I re-installed Sims 2 DD WITHOUT the fun pack), Seasons, Freetime, Open for Business, and Apartment Life. Then, a few days ago, my neighborhoods had mysteriously vanished. ALL of them. And I couldn't create a new neighborhood either, because I didn't have any neighborhood templates. I tried uninstalling and reinstalling a few times. Right now, I only have Sims 2 Double Deluxe installed (plus Sims 2 Download edition, Nightlife, and Celebrations Stuff), no patches. I still can't load any neighborhoods. I get a blank error message right before starting the game. Clicking yes results in the game starting up, but still no neighborhoods. Clicking no cancels the loading.

The neighborhood files are still there but the neighborhoods themselves don't show up when I load the game.

No SimPE.

Additional info:
Operating system: Windows 8
Computer specs: 6.00 GB RAM, 64-bit operating system
Windows updates: I remember Norton asking about some kind of web program, and I had it cleaned out before I started the game up. I don't know if that's relevant or not, but I'm including it just in case it is.
Lab Assistant
#636 Old 28th Jul 2013 at 10:14 PM
Operating system: XP Home edition SP3

Computer specs: 2.0GHZ Intel Celeron; 3.25 Gb RAM; Nvdia GeForce 7300

Games: Base; Nightlife; Pets; Apartment Life; Ikea stuff; M&G stuff; Celebration stuff (not sure about patches at this point)

Details of Neighborhood loss: I recently lost everything on my hard drive, but luckily enough was able to restore some of the things. I re-installed my game before adding my folders (the My Documents/EA games folder.) I ran the game once, to make sure it ran alright before adding the folders. Most of the neighborhoods work alright, although there are some people missing from some the neighborhoods.
Belladonna Cove doesn't have any of the changes I made to it; Strangetown, Veronaville and Pleasantview have some of the changes I made, but missing some people. My custom neighborhood, Tide Springs, won't get past the loading screen. It runs the blue flashing bars at the top, but after that nothing happens.

Neighbourhood File details: My neighborhood files are still there, downtowns included.

If there's anything else that might help in the aid of investigation this problem, please let me know.
Field Researcher
#637 Old 16th Sep 2013 at 12:22 AM
Hi, it had been a while since I played and I loaded up my game again to see that one of my custom hoods was gone. I looked at files in SimPE too and couldn't find Fairy Island. Because it's been so long, I couldn't really say what may have caused it. I am unable to find hide nor hair of it...

I am happy to hear any ideas for my Storybook expansion project, as well as open to others helping.
Also, check out my object recoloring tutorial.
Test Subject
#638 Old 4th Dec 2013 at 7:55 PM
Operating system: Windows 7

Computer specs: Don't know but I know it fits the Sims 2 installation criteria.

Games: Sims 2 Double Deluxe(Original, Nightlife and Celebration), no patch

Details of Neighbourhood loss: I lost Veronaville, Pleasantview and Strangetown. I uninstalled the game a long time ago and took a break and just recently re-installed it, only to find several problems. It used to work perfectly earlier. I have not removed my Downloads folder. The only hack I used is "motherlode."

Neighbourhood File details: I have all my neighbourhood files in my docs and the c drive. I even replaced by my docs neighbourhood files with the ones from the drive to reset but it did not work .

Sim PE Investigation: ?

What changed on your system immediately before the corruption: There is no corruption or change. I simply uninstalled, and then re-installed several months later.

Any other relevant information: When I first re-installed the game, I got the error of "running the wrong version" but I fixed it. However, when the screen loaded, there was no neighbourhoods and I couldn't even make a custom neighbourhood. I already tried resetting neighbourhoods by copying and pasting. I sincerely do not know what is wrong with my game. There are no scratches on my CD, no installation errors. Just this. Also I did not create back-up since I didn't really make anything in the game.

Could you also try this: Already done and did not work.
Site Helper
#639 Old 4th Dec 2013 at 9:39 PM Last edited by Mootilda : 4th Dec 2013 at 10:38 PM.
What happens if you just move the entire Documents\EA Games\The Sims 2 folder to your desktop? Can you see and play the shipped neighborhoods?

Is it possible that you used to have the Store Edition installed? Neighborhoods will require that exact same version of the Store Edition (or later). Unfortunately, the Store Edition is no longer available free from EA.

You can check whether your neighborhoods require the Store Edition by opening one of the neighborhood packages in SimPE and looking for the VERS record. The plugin view will show you the game engine in plain text.

If you don't have SimPE, the Clean Installer will show you the game engine for your lots. Just Browse to your neighborhoods Lots folder and select any lot (or check a couple, since the engine will reflect the last time that a lot was modified). The game engine version is displayed on the bottom left of the window.
Doing all the things, and *mostly* not failing.
retired moderator
#640 Old 17th Dec 2013 at 3:34 AM Last edited by Phaenoh : 18th Dec 2013 at 1:25 AM.
7 64bit, Intel i7-3770 Processor CPU @ 3.4GHz, 8 GB RAM, NVidia GeForce GT 640
All EPs and SPs and all patches, installed from disks, playing with NoCDs

I've been losing Pleasantview lately. Fortunately, I have backups, but playing anymore is one step forward and three steps back. I've discovered that Mootilda's Neighborhood Checker will let me know if my hood is gone before I have to load the game, so I can put in the most recent backup, but it's really starting to bug me! As far as I know, the only neighborhood hack I have is Paladin's checkbook, but that has been sitting dormant in my game for years, and I'm not sure I've actually ever used it.

My files are all still there, but the neighborhood.package gets corrupted, so I have to replace that one. It is the only file that has a .bkp as well as a .bak. I have no idea where the .bkp came from, and removing it didn't help. When I load the corrupted file in SimPE, everything is listed as being 'unknown'. Loading a non corrupted backup is fine and perfectly editable.

The only thing I've been doing with my comp lately is light interneting, but most recently in my sim world, I've been having a bit of trouble getting my AnyGames to behave. Sometimes they like to disappear and mess with whether or not my real game will load, but a quick reinstall of the icons fixes that issue immediately. I have a lot of untested CC, but I just did a test of taking all that out (not my tried and true CC that has been ok for years, just the new things) and that didn't help. A while ago I combined my existing Pleasantview with a played Belladonna Cove, and that mostly well, somehow I lost Marcus Baldwin in the mix. He is still listed with his family, but when I go to load them, he isn't on the lot and Inge's Cat summoner can't get him to show up. I went through and deleted out a lot of strays, perhaps I deleted his character file by accident. Most recently I used Mootilda's Hood Checker to try to 'fix' whatever it does. Maybe that had something to do with this?

Two interesting things that happen when I put the backups in after a corruption happens, all Buy and Build changes from the corrupted hood somehow find themselves in the backup. I'm guessing this is because I replace the neighborhood.package file without reverting to the old lot file. Secondly, if anyone aged up in the corrupted file they have the body of their new age but still act like their previous age. It's the cutest thing ever to see kids crawling and their parents carrying them. That sounds like another disjointure from having an older neighborhood file and a newer character file. This is easily fixed with the boolprop Sim Modder to age up then back down.

I've attached the latest corruption and the most recent working back up. Let me know if you need further files, like the lots or characters for any of the families. This evening I was trying to play my LeCroix family (Brandi Broke's family), but I first started seeing this issue with the Calientes' (Nina and her kids Dawn and Nico) and the Bachels' (Dina nee Caliente, Michael Bachel(or) and their daughter Josie. I was finally able to play through them and recombine their households so the corruption is a sometimes thing, but I just don't know what's triggering it. Poor Nico had to be born 3 times!

Dunno why the working one won't attach, here's a link

Edit: further testing reveals it is most certainly NOT my CC. I did a full yank of it all and still can't get a good save 100% of the time. I really don't want to lose this hood, I've had them since game launch!
Download - please read all instructions before downloading any files!
File Type: rar N001_Neighborhood-BROKEN.rar (1.54 MB, 12 downloads) - View custom content
Test Subject
#641 Old 11th Jan 2014 at 10:12 PM
Can someone help me? right so i have freetime, seasons , pets and nightlife installed, we have never had any crashes or problems and the game runs smoothly, however when my sister went on it in the morning at about 8am she went on it untill 10pm without closing it and she said it crashed. It didn't come up with an error it just went off, then she reloaded it and veronaville was gone we got upset because we worked hard on antoino monty's family because he had died of old age and benedick was an elder. They have loads of memories and have achived so much i wish to get them back please help thanks.
Site Helper
#642 Old 12th Jan 2014 at 12:02 AM Last edited by Mootilda : 12th Jan 2014 at 12:24 AM.
thesims267284: Unfortunately, there isn't much that we can do to help. If you have a recent backup, then my suggestion is to restore from that backup. If you don't have a recent backup, we may be able to help you to recreate your neighborhood from scratch, salvaging some of your lots and possibly some of your sim's appearances.

Phaenoh, sorry that I didn't see this until just now. Your "broken" neighborhood is in really bad shape. SimPE can't even find the normal records inside of the neighborhood package, but instead finds tons of records which are unrecognized. That means that the internal structure of the file (possibly the index) is being destroyed, which means that there's no likelihood of salvaging anything from that package.

Note that even your "working" copy has some very odd record types, which implies that the corruption of the file has already begun. One record of concern is "--- User Defined --- (---)".

It's hard to imagine why this happened. However, once the internal structure of the file is compromised, it's not surprising that the corruption would spread as the file is overwritten each time that you play. Have you checked the integrity of your hard drive? Do you always save and quit in separate steps?

In general, you should backup the entire neighborhood folder and not just the neighborhood package. The neighborhood folder works as a unit and mismatches between the neighborhood package and the user packages can cause problems.
Doing all the things, and *mostly* not failing.
retired moderator
#643 Old 12th Jan 2014 at 2:19 AM
Yeah, I figured it was toast not long after I posted. That hood is just so old and I did so many questionable things before I knew better. Happily though, I've moved everyone to a new neighborhood (the safe ways) and I'm almost back in good shape.

Would you mind taking a look at their new hood, you seem to know things to look for that I don't even know about. To move them, I stuff everyone into 1 lot and exported that, then put them in a temp hood to clean everything up, then moved them to the hood I have attached.

I didn't know about the save and quit bit, but I think I do just cuz I'm too paranoid not to make sure it saves. I'll remember for the future now though.
Download - please read all instructions before downloading any files!
File Type: rar I002_Neighborhood.rar (422.9 KB, 11 downloads) - View custom content
Test Subject
#644 Old 12th Jan 2014 at 5:46 PM Last edited by BananaParty : 12th Jan 2014 at 9:34 PM.
Exiting times! I had my custom neighbourhoods and all downloaded items (such as furniture and clothes) disappear yesterday after not playing for quite some time, and I think I have found the solution today, because I got everything back! I'm ecstatic! I shall try to describe everything I tried as I leaving out something might not result in the same result. Hopefully this can also help someone else. But first I'll fill this in:

Operating system: Win 8
Computer specs: I don't know. If anyone thinks it's relevant to my solution, I'll try to find out. Perhaps I should mention it's a laptop?
Games: Sims 2 base game and all Expansion Packs (last being apartment life) and no Stuff packs. Unsure about patches.
Details of Neighbourhood loss: All custom neighbourhoods (specifically N005 and N006) and all downloaded items.
Neighbourhood File details: The folders for N005 and N006 were gone (and the files within them). Neighbourhoodmanager.package and cigen.package were also gone.
What changed on your system immediately before the corruption: Nothing out of what I always do. But I hadn't played the game for at least 2 months, maybe more.
Any other relevant information: The game was acting like I just installed the Sims 2 and all expansion packs, when that's not the case at all.

Could you also try this:

Go to My Documents/ EA Games/ The Sims2/ Neighbourhoods and cut and paste the neighbourhoodManager.package file to your desktop. Now go to Program files/ EA Games/ The Sims2/ TS Data/ Res/ User Data/ Neighbourhoods and copy the neighbourhoodmanager.package file- paste it into your Documents folder where your old neighbourhoodmanager file was. Does that make any difference? I didn't have to do it, it popped up after starting and closing the game a few times and removing the cache files that were there (accessory.cache and groups.cache)

When I started my game yesterday, all my custom neigbourhoods were gone. I tried going into Belladonna cove, and the game acted like I had just installed sims 2 and all of the expasion packs for the first time (showing during loading "creating pets", "creating hobbies" and so on). I turned the game off and discovered that N005 and N006 (all the custom neighbourhoods I have) folders were gone.

The first thing I tried was removing the cache files in The Sims 2 folder, which were for me accessory.cache and groups.cache, because I had heard that they could become outdated (I know very little about computers so wether or not this is true...). Then restarted the computer and game. No changes. Went back to the files: Noticed Neighbourhoodmanager.package had appeared, and the cache-files had came back. Started the game again. No changes.

I pretty much gave up then and prepared to restore with my backup (6 months old ) and thought that I might as well make backups for other files when I was at it. It was then I noticed something strange: In My documents, inside a folder I use for essays I have written, were an EA games folder. And inside I found the Sims 2 folder, cigen.package and the folders for N005 and N006. Hurray! I copied the whole folder (the Sims 2 folder) to the EA games folder (that is in the right place) and pasted (and overwrote every file that had the same name). I turned on the game - and it worked. Everything that went missing are back where it belongs, all the sims, and everything (so far) runs smoothly.

So tl;dr: I removed Groups.cache and Accessory.cache, restarted game, saw the cache-files were back + Neighbourhoodmanager.package had appeared. Found an extra EA games folder in an unexpected place containing the missing files. Copied all The Sims2 files from there to where it should be. Fixed!

I have no idea of how that extra EA games folder was created or when, but it must have been recently, perhaps when I started the game yesterday. I'm 100% sure I didn't do it myself, that's for sure.

I hope this may help others with the same problems. If your neighbourhoods files are missing, maybe they can be found in an unexpected place, in an another EA games folder? Worth a shot, perhaps
Test Subject
#645 Old 9th Mar 2014 at 6:44 AM Last edited by sylph_of_hope55 : 17th Jul 2014 at 7:03 PM.
Operating System: Windows 7 Home Edition, Acer laptop
Computer Specs: 64-bit, Intel R Core i5 CPU, M560 @ 2.67GHz, 4.00 GB RAM
Games: Base game, Sims 2 Deluxe Edition which is a digital download off of Origin, only for starters, but I have all the EP's.
Details: After reinstalling the base game after a couple of years, on the first load there are no neighborhoods installed at all, and the only option available is to create a custom neighborhood, but after clicking on the custom neighborhood there are no other options and it's impossible to go further, so basically the only thing to do is quit.
Neighborhood file details: Going to the My Documents reveals that after installation I'm missing quite a bit of files, the neighborhoods file one of them, and I have no idea what happened to them. In fact, after looking at My Documents, installation doesn't even CREATE an EA folder with the Sims 2 files in it.
SimPE: I don't believe I have SimPE anymore.
What changed about on my system: I changed laptops from a Toshiba to an Acer laptop after moving. I also didn't try adding any custom content because I wanted to make sure the game worked before doing so, but the neighborhoods weren't loading from the first installation on this laptop. They worked perfectly on my previous laptop.
Test Subject
#646 Old 16th Jun 2014 at 11:28 PM
Hey everyone, I know no one has posted here in months, so I hope someone sees this and can help!

The battery port on my laptop doesn't work, so I use it plugged in. It often gets accidentally unplugged and I have to restart my computer. TWICE when this has happened and I have been playing the Sims, I turn my laptop back on and open the Sims back up to see that I have a neighborhood missing. The first time this happened it was Riverside Heights or whatever the Seasons neighborhood is. The second time it was a custom neighborhood I had started and had a lot invested in, called Treeview! The files are all still there in the folder - I can see all the snapshots I took, players I created, etc., but the neighborhood just does not show up as an option to play. I've looked everywhere for an an answer. I don't use any programs at all for customizing - the only custom content I have is stuff from here, but this happened with the Riverside neighborhood long before I even knew you could use custom content. Any help at all would be appreciated!!

Operating system - Mac OSX 10.6.8
Computer Specs - 2.4 GHz Intel Core 2 Duo, 4 GB 667 MHz DDR2 SDRAM
Game - All Mac expansion packs, so the only ones I don't have are AL and FT
Site Helper
#647 Old 17th Jun 2014 at 12:38 AM
If the game crashes because the computer turns off, there's no guarantee that your neighborhoods will survive. Start keeping backups so that the next time that it happens you won't lose everything.
Test Subject
#648 Old 29th Jul 2014 at 1:20 PM Last edited by suelorcha : 31st Jul 2014 at 12:07 AM.
I had all my neighbourhoods disappear and the game loaded up like it had been newly installed. I moved a few files around ( I hardly know what I'm doing, I'm not computer savvy at all), but miraculously got all my hoods back.
My custom content is not showing up in the game, however. It has not gone altogether, though, because I can see the files there when I look in the downloads folder. How can I get it back in the game? I have custom content enabled btw.

Fixed, thanks to the help section and step by step instructions on getting cc into the game
Test Subject
#649 Old 27th Sep 2014 at 3:06 AM
Hello I have the Sims 2 ultimate collection. Where are the saved games stored? My computer had to be wiped due to some issues so i saved the the Sims folder from Documents>EA Games> The Sims 2 Ultimate Collection. When i got my commuter back i re installed the game through origin and then put the folder back. my pictures and videos show up but not my families nor houses. Did i do something wrong? thanks in advance for your help.
Test Subject
#650 Old 1st Nov 2014 at 2:56 PM
Oops, hope this is the right place to post...

Basically, the other night I was playing my custom hood. I didn't do anything substantial, just made them cook a few meals, sleep a few times, the usual. No system changes, updates or CC downloads happened, but when I woke up the next morning the neighbourhood had disappeared. I tried reloading the game, rebooting my computer and moving all the files into a new folder of the same name, but as you can see I still have nothing. I then later noticed that even Pleasantview had vanished for some reason too. I don't really use pleasantview that much anymore so I'll probably just replace that with a fresh one, it's the custom hood I'm most worried about!

Operating System: Windows 7 Ultimate Edition (64 bit)
Computer Specs: 2.13GHz Intel Processor, 3.5 GB RAM, NVIDIA GeForce 8400
Games: All expansion and stuff packs. Unsure about patches but i don't think i have any (unless you count no-cd patches)
Neighbourhood File details: All files are present and appear to be in the same condition as my working neighbourhoods
SimPE investigation: Neighbourhoods turn up, but both listed as Unknown and have no sims in the sim browser.
Other Information: Recently my belladonna cove reset itself to box condition for no reason, unsure if related but does seem similar...

Replacing the neighbourhoodmanager file has made no difference. I'm honestly at my wits end of what to do here. Thankyou for you time!
Test Subject
4th Dec 2014 at 5:18 PM
This message has been deleted by lowannn.
Page 26 of 28
Back to top