Replies: 7 (Who?), Viewed: 826 times.
Lab Assistant
Original Poster
#1 Old 8th Nov 2020 at 5:53 PM
Default Milkshape crashes when I check draw vertices with bone colours
I had deleted the same thread before since Vulrien sims had already answered my question but I'm wondering if anyone can tell me where I could've accidentally imported 2 skeletons while converting? I'm really confused as I'm a beginner. I'm following Vulrien sims's 4t2 clothing tutorial.
Mad Poster
#2 Old 8th Nov 2020 at 6:23 PM Last edited by simmer22 : 9th Nov 2020 at 3:14 PM.
I've never come across this happening for that tick box, not even with two skeletons.

The two skeletons issue is easy to fix if you have it - export the mesh you want to fix as Unimesh, reset Milkshape to a new file, then import a mesh of the same type you want to fix so you have a clean skeleton (same age/gender, top or body or pants), import the mesh you want to fix, and if you get the question about skeletons click no (you might not get it - it was partly removed with a newer version of the plugins and shouldn't appear with toddler and above).

It could be you have another skeleton in there, like parts of the TS4 skeleton or some such. Could also be the mesh has too many vertices if it's high-poly?
Lab Assistant
Original Poster
#3 Old 9th Nov 2020 at 8:02 AM Last edited by ClaudetteCorleone : 9th Nov 2020 at 1:56 PM.
@simmer22, thanks for clearing things up about skeleton fix I was confused when there was no pop up, I had also asked him about it.

Polycount is 4696, is that high? Though I'll probably redo the whole process as I am unsure, but I've got a question regarding the tutorial. During step 11 - does it mean I should delete all body parts completely even the unseen parts? Speaking of the TS4 skeleton being in there, is it because I didn't delete everything?
Mad Poster
#4 Old 9th Nov 2020 at 3:17 PM
4696 is not high. I was thinking more like 30.000 +++
(Milkshape has a limit at around double that for CAS meshes, I think - not entirely sure, as I don't usually work with high-poly CAS meshes, but some simmers have reported crashes with hair conversions)

If you still get crashing when ticking the box, can you upload the file? There are a few things I'm thinking it could be but it's easier to check first and explain after (so I don't have to explain ten different things, I mean). It's always easier to do problemsolving with the actual file.
Lab Assistant
Original Poster
#5 Old 9th Nov 2020 at 3:24 PM Last edited by ClaudetteCorleone : 10th Nov 2020 at 10:45 AM.
Sure, but to let you know I did stop at step 11 due to redoing the process. I probably should've kept it my bad. I'll upload the file once I get the issue again.

(Edit) Here it is:
Download - please read all instructions before downloading any files!
File Type: zip (127.1 KB, 2 downloads)
Mad Poster
#6 Old 9th Nov 2020 at 7:32 PM Last edited by simmer22 : 9th Nov 2020 at 7:49 PM.
I get the issue with your file, too, so there's definitely something going on.

I think the reason for the error could be is that the mesh doesn't seem to be assigned (although it's still a bit weird because I haven't seen it happen before even with an unassigned mesh). I tested by turning on animation mode, and the mesh isn't moving along with the skeleton, which it should if it was assigned. My guess is that something has gone wrong in the assigning process.

I can't see an extra skeleton in there, so that's good.

There's a few other bugs while I'm at it - I get the "huge joints" issue with your file so I assume you could potentially have some issues with that, but it's easily fixed in Preferences if you happen to get it (visible if you turn the skeleton on)
(file --> Preferences --> Misc --> Joint size --> 0.010000 --> OK --> Click all 4 windows to reset if it doesn't on its own).

And comments are lacking. When the mesh is working again, they need to be set as such:
ModelName: body (body2 for the other group)
Opacity: -1
NumSkinWgts: 3
Lab Assistant
Original Poster
#7 Old 10th Nov 2020 at 4:55 AM Last edited by ClaudetteCorleone : 10th Nov 2020 at 4:43 PM.
Inputting the comments did the trick. Though the shoe mesh is not included any clue why? I regroup it with the Unimesh. How do you extract and add a shoe mesh? I probably did something wrong when doing so as I don't know how to...

(Edit) Nevermind I figured it out, I can't thank you enough for clearing things up! , simmer22.

Originally Posted by simmer22
Make sure the legs also have bone assignments. If they're grey when "bone colors" is ticked, they don't have weights.

I had fixed it earlier, thanks for the info!
Mad Poster
#8 Old 10th Nov 2020 at 3:19 PM
Make sure the legs also have bone assignments. If they're grey when "bone colors" is ticked, they don't have weights.
Back to top