Replies: 127 (Who?), Viewed: 123553 times.
Page 1 of 6
Test Subject
Original Poster
#1 Old 16th Aug 2005 at 8:50 PM Last edited by simsample : 10th Nov 2006 at 8:39 PM.
Default Tutorial: Converting Videos for Sim TV Viewing
How to Convert Videos for Sim TV Viewing for Dummies

In this new tutorial we will be showing you how to convert your videos to import them into the game. This tutorial assumes the original video format is AVI, so if you have a WMV or RM file, please google for a separate tutorial to convert from that format to AVI.

In this tutorial there is only one program that will be needed:
VirtualDub


===================
First thing you will need to do is open VirtualDub. once open you will be greeted with a screen like this one:


and just like any other program, locate and open your video file:


once opened, go to the video menu and select filters:


you will now be greeted with this window:


Click add, find the resize filter and click ok:


you will be greeted with this window. fill it out exactly as shown here then click ok and ok again:


you should now be back to the main virtualdub screen. go back to the video menu and select Frame Rate this time:


you will be greeted with this window. fill it out exactly as shown and click ok:


you should now be back to the main virtualdub screen. go back to the video menu and now select compression:


you will be greeted with this window. once again, fill it exactly as shown and click ok:



now to do the audio.


click the audio menu and select Full Processing Mode. this will not bring up a window:


go back to the audio menu and select compression:


you will be greeted with this window. fill it out as follows:


thats it!


nope. hold on one sec. still got one last step you cheeky bugger now we have to save it.

go to the file menu and do save AVI:


you will be greeted with a standard save window. just save it anywhere (or into a sims 2 video folder to go directly to the game). once you hit ok, you will be greeted with this window where it will now be encoding the video:


depending on the speed of your system, the length of the video, size, etc. it may take a while to encode. but your patience will soon be rewarded.
Advertisement
Test Subject
#2 Old 16th Aug 2005 at 9:18 PM
Thanks =D
Test Subject
#3 Old 16th Aug 2005 at 10:00 PM
dude thnx again
Test Subject
#4 Old 16th Aug 2005 at 10:09 PM
Nice tutorial. A Great alternative to using some costly tool.
Test Subject
#5 Old 17th Aug 2005 at 12:03 AM
hey i just realized that this program doesnt just resize avi's it also converts other files such as mpg's to avi's, but wmv doesnt work
Banned
#6 Old 17th Aug 2005 at 12:04 AM
Yes, licensing means that wmv isn't supported.

Virtualdub is very versatile and can convert certain filetypes though
Test Subject
#7 Old 26th Aug 2005 at 6:12 AM
Default Tv Help
Hi everyone.
I was wondering if anyone could help me. I am trying to make music videos for the TV. I seemed to have got it right and the videos are working fine on the sims 2 tvs. only one problem.. the audio.

It seems to start for just a second, and then it loops, like a really bad CD skip. The video continues, but the sound just keeps looping like a bad cd. I was wondering, any of you out there who make custom tv stuff, can you help me with this? is there particular audio settings needed to be used? or something, I am really stuck any help would be so appreciated.
Thank you
Vicky
[email protected]
Test Subject
#8 Old 26th Aug 2005 at 6:33 AM Last edited by coffeehedake : 26th Aug 2005 at 6:35 AM.
Try to stick with MPEG Layer-3 (MP3) for the compression, I believe Vchat was recommending 56kBit 22050Hz Stereo. (Believe that's what I used for all of my Thundercats episodes ) Also, make sure you have the mode set to 'full processing mode' for the audio compression, not 'direct stream copy.' This will allow you to access the compression options instead of copy the audio directly out of your source material.

As far as why it's skipping... could be a error in your source material's audio track which would cause funky things to happen when the AVI is being re-encoded.

Just a thought, though.

-Coffee
Test Subject
#9 Old 26th Aug 2005 at 6:34 AM
Default still no work
I tried this tutorial as well, the same thing though, the audio just didnt want to progress.

It didnt have the option of 56kBit/s, 22.050 Hz stereo. Unless i clicked on 'show all formats' and it had it there, only it didnt save when i tried it.

So I chose
56Bit/s 24,000.
still the audio didnt work. I really dont know what else I can do.
Test Subject
#10 Old 26th Aug 2005 at 6:37 AM Last edited by coffeehedake : 26th Aug 2005 at 6:39 AM.
You may have a mono audio track.

If you open the audio conversion options, you can copy the mono tack into both channels (making fake stereo) and also allowing you to use the 22.050Hz Stereo option in your compression window.

Should be in audio->conversion (or CTRL+N) on the bottom right of the audio conversion window is the "channels" options, if it says "No Change (mono)" you have a mono track, just tick the stereo option there, and try to open up your audio compression options again.

-Coffee
Test Subject
#11 Old 26th Aug 2005 at 6:38 AM
Quote:
Originally Posted by coffeehedake
Try to stick with MPEG Layer-3 (MP3) for the compression, I believe Vchat was recommending 56kBit 22050Hz Stereo. (Believe that's what I used for all of my Thundercats episodes ) Also, make sure you have the mode set to 'full processing mode' for the audio compression, not 'direct stream copy.' This will allow you to access the compression options instead of copy the audio directly out of your source material.

As far as why it's skipping... could be a error in your source material's audio track which would cause funky things to happen when the AVI is being re-encoded.

Just a thought, though.

-Coffee


Hi there,
thank you for the reply. I tried a few different files and they all do the same thing. I wonder if there is program that converts layers? ill keep on trying though
Test Subject
#12 Old 26th Aug 2005 at 6:41 AM
LOL... Sorry I keep editing my post while you are writing a new one... oi!

Any luck as far as the channel conversions within VirtualDub?
Test Subject
#13 Old 26th Aug 2005 at 6:42 AM
Quote:
Originally Posted by coffeehedake
You may have a mono audio track.

If you open the audio conversion options, you can copy the mono tack into both channels (making fake stereo) and also allowing you to use the 22.050Hz Stereo option in your compression window.

Should be in audio->conversion (or CTRL+N) on the bottom right of the audio conversion window is the "channels" options, if it says "No Change (mono)" you have a mono track, just tick the stereo option there, and try to open up your audio compression options again.

-Coffee

The audio conversion is disabled for some reason so i cant select it.
Test Subject
#14 Old 26th Aug 2005 at 6:44 AM
Quote:
Originally Posted by coffeehedake
LOL... Sorry I keep editing my post while you are writing a new one... oi!

Any luck as far as the channel conversions within VirtualDub?


its got 'no change stereo' on. So i guess its not mono. hmm
Test Subject
#15 Old 26th Aug 2005 at 6:44 AM
Do you have the audio set to 'full processing mode' ? If not, all of those other options, like conversion, etc, would be greyed out... Otherwise, Hmm... I might have to sit and ponder this one for a second.

- Coffee
Test Subject
#16 Old 26th Aug 2005 at 6:47 AM
Okay... well from the sounds of it... there may be an problem in the audio track in your source material... you *MAY* be able to export the audio track as a wav file, and import it back in under full processing mode if it's giving you trouble. Keep in mind, the wav file is going to be rather huge.


File-> Save Wav

Then, select Audio-> Wav Audio and browse to your wav file you just extracted
-Coffee
Test Subject
#17 Old 26th Aug 2005 at 6:47 AM
Quote:
Originally Posted by coffeehedake
Do you have the audio set to 'full processing mode' ? If not, all of those other options, like conversion, etc, would be greyed out... Otherwise, Hmm... I might have to sit and ponder this one for a second.

- Coffee


yup at least i figured that out lol but its says that its stereo though.
Test Subject
#18 Old 26th Aug 2005 at 6:49 AM
Damn ive tried a few and they are all like that. Oh well. Thank you for your help though. I aprpeciate it.
Test Subject
#19 Old 26th Aug 2005 at 6:54 AM
Did you give that Wav export option a try... sorry I keep editing my posts to give you a better explanation and by then you have already posted...

I'm very tired, and not thinking quite right tonight. (Hey, that rhymes!)

-Coffee
Test Subject
#20 Old 26th Aug 2005 at 6:56 AM
Quote:
Originally Posted by coffeehedake
Did you give that Wav export option a try... sorry I keep editing my posts to give you a better explanation and by then you have already posted...

I'm very tired, and not thinking quite right tonight. (Hey, that rhymes!)

-Coffee


So i choose the wav i saved, and then try to convert it again? it still only has the option of 24000
Test Subject
#21 Old 26th Aug 2005 at 7:03 AM
I tried it and it still does it,

Oh well, thank you though, you have been very kind.
Test Subject
#22 Old 26th Aug 2005 at 7:10 AM
That is very, very odd indeed.

Here's a question for you... how big are your source videos? Maybe I can convert them for you. If they're huge, how big is that wav file you just extracted. Chances are the audio needs to be fixed (either with downsampling or whatever) maybe I can fix the audio for you seperately.

-Coffee
Test Subject
#23 Old 26th Aug 2005 at 7:13 AM
Hi there,
they are th length of like a music video, 4 mins or so each. Can you tell me how to fix the audio? maybe I can do it myself if I have the right software. If not thats ok, I dont want to bother you with it dear. Youve been nice enough.
Test Subject
#24 Old 26th Aug 2005 at 7:20 AM
I tried other files that did have the 22.050 thing and they didnt work out either, I so far I tried about 9 differnet files, i figured they cant all be bad, and none of them worked.
Test Subject
Original Poster
#25 Old 26th Aug 2005 at 7:26 AM
one way i would suggest to fix the audio is to save it out as a wav like coffeehedake mentioned, but then open it up in a program called Goldwave (do a quick google search.) open up the wav file in goldwave, then simply go to save as and make sure the save as type dropdown has wave (*.wav) selected and the attributes says PCM signed 16 bit, stereo. then take that new wave file and again follow coffeehedake's directions by going into virtualdub, go to the audio menu, select wav audio and browse for the new wave file you saved in goldwave.

this in most cases will fix odd corruptions in the audio. should get you back on track with the tutorial.
Page 1 of 6
Back to top