Replies: 234 (Who?), Viewed: 122998 times.
Page 3 of 10
Consciously Undead
retired moderator
#51 Old 14th May 2006 at 6:26 PM
I am very sure that I cannot scroll down further- I can't see any scroller, and when I try using the arrow keys to scroll down further, it stops at 0x7 screen

If you're not part of the solution, you're part of the precipitate
Part-time Hermit
Original Poster
#52 Old 14th May 2006 at 6:49 PM
Then it seems that SimPE is not finding the CEP files correctly for some reason. I'm not sure how to fix that. Does the package have any Material Overrides? I would try reinstalling CEP just in case. If that still doesn't help, then you will have to color-enable it manually. I can post instructions for doing that if the CEP reinstallation doesn't help.
Consciously Undead
retired moderator
#53 Old 14th May 2006 at 6:58 PM
I've cloned another TV, and it's come up- is it possible to clone the node, then place it in my existing TV?

Also, if an object already has subsets that can be recoloured, can they be deleted?

If you're not part of the solution, you're part of the precipitate
Part-time Hermit
Original Poster
#54 Old 14th May 2006 at 7:26 PM
I'm not sure how it would work to replace the GMND with one from another object. Might get a bit more complicated than it needs to. Probably easier in the end to add the missing line manually. I'll write the instructions for doing so. But we also may have to add the Material Overrides if they aren't there. Are they?

You can remove the recolorablity of the original subsets or delete the subsets altogether if you're not using them. If there is neither tsDesignModeEnabled nor Material Overrides included in the package, they are not recolorable to begin with and you don't need to do anything to disable them. If you want to delete those subsets altogether, delete the mesh subsets in GMDC, the Shape entries for them in the Parts tab, the Material Definitions related to them, and the textures if they have separate textures that remaining parts of your objects are not using.

To add the missing tsDesignModeEnabled, open the GMND, click the Edit Blocks tab, and from the drop down list select (cDataListExtension), then click Add and Commit. Then go back to the Content tab, and with the first entry on the Blocklist selected, go to cObjectGraphNode tab. On the right you see a section called Datalist Extension Reference. Click Add, then click on the new line, then change the last number of the Index number in the box to whatever comes next on the list (in your case, probably 8), and then the last number of the Enabled value to 1. Now your new line should look like the existing ones, click Commit. Then go back to the cGeometryNode tab, and select your new entry from the Blocklist (at the end of it). In the cExtension tab, into the Name field type tsDesignModeEnabled, then click Commit. Then from the dropdown list in the bottom right corner select Array and click Add. Then click on the new line in the Items box and into the Name field enter the name of your recolorable subset, then click Commit. Repeat adding the Array and naming it for the second recolorable subset and Commit again. Save your object.

If the package doesn't have any Material Overrides either, we'll have to add them, too, but I'll wait for your response first if they are missing or not.
Consciously Undead
retired moderator
#55 Old 14th May 2006 at 7:41 PM
I'm having real difficulty following those instructions IB- I think I may reload my mesh into the new package, and add in the subsets as needed, now that I can make them recolourable- thanks for all your help in this issue

If you're not part of the solution, you're part of the precipitate
Part-time Hermit
Original Poster
#56 Old 14th May 2006 at 7:48 PM
I'm sorry, I tried to make the instructions as detailed as possible . I hope you have better luck with your new clone.
Test Subject
#57 Old 15th May 2006 at 7:22 PM
I was having the same problem with the tsDesignModeEnabled not showing up but your instructions fixed it. Thanks very much! Great tutorial
Test Subject
DELETED POST
15th May 2006 at 7:29 PM
This message has been deleted by cosmikchyc.
Lab Assistant
#58 Old 14th Jul 2006 at 3:07 PM
is it a SimPE problem?? because when I export anyobject, it has not got tsdesing... and material overrides....
Part-time Hermit
Original Poster
#59 Old 14th Jul 2006 at 4:26 PM
Do you have the CEP installed? Which objects are you cloning? You may have to check the "stand-alone" option for some objects.
Lab Assistant
#60 Old 14th Jul 2006 at 4:55 PM
yes, I've got it. also I've tried it with the ''stand alone'' option and hasn't the Material ower... and tsdesing...
I've cloned a plant. but I've tried it with all maxis plants models and doesn't works in any case...
Part-time Hermit
Original Poster
#61 Old 14th Jul 2006 at 5:02 PM
Do you have the CEP files included in the files that SimPE uses? Go to Extra -> SimPE Preferences -> File table and check that CEP is selected. Are they indoor plants that you're talking about, or outdoor?
Lab Assistant
#62 Old 14th Jul 2006 at 5:09 PM
in door plants, IB. well, I am going to try it.
edit: yes, IB. CEP is activated. look at:
Part-time Hermit
Original Poster
#63 Old 14th Jul 2006 at 5:26 PM
Hmm, the only thing I have left to suggest is to try to reinstall CEP. When I try to clone indoor plants, the MMATs show up just fine.
Lab Assistant
#64 Old 14th Jul 2006 at 5:33 PM
I've tried it and doesnt works too...
IB, If your in door plants looks fine, could you send me a original maxis plant for edit?
Part-time Hermit
Original Poster
#65 Old 14th Jul 2006 at 5:42 PM
Which plant would you like it to be? A table, floor, or hanging plant, something more specific?

Also, let me know your email address, either here or in PM .
Lab Assistant
#66 Old 14th Jul 2006 at 5:44 PM Last edited by Karlius : 16th Jul 2006 at 3:51 PM.
can be this IB?

thank you!

edit1: yes of course, if you need my email for send here you have: [email protected]

edit: IB, have you got the plant?
Lab Assistant
#67 Old 21st Aug 2006 at 8:52 AM
Hi I have been creating objects for awhile but I'm having some trouble with my shower. In SimPE it lets me reskin the subset but then in game it only shows the shower and now glass subset or recolors.
Download - please read all instructions before downloading any files!
File Type: rar Saiz-modernshowerv2.rar (291.1 KB, 14 downloads)

Im back again making meshes, pm me a request

Click Here to See All My Creations
Part-time Hermit
Original Poster
#68 Old 21st Aug 2006 at 2:54 PM
Saiz08, your subset names and numbers do not match. Remember that you can only have two recolorable subsets. In GMDC, you have subsets called showercommunal_surface, glass1, glass2, but in the tsDesignModeEnabled you have, instead, subsets called showercommunal_surface, glass1, glass. So, you have 3 subsets listed in the tsDesignModeEnabled instead of the allowed 2, and one of their names doesn't match the ones in GMDC. You have MMATs for subsets called showercommunal_surface and glass.

What I recommend you to do is to 1) combine the glass1 and glass2 subsets in GMDC to one subset called just glass, edit the subsets in the Parts tab in Shape to match the ones in GMDC after aforementioned changes and 3) remove the subset glass1 from the tsDesignModeEnabled list. And then fix integrity and save.

Karlius, I'm very sorry, I completely missed your updated post and have still not sent you the file! Do you still need it? Let me know and I'll send it if necessary. Make sure to PM me if I keep being forgetful .
Lab Assistant
#69 Old 21st Aug 2006 at 3:03 PM Last edited by Saiz08 : 21st Aug 2006 at 3:11 PM.
Yeah Thanks, I fiqured I was just doing something stupid. I need to remember how to use SimPE again its been awhile. And thanks for taking a look at it.

Im back again making meshes, pm me a request

Click Here to See All My Creations
Field Researcher
#70 Old 22nd Aug 2006 at 8:13 PM
Bliss, I just successfully used this tutorial for the 1000th (or so) time and I wanted to thank you again for teaching me how to do this.
Part-time Hermit
Original Poster
#71 Old 22nd Aug 2006 at 8:23 PM
You're welcome
Instructor
#72 Old 7th Sep 2006 at 1:12 AM
You know, at first this made no sense to me. Until I got into it and really started messing with it. I finally printed it out and it stays next to me at my computer. It is my minibible. Thank you.
Scholar
#73 Old 13th Oct 2006 at 2:20 AM
I cant find the Material Override in my package. What do I do?

Call me Paco!
Rhymes with Taco

I'm currently taking requests until August 12th.
The ModFather
retired moderator
#74 Old 14th Oct 2006 at 12:44 AM
Ehm... what package? Have you cloned an object and in the clone there are no Material Overrides?
If so, this means that the original object doesn't have textures of its own, but it borrows the textures from an external object.
For instance, most loveseats take the textures from the corresponding sofa: if you clone the loveseat you won't find any MMAT in the package.

One solution (but it should be performed wisely) is to click the cloning option "Create as stand-alone": this will break all the connections to the external object, and the right MMATs will be included in the package.
But be careful: if you clone, for instance, a bed with that option active, your new bed will NOT use any more the Maxis beddings!

I've finally started my Journal. Information only, no questions.

My latest activity: CEP 9.2.0! - AnyGameStarter 2.1.1 (UPD) - Scriptorium v.2.2f - Photo & Plaques hide with walls - Magazine Rack (UPD) - Animated Windows Hack (UPD) - Custom Instrument Hack (UPD) - Drivable Cars Without Nightlife (UPD) - Courtesy Lights (FIX) - Custom Fence-Arches - Painting-TV - Smarter Lights (UPD)


I *DON'T* accept requests, sorry.
Lab Assistant
#75 Old 15th Oct 2006 at 4:55 PM
When I've taken all these steps I would make recolors but in my recource tree there are two material definitions and two material overrides but I have only one texture image. Where have I made my mistake?
Page 3 of 10
Back to top