Replies: 15 (Who?), Viewed: 8686 times.
Destroyer of Worlds
staff: administrator
Original Poster
#1 Old 24th Sep 2009 at 1:43 PM
Default Clean Installer Empty Packages
I've already found similar issues elsewhere, followed the suggested fix, and am still having the same problem.

Every time I try to package my lot with the Clean Installer I get "empty packages" for absolutely everything in the pack. I read that this could be due to strange characters so I changed them. However, I recently submitted the exact same lot for upload and, after a rejection due to some tweaking I needed to make to the file package, I am repacking it without all the extra recolors and such. This exact same package had been packaged properly and uploaded. I had just taken out all buyable custom content (kitchen counters, bathroom fixtures, etc) and left only the build custom content. Now, I am trying to repack it differently and and it gives me that awful message!

I have deleted the packaged lot and repackaged it in game. I have changed the name of the lot when doing "save as". I have tried going into my downloads file and deleting everything with non-English characters and things such as &, %, etc. I uninstalled and downloaded/reinstalled the latest version of Clean Installer (which is what I already had) and it still does not work. Is there something ridiculously simple that I am somehow overlooking? I never thought I would be thankful for a rejection but if it was just a change, I would be well over my 72 hour limit just because of this! Otherwise I could have had it done next day. Please, please help me!
Advertisement
Warrior Gryphon
site owner
#2 Old 24th Sep 2009 at 2:08 PM
Theres a simple solution: Don't save over the same file. Always choose a new name for your modified sims2pack files. Start from a working sims2pack and save as.

Story books are full of fairy tales, of Kings and Queens, and the bluest skies.
Destroyer of Worlds
staff: administrator
Original Poster
#3 Old 26th Sep 2009 at 1:30 PM
I have been doing that. Everytime.
Banned
DELETED POST
11th Apr 2010 at 9:14 PM
This message has been deleted by Vampire_of_Death.
#4 Old 11th Apr 2010 at 9:15 PM
Me too, and I can not find a fix ANYWHERE. Has anyone found a solution? I have been saving in different locations and everything posted above.

Thanks.
Site Helper
#5 Old 12th Apr 2010 at 3:41 AM Last edited by Mootilda : 12th Apr 2010 at 4:03 AM.
I've just taken over development of the Clean Installer, so I'd like to understand your problem better, in the hopes that I can find a solution. So please, bear with me.

As I understand it, you have a Sims2Pack which contains custom content. You are trying to repackage that Sims2Pack without some of the custom content. So, you open the Sims2Pack with the Clean Installer, uncheck the custom content that you want to remove, and then "Save As..." a Sims2Pack with a different name than the original. You exit out of the Clean Installer, then try opening the new Sims2Pack and it shows as an empty package.

Is that correct?

If so, could you please attach the original Sims2Pack, so that I can take a look at it; it would also help if I knew which CC you want to keep (or remove) and what the new Sims2Pack name is. Hopefully, I can reproduce your problem, which is the first step to finding a solution.

If not, could you please try to specify exactly what you are doing in that level of detail?
#6 Old 12th Apr 2010 at 6:14 AM
Actually, here is a video of what exactly is happening. And just so you know, it is a lot that is doing this, not a sim. I just wanted to clarify.

Its a bit laggy, but it will do.

http://www.youtube.com/watch?v=XmuvEOOKdb0

Here is a list of things that I would like removed:
Palace D floor
nanifirealarm2rec1 Object Recolor
I am pretty sure that is all, but I have to double check the creator policies.


Thank you so much for all of your help, I really appreciate it.


Also, I just noticed, one of teh first downloads, a dresser by Maylin, is showing as an empty package, is there a reason, how can I fix it?

Thanks again,
Vampy
Download - please read all instructions before downloading any files!
File Type: rar Medieval Set by Vampy.rar (3.81 MB, 13 downloads) - View custom content
Site Helper
#7 Old 12th Apr 2010 at 5:08 PM Last edited by Mootilda : 12th Apr 2010 at 6:10 PM.
Sorry, I have no ability to watch videos. However, I believe that I've managed to reproduce your problem. (See attached screenshot.)

Unfortunately, this problem also occurs with the latest Clean Installer test version and there were no obvious errors during debugging, so it may take a while for me to try to find the problem.

In the interim, I'm going to make a guess about where the problem might lie: I suspect that some of the custom content may have a problem which the Clean Installer was unable to detect. If you wanted to speed things up, you might try this:
1) backup your entire save game folder
2) Repeat for each piece of CC included with the lot, except for the two that you don't want:
2.A) Remove the CC from your Downloads folder (or rename it temporarily from <name>.package to <name>.Unused)
2.B) Package your lot in game
2.C) Try removing the two CC that you don't want using the Clean Installer.

If the Clean Installer starts to work correctly, let me know which package made the difference.

I'm sorry that I can't solve this quickly. I'm still not familiar enough with the Clean Installer... it can take a while to learn everything.
Screenshots
#8 Old 12th Apr 2010 at 9:39 PM
Yea, thats my problem.

I will try that, it might work. Also, just so you know, I have had that problem with packaging lots forever. It has always had the empty package error.

Thanks for all your help and I will make sure to let you know if it works.
Site Helper
#9 Old 13th Apr 2010 at 12:07 AM Last edited by Mootilda : 13th Apr 2010 at 2:15 AM.
I have never had that problem before, except with your lot. That seems to imply that some of your CC is at fault. Have you had the same CC "forever"? Did the Clean Installer ever work for you?

heaven_sent_8_18, it might be worth downloading the package above and running it through the Clean Installer. You wouldn't have to actually install the lot, just look through the CC to see whether any of it matches the CC that you're using. If so, please let us know.

[Update:]

Quote:
Originally Posted by Vampire_of_Death
Also, I just noticed, one of teh first downloads, a dresser by Maylin, is showing as an empty package, is there a reason, how can I fix it?
I'm becoming more and more convinced that the problem lies with that initial empty package. As far as the Clean Installer can tell, that particular CC is completely empty; ie, there's nothing there except the name. Is there any way that you could remove just that package from your Downloads folder, then package the lot and see whether the Clean Installer works correctly?

heaven_sent_8_18, are you also seeing one or more initial empty packages when you open your lots using the Clean Installer?
Inventor
#10 Old 1st Jul 2010 at 5:54 PM
Apologies for bringing this thread up again, but I have been having the exact same problems as the previous posters with Empty packages appearing when I do "Save As" (and saving it with a different filename to the original). I get Empty packages for everything. I use two computers and have Sims 2 installed on both. I do my creating and packaging on my desktop computer and then transfer the file via an external hard drive to my laptop version, which I then install into the game to check it's appearing correctly.

Just to mention that it doesn't occur for EVERY Sims2pack I have created, but I'm having problems with an Apartment lot I'm preparing to submit. I'm wondering why my computers like to show up certain lots and not others when I fire up the game.

The apartment lot I want to submit is clean and unplayed by sims (although a clone has been playtested in-game to make sure all is working correctly). It has also been properly converted into an apartmentbase, and the original sim2pack is hack-free except for a Phone-Line Controller hack I want to get rid of.

Any advice/help would be appreciated.
Inventor
#11 Old 1st Jul 2010 at 6:09 PM
I just found the solution to my problem above with this thread -

http://sumomo.modthesims.info/showthread.php?t=200668

Thank God for that, it was driving me barmy why it wasn't working!
Site Helper
#12 Old 2nd Jul 2010 at 12:53 AM Last edited by Mootilda : 2nd Jul 2010 at 1:27 AM.
Thanks for the link. In that thread, I've asked for a sample Sims2Pack with this problem. If I can reproduce the problem, then I should be able to fix it.

[Update:]

This is looking good. I changed to UTF8 encoding and the Medieval Set by Vampy (above) seems to be working now.

I have a new version of the Clean Installer in the upload acceptance queue now. Once that's available, I'll update with this fix.
Test Subject
#13 Old 19th Jun 2012 at 4:09 AM
I actually have very simple question that has to deal with Empty Packages in my game. It's really the first time I am using a program to clean up some of my downloads so I'm a bit confused. If I delete Empty Packages will that affect my game at all?
Site Helper
#14 Old 19th Jun 2012 at 4:23 AM Last edited by Mootilda : 19th Jun 2012 at 7:19 PM.
No. An empty package has nothing in it, so it can't affect your game.

However, whenever you are concerned about something like this, there's a really simple solution: backup. If you backup and then try something which doesn't work as expected, you can just restore from your backup and everything will be OK again. Here's how:
http://simswiki.info/wiki.php?title=Game_Help:Back_Ups
Test Subject
#15 Old 20th Jun 2012 at 5:00 AM
Well it seems like I have another question to ask.

For about a week now whenever I go to play a certain residential lot; where my main family lives; the game plays for about three minutes and then crashes. I tested this twice already and saw the same results whenever I click on that residential lot. However all of the other lots are perfectly fine when I go to play them. If I send my main family to a community lot I can play the game, but not on this one residential lot.

This may have to deal with some of the custom content I downloaded. When I re-decorated that lot with the custom content that's when the game started to crash. Though, even after I deleted the furniture in the home using Buy Mode the game still seems to crash.


[Sorry for not posting this in the correct forums. I'm in a bit of a hurry.]
Site Helper
#16 Old 20th Jun 2012 at 2:27 PM
Quote:
Originally Posted by DezyandCream
[Sorry for not posting this in the correct forums. I'm in a bit of a hurry.]
Unfortunately, posting in the wrong forum and hijacking an unrelated thread will not speed things up. In fact, it's likely to slow things down.

Post your problem in the Sims 2 Help forum after doing the (required) Game Problem FAQ. If you post without doing the FAQ, you will again slow down the likelihood of solving your problem.
Back to top