Replies: 3 (Who?), Viewed: 8845 times.
Test Subject
Original Poster
#1 Old 23rd Jan 2011 at 5:30 AM
Default Changing the default install folder
Hi,
I'm wondering if there's a way to permanently change the default S2PCI installation folder?
I know I can browse for where I keep my files, but it does get a bit tedious doing that every time I want to install a file I've downloaded.

To give you a bit of background in case it helps -

I have 2 profiles set up on my computer. The normal everyday one, and another with minimum programs, background tasks etc so all the power goes to the game.

The S2PCI keeps deciding it wants to install files here
F:\My Documents\EA Games\The Sims 2

and I'd like it to install here
C:\Documents and Settings\Sims2\My Documents\EA Games\The Sims 2\Downloads\test

Is there a way to change it so I don't have to search the new path every time I want to install a file?

I think I must have 2 versions installed from some time ago and don't know what I can safely move...hence just changing the S2PCI path would be safer.

Thanks.
Advertisement
Site Helper
#2 Old 23rd Jan 2011 at 6:25 AM Last edited by Mootilda : 23rd Jan 2011 at 6:01 PM.
At this time, the Clean Installer sets the initial path from the registry entries which the game set up when it was installed. You can specify a subfolder of Downloads which you would always like to use, but there's no way to specify a completely different folder on a different drive. This is my next big project for the Clean Installer: getting the non-default installation working well.
Test Subject
Original Poster
#3 Old 25th Jan 2011 at 6:46 AM
Ok thanks for letting me know.
Site Helper
#4 Old 7th Apr 2011 at 9:50 PM Last edited by Mootilda : 7th Apr 2011 at 10:31 PM.
This feature is now available. With the newest version 1.6.14, you can open the S2PCI.ini file and change the line:
SaveGamePath=""

to:
SaveGamePath="<path to your specific EA Games\The Sims 2 folder>"

For example, to set the install directory to your first AnyGame, you might type:
SaveGamePath="C:\My Documents\AnyGameStarter\AnyGame1\EA Games\The Sims 2"

To go back to the default save game location, change the line back to:
SaveGamePath=""
Back to top