Replies: 7 (Who?), Viewed: 5523 times.
Lab Assistant
Original Poster
#1 Old 14th May 2020 at 8:24 PM
Default Clean Installer says simspack files are Installed, but don't show up in game

Like the title says, I've downloaded some houses from here on ModTheSims and used the CleanInstaller to install them (they are simspack files). In CleanInstaller it looks like everything worked without an issue, it says its installed. But they're not showing up in the game. Any idea what could be causing this?

Thanks so much
Mad Poster
#2 Old 14th May 2020 at 9:11 PM
Are you sure the Clean Installer has been set up to actually install packages in your Downloads folder?

If you have the CD versions of the game (not collections) the program usually knows what to do when installing, but it may depend on which version you're using.
In the Clean Installer settings, make sure you've specified a location to install the files in - there's a "choose directory" dropdown list at the top.

If that doesn't help:

If you have collections, the Ultimate Collection, have used a different install location for the game, or use anything else than Windows (Windows 10 can also be a potential problem), you may have to manually set the location of your game in one of the Clean Installer files.

- Go to the location of the "Sims2Pack Clean Installer" folder (should be somewhere in "Program Files (X86)" or similar)
- Locate the "S2PCI" file, open it with Notepad, it may not open automatically in Notepad, but you should be able to select it from a list of programs (DON'T use Word or Wordpad or any other program)
- Where it says
either make sure it points to the proper place already, or point it to the proper place by going to your Downloads folder and then one step back (the "The Sims 2" or "The Sims 2 Ultimate Collection" folder, in Documents), and paste this in, making sure to keep the small "TM"
Mine says
SaveGamePath="C:\Users\USERNAME\Documents\EA Games\The SimsTM 2 Ultimate Collection"
(TM is small in the path but cuts off in the forum post, and I have the actual username on my computer, but yours will be different anyway)

This did work very well when I had some problems on my Windows 7 laptop (where I had the CD version of the game), but I've had a strange issue on my Windows 10 laptop (with the UC), where it has made a "Downloads" and "Teleport" folder in the "EA Games" folder instead. I'm not sure if this is because of a path issue, or it just doesn't understand the "TM", and I haven't had to install a lot of files, but it wouldn't be more of a problem than just moving the files from these folders over to the actual folders one step forward. If anyone knows a solution to it, I wouldn't mind knowing...
Lab Assistant
Original Poster
#3 Old 14th May 2020 at 9:49 PM
Wow this is exactly what I was hoping for. Thank you so much.

I'm running the UC on Windows 10, and you're right, the S2CPI file was empty. I've added in the directory.
("C:\Users\jojay\OneDrive\Documents\EA Games\The Sims™ 2 Ultimate Collection")
I just booted up the game after installing a new lot with the new directory in the S2CPI file and still no CC lots. :/

It created a second folder in the EA games folder that has Teleport and Downloads folders in it, it looks like this: "The Simsâ„¢ 2 Ultimate Collection".
So now i have "C:\Users\jojay\OneDrive\Documents\EA Games\The Sims™ 2 Ultimate Collection"
"C:\Users\jojay\OneDrive\Documents\EA Games\The Simsâ„¢ 2 Ultimate Collection"
both with teleport and downloads folders in them.

Any ideas on where to go from here? Thanks so much for any help. Sims 2 has been a fun lesson in messing around with files the past few days.
Lab Assistant
Original Poster
#4 Old 14th May 2020 at 9:58 PM
Also, are the lots' files supposed to stay in Teleport and Downloads, or do they have a different final resting place that I could possibly manually move them to?
Lab Assistant
Original Poster
#5 Old 14th May 2020 at 10:17 PM
Ok for anyone else having this issue, so far I haven't been able to get CleanInstaller to work fully - (is it updated for Windows 10?) but was able to get the CC Lots in my game by moving the files manually.

I followed this walkthrough:

Basically you copy and paste the files in the Teleport folder into your LotCatalog folder in The Sims 2 folder. There are already files there with names like "cx_000000(number).package". Rename your new lot files to follow the "cx_000000(number).package" system, and continue from the highest number.

So the highest number lot already in there was "cx_00000060.package". I started re-naming my new lots one by one, going up incrementally. "cx_00000061.package", and so on.

You will get a pop up that says changing the extension of the file may cause it to not work correctly. Just press OK. Changing the extension this way makes the game able to read the lot.

Hope that helps for anyone else! If I were better at programming I'd try to fix or figure out why Clean Installer isn't able to do the whole thing but that's for another day.

Oh also make sure you copy any included CC from the Downloads folder (next to the Teleport folder) into your Downloads folder where you keep the rest of your CC or else it won't show up.
Mad Poster
#6 Old 14th May 2020 at 11:42 PM
If the installed files appear in those extra folders, you should be able to move them to the proper folders without any problems. I don't know why the UC and/or Windows 10 does this, though.

The weird files that appear in Teleport when installing houses are the houses - they'll be transferred to the right place (the LotCatalog folder) when you start up your game.

Personally I tend to keep all the CC from a lot in a separate folder, so I can remove any unwanted files (like tons of mailbox/trashcan recolors) or troubleshoot crashing lots. I've had my share of problems from downloaded lots, and it makes things easier.
Needs Coffee
retired moderator
#7 Old 15th May 2020 at 2:31 AM
Lots need to go to the teleport folder, not the download folder. The CC can go to the download folder.

If you have the disappearing CC issue, you are not alone. If I install cc from a lot and then move it, it disappears from my game.

"I dream of a better tomorrow, where chickens can cross the road and not be questioned about their motives." - Unknown
~Call me Jo~
Mad Poster
#8 Old 15th May 2020 at 4:37 PM
Disappearing CC? As in it installs to the proper folder then disappears? Huh, I don't think I've ever seen that. Could potentially be a problem if it installs to Teleport or if it never actually installs to a folder. Maybe S2CI makes new folders where it thinks they're supposed to be - have you checked in documents to see if there's folders in the 'default' path?
Back to top