Replies: 14 (Who?), Viewed: 5295 times.
Test Subject
Original Poster
#1 Old 6th Jun 2007 at 12:55 PM
Default Trying to include CC in lot: NullReferenceException -error
For days I’m trying to package a lot with some custom content included. CleanInstaller gives me an error message:

System NullReferenceException: Object reference not set to an instance of an object.
at Sims2Pack_Installer.Util.getFolderName (String fileName)
at Sims2Pack_Installer.S2CPPackage.GetItem ()
at Sims2Pack_Installer.S2Sims2Pack.RecognizeFiles ()


I don’t know if this should be a new thread, since this one looks quite similar to mine
http://www.modthesims2.com/archive/...p/t-140069.html

I’ve done all the checking via Google and forums but found no solution for this problem. Tried emptying the dowload folder (exept for CEP-latest version,check), did all the renaming and saving according to the textbook. Even tried this suggestion (saving the CC and the lot separetely) but that didn’t help either.
If I do it the way I was accustomed to - click the blue house icon, save as… new name-, there’s no problem. It’s clearly the CC that causing it.
I’m hoping for some solution because this house needs a huge amount of downloads and it would be nice to offer at least a (pemission granted) part of these to downloaders.
Advertisement
Mad Poster
#2 Old 6th Jun 2007 at 1:28 PM
If I understand your lot is sim2packed and you want to clean it ?
If so, can you install it in an empty download folder ? then in game you can clean all unwanted recolors with the recolor tool.
I have no the solution to the S2CI issue, there is a forum for it : http://www.modthesims2.com/forumdisplay.php?f=441

You know a site allowing re-upload of free build/buy stuff in lots ? Help us to update the list !

* Plus j'échoue plus je m'approche de la réussite
* The more I fail the more I approach the success

(Lao patul MMVI AD)
Test Subject
Original Poster
#3 Old 6th Jun 2007 at 4:00 PM
That’s right, I was trying to make my download as clean as possible so I tried Khakidoo’s empty Download folder methode
http://modthesims2.com/showthread.php?t=228501
And your own tip:
http://modthesims2.com/showthread.p...ewpost&t=234359
but due to the error I can’t install any custom content with the Clean Installer. The only thing I CAN do is install my lot as “LotSegmentForUpload” but then my beautifull decorated garden is littered with basegame statues, vazes, enormous trees instead of nice bushes etc.LOL, because obvisously the game can’t find these new meshes.
During my search I didn’t notice in whitch forum I was reading, sorry for this. Anyhow, I haven’t seen a sollution for this problem in the S2CI- forum either. But I’ll repeat my question over there. Thanks anyway
Mad Poster
#4 Old 6th Jun 2007 at 5:20 PM Last edited by patul : 6th Jun 2007 at 5:31 PM.
If you can install the lot, can you install the CC one after the other with the S2ci ?
Otherwise manualy package after package to find the corrupted one ! (may be long because you must repack and re test -not necesary exit the game-, do it by bunch first)

You know a site allowing re-upload of free build/buy stuff in lots ? Help us to update the list !

* Plus j'échoue plus je m'approche de la réussite
* The more I fail the more I approach the success

(Lao patul MMVI AD)
Mad Poster
#5 Old 6th Jun 2007 at 5:39 PM
May try this.

install the cc half by half to track out which half has the corrupted.
If both halves have the corrupted, then there're more than one corrupted.
carry on the half by half method to single out the corrupted.
Test Subject
Original Poster
#6 Old 6th Jun 2007 at 8:46 PM
I know what you both mean, I'll try that. But shouldn't a corrupt file have given me more trouble in a much earlier stage? I mean, I made several -in between- saves with the S2CI and could install the house problem free each time. With all the custom content available in the downloadsfolder of course. Anyway, it's worth a try! Thanks!
Mad Poster
#7 Old 6th Jun 2007 at 9:36 PM
Silly question had you try to install with the maxis installer ?
The half by half method is the best, after a first detection divide the won part by half, then again and again to find the bad package
courage

You know a site allowing re-upload of free build/buy stuff in lots ? Help us to update the list !

* Plus j'échoue plus je m'approche de la réussite
* The more I fail the more I approach the success

(Lao patul MMVI AD)
Test Subject
Original Poster
#8 Old 7th Jun 2007 at 12:18 PM
Some wise person over here once wrote that there was no such thing as a silly or a stupid question, that’s why I even dare to post on these forums!
No, I haven't tried it with the Maxis Installer. To tell you the truth I didn't even know the thing existed.....
To rule out the possibility that – maybe by some faulty installation of S2CI – the program wasn’t able to track back the path to my subfolders (objects, build items, etc.), I did a quick test: Selected: lotSegmentForUpload, checked some random items of each group, did a “save as..” – perfect! So I’m afraid you’re right, there’s some item or recolor in there that’s causing the problem. So I know what to do next…… (sometimes I hate this game!!!)
Mad Poster
#9 Old 7th Jun 2007 at 1:19 PM
To install a sim2pack with the maxis installer, right click your pack then choose open with, the browse your program files/the (die) Sims 2 /TSbin folders (I dont remind where is las version) to find the SimInstaller.exe program.
If it is not for you it is for thurther readers of this thread :D

You know a site allowing re-upload of free build/buy stuff in lots ? Help us to update the list !

* Plus j'échoue plus je m'approche de la réussite
* The more I fail the more I approach the success

(Lao patul MMVI AD)
Test Subject
Original Poster
#10 Old 7th Jun 2007 at 7:39 PM
Well there I am again. This went faster then I expected, but I have to admit I was lucky. I started my investigastion by doing a search under the most likely suspects- the recolors. Then, just for the fun I tried to package the lot with just the 8 walls and the 1 floor, what could go wrong with that? But there it was; the error report! This narrowed the search down quite a bit.
To cut this story short: the whole problem was caused by a wallpaper. One from the Grand Trianon project, to be precise: “GT_Moon&Sun_WP.package”
I’ve downloaded it again, installed it, redecorated the room, saved the game and made a save with the S2CI. Left the game and tried the save as / renaming routine again. There it was: the wallpaper caused for 100 % sure the errormessage.
It would be easy enough for me to replace the room with some other wallpaper and carry one with the work. But what still bothers me: How can a simple wallpaper cause this to happen. There’s nothing wrong with it in the game, I’ve checked it with SimPE - it didn’t see anything wrong with it. The only problem is CleanInstaller can’t package it. I don’t know if this is of any significance for the general knowledge base, the makers of the wallpaper or people who are very into S2CI. Anyway, my problem (so far!!!) is fixed. Thanks for the advice!
Mad Poster
#11 Old 7th Jun 2007 at 9:45 PM
May be a corrupted download or extraction or copy.... Do you use te SimFileMaid 3000 to install your downloads? This program is known for this kind of issues.

You know a site allowing re-upload of free build/buy stuff in lots ? Help us to update the list !

* Plus j'échoue plus je m'approche de la réussite
* The more I fail the more I approach the success

(Lao patul MMVI AD)
Test Subject
Original Poster
#12 Old 8th Jun 2007 at 8:52 AM
Absolutely not. No downloadmanagers, nothing. Apart from some difficulties with downloading during busy times at MTS2 (incomplete rar’s) I never had any problems with my downloads. I checked the size of the content and that was correct. Remember, I downloaded it again, the wallpaper shows up in the game the way it should. So there MUST be something wrong in the filestructure or maybe the filename? Something that makes it impossible to pick up with S2CPI. Maybe the “&” in the filename???? Here’s what SimPE comes up with in the Resource List.
http://img172.imageshack.us/img172/...allpaperrl0.png
I haven’t got a clue what it all means but maybe there’s some wizzard over there that can “read” what is says? The more I think about it, shouldn’t this be a typical CleanInstaller forum topic, like you suggested earlier, Patul? Aren’t moderators able to move topics by the push of a button? Maybe this subject might be of interest for the people over there….
world renowned whogivesafuckologist
retired moderator
#13 Old 8th Jun 2007 at 9:10 AM
Clean Installer seems to error if there's something odd in the tooltip description as well - the & in the filename can cause that as well as any other special characters it's having to read. The same thing happens if you try to remove custom content from a package with a creator's tooltip with special characters in it... I've seen it happen many times when the tooltip was originally in an asian character language (usually interpreted as gibberish/boxes by Windows), or creators who have an @ symbol in their names that are used in their tooltips.

After taking a look at that specific file I'd say it's most likely the & in the name causing it. Try renaming the file, packing the lot, and seeing if you still have the problem with the renamed file.

Shifting to Clean Installer forum as this is more about Clean Installer's quirks than building.

my simblr (sometimes nsfw)

“Dude, suckin’ at something is the first step to being sorta good at something.”
Panquecas, panquecas e mais panquecas.
Test Subject
Original Poster
#14 Old 8th Jun 2007 at 2:00 PM
Problem solved!!!!
I copied the ‘GT_Moon&Sun_WP.package’ in my Downloads folder. Named the new version ‘GT_MoonAndSun_WP.package’ . Moved the original file to my desktop. Went into the game, built four walls with the “new” renamed wallpaper. Saved it with S2PCI.
When I opened the Sims 2 Instalable packaged I could now do the saving as/renaming thing problem free!
I thought the makers of the Grand Trianon Collection ( the Dream Team)
http://www.modthesims2.com/showthread.php?t=76172
should be informed about this but I just saw that this download is unsupported….. I don’t think it would be right to offer my lot with a wallpaper included that I renamed without permission from the creator(s), so I’ll pick another one for my house. Thanks everyone for pointing me in the right direction, and I hope this might be helpful to others
Test Subject
#15 Old 15th Oct 2007 at 6:14 PM
Ok, the problem is a little deeper for me. I've built a house and wanted to include some FSF content, actually FSF content from Steffor at Avalon to be specific. I get the same error messages as noted throughout this post but it must be happening with all special characters and not just the & symbol. Case in point, when I look at Steffor's file names they are titled as such within Clean Installer ***** file name ***Steffor. Within the download folder, they are named without the special character of *****. When trying to package, I get the now, infamous error message upon trying to save and then all Steffor's packages end up being wiped from the file (along with some others that have special characters within)
Back to top