Replies: 1 (Who?), Viewed: 83 times.
Test Subject
Original Poster
#1 Old 24th Mar 2021 at 7:22 PM

This user has the following games installed:

Sims 3, World Adventures, Ambitions, Late Night, Generations, Showtime, Supernatural, Seasons, University Life, Island Paradise, Into the Future
My game won't recognise ANY mods???
Hi guys, this is my first post here so if i haven't made myself 100% clear then i'm really sorry!
Anyway, to start things off here are my specs:

So i'm running the sims 3 on windows 10. I also have the sims 4 installed on this device and it works just fine, but as i've recently... gone off the sims 4, i wanted to go back to my roots which are in the sims 3.
So i started playing the game vanilla, because i was unsure about whether or not i wanted to install any cc, as i tend to go crazy. However, since i've become more of a maxis match player, i decided to give it a go. So, i downloaded the mods folder from and placed it in my documents > electronic arts > the sims 3 folder (i'm running the origin version of the game).

I started classically with the no intro mod, which worked fine for a while (i would periodically load up the game between cc shopping to make sure that mod still worked, because if it did, i was pretty sure most other package files would work too). However, around the time i installed sao paten (which had to be installed via a sims 3 pack file rather than a package file), i started noticing that my no intro mod wasn't working. So i tried a different version of it to see if maybe that version didn't work, because i'd read somewhere that the older version of the mod had issues in certain scenarios or something. Anyway, the new version that also included the maxis logo didn't work either. So i started removing my other mods out of my mods folder and testing, until finally ONLY the no intro mod was left... but the game still won't detect it. I've also re-downloaded the mods folder from the aforementioned link, and it still won't work. The only vaguely custom-contentish thing i have installed now is that custom world sao paten, but it's cc free and only contains expansion items i think, no store content. So i'm currently very confused and i'd really like to avoid having to re-install the whole game, as it was a hassle in the first place with downloading store content etc.

Anyway, i hope someone can help because i'm starting to get super sad that i can't play my favourite game
#2 Old 31st Mar 2021 at 12:25 AM
You've probably done this but since you didn't mention it... Did you remember to delete the cache files every time you removed or added something to the game (into the Mods -folder)?
Back to top