Replies: 3 (Who?), Viewed: 119 times.
Test Subject
Original Poster
#1 Old 15th Mar 2021 at 10:02 PM Last edited by dwooming : 15th Mar 2021 at 10:19 PM.

This user has the following games installed:

Sims 3, World Adventures, Ambitions, Late Night, Generations, Pets, Showtime, Supernatural, Seasons, University Life, Island Paradise, Into the Future
Sims 3 Main Menu Does Not Load Properly - Picture of error

Hi, been playing The Sims for awhile and have never come across this problem before, tried searching it up on Google and seems like I'm the only one expierncing this, I just save + quit my game because I got bored, then relaunched due to boredom again, but then when game launcher.. launched, I clicked play and the game was loading with the music, everything seemed to be normal, but then I come across this? all the buttons are clickable, but don't do anything, there is no towns, the settings menu is just a bunch of empty buttons. I don't understand how this can suddenly happen?
Test Subject
Original Poster
#2 Old 15th Mar 2021 at 10:04 PM
Would like to add yes I have tried deleting cache files, reinstalling eps, even tried configuring the compatibility mode, windows troubleshooter, nothing! Still does that
Mad Poster
#3 Old 16th Mar 2021 at 1:30 AM
rename your TS3 user folder to .backup and then run the game see if it fixes it.

Sanity is overrated.

Nitromon is a type of Pokemon encountered in the Pokemon Nitrome Version series.

There. Mystery solved.
Test Subject
Original Poster
#4 Old 16th Mar 2021 at 2:07 AM
just want to say i have fixed it, however i had to reinstall the whole game (if you have this problem remember to backup your game files!)
Back to top