Replies: 12 (Who?), Viewed: 6974 times.
Test Subject
Original Poster
#1 Old 19th Nov 2016 at 7:16 PM
Default bodyshop won't import
Hi:

I recently started retexturing hair and it's been kind of fun, but sometimes, for some of the hairs and/or new textures, bodyshop won't let me import back to game. This seems to happen mostly on some peggy hairs. Is this a thing or am I doing something wrong?

Thank you
Advertisement
Née whiterider
retired moderator
#2 Old 20th Nov 2016 at 4:00 PM
What happens when you try to import the recolour?

What I lack in decorum, I make up for with an absence of tact.
Test Subject
Original Poster
#3 Old 20th Nov 2016 at 11:44 PM
Quote:
Originally Posted by Nysha
What happens when you try to import the recolour?


Well, i get a message i'll try to translate: "the custom content can´t be imported. make sure the files are in the correct place and format"
Née whiterider
retired moderator
#4 Old 21st Nov 2016 at 12:40 AM
Okay - try making a new project, not changing anything, and just clicking Import straight away. Do you get the same error message?

What I lack in decorum, I make up for with an absence of tact.
Test Subject
Original Poster
#5 Old 21st Nov 2016 at 6:14 PM
No, it imports it. Should I export the copy and try to retexture it?
Turquoise Dragon
retired moderator
#6 Old 21st Nov 2016 at 10:10 PM
When you save the new textures are you keeping them in BMP format?
Test Subject
Original Poster
#7 Old 21st Nov 2016 at 11:29 PM
Quote:
Originally Posted by gdayars
When you save the new textures are you keeping them in BMP format?


Yes, I keep that format...
Test Subject
#8 Old 13th Feb 2021 at 2:46 AM
I am having this exact issue. Changing nothing = fine import, changing texture and saving in same format and location generates error message. Has anyone solved it?
Mad Poster
#9 Old 13th Feb 2021 at 3:15 AM Last edited by simmer22 : 13th Feb 2021 at 3:27 AM.
Are you using Photoshop or Gimp (or another program)? In some programs you have to be very spesific with how you save files for Bodyshop to accept them.

Photoshop usually lets you save over with the same format, but with Gimp and some other programs you have to do "Save as..." because they don't allow for saving over the same file or have other save settings. If you save as the wrong setting, you either get errors or weird colors.

I think you have to save the files as BMP 24-bit. Make sure you don't change other settings, like size and such (Bodyshop is very wary of this - if you have to change size of anything, do it both to the texture and belonging alpha before updating the texture, or you will get errors).

And just a reminder, but don't edit the package file in the Project folder. It's a template file, and is only really there to save the settings for the file, and these won't show in your game, only in the Project section of Bodyshop. If you try to edit the project files a bit too much, this can sometimes cause errors in Bodyshop, so probably best not to. Finished files end up in SavedSims when you do "import to game".
Test Subject
#10 Old 13th Feb 2021 at 4:47 AM
I'm only doing the textures, and only in MS Paint, and they're in BMP. Definitely not playing with sizes, just strict recolors of clothes I already had. It used to work fine and I made a few outfits, but now the error message
Mad Poster
#11 Old 13th Feb 2021 at 6:22 AM
Which version of MS paint? Windows 10? Looks like it should save as the original file format (24-bit BMP), so that's a bit strange.

Does it happen to several items or just a few particular items? Could be something in those files. Sometimes files work fine all up until you try recoloring them (especially things like default replacements). Have you tried recoloring a plain (non-replacement) EAxis item?
Test Subject
#12 Old 13th Feb 2021 at 5:04 PM
Quote:
Originally Posted by simmer22
Which version of MS paint? Windows 10? Looks like it should save as the original file format (24-bit BMP), so that's a bit strange.

Does it happen to several items or just a few particular items? Could be something in those files. Sometimes files work fine all up until you try recoloring them (especially things like default replacements). Have you tried recoloring a plain (non-replacement) EAxis item?


That cracked it! It might be bc I was trying to make a recolor of what was already a recolor; I tried the same recolor scheme on a Maxis skirt and it worked! Thank you so much!! <3
Mad Poster
#13 Old 13th Feb 2021 at 8:11 PM
Chances are there was something in the files you tried to recolor first that Bodyshop didn't like, then. You should be able to recolor regular CC, but all CC may not be recolorable, depending on how it's made.
Back to top