Replies: 1160 (Who?), Viewed: 506591 times.
Page 40 of 47
Field Researcher
#976 Old 31st Jan 2009 at 4:14 PM
Quote:
Originally Posted by Numenor
In SimPE you can actually preview even the recolours (without GMDC), but if you don't find the package in the Downloads, there's nothing to preview -
However, just for information, SimPE has 2 different preview features:

1) Select one MMAT (either in a cloned object or in a simple recolour) and click "Preview"

2) Select the menu Tools -> Content Preview; SimPE will spawn a small preview window, where you can drag&drop packages or even ZIP/RAR archives.

NOTE: both previews can sometimes fail, they are not 100% functional; but in most cases they work.

NOTE2: if you want to preview a recolour created for a custom object, SimPE must be set up so to *find* the original object; in order to do so, open the menu Extras -> Preferences -> File Table and click "Add Downloads Folder".


Living and learning.
I didn't know it. Very simple to test. Not the correct area, but, even transparent recolours?
I hate to test transparent recolours with Milkshape, but with non-transparent it's nice.

It's alright to make mistakes you're only human. Inside everybody's hiding something. Take time to catch your breath and choose your moment. Don't slide.
The ModFather
retired moderator
Original Poster
#977 Old 31st Jan 2009 at 11:18 PM
SimPE has some problems displaying semi-transparent textures; the object *is* displayed, but the overall look may be different than the one visible in game.

I've finally started my Journal. Information only, no questions.

My latest activity: CEP 9.2.0! - AnyGameStarter 2.1.1 (UPD) - Scriptorium v.2.2f - Photo & Plaques hide with walls - Magazine Rack (UPD) - Animated Windows Hack (UPD) - Custom Instrument Hack (UPD) - Drivable Cars Without Nightlife (UPD) - Courtesy Lights (FIX) - Custom Fence-Arches - Painting-TV - Smarter Lights (UPD)


I *DON'T* accept requests, sorry.
Test Subject
#978 Old 1st Feb 2009 at 9:45 AM
You do not know how much I love you right now! There were somany objects I wanted recoloured, but didn't know how to!
Test Subject
#979 Old 12th Feb 2009 at 7:09 PM
I have been following this tutorail to the tee. I have a problem. Before I start I have in the last couple of days downloaded and installed all of the required programs to do this. The problem is on step number 3. When I select the texture image (TXTR) in the resource tree I do not have any additional subentries come up for the lit lamp file or the unlit lamp file. How do I get this subwindow come up?
The ModFather
retired moderator
Original Poster
#980 Old 12th Feb 2009 at 8:12 PM
It's not a "subwindow": when you select the TXTR entry in the left panel, you filter the package content, allowing SimPE to show only the TXTR contained in the package. If you don't see two textures, but only one, the reason may be:
1) SimPE is not correctly pulling all the needed files (it's possible, with few objects), or
2) you are not creating a recolour for a multi-state part: for example, you are creating a recolour for a lamp base instead of recolouring the bulb/shade.

I can be more detailed if you tell me exactly which lamp is causing the error; also, I need to know if the "subset selector" (i.e. the last image of step 2) shows up correctly.

I've finally started my Journal. Information only, no questions.

My latest activity: CEP 9.2.0! - AnyGameStarter 2.1.1 (UPD) - Scriptorium v.2.2f - Photo & Plaques hide with walls - Magazine Rack (UPD) - Animated Windows Hack (UPD) - Custom Instrument Hack (UPD) - Drivable Cars Without Nightlife (UPD) - Courtesy Lights (FIX) - Custom Fence-Arches - Painting-TV - Smarter Lights (UPD)


I *DON'T* accept requests, sorry.
Instructor
#981 Old 13th Feb 2009 at 10:13 PM
Default alpha edit of an object texture
To be exact this is rather a texturing than a recoloring issue but I didn't find a better thread and probably it's the easiest thing to post it here:

For my nearly finished office set I wanted to create some decorative documents on a simple plane mesh. The texture is partly transparent but the edges didn't look as sharp as I want and so I had the idea to export the alpha map in SimPE and sharpen the edges to reimport it then. Everything looked fine in SimPE's preview and so I wanted to test the object in game.
The problem is that the parts which should be transparent appear black in game, please see the attached screenshot. Strangely enough also the preview picture in the catalogue has the right transparency.

I'd be glad about some advice!
Best Regards
jon119
Screenshots
Test Subject
#982 Old 14th Feb 2009 at 3:50 AM
I also used the same lamp as in the tutorial; the 4 x 4 designer chandelier. In step 2: I unchecked the metal box for the base, made sure the box for the shade and auto select was checked and hit Ok. The subset selector appears to show correctly.

In step 3: The plugin button on the bottom left hand side (actually says plugin view) I clicked on that, selected the texture image on the upper left hand of the screen as directed and then again nothing is displayed for the 2 texture files on the right hand side of the screen to select and export.
The ModFather
retired moderator
Original Poster
#983 Old 14th Feb 2009 at 11:32 AM
jon119 - When doing the "Build DXT", be sure to select the DXT3 format; the default DXT1 doesn't support transparency. Also, the TXMT associated to the papers must have the "stdMatAlphaBlendMode" set to "blend".

furymonkey - I retried, and the recolour package was created as expected. What do you read in the left panel? You should see:
- Material Definition (TXMT) (2)
- Material Override (MMAT) (2)
- Texture Image (TXTR) (2)
Before clicking on "texture image" on the left hand of the screen, you should see 6 files in total in the right panel.
Do the following:
1) in Extra -> Preferences -> File Table, click "Reset"
2) in Extra -> Preferences -> SimPE settings, click "Reset Layout"
3) on the right hand of the screen, click on "Filter Resources" and be sure that all the fields are empty
4) RESTART SimPE.

I've finally started my Journal. Information only, no questions.

My latest activity: CEP 9.2.0! - AnyGameStarter 2.1.1 (UPD) - Scriptorium v.2.2f - Photo & Plaques hide with walls - Magazine Rack (UPD) - Animated Windows Hack (UPD) - Custom Instrument Hack (UPD) - Drivable Cars Without Nightlife (UPD) - Courtesy Lights (FIX) - Custom Fence-Arches - Painting-TV - Smarter Lights (UPD)


I *DON'T* accept requests, sorry.
Instructor
#984 Old 14th Feb 2009 at 11:38 AM
Ah, I used DXT3 but what I forgot was the TXMT. I'm really a bit absentminded at the moment, I normally should have remmebered the blend mode...
Test Subject
#985 Old 14th Feb 2009 at 6:31 PM
Resetting the PE settings worked :-) I did my first recolor. WooHoo!!! Your the best!!!
Fixing this just made my day....now I'm off to try a few more recolors.
Thank you again for your help!
Lab Assistant
#986 Old 27th Feb 2009 at 8:52 PM Last edited by sehana : 27th Feb 2009 at 10:35 PM.
what is it that I have to do if Build DXT is greyed out??

i do have the latest version of SimPE i also downloaded and installed http://developer.nvidia.com/object/...ies_legacy.html

*.* ~Sehana~
Sehana Fortress.com | Entertainment | Sims2 | Sims3 | Blog | Twitter |
Test Subject
#987 Old 27th Feb 2009 at 9:51 PM
Okay, I have the latest version of SimPE - I have DDS utilities installed; and I have it pointed to it. I have all the EPs installed. I don't know why, but there are A LOT of maxis objects missing from my list in SimPE. I tried looking in the File Table thing. Everything there is checked that is installed, so where are all my objects? I've only got stuff showing up from the Holiday Pack; is there something wrong there?
The ModFather
retired moderator
Original Poster
#988 Old 28th Feb 2009 at 11:10 AM
If you still haven't tried, go to the File Table again and click "Reset".
Other things to try, while in Extra -> Preferences:
- in "System Folders", check that the paths to your EP and SP are correct;
- in System Check, click "Run" and wait for ALL the 3 marks to become green;
- in SimPE Settings, click Clear Cache;

When done, RESTART SimPE before trying again the Object Workshop.

I've finally started my Journal. Information only, no questions.

My latest activity: CEP 9.2.0! - AnyGameStarter 2.1.1 (UPD) - Scriptorium v.2.2f - Photo & Plaques hide with walls - Magazine Rack (UPD) - Animated Windows Hack (UPD) - Custom Instrument Hack (UPD) - Drivable Cars Without Nightlife (UPD) - Courtesy Lights (FIX) - Custom Fence-Arches - Painting-TV - Smarter Lights (UPD)


I *DON'T* accept requests, sorry.
Lab Assistant
#989 Old 1st Mar 2009 at 5:43 AM Last edited by sehana : 1st Mar 2009 at 5:54 AM.
OHHHH that's what I didn't do... is go to the system folders and put the file address for the DDS....

*.* ~Sehana~
Sehana Fortress.com | Entertainment | Sims2 | Sims3 | Blog | Twitter |
Test Subject
#990 Old 13th Mar 2009 at 8:00 AM Last edited by hauntedutah : 13th Mar 2009 at 6:56 PM. Reason: Fix'd!
Recolor not showing up in game.
Edit:
I got it to work yay! I was putting the .PNG file into the downloads folder rather than the package file. I feel like such a bonehead haha!

This leaves me with one more question though. What do I do with the .PNG file? Do I just leave it in my projects folder or can I delete it? Also, if I get to the point where I want to share my creations, what do I need to include in the download? Just the package file or both the PNG and package?

Again thank you SO much for this program as well as the tutorial, this has definitely given the game a new life for me!!!!
Field Researcher
#991 Old 13th Mar 2009 at 10:13 PM
You're done with the .png; there's a compressed version of it in the .package now (in much the same way that Bodyshop "projects" files are no longer needed once you import a package).
The .package is the recolour.
Delete it, save it- whatever you'd like (personally, I keep all of my old projects lying around in case I'm inspired to improve them later).
Test Subject
#992 Old 14th Mar 2009 at 12:56 AM
Thank you Neder!! I think it I may at the very least keep my first ones, may be fun to go back for a chuckle seeing as my digital painting skills aren't that great yet haha.
Top Secret Researcher
#993 Old 14th Mar 2009 at 4:57 AM
Hey, first of all, thanks for this tutorial.

Second, I have a really strange problem with the recolors I made. Well, I made all the recolors of a certain decoration in SimPE, in this is how they turned out in-game:


But when you zoom away from them, this is what they all look like:


I dunno what I did wrong: I did all the recolors in SimPE, used Import to import all the signs, and then committed and saved. Is there some alternative way I should've done the recoloring?
Field Researcher
#994 Old 14th Mar 2009 at 5:10 AM
I'm guessing you didn't "Update all sizes."
Field Researcher
#995 Old 16th Mar 2009 at 1:06 AM
SimPE Weirdness
I have been recoloring Maxis objects for some time now, using Wizards of SimPE.

Today, I've been trying my hand at SimPE so that I may learn to recolor custom objects.

This is my first attempt. Something very strange happens.

When I view the recolor of a custom painting I did from FAR AWAY, it looks just fine:



However, when I zoom in closer, it turns into THIS:



Please forgive me if this question has been asked and answered already. I couldn't bring myself to sift through 40 pages of posts!

Thank you, in advance, for any help you can give me.
It is greatly appreciated.

Sugah's Place
... Providing quality Sims 2 downloads in a fun, friendly forum setting ...
Specializing in gorgeous Sim models, CC recolors, custom walls, prime real estate, original challenges & more!
Me? Sarcastic? Never.
staff: administrator
#996 Old 16th Mar 2009 at 1:49 AM
It looks like you may have used the import option instead of the build dxt and the texture wasn't applied to all sizes. Use the build dxt instead, you get better quality.
Field Researcher
#997 Old 16th Mar 2009 at 2:17 AM
Thank you!
I feel like that's what's happening...that the texture isn't being resized properly. I DID use the import option, which is probably the issue.

I will start over again. Thank you, HugeLunatic, for responding so quickly.
Wish me luck!

Sugah's Place
... Providing quality Sims 2 downloads in a fun, friendly forum setting ...
Specializing in gorgeous Sim models, CC recolors, custom walls, prime real estate, original challenges & more!
Field Researcher
#998 Old 17th Mar 2009 at 10:10 AM
Default grrr
I tried creating recolors for Kevinshope's cloth covered cross, but the recol's will absolutely not show up! I did everything in this tute, and nothing! Now I know he said that we could recolor his cross, but if he forgot to make the object itself recolorable, is it possible to reverse that within the object itself?
Test Subject
#999 Old 21st Mar 2009 at 12:15 AM Last edited by Numenor : 21st Mar 2009 at 3:36 AM. Reason: Attachment moved to first post
*GERMAN TRANSLATION HAS BEEN LOST* (If you have it, please post it)

Here it is
The ModFather
retired moderator
Original Poster
#1000 Old 21st Mar 2009 at 3:35 AM
Got it! Thanks for providing it again!

I've finally started my Journal. Information only, no questions.

My latest activity: CEP 9.2.0! - AnyGameStarter 2.1.1 (UPD) - Scriptorium v.2.2f - Photo & Plaques hide with walls - Magazine Rack (UPD) - Animated Windows Hack (UPD) - Custom Instrument Hack (UPD) - Drivable Cars Without Nightlife (UPD) - Courtesy Lights (FIX) - Custom Fence-Arches - Painting-TV - Smarter Lights (UPD)


I *DON'T* accept requests, sorry.
Page 40 of 47
Back to top